症狀
請考慮以下案例:
- 您在未加入 Windows 網域的伺服器上安裝了 Microsoft SQL Server 2014。
- 您可以使用 SQL 驗證和 SSMS) SQL Server Management Studio 2014 (從遠端用戶端連線到伺服器。
- 您嘗試在用戶端上開啟記憶體最佳化資料表範本。
在此案例中,您收到下列錯誤訊息:
注意
無法連線至伺服器 “<ServerName>”
目標主體名稱不正確。 無法產生 SSPI 內容
原因
發生此問題的原因是,SSMS 一律不使用目前連線的認證和驗證模式,而是始終使用 Windows 驗證連線到伺服器。 當 SSMS 嘗試開啟記憶體最佳化的資料表建立範本,然後檢查資料庫是否有任何記憶體最佳化物件時,這會造成連線失敗。
解決方式
此問題已先在下列 SQL Server 累積更新中修正。
SQL Server 2014 累積更新 3 /zh-tw/help/2984923
關於 SQL Server 的累積更新
SQL Server 的每個新累積更新都包含所有 Hotfix 和先前累積更新的所有安全性修正程式。 查看 SQL Server 的最新累積更新:
狀態
Microsoft 已確認這是「適用對象」一節中列出的 Microsoft 產品中的問題。