KB4010344 - 修正:如果伺服器名稱太長,sp_msx_enlist預存程序無法將目標伺服器編入 SQL Server 2014 或 2016 的主要伺服器

套用到
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

症狀

假設您在 Microsoft SQL Server 2014 或 2016 中使用多伺服器環境。 當您嘗試使用 sp_msx_enlist 預存程序將目標伺服器登記到主要伺服器時,如果您為 @msx_server_name 引數指定的伺服器名稱長度超過 32 個字元,則作業可能會失敗。 此外,您可能會收到類似下列的錯誤訊息:

注意

Msg 22026, Level 16, State 1, Line LineNumber

登記作業失敗 (原因: 伺服器等候SQL Server Agent的回應時已超過逾時。請確定 SQL Server Agent 服務正在) 執行

解決方式

此問題已在下列 SQL Server 累積更新中修正:

SQL Server 2016 RTM 的累積更新 5

SQL Server 2016 SP1 的累積更新 2

SQL Server 2014 SP2 的累積更新 4

關於 SQL Server 的累積匯報

SQL Server 的每個新累積更新都包含所有 Hotfix 和先前累積更新的所有安全性修正程式。 查看 SQL Server 的最新累積更新:

適用於 SQL Server 2016 的最新累積更新
        
         適用於 SQL Server 2014 的最新累積更新

狀態

Microsoft 已確認這是「適用對象」一節中列出的 Microsoft 產品中的問題。

參考資料

了解 Microsoft 用來說明軟體更新的術語。