Důležité informace: V Excel 2016, Excel Mobile a Excel pro web byla funkce CONCATENATE nahrazuje funkcí CONCAT. I když je funkce CONCATENATE kvůli zpětné kompatibilitě pořád k dispozici, měli byste zvážit možnost používání funkce CONCAT, protože je výkonnější.

Jedním z nejobvyklejších případů, kdy dojde k chybě #HODNOTA! u funkce CONCATENATE je, když se pokusíte vytvořit řetězec, který obsahuje odkaz na buňku s chybou, například #HODNOTA!.

V následujícím příkladu chceme zřetězit D2, E2 a F2, kde E2 má #VALUE! .

Chyba #HODNOTA! u funkce CONCATENATE

Chyba v E2 způsobí, že funkce zobrazí #VALUE! . Aby tato chyba fungovala úspěšně, musíte chybu nahradit jinou hodnotou než chybou. Můžete vytvořit vzorec, který vyhledá chybu v odkazu na buňku, a pokud ano, zobrazí textový řetězec, ve kterém se místo chyby zobrazí 0 (nebo můžete nahradit vlastním textem hodnotu 0, ale budete muset text zalamovat do uvozovek – "Váš text").

Takovýto vzorec bude fungovat:

=KDYŽ(JE.CHYBA(E2),CONCATENATE(D2;" ";0;" ";F2))

Funkce IF a ISERROR používané jako alternativní řešení pro zřetězit řetězec pomocí #VALUE! #BUSY!

Jak to funguje? Funkce KDYŽ používá funkci IFERROR ke zjištění, jestli je chyba v buňce E2, a pokud tam je, zkombinuje funkce CONCATENATE hodnoty v buňce D2, E2 a F2 (funkce nahradí chybu číslem 0) a zobrazí výsledný textový řetězec. Poznámka: K vizuálnímu oddělení hodnot se ve vzorci používají mezery (" ").

Oprava chyby #HODNOTA! pomocí funkce CONCATENATE v Excelu 2003 a starších verzích

Pokud se zobrazuje chyba #HODNOTA! v aplikaci Office Excel 2003 nebo starších verzích, bude nutné v aplikaci Excel zrušit zaškrtnutí možnosti převodu výpočtu vzorců (TFE). Při zřetězování buněk postupujte podle pokynů #VALUE! .

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Oprava chyby #HODNOTA! chyba

CONCATENATE

Funkce CONCAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×