Použití čtečky obrazovky k vytvoření grafu v desktopových databázích Accessu

Tento článek je určen lidem se zrakovým nebo kognitivním postižením, kteří s produkty Microsoft 365 používají program pro čtení obrazovky, jako je Microsoft Předčítání, JAWS nebo NVDA. Tento článek je součástí sady obsahu Podpora čtečky obrazovky pro Microsoft 365, kde najdete další informace o přístupnosti v našich aplikacích. Pokud potřebujete obecnou pomoc, navštivte domovskou stránku podpory Microsoftu.

Pomocí Access klávesnice a čtečky obrazovky můžete ve formuláři vytvořit výsečový, sloupcový nebo čárový graf. Aplikaci jsme otestovali s programy Předčítání, JAWS a NVDA, ale může fungovat i s jinými čtečkami obrazovky, pokud splňují obvyklé standardy přístupnosti a techniky. Dozvíte se také, jak formátovat, měnit velikost nebo přesouvat graf.

Do formuláře můžete přidat graf, který bude vizualizovat data. Graf je možné svázat s tabulkou nebo dotazem a přizpůsobit pomocí nejrůznějších vlastností.

Další informace o grafech a rozhodování o tom, který graf byste měli vytvořit, najdete v části Výběr nejlepšího typu grafu pro vaše potřeby v tématu Vytvoření grafu ve formuláři nebo sestavě.

Poznámky: 

V tomto tématu

Vytvoření grafu

Pokud chcete úspěšně vytvořit graf v Access, vytvořte vazbu grafu se zdrojem dat, jako je tabulka nebo dotaz, a namapovat pole na rozměry grafu.

  1. Přejděte na formulář, ve kterém chcete graf vytvořit, a stiskněte Shift+F10. Zobrazí se místní nabídka. Stisknutím klávesy D otevřete formulář v návrhovém zobrazení.

  2. Pokud chcete vybrat typ grafu, stiskněte Alt+J, D, H, 1. Otevře se nabídka grafu. Udělejte jednu z těchto věcí:

    • Pokud chcete vytvořit výsečový graf, stiskněte klávesu P.

    • Pokud chcete vytvořit sloupcový graf, stiskněte klávesu C.

    • Pokud chcete vytvořit čárový graf, stiskněte L.

  3. Stiskněte klávesu Enter. Do formuláře se vloží zástupný graf. Otevře se Nastavení Graf.

  4. Pokud chcete fokus přesunout do podokna Nastavení grafu, stiskněte klávesu F6, dokud neuslyšíte, že se v podokně nachází položka. Možná budete muset požádat kolegu, aby vám pomohl s identifikací podokna.

  5. Pokud chcete přesunout fokus na kartu Data, stiskněte opakovaně kombinaci kláves Shift+Tab, dokud neuslyšíte aktuální kartu. Pak opakovaně stiskněte klávesu Šipka vpravo, dokud neuslyšíte, že jste na kartě Data. Zobrazí se vlastnosti karty.

  6. Pokud chcete vybrat nebo změnit typ zdroje dat pro graf, stiskněte opakovaně klávesu Tab, dokud neuslyšíte"Zdroj dat", za ním následuje aktuální typ zdroje, například Tabulka. Pokud chcete změnit typ zdroje dat, stiskněte opakovaně klávesu Šipka vlevo nebo Šipka vpravo, dokud neuslyšíte typ zdroje, který chcete použít.

  7. Stiskněte jednou klávesu Tab. Uslyšíte název aktuálního zdroje dat a potom pole se seznamem. Pokud nebyl vybraný žádný zdroj dat, uslyšíte, že jste v poli se seznamem. Pokud chcete vybrat nebo změnit zdroj dat, stiskněte opakovaně klávesu Šipka dolů, dokud neuslyšíte název zdroje, který chcete použít, a pak stiskněte Enter.

    Ukázkový diagram se ve výchozím nastavení nahradí živým grafem, který použije první dvě pole ze zdroje dat jako rozměry grafu Osa (kategorie) a Hodnoty (osa Y). První sloupec v tabulce je často primární klíč, který v grafu pravděpodobně nebudete chtít použít.

  8. Pokud chcete vytvořit graf, musíte vybrat aspoň dvě pole v možnostech Osa (Kategorie),Legenda (Řady)a Hodnoty (osa Y). Pokud chcete přejít na možnost, stiskněte opakovaně klávesu Tab, dokud neuslyšíte požadovanou možnost, například "Osa, kategorie". Opakovaně stiskněte klávesu Šipka nahoru nebo Šipka dolů, dokud neuslyšíte název pole, které chcete použít. Pokud je pole prezentováno jako zaškrtávací políčko, vyberte ho stisknutím mezerníku. Pokud je pole přepínač, vybere se automaticky při pohybu po poli. Další informace o jednotlivých možnostech a o tom, co dělají s grafem, najdete v části Nastavení dat v kroku 3 v tématu Vytvoření grafu ve formuláři nebo sestavě.

Formátování grafu

Graf a jeho různé prvky můžete formátovat. Můžete také formátovat jednotlivé datové řady, což jsou sady hodnot ve sloupci, liniovém nebo výsečovém výsečovém grafu, které odpovídají legendě grafu. Možnosti formátování závisí na typu grafu.

Podrobné informace o vlastnostech datových řad, které můžete formátovat, najdete v části Nastavení formátu v kroku 3 v tématu Vytvoření grafu ve formuláři nebo sestavě.

Formátování výsečového grafu

Vlastnosti výsečového grafu můžete upravit pomocí podokna Seznam vlastností. Možná budete muset požádat kolegu, aby vám pomohl vybrat vlastnosti, které chcete upravit v kroku 8.

  1. Otevřete formulář s grafem v návrhovém zobrazení podle pokynů v tématu Vytvoření grafu.

  2. Opakovaně stiskněte klávesu F6, dokud neuslyšíte, že jste na pracovním prostoru a za ním název formuláře.

  3. Pokud chcete přesunout fokus na graf, stiskněte opakovaně klávesu Tab, dokud neuslyšíte číslo grafu, například "Chart 19, collapsed" (Sbalený graf 19).

  4. Stisknutím klávesy F4 otevřete podokno Seznam vlastností.

  5. Stiskněte jednou klávesu F6. Fokus se přesune na řádek vlastností v podokně Seznam vlastností. Uslyšíte číslo řádku a obsah buňky vlastnosti.

  6. V podokně Seznam vlastností jsou nastavení ovlivňující vzhled grafu obvykle na kartě Formát. Pokud chcete přejít na kartu a vybrat ji, stiskněte opakovaně klávesu Tab, dokud neuslyšíte aktuálně vybranou položku karty, například "Data tab item, selected" (Vybraná položka karty Data). Opakovaně stiskněte klávesu Šipka vlevo nebo Šipka vpravo, dokud neuslyšíte, že jste na položce karty Formát. Zobrazí se vlastnosti karty Formát.

    Tip: Pokud chcete zkontrolovat všechny dostupné vlastnosti grafu, vyberte kartu Vše.

  7. Pokud chcete fokus přesunout na seznam vlastností na vybrané kartě, stiskněte jednou klávesu Tab.

  8. Pokud chcete procházet vlastnosti vybrané karty, stiskněte klávesu Šipka nahoru nebo Šipka dolů. Pokud chcete rozbalit podnabídky, stiskněte kombinaci kláves Alt+Šipka dolů. Pokud chcete vybrat položku v podnabídce, stiskněte opakovaně klávesu Šipka nahoru nebo Šipka dolů, dokud neuslyšíte požadovanou možnost, a stisknutím klávesy Enter ji vyberte. Pokud chcete upravit textová pole, zadejte do pole novou hodnotu.

  9. Podokno Seznam vlastností zavřete stisknutím klávesy F4.

Formátování sloupcového nebo čárového grafu

  1. Otevřete formulář s grafem v návrhovém zobrazení podle pokynů v tématu Vytvoření grafu.

  2. Opakovaně stiskněte klávesu F6, dokud neuslyšíte, že jste na pracovním prostoru a za ním název formuláře.

  3. Pokud chcete přesunout fokus na graf, stiskněte opakovaně klávesu Tab, dokud neuslyšíte číslo grafu, například "Chart 19, collapsed" (Sbalený graf 19).

  4. Pokud chcete fokus přesunout do podokna Nastavení grafu, stiskněte klávesu F6, dokud neuslyšíte, že se v podokně nachází položka. Možná budete muset požádat kolegu, aby vám pomohl s identifikací podokna.

  5. Kartu Formát vyberete tak, že opakovaně stisknete kombinaci kláves Shift+Tab, dokud neuslyšíte aktuální kartu, a pak opakovaně stiskněte klávesu Šipka vpravo, dokud neuslyšíte, že jste na kartě Formát.

  6. Pokud chcete fokus přesunout na seznam vlastností na kartě Formát, stiskněte jednou klávesu Tab.

  7. Na kartě Formát se můžete pohybovat stisknutím klávesy SR+Šipka vpravo nebo Šipka vlevo. Nabídky rozbalíte stisknutím kláves Alt+Šipka dolů. Nabídku můžete procházet stisknutím klávesy Šipka nahoru nebo Šipka dolů. Možnost vyberete stisknutím mezerníku nebo klávesy Enter. Pokud chcete upravit textová pole, zadejte do pole novou hodnotu.

Změna velikosti grafu

  1. Otevřete formulář s grafem v návrhovém zobrazení podle pokynů v tématu Vytvoření grafu.

  2. Opakovaně stiskněte klávesu F6, dokud neuslyšíte, že jste na pracovním prostoru a za ním název formuláře.

  3. Pokud chcete přesunout fokus na graf, stiskněte opakovaně klávesu Tab, dokud neuslyšíte číslo grafu, například "Chart 19, collapsed" (Sbalený graf 19).

  4. Pokud chcete změnit velikost grafu, stiskněte kombinaci kláves Shift+Šipka. Možná budete potřebovat kolegu, který vám pomůže identifikovat vhodné rozměry grafu.

Přesunutí grafu

  1. Otevřete formulář s grafem v návrhovém zobrazení podle pokynů v tématu Vytvoření grafu.

  2. Opakovaně stiskněte klávesu F6, dokud neuslyšíte, že jste na pracovním prostoru a za ním název formuláře.

  3. Pokud chcete přesunout fokus na graf, stiskněte opakovaně klávesu Tab, dokud neuslyšíte číslo grafu, například "Chart 19, collapsed" (Sbalený graf 19).

  4. Pomocí kláves se šipkami přesuňte graf. Možná budete potřebovat kolegu, který vám pomůže identifikovat vhodné místo pro graf.

Propojení grafu s daty ve formuláři nebo sestavě

Pokud chcete, aby graf reflektoval data ve formuláři nebo sestavě, propojte ho se stejným zdrojem dat jako formulář nebo sestavu. Potom můžete nastavit odpovídající hodnotu pole pro vlastnosti dat Podřízené propojovací pole a Propojovací hlavní pole grafu.

  1. Vytvořte vazbu mezi formulářem nebo sestavou a zdrojem dat. Podrobné pokyny najdete v tématu Použití čtečky obrazovky k vytvoření formuláře v desktopových databázích Accessu nebo Použití čtečky obrazovky k vytvoření sestavy v desktopových databázích Accessu.

  2. Ve formuláři nebo sestavě přidejte graf podle pokynů v tématu Vytvoření grafu. Při výběru zdroje dat vyberte stejný zdroj jako ve formuláři nebo sestavě.

  3. Otevřete formulář nebo sestavu v návrhovém zobrazení podle pokynů v tématu Vytvoření grafu.

  4. Pokud chcete přesunout fokus na graf, stiskněte opakovaně klávesu Tab, dokud neuslyšíte číslo grafu, například "Chart 19, collapsed" (Sbalený graf 19).

  5. Stisknutím klávesy F4 otevřete podokno Seznam vlastností.

  6. Stiskněte jednou klávesu F6. Fokus se přesune na řádek vlastností v podokně Seznam vlastností. Uslyšíte číslo řádku a obsah buňky vlastnosti.

  7. Pokud chcete přejít na kartu Data a vybrat ji, stiskněte opakovaně klávesu Tab, dokud neuslyšíte aktuálně vybranou položku karty, například "Format tab item, selected" (Formátovat položku karty, vybraná). Opakovaně stiskněte klávesu Šipka vlevo nebo Šipka vpravo, dokud neuslyšíte, že jste na položce karty Data. Zobrazí se vlastnosti karty Data.

  8. Požádejte kolegu, aby vám pomohl přesunout fokus na pole vlastnosti Podřízené propojovací pole nebo Hlavní propojovací pole.

  9. V poli vybrané vlastnosti otevřete místní nabídku stisknutím kláves Shift+F10. Dialogové okno Propojovací program pole podformuláře otevřete stisknutím klávesy B.

  10. Dialogové okno Propojovací program polí podformuláře obsahuje samostatné nabídky pro hlavní a podřízené pole. V dialogovém okně se můžete pohybovat stisknutím klávesy SR+Šipka vpravo nebo Šipka vlevo. Pokud chcete rozbalit seznam hlavních nebo podřízených polí, stiskněte kombinaci kláves Alt+Šipka dolů. Seznam můžete procházet stisknutím klávesy Šipka dolů. Pokud chcete vybrat pole, na které chcete vytvořit odkaz, stiskněte Enter. Možná budete muset požádat kolegu, aby vám pomohl s navigací v dialogovém okně.

    Tip: Pokud si nejste jistí, které pole chcete použít, stiskněte opakovaně klávesu SR+šipka vpravo, dokud se nedosáhnete na tlačítko Navrhnout, a stisknutím klávesy Enter ho vyberte. Access do vybraného pole vlastnosti vloží doporučené pole.

  11. Uložte formulář nebo sestavu.

  12. Ověřte, jestli graf funguje očekávaným způsobem v zobrazení Formulářnebo Sestava. Můžete třeba filtrovat formulář nebo sestavu podle pole kategorie a aktualizovat tak graf. Možná budete muset požádat kolegu, aby vám pomohl s ověřením grafu.

Viz taky

Použití čtečky obrazovky k vytváření tabulek v desktopových databázích Accessu

Použití čtečky obrazovky k vytvoření dotazu v desktopových databázích Accessu

Použití čtečky obrazovky k vytvoření formuláře v desktopových databázích Accessu

Použití čtečky obrazovky k exportu accessové tabulky do Excelového sešitu

Použití čtečky obrazovky k přenesení dat z Excelu do desktopových databázích Accessu

Klávesové zkratky pro aplikaci Access

Použití čtečky obrazovky k procházení a ovládání Accessu

Technická podpora pro zákazníky s postižením

Microsoft se snaží poskytovat nejlepší možnosti práce a prostředí všem svým zákazníkům. Pokud máte nějaké postižení nebo se chcete zeptat na něco v souvislosti s přístupností, obraťte se prosím se žádostí o technickou pomoc na Microsoft Disability Answer Desk. Tým podpory Disability Answer Desk je vyškolený v používání mnoha oblíbených technologií usnadnění a může nabídnout pomoc v angličtině, španělštině, francouzštině a americkém znakovém jazyku. Kontaktní informace pro vaši oblast najdete na webu Microsoft Disability Answer Desk.

Pokud jste uživatelem ve státní správě, komerční sféře nebo velkém podniku, obraťte se prosím na enterprise Disability Answer Desk.

Potřebujete další pomoc?

Zapojte se do diskuse

Zeptejte se komunity >

Získat podporu

KONTAKTUJTE NÁS >

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×