Mit einem Datenmodell können Sie Daten aus mehreren Tabellen integrieren und so effektiv eine relationale Datenquelle in einer Excel-Arbeitsmappe erstellen. In Excel werden Datenmodelle transparent verwendet und stellen tabellarische Daten bereit, die in PivotTables und PivotCharts verwendet werden. Ein Datenmodell wird als Eine Sammlung von Tabellen in einer Feldliste visualisiert, und meistens werden Sie niemals wissen, dass es vorhanden ist.

Bevor Sie mit der Arbeit mit dem Datenmodell beginnen können, müssen Sie einige Daten abrufen. Dazu verwenden wir die & Transformieren(Power Query)-Erfahrung, daher sollten Sie einen Schritt zurück gehen und ein Video ansehen oder unserem Lernleitfaden zu Get & Transform und Power Pivot folgen.

Wo ist Power Pivot enthalten?

Wo befindet sich Get & Transform (Power Query)?

  • Excel 2016 & Excel für Microsoft 365 – Get & Transform (Power Query) wurde in Excel auf der Registerkarte "Daten" integriert.

  • Excel 2013 – Power Query ist ein Add-In, das in Excel enthalten ist, aber aktiviert werden muss. Wechseln Sie zu "Datei > Optionen > Add-Ins", und wählen Sie dann in der Dropdownliste " Verwalten " am unteren Rand des Bereichs COM-Add-Ins > "Gehe zu" aus. Überprüfen Sie Microsoft Power Query für Excel, und klicken Sie dann auf "OK", um es zu aktivieren. Dem Menüband wird eine Power Query Registerkarte hinzugefügt.

  • Excel 2010Laden Sie das Power Query-Add-In herunter, und installieren Sie es.. Nach der Aktivierung wird dem Menüband eine Power Query Registerkarte hinzugefügt.

Erste Schritte

Zuerst müssen Sie einige Daten abrufen.

  1. Verwenden Sie in Excel 2016 und Excel für Microsoft 365Daten > Abrufen & Transformieren von Daten > Abrufen von Daten, um Daten aus einer beliebigen Anzahl externer Datenquellen zu importieren, z. B. einer Textdatei, einer Excel-Arbeitsmappe, einer Website, Microsoft Access, SQL Server oder einer anderen relationalen Datenbank, die mehrere verknüpfte Tabellen enthält.

    Wechseln Sie in Excel 2013 und 2010 zu Power Query > Externe Daten abrufen, und wählen Sie Ihre Datenquelle aus.

  2. Sie werden in Excel aufgefordert, eine Tabelle auszuwählen. Wenn Sie mehrere Tabellen aus derselben Datenquelle abrufen möchten, aktivieren Sie die Option "Auswahl mehrerer Tabellen aktivieren ". Wenn Sie mehrere Tabellen auswählen, erstellt Excel automatisch ein Datenmodell für Sie.

    Hinweis: Für diese Beispiele verwenden wir eine Excel-Arbeitsmappe mit fiktiven Schülerdetails zu Kursen und Noten. Sie können unsere Beispielarbeitsmappe "Studentendatenmodell" herunterladen und dies nachverfolgen.You can download our Student Data Model sample workbook, and follow along. Sie können auch eine Version mit einem abgeschlossenen Datenmodell herunterladen..

    Abrufen des & Transform (Power Query)-Navigators
  3. Wählen Sie eine oder mehrere Tabellen aus, und klicken Sie dann auf "Laden".

    Wenn Sie die Quelldaten bearbeiten müssen, können Sie die Option "Bearbeiten" auswählen. Weitere Informationen finden Sie unter: Einführung in die Abfrage-Editor (Power Query).For more details see: Introduction to the Abfrage-Editor (Power Query).

Sie verfügen jetzt über ein Datenmodell, das alle importierten Tabellen enthält, und diese werden in der PivotTable-Feldliste angezeigt.

Hinweise: 

  • Modelle werden implizit erstellt, wenn Sie mindestens zwei Tabellen gleichzeitig in Excel importieren.

  • Modelle werden explizit erstellt, wenn Sie Daten mithilfe des Power Pivot-Add-Ins importieren. Im Add-In wird das Modell in einem Registerkartenlayout dargestellt, das Excel ähnelt, in dem jede Registerkarte Tabellendaten enthält. Informationen zu den Grundlagen des Datenimports mithilfe einer SQL Server-Datenbank finden Sie unter Abrufen von Daten mithilfe des Power Pivot-Add-Ins.

  • Ein Modell kann eine einzelne Tabelle enthalten. Um ein Modell auf der Grundlage nur einer Tabelle zu erstellen, wählen Sie die Tabelle aus, und klicken Sie in Power Pivot auf Zu Datenmodell hinzufügen. Dies ist beispielsweise sinnvoll, wenn Sie Power Pivot-Funktionen, z. B. gefilterte Datasets, berechnete Spalten, berechnete Felder, KPIs und Hierarchien, verwenden möchten.

  • Tabellenbeziehungen können automatisch erstellt werden, wenn Sie verknüpfte Tabellen importieren, die Primär- und Fremdschlüsselbeziehungen aufweisen. In Excel können die Informationen zu importierten Beziehungen normalerweise als Grundlage für Tabellenbeziehungen im Datenmodell verwendet werden.

  • Tipps zum Verringern der Größe eines Datenmodells finden Sie unter Erstellen eines speichereffizienten Datenmodells mit Excel und Power Pivot.

  • Weitere Informationen finden Sie unter Lernprogramm: Importieren von Daten in Excel und Erstellen eines Datenmodells.

Tipp: Wie können Sie feststellen, ob Ihre Arbeitsmappe über ein Datenmodell verfügt? Wechseln Sie zu Power Pivot > Verwalten. Wenn Arbeitsblatt-ähnliche Daten angezeigt werden, ist ein Modell vorhanden. Siehe: Erfahren Sie, welche Datenquellen in einem Arbeitsmappendatenmodell verwendet werden , um mehr zu erfahren.

Erstellen von Beziehungen zwischen Ihren Tabellen

Der nächste Schritt besteht darin, Beziehungen zwischen Ihren Tabellen zu erstellen, damit Sie Daten aus beliebigen Tabellen abrufen können. Jede Tabelle muss über einen Primärschlüssel oder einen eindeutigen Feldbezeichner verfügen, z. B. "Studenten-ID" oder "Kursnummer". Die einfachste Möglichkeit besteht darin, diese Felder zu ziehen und abzulegen, um sie in der Diagrammansicht von Power Pivot zu verbinden.

  1. Wechseln Sie zu Power Pivot > Verwalten.

  2. Wählen Sie auf der Registerkarte " Start " die Option "Diagrammansicht" aus.

  3. Alle importierten Tabellen werden angezeigt, und Sie sollten einige Zeit in Anspruch nehmen, um die Größe zu ändern, je nachdem, wie viele Felder die einzelnen Felder haben.

  4. Ziehen Sie als Nächstes das Primärschlüsselfeld aus einer Tabelle in die nächste. Das folgende Beispiel ist die Diagrammansicht unserer Kursteilnehmertabellen:

    Power Query Datenmodell-Beziehungsdiagrammansicht

    Wir haben die folgenden Links erstellt:

    • tbl_Students | Student ID > tbl_Grades | Studenten-ID

      Mit anderen Worten: Ziehen Sie das Feld "Studenten-ID" aus der Tabelle "Kursteilnehmer" in das Feld "Studenten-ID" in der Tabelle "Noten".

    • tbl_Semesters | Semester-ID > tbl_Grades | Semester

    • tbl_Classes | Klassennummer > tbl_Grades | Klassennummer

    Hinweise: 

    • Feldnamen müssen nicht identisch sein, um eine Beziehung zu erstellen, aber sie müssen denselben Datentyp aufweisen.

    • Die Verbinder in der Diagrammansicht haben eine "1" auf der einen Seite und eine "*" auf der anderen Seite. Dies bedeutet, dass es eine 1:n-Beziehung zwischen den Tabellen gibt und bestimmt, wie die Daten in Ihren PivotTables verwendet werden. Weitere Informationen finden Sie unter: Beziehungen zwischen Tabellen in einem Datenmodell .

    • Die Verbinder deuten nur darauf hin, dass es eine Beziehung zwischen Tabellen gibt. Sie zeigen Ihnen nicht an, welche Felder miteinander verknüpft sind. Um die Links anzuzeigen, wechseln Sie zu Power Pivot > Verwalten > Entwurf > Beziehungen > Beziehungen verwalten. In Excel können Sie zu "Daten > Beziehungen" wechseln.

Verwenden eines Datenmodells zum Erstellen einer PivotTable oder eines PivotCharts

Eine Excel-Arbeitsmappe kann nur ein Datenmodell enthalten, aber dieses Modell kann mehrere Tabellen enthalten, die wiederholt in der gesamten Arbeitsmappe verwendet werden können. Sie können einem vorhandenen Datenmodell jederzeit weitere Tabellen hinzufügen.

  1. Wechseln Sie inPower Pivotzu "Verwalten".

  2. Wählen Sie auf der Registerkarte " Start " die Option "PivotTable" aus.

  3. Wählen Sie aus, wo die PivotTable platziert werden soll: ein neues Arbeitsblatt oder die aktuelle Position.

  4. Klicken Sie auf "OK", und Excel fügt eine leere PivotTable hinzu, wobei der Feldlistenbereich auf der rechten Seite angezeigt wird.

    Power PivotTable-Feldliste

Erstellen Sie als Nächstes eine PivotTable, oder erstellen Sie ein PivotChart. Wenn Sie bereits Beziehungen zwischen den Tabellen erstellt haben, können Sie jedes ihrer Felder in der PivotTable verwenden. Wir haben bereits Beziehungen in der Beispielarbeitsmappe "Student Data Model" erstellt.

Hinzufügen von vorhandenen, nicht verknüpften Daten zu einem Datenmodell

Angenommen, Sie haben viele Daten importiert oder kopiert, die Sie in einem Modell verwenden möchten, aber nicht zum Datenmodell hinzugefügt haben. Neue Daten in ein Modell zu übertragen, ist einfacher, als Sie denken.

  1. Wählen Sie zunächst eine beliebige Zelle innerhalb der Daten aus, die Sie dem Modell hinzufügen möchten. Es kann sich um einen beliebigen Datenbereich handeln, aber Daten, die als Excel-Tabelle formatiert sind, sind am besten geeignet.

  2. Fügen Sie die Daten mithilfe eines der folgenden Verfahren hinzu:

  3. Klicken Sie auf Power Pivot > Zu Datenmodell hinzufügen.

  4. Klicken Sie auf Einfügen > PivotTable, und aktivieren Sie dann im Dialogfeld "PivotTable erstellen" die Option Dem Datenmodell diese Daten hinzufügen.

Jetzt wird der Bereich oder die Tabelle dem Modell als verknüpfte Tabelle hinzugefügt. Weitere Informationen zum Arbeiten mit verknüpften Tabellen in einem Modell finden Sie unter Hinzufügen von Daten mit verknüpften Excel-Tabellen in Power Pivot.

Hinzufügen von Daten zu einer Power Pivot Tabelle

In Power Pivot können Sie einer Tabelle keine Zeile hinzufügen, indem Sie Daten direkt in eine neue Zeile eingeben, wie dies in einem Excel-Arbeitsblatt der Fall ist. Sie können jedoch Zeilen hinzufügen, indem Sie die Quelldaten kopieren und einfügen oder die Quelldaten aktualisieren und das Power Pivot-Modell aktualisieren.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Abrufen von & Transform- und Power Pivot-Lernhandbüchern

Einführung in den Abfrage-Editor (Power Query)

Erstellen eines speichereffizienten Datenmodells mit Excel und Power Pivot

Lernprogramm: Importieren von Daten in Excel und Erstellen eines Datenmodells

Feststellen, welche Datenquellen im Datenmodell einer Arbeitsmappe verwendet werden

Beziehungen zwischen Tabellen in einem Datenmodell

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern

Schulungen erkunden >

Neue Funktionen als Erster erhalten

Microsoft Insider beitreten >

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×