Textimport-Assistent

Obwohl Sie nicht direkt aus einer Textdatei oder einem Word-Dokument nach Excel exportieren können, können Sie den Textimport-Assistenten in Excel verwenden, um Daten aus einer Textdatei in ein Arbeitsblatt zu importieren. Der Textimport-Assistent untersucht die Textdatei, die Sie importieren, und hilft Ihnen, sicherzustellen, dass die Daten auf die von Ihnen personenbezogene Weise importiert werden.     

Hinweis: Der Textimport-Assistent ist ein älteres Feature, das zur Rückkompatibilität weiterhin unterstützt wird. Alternativ können Sie eine Textdatei importieren, indem Sie eine Verbindung mit Power Query herstellen.

Wechseln Sie zur Registerkarte Daten > Externe Daten > Aus Text. Doppelklicken Sie dann im Dialogfeld Textdatei importieren auf die Textdatei, die Sie importieren möchten, und das Dialogfeld Textimport-Assistent wird geöffnet.

Schritt 1 von 3

Ursprünglicher Datentyp    Wenn Elemente in der Textdatei durch Registerkarten, Doppelpunkte, Semikolons, Leerzeichen oder andere Zeichen getrennt sind, wählen Sie Trennzeichen aus. Wenn alle Elemente in jeder Spalte die gleiche Länge aufweisen, wählen Sie Feste Breite aus.

Starten des Importvorganges in Zeile    Geben Sie eine Zeilennummer ein, oder wählen Sie sie aus, um die erste Zeile der Daten anzugeben, die Sie importieren möchten.

Dateiherkunft    Wählen Sie den Zeichensatz aus, der in der Textdatei verwendet wird. In den meisten Fällen können Sie diese Einstellung als Standardeinstellung be lassen. Wenn Sie wissen, dass die Textdatei mit einem anderen Zeichensatz als dem Zeichensatz erstellt wurde, den Sie auf Ihrem Computer verwenden, sollten Sie diese Einstellung so ändern, dass sie diesem Zeichensatz entsprechen. Wenn Auf Ihrem Computer beispielsweise der Zeichensatz 1251 (Kyrillisch, Windows) festgelegt ist, Sie aber wissen, dass die Datei mit dem Zeichensatz 1252 (Westeuropäischen, Windows) erstellt wurde, sollten Sie Dateiherkunft auf 1252 festlegen.

Vorschau der Datei    In diesem Feld wird der Text so angezeigt, wie er angezeigt wird, wenn er in Spalten auf dem Arbeitsblatt getrennt ist.

Schritt 2 von 3 (getrennte Daten)

Trennzeichen    Wählen Sie das Zeichen aus, mit dem Werte in der Textdatei getrennt werden. Wenn das Zeichen nicht aufgeführt ist, aktivieren Sie das Kontrollkästchen Sonstige, und geben Sie dann das Zeichen in das Feld ein, das den Cursor enthält. Diese Optionen sind nicht verfügbar, wenn Ihr Datentyp feste Breite hat.

Behandeln aufeinander folgenden Trennzeichen als eins    Aktivieren Sie dieses Kontrollkästchen, wenn Ihre Daten ein Trennzeichen von mehr als einem Zeichen zwischen Datenfeldern enthalten oder wenn Ihre Daten mehrere benutzerdefinierte Trennzeichen enthalten.

Textqualifizierer    Wählen Sie das Zeichen aus, das Werte in die Textdatei einschließt. Wenn Excel auf das Textqualifiziererzeichen trifft, wird der ganze Text, der diesem Zeichen folgt und dem nächsten Vorkommen dieses Zeichens voran geht, als ein Wert importiert, auch wenn der Text ein Trennzeichen enthält. Wenn das Trennzeichen z. B. ein Komma (,) und der Textqualifizierer ein Anführungszeichen ist ("), wird "Dallas, Texas" als Dallas, Texasin eine Zelle importiert. Wenn kein Zeichen oder das Apostroph (') als Textqualifizierer angegeben ist, wird "Dallas, Texas" als "Dallas und Texas" in zwei benachbarte Zellen importiert.

Wenn das Trennzeichen zwischen Textqualifizierern auftritt, werden die Qualifizierer im importierten Wert von Excel nicht mehr angezeigt. Wenn zwischen Textqualifizierern kein Trennzeichen auftritt, enthält Excel das Qualifiziererzeichen in den importierten Wert. Daher wird "Dallas Texas" (mit dem Anführungszeichentextqualifizierer) in eine Zelle als "Dallas Texas" importiert.

Datenvorschau    Überprüfen Sie den Text in diesem Feld, um sicherzustellen, dass der Text auf dem Arbeitsblatt nach Benennung in Spalten getrennt wird.

Schritt 2 von 3 (Daten mit fester Breite)

Datenvorschau    Legen Sie die Feldbreiten in diesem Abschnitt fest. Klicken Sie auf das Vorschaufenster, um einen Spaltenumbruch zu setzen, der durch eine vertikale Linie dargestellt wird. Doppelklicken Sie auf einen Spaltenumbruch, um ihn zu entfernen, oder ziehen Sie einen Spaltenumbruch, um ihn zu verschieben.

Schritt 3 von 3

Klicken Sie auf die Schaltfläche Erweitert, um eine oder mehrere der folgenden Schritte zu unternehmen:

  • Geben Sie den Typ der Dezimal- und Tausendertrennzeichen an, die in der Textdatei verwendet werden. Wenn die Daten in Excel importiert werden, entsprechen die Trennzeichen denen, die für Ihren Standort unter Regionale und Sprachoptionen oder Regionale Einstellungen (Windows-Systemsteuerung) angegeben sind.

  • Geben Sie an, dass mindestens ein numerischer Wert ein nachgestelltes Minuszeichen enthalten kann.

Spaltendatenformat    Klicken Sie auf das Datenformat der Spalte, die im Abschnitt Datenvorschau ausgewählt ist. Wenn Sie die ausgewählte Spalte nicht importieren möchten, klicken Sie auf Spalte nicht importieren (überspringen).

Nachdem Sie eine Datenformatoption für die ausgewählte Spalte ausgewählt haben, zeigt die Spaltenüberschrift unter Datenvorschau das Format an. Wenn Sie Datum auswählen,wählen Sie im Feld Datum ein Datumsformat aus.

Wählen Sie das Datenformat aus, das den Vorschaudaten genau entspricht, damit Excel die importierten Daten richtig konvertieren kann. Beispiel:

  • Wenn Sie eine Spalte mit allen Währungszahlenzeichen in das Excel-Währungsformat konvertieren möchten, wählen Sie Allgemein aus.

  • Wenn Sie eine Spalte mit allen Zahlenzeichen in das Excel-Textformat konvertieren möchten, wählen Sie Text aus.

  • Um eine Spalte mit allen Datumszeichen zu konvertieren, wählen Sie jedes Datum in der Reihenfolge von Jahr, Monat und Tag in das Excel-Datumsformat aus, und wählen Sie dann im Feld Datum den Datumstyp YMD aus.

Excel importiert die Spalte als "Allgemein", wenn die Konvertierung unbeabsichtigte Ergebnisse liefern könnte. Beispiel:

  • Wenn die Spalte eine Kombination aus Formaten wie alphabetischen und numerischen Zeichen enthält, konvertiert Excel die Spalte in Allgemein.

  • Wenn sich jedes Datum in einer Spalte mit Datumsangaben in der Reihenfolge von Jahr, Monat und Datum befindet und Sie Datum zusammen mit einem Datumstyp von MDYauswählen, konvertiert Excel die Spalte in das Format Allgemein. Eine Spalte, die Datumszeichen enthält, muss eng mit einem integrierten Datums- oder benutzerdefinierten Datumsformat in Excel übereinstimmen.

Wenn Excel eine Spalte nicht in das von Ihnen angezeigte Format konvertiert, können Sie die Daten nach dem Importieren konvertieren.

Wenn Sie die optionen ausgewählt haben, klicken Sie auf Fertig stellen, um das Dialogfeld Daten importieren zu öffnen, und wählen Sie aus, wo Die Daten gespeichert werden.

Importieren von Daten

Legen Sie diese Optionen für die Steuerung der Datenimportprozesse ein, einschließlich der zu verwendenden Datenverbindungseigenschaften und der Datei und des Bereichs, die mit den importierten Daten auffüllt werden sollen.

  • Die Optionen unter Auswählen, wie diese Daten in Ihrer Arbeitsmappe angezeigt werden sollen, sind nur verfügbar, wenn Sie ein Datenmodell vorbereitet haben, und wählen Sie die Option aus, um diesen Import zu diesem Modell hinzuzufügen (siehe das dritte Element in dieser Liste).

  • Geben Sie eine Zielarbeitsmappe an:

    • Wenn Sie Vorhandenes Arbeitsblatt auswählen,klicken Sie auf eine Zelle im Blatt, um die erste Zelle der importierten Daten zu platzieren, oder klicken und ziehen Sie, um einen Bereich auszuwählen.

    • Wählen Sie Neues Arbeitsblatt aus, um in ein neues Arbeitsblatt zu importieren (beginnend bei Zelle A1)

  • Wenn Sie über ein Datenmodell verfügen, klicken Sie auf Diese Daten zum Datenmodell hinzufügen, um diesen Import in das Modell zu importieren. Weitere Informationen finden Sie unter Erstellen eines Datenmodells in Excel.

    Beachten Sie, dass durch Auswählen dieser Option die Optionen unter Auswählen, wie diese Daten in Der Arbeitsmappe angezeigt werden soll, aufgehoben werden.

  • Klicken Sie auf Eigenschaften, um beliebige Externe Datenbereichseigenschaften zu festlegen. Weitere Informationen finden Sie unter Verwalten externer Datenbereiche und deren Eigenschaften.

  • Klicken Sie auf OK, wenn Sie mit dem Importieren Ihrer Daten fertig sind.

Hinweise: Der Textimport-Assistent ist ein älteres Feature, das möglicherweise aktiviert werden muss. Wenn Sie dies noch nicht getan haben, dann: 

  1. Klicken Sie auf Datei > Optionen > Daten.

  2. Wählen Sie unter Ältere Datenimport-Assistenten anzeigendie Option Aus Text (Legacy) aus.

Nachdem Sie die Option aktiviert haben, wechseln Sie zur Registerkarte Daten > & Daten transformieren > Daten > Legacy-Assistenten > Aus Text (Legacy). Doppelklicken Sie dann im Dialogfeld Textdatei importieren auf die Textdatei, die Sie importieren möchten, und der Textimport-Assistent wird geöffnet.

Schritt 1 von 3

Ursprünglicher Datentyp    Wenn Elemente in der Textdatei durch Registerkarten, Doppelpunkte, Semikolons, Leerzeichen oder andere Zeichen getrennt sind, wählen Sie Trennzeichen aus. Wenn alle Elemente in jeder Spalte die gleiche Länge aufweisen, wählen Sie Feste Breite aus.

Starten des Importvorganges in Zeile    Geben Sie eine Zeilennummer ein, oder wählen Sie sie aus, um die erste Zeile der Daten anzugeben, die Sie importieren möchten.

Dateiherkunft    Wählen Sie den Zeichensatz aus, der in der Textdatei verwendet wird. In den meisten Fällen können Sie diese Einstellung als Standardeinstellung be lassen. Wenn Sie wissen, dass die Textdatei mit einem anderen Zeichensatz als dem Zeichensatz erstellt wurde, den Sie auf Ihrem Computer verwenden, sollten Sie diese Einstellung so ändern, dass sie diesem Zeichensatz entsprechen. Wenn Auf Ihrem Computer beispielsweise der Zeichensatz 1251 (Kyrillisch, Windows) festgelegt ist, Sie aber wissen, dass die Datei mit dem Zeichensatz 1252 (Westeuropäischen, Windows) erstellt wurde, sollten Sie Dateiherkunft auf 1252 festlegen.

Vorschau der Datei    In diesem Feld wird der Text so angezeigt, wie er angezeigt wird, wenn er in Spalten auf dem Arbeitsblatt getrennt ist.

Schritt 2 von 3 (getrennte Daten)

Trennzeichen    Wählen Sie das Zeichen aus, mit dem Werte in der Textdatei getrennt werden. Wenn das Zeichen nicht aufgeführt ist, aktivieren Sie das Kontrollkästchen Sonstige, und geben Sie dann das Zeichen in das Feld ein, das den Cursor enthält. Diese Optionen sind nicht verfügbar, wenn Ihr Datentyp feste Breite hat.

Behandeln aufeinander folgenden Trennzeichen als eins    Aktivieren Sie dieses Kontrollkästchen, wenn Ihre Daten ein Trennzeichen von mehr als einem Zeichen zwischen Datenfeldern enthalten oder wenn Ihre Daten mehrere benutzerdefinierte Trennzeichen enthalten.

Textqualifizierer    Wählen Sie das Zeichen aus, das Werte in die Textdatei einschließt. Wenn Excel auf das Textqualifiziererzeichen trifft, wird der ganze Text, der diesem Zeichen folgt und dem nächsten Vorkommen dieses Zeichens voran geht, als ein Wert importiert, auch wenn der Text ein Trennzeichen enthält. Wenn das Trennzeichen z. B. ein Komma (,) und der Textqualifizierer ein Anführungszeichen ist ("), wird "Dallas, Texas" als Dallas, Texasin eine Zelle importiert. Wenn kein Zeichen oder das Apostroph (') als Textqualifizierer angegeben ist, wird "Dallas, Texas" als "Dallas und Texas" in zwei benachbarte Zellen importiert.

Wenn das Trennzeichen zwischen Textqualifizierern auftritt, werden die Qualifizierer im importierten Wert von Excel nicht mehr angezeigt. Wenn zwischen Textqualifizierern kein Trennzeichen auftritt, enthält Excel das Qualifiziererzeichen in den importierten Wert. Daher wird "Dallas Texas" (mit dem Anführungszeichentextqualifizierer) in eine Zelle als "Dallas Texas" importiert.

Datenvorschau    Überprüfen Sie den Text in diesem Feld, um sicherzustellen, dass der Text auf dem Arbeitsblatt nach Benennung in Spalten getrennt wird.

Schritt 2 von 3 (Daten mit fester Breite)

Datenvorschau    Legen Sie die Feldbreiten in diesem Abschnitt fest. Klicken Sie auf das Vorschaufenster, um einen Spaltenumbruch zu setzen, der durch eine vertikale Linie dargestellt wird. Doppelklicken Sie auf einen Spaltenumbruch, um ihn zu entfernen, oder ziehen Sie einen Spaltenumbruch, um ihn zu verschieben.

Schritt 3 von 3

Klicken Sie auf die Schaltfläche Erweitert, um eine oder mehrere der folgenden Schritte zu unternehmen:

  • Geben Sie den Typ der Dezimal- und Tausendertrennzeichen an, die in der Textdatei verwendet werden. Wenn die Daten in Excel importiert werden, entsprechen die Trennzeichen denen, die für Ihren Standort unter Regionale und Sprachoptionen oder Regionale Einstellungen (Windows-Systemsteuerung) angegeben sind.

  • Geben Sie an, dass mindestens ein numerischer Wert ein nachgestelltes Minuszeichen enthalten kann.

Spaltendatenformat    Klicken Sie auf das Datenformat der Spalte, die im Abschnitt Datenvorschau ausgewählt ist. Wenn Sie die ausgewählte Spalte nicht importieren möchten, klicken Sie auf Spalte nicht importieren (überspringen).

Nachdem Sie eine Datenformatoption für die ausgewählte Spalte ausgewählt haben, zeigt die Spaltenüberschrift unter Datenvorschau das Format an. Wenn Sie Datum auswählen,wählen Sie im Feld Datum ein Datumsformat aus.

Wählen Sie das Datenformat aus, das den Vorschaudaten genau entspricht, damit Excel die importierten Daten richtig konvertieren kann. Beispiel:

  • Wenn Sie eine Spalte mit allen Währungszahlenzeichen in das Excel-Währungsformat konvertieren möchten, wählen Sie Allgemein aus.

  • Wenn Sie eine Spalte mit allen Zahlenzeichen in das Excel-Textformat konvertieren möchten, wählen Sie Text aus.

  • Um eine Spalte mit allen Datumszeichen zu konvertieren, wählen Sie jedes Datum in der Reihenfolge von Jahr, Monat und Tag in das Excel-Datumsformat aus, und wählen Sie dann im Feld Datum den Datumstyp YMD aus.

Excel importiert die Spalte als "Allgemein", wenn die Konvertierung unbeabsichtigte Ergebnisse liefern könnte. Beispiel:

  • Wenn die Spalte eine Kombination aus Formaten wie alphabetischen und numerischen Zeichen enthält, konvertiert Excel die Spalte in Allgemein.

  • Wenn sich jedes Datum in einer Spalte mit Datumsangaben in der Reihenfolge von Jahr, Monat und Datum befindet und Sie Datum zusammen mit einem Datumstyp von MDYauswählen, konvertiert Excel die Spalte in das Format Allgemein. Eine Spalte, die Datumszeichen enthält, muss eng mit einem integrierten Datums- oder benutzerdefinierten Datumsformat in Excel übereinstimmen.

Wenn Excel eine Spalte nicht in das von Ihnen angezeigte Format konvertiert, können Sie die Daten nach dem Importieren konvertieren.

Wenn Sie die optionen ausgewählt haben, klicken Sie auf Fertig stellen, um das Dialogfeld Daten importieren zu öffnen, und wählen Sie aus, wo Die Daten gespeichert werden.

Importieren von Daten

Legen Sie diese Optionen für die Steuerung der Datenimportprozesse ein, einschließlich der zu verwendenden Datenverbindungseigenschaften und der Datei und des Bereichs, die mit den importierten Daten auffüllt werden sollen.

  • Die Optionen unter Auswählen, wie diese Daten in Ihrer Arbeitsmappe angezeigt werden sollen, sind nur verfügbar, wenn Sie ein Datenmodell vorbereitet haben, und wählen Sie die Option aus, um diesen Import zu diesem Modell hinzuzufügen (siehe das dritte Element in dieser Liste).

  • Geben Sie eine Zielarbeitsmappe an:

    • Wenn Sie Vorhandenes Arbeitsblatt auswählen,klicken Sie auf eine Zelle im Blatt, um die erste Zelle der importierten Daten zu platzieren, oder klicken und ziehen Sie, um einen Bereich auszuwählen.

    • Wählen Sie Neues Arbeitsblatt aus, um in ein neues Arbeitsblatt zu importieren (beginnend bei Zelle A1)

  • Wenn Sie über ein Datenmodell verfügen, klicken Sie auf Diese Daten zum Datenmodell hinzufügen, um diesen Import in das Modell zu importieren. Weitere Informationen finden Sie unter Erstellen eines Datenmodells in Excel.

    Beachten Sie, dass durch Auswählen dieser Option die Optionen unter Auswählen, wie diese Daten in Der Arbeitsmappe angezeigt werden soll, aufgehoben werden.

  • Klicken Sie auf Eigenschaften, um beliebige Externe Datenbereichseigenschaften zu festlegen. Weitere Informationen finden Sie unter Verwalten externer Datenbereiche und deren Eigenschaften.

  • Klicken Sie auf OK, wenn Sie mit dem Importieren Ihrer Daten fertig sind.

Hinweis: Wenn sich Ihre Daten in einem Word-Dokument befindet, müssen Sie sie zuerst als Textdatei speichern. Klicken Sie auf Datei > Speichern unter, und wählen Sie Als Dateityp Nur-Text (TXT) aus.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Einführung in Microsoft Power Query für Excel

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×