KB3171544 - FIX: Error 8624 occurs when you run a query against a nonclustered columnstore index in SQL Server 2016

Applies To
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptoms

Assume that you run a query against a nonclustered columnstore index in Microsoft SQL Server 2016. If the total amount of data in fixed length columns is close to the row size limit, for example, select * from an index that contains an int, a bigint, a datetime, a char (8000), and a char (29); and a key column is involved in a predicate, you receive the following error message:

Note

Msg 8624, Level 16, State 27
Internal Query Processor Error: The query processor could not produce a query plan. For more information, contact Customer Support Services

Resolution

Cumulative Update information

This issue was first fixed in the following cumulative update of SQL Server.

Recommendation: Install the latest cumulative update for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. We recommend that you download and install the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.