PHAKU-funktio

Vihje: Kokeile käyttää uutta XHAKU-funktiota, PHAKU-funktion parannettua versiota, joka toimii mihin tahansa suuntaan ja palauttaa oletusarvoisesti tarkat vastineet, mikä helpottaa ja helpottaa sen edeltäjän käyttöä.

Käytä PHAKU-funktiota, kun haluat etsiä tietoja taulukosta tai alue riviltä. Voit esimerkiksi etsiä auton osan hinnan osanumerosta tai etsiä työntekijän nimen työntekijätunnuksen perusteella.

Vihje: Näistä Microsoft Creatorsin YouTube-videoista saat lisää ohjeita PHAKU-funktion kanssa!

Yksinkertaisin PHAKU-funktion muoto on seuraava:

=PHAKU(Etsittävä alue, josta haluat etsiä sitä, palautettavan arvon sisältävän alueen sarakenumero, palauttaa summittaisen tai tarkan vastineen, joka ilmaistaan arvolla 1/TOSI tai 0/EPÄTOSI).

Selaimesi ei tue videotoimintoa.

Vihje: PHAKU-funktion salassa on järjestää tiedot niin, että etsimäsi arvo (Hedelmät) on etsimäsi palautusarvon (Summa) vasemmalla puolella.

PHAKU-funktion avulla voit etsiä arvon taulukosta.

Syntaksi

PHAKU (hakuarvo; taulukko_matriisi; sar_indeksi_nro; [alue_haku])

Esimerkki:

  • =PHAKU(A2;A10:C20;2;TOSI)

  • =PHAKU("Sallinen",B2:E7,2,EPÄTOSI)

  • =PHAKU(A2;'Asiakastiedot'! A:F,3,EPÄTOSI)

Argumentin nimi

Kuvaus

hakuarvo    (pakollinen)

Tämä on haettava arvo. Etsittävän arvon on oltava solualueen ensimmäisessä sarakkeessa, jonka määrität table_array argumentissa.

Jos taulukko-matriisi kattaa esimerkiksi solut B2:D7, lookup_value on oltava sarakkeessa B.

Hakuarvo voi olla arvo tai solun viittaus.

taulukko_matriisi    (pakollinen)

Solualue, jolta PHAKU etsii hakuarvoa ja palautusarvoa. Voit käyttää nimettyä aluetta tai taulukkoa, ja voit käyttää argumentissa nimiä soluviittausten sijaan. 

Solualueen ensimmäisen sarakkeen on sisällettävä lookup_value. Solualueeseen on sisällytettävä myös etsittävä palautusarvo.

Katso lisätietoja laskentataulukon alueiden valitsemisesta.

sar_indeksi_nro    (pakollinen)

Palautusarvon sisältävä sarakenumero (alkaen numerosta 1 rivintable_array vasemmanpuoleisimman sarakkeen numerosta).

alue_haku   (valinnainen)

Totuusarvo, jolla määritetään, hakeeko PHAKU epätarkan vai tarkan vastineen:

  • Arvioitu vastine – 1/TOSI olettaa, että taulukon ensimmäinen sarake on lajiteltu joko numero- tai aakkosjärjestykseen ja etsii sitten lähimmän arvon. Tämä on oletusarvoinen menetelmä, jos muuta ei ole määritetty. Esimerkiksi =PHAKU(90;A1:B100;2;TOSI).

  • Tarkka vastine – 0/EPÄTOSI etsii täsmällistä arvoa ensimmäisestä sarakkeesta. Esimerkiksi =PHAKU("Smith";A1:B100;2;EPÄTOSI).

Näin pääset alkuun

Anna seuraavat neljä tietoa, jotta voit muodostaa PHAKU-funktion syntaksin:

  1. Hakemasi arvo, eli hakuarvo.

  2. Alue, jossa hakuarvo sijaitsee. Muista, että hakuarvon tulisi aina löytyä alueen ensimmäisestä sarakkeesta, jotta PHAKU-funktio toimisi oikein. Jos esimerkiksi hakuarvo on solussa C2, määrittämäsi alueen tulisi alkaa sarakkeesta C.

  3. Hakualueen sarakenumero, joka sisältää palautusarvon. Jos esimerkiksi määrität alueeksi B2:D11, sinun on laskettava B ensimmäiseksi sarakkeeksi, C toiseksi ja niin edelleen.

  4. Voit halutessasi antaa määritelmän TOSI, jos haluat palautusarvon epätarkan vastineen tai EPÄTOSI, jos haluat palautusarvon tarkan vastineen. Jos et määritä mitään, oletusarvona on aina TOSI tai epätarkka vastine.

Nyt yhdistä kaikki edellä mainitut seuraavasti:

=PHAKU(hakuarvo, hakuarvon sisältävä alue, palautusarvon sisältävän alueen sarakenumero, arvioitu vastine (TOSI) tai Tarkka vastine (EPÄTOSI)).

Esimerkkejä

Seuraavassa on muutamia esimerkkejä PHAKU-funktiosta:

Esimerkki 1

PHAKU-funktion 1. esimerkki

Esimerkki 2

PHAKU-funktion 2. esimerkki

Esimerkki 3

PHAKU-funktion 3. esimerkki

Esimerkki 4

PHAKU-funktion 4. esimerkki

Esimerkki 5

PHAKU-funktion 5. esimerkki

PHAKU-funktion avulla voit yhdistää useita taulukoita yhdeksi taulukoksi, kunhan yhdellä taulukoista on yhteisiä kenttiä muiden kanssa. Tämä voi olla erityisen hyödyllistä, jos haluat jakaa työkirjan niiden käyttäjien kanssa, joilla on vanhempi Excel-versio, jotka eivät tue tietoominaisuuksia, joissa on useita taulukoita tietolähteinä – yhdistämällä lähteet yhteen taulukkoon ja muuttamalla tietoominaisuuden tietolähteen uuteen taulukkoon, tietoominaisuutta voidaan käyttää vanhemmissa Excel-versioissa (jos vanhempi versio tukee tieto-ominaisuutta).

Laskentataulukko, jossa on sarakkeita, jotka käyttävät PHAKU-funktiota tietojen keruussa muista taulukoista

Sarakkeissa A–F ja H on arvoja tai kaavoja, jotka käyttävät vain arvoja laskentataulukossa, ja muut sarakkeet käyttävät PHAKU-funktiota sekä sarakkeen A (asiakaskoodi) ja sarakkeen B (Attorney) arvoja tietojen saamiseen muista taulukoista.

  1. Kopioi taulukko, jossa on yhteisiä kenttiä, uuteen laskentataulukkoon ja anna sille nimi.

  2. Avaa Yhteyksien hallinta > tietotyökalujen > Yhteydet-valintaikkuna valitsemalla Tietotyökalut.

    Yhteyksien hallinta -valintaikkuna
  3. Ota huomioon seuraavat seikat kunkin luettelossa olevan yhteyden suhteen suhteen mukaisesti:

    • Kenttä, joka linkittää taulukot (lueteltu valintaikkunan sulkeissa). Tämä on lookup_value PHAKU-kaavan kaava.

    • Liittyvän hakutaulukon nimi. Tämä on table_array PHAKU-kaavassa.

    • Aiheeseen liittyvän hakutaulukon kenttä (sarake), joka sisältää uuteen sarakkeeseen haluasi tiedot. Näitä tietoja ei näytetä Yhteyksien hallinta -valintaikkunassa. Sinun on katsottava aiheeseen liittyvää hakutaulukkoa, jotta näet, minkä kentän haluat noutaa. Haluat ottaa huomioon sarakkeen numeron (A=1) – tämä on col_index_num kaavassa.

  4. Jos haluat lisätä kentän uuteen taulukkoon, kirjoita PHAKU-kaava ensimmäiseen tyhjään sarakkeeseen vaiheessa 3 kerättyjen tietojen avulla.

    Tässä esimerkissä sarake G käyttää Attorney-taulukkoa (lookup_value)laskun korkotietojen saamiseen neljännestä sarakkeesta(col_index_num = 4) Attorneys-laskentataulukkotaulukosta tblAttorneys (table_array)kaavalla =PHAKU([@Attorney],tbl_Attorneys,4,EPÄTOSI).

    Kaava voi käyttää myös soluviittausta ja alueviittausta. Tässä esimerkissä se olisi =PHAKU(A2,'Attorneys'! A:D,4,FALSE).

  5. Jatka kenttien lisäämistä, kunnes sinulla on kaikki tarvittavat kentät. Jos yrität valmistella useita taulukoita sisältäviä tietoominaisuuksia sisältävän työkirjan, muuta tietoominaisuuden tietolähde uuteen taulukkoon.

Ongelma

Mistä ongelma johtuu?

Väärä arvo palautettiin

Jos alue_haku on TOSI tai se on jätetty pois, ensimmäinen sarake on lajiteltava numero- tai aakkosjärjestykseen. Jos ensimmäistä saraketta ei ole lajiteltu, palautusarvo voi olla odottamaton. Lajittele ensimmäinen sarake tai hae tarkka vastine EPÄTOSI-funktiolla.

#PUUTTUU! solussa

  • Jos alue_haku on TOSI ja hakuarvo on pienempi kuin taulukko_matriisin ensimmäisen sarakkeen pienin arvo, palautetaan virhearvo #PUUTTUU!.

  • Jos alue_haku on EPÄTOSI, #PUUTTUU!-virhearvo tarkoittaa, ettei tarkkaa lukua löydy.

Lisätietoja PHAKU-funktion #PUUTTUU!-virhearvon ratkaisemiseksi löytyy kohdasta PHAKU-funktion #PUUTTUU-virheen korjaaminen.

#VIITTAUS! solussa

Jos col_index_num on suurempi kuin taulukko matriisin sarakkeiden määrä,saat #REF! -virhearvon.

Lisätietoja ongelmien ratkaisemisesta #REF! -virheet PHAKU-funktiossa, katso ohjeet #REF! -virheen korjaamiseen.

#ARVO! solussa

Jos table_array on pienempi kuin 1, saat #VALUE! -virhearvon.

Lisätietoja ongelmien ratkaisemisesta #VALUE! -virheet PHAKU-funktiossa, katso PHAKU-funktion #VALUE!-virheen korjaaminen.

#NIMI? solussa

#NIMI? -virhearvo tarkoittaa yleensä, että kaavasta puuttuvat lainausmerkit. Kun etsit henkilön nimeä, varmista, että nimi on lainausmerkeissä kaavassa. Kirjoita esimerkiksi nimi muodossa "Sallinen" kaavassa =PHAKU("Sallinen",B2:E7,2,EPÄTOSI).

Lisätietoja on kohdassa #NAME!.

#SPILL! solussa

Tämä #SPILL! -virhe tarkoittaa yleensä sitä, että kaava käyttää hakuarvon implisiittistä risteyskohtaa ja käyttää koko saraketta viitteenä. Esimerkiksi =PHAKU( A:A,A:C,2,EPÄTOSI). Voit ratkaista ongelman ankkuroitumalla hakuviittauksen @-operaattoriin seuraavasti: =PHAKU( @A:A,A:C,2,EPÄTOSI). Vaihtoehtoisesti voit käyttää perinteistä PHAKU-menetelmää ja viitata yksittäiseen soluun koko sarakkeen sijaan: =PHAKU(A2,A:C,2,EPÄTOSI).

Tee näin

Miksi

Käytä suoria viittauksia alue_haussa

Suorien viittausten avulla voit täyttää kaavan siten, että se suorittaa haun aina samalla hakualueella.

Katso lisätietoja suorien soluviittausten käyttämisestä.

Älä tallenna luku- tai päivämääräarvoja tekstinä.

Kun etsit lukua tai päivämääräarvoja, varmista, että taulukko_matriisi-argumentin ensimmäisen sarakkeen tiedot on tallennettu tekstiarvoina. Muussa tapauksessa PHAKU-funktio saattaa palauttaa virheellisen tai odottamattoman arvon.

Ensimmäisen sarakkeen lajitteleminen

Lajittele taulukko_matriisin ensimmäinen sarake ennen PHAKU-funktion käyttämistä, jos alue_haku on TOSI.

Yleismerkkien käyttäminen

Jos range_lookup on EPÄTOSI ja lookup_value on tekstiä, voit käyttää lookup_value. Kysymysmerkki vastaa mitä tahansa yksittäistä merkkiä. Tähti vastaa mitä tahansa merkkijonoa. Jos haluat löytää todellisen kysymysmerkin tai tähden, kirjoita tilde (~) merkin eteen.

Esimerkiksi =PHAKU("Fontti?",B2:E7,2,EPÄTOSI) etsii kaikki Teesnä-esiintymät, joiden viimeinen kirjain voi vaihdella.

Varmista, ettei tiedoissa ole virheellisiä merkkejä.

Kun etsit tekstiarvoja ensimmäisestä sarakkeesta, tarkista, että ensimmäisen sarakkeen tietojen alussa tai lopussa ei ole välilyöntejä ja etteivät tiedot sisällä epäyhtenäisesti käytettyjä suoria (' tai ") ja kaarevia (‘ tai “) lainausmerkkejä tai tulostumattomia merkkejä. Muussa tapauksessa PHAKU-funktio saattaa palauttaa odottamattoman arvon.

Lopussa olevat välilyönnit täytyy ehkä poistaa, jotta saat tarkat tulokset. KokeileSIIVOA-funktiota tai POISTA.VÄLIT-funktiota.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Pikaopas: PHAKU-kertaus
Pikaopas: PHAKU-funktion vianmääritysvinkkejä
YouTube: PHAKU-videot Microsoft Creatorsilta
PHAKU-funktion #VALUE!-virheen korjaaminen
PHAKU-funktion #N/A-virheen korjaaminen
Yleistä Excelin kaavoista
Katkenneiden kaavojen vältteleminen
Kaavoissa havaittujen virheiden etsiminen
Excelin funktiot (aakkosjärjestyksessä)
Excel-funktiot (luokittain)
PHAKU (ilmainen esikatselu)

Tarvitsetko lisäohjeita?

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×