A #HIV! hiba javítása

A #HIV! hiba akkor jelenik meg, amikor egy képlet egy nem érvényes cellára hivatkozik. Ez akkor történik a leggyakrabban, ha a képletek által hivatkozott cellákat törlik, vagy tartalmat illesztenek be rájuk.

Példa – Oszlop törlésével okozott #HIV! hiba

A következő példa a =SZUM(B2,C2,D2) képletet használja az E oszlopban.

Az explicit cellahivatkozásokat használó képletek, mint amilyen például a =SZUM(B2,C2,D2), egy oszlop törlése esetén #HIV! hibát okoznak.

A B, a C vagy a D oszlop törlése #HIV! hibát okozna. Ebben az esetben a C oszlopot (2007-es értékesítés) fogjuk törölni, így a képlet a következő lesz: =SZUM(B2,#HIV!,C2). Amikor ehhez hasonló explicit cellahivatkozást használ (ahol az egyes cellákra egyenként hivatkozik, vesszővel elválasztva), és töröl egy hivatkozott sort vagy oszlopot, az Excel nem tudja azt feloldani, ezért #HIV! hibát ad vissza. Ez az elsődleges oka annak, hogy nem ajánlott az explicit cellahivatkozások használata a függvényekben.

Példa egy oszlop törlésével okozott #HIV! hibára.

Megoldás

  • Ha véletlenül törölt sorokat vagy oszlopokat, akkor a Visszavonás gombra vagy a gyorselérési eszköztárra kattintva (illetve a CTRL+Z billentyűkombinációval) azonnal visszaállíthatja őket.

  • Módosítsa úgy a képletet, hogy az az egyéni cellák helyett tartományhivatkozást használjon, például =SZUM(B2:D2). Most már bármilyen oszlopot törölhet az összegtartományon belül, és az Excel ennek megfelelően automatikusan módosítani fogja a képletet. Sorok összegzéséhez a =SZUM(B2:B5) képletet is használhatja.

Példa – Helytelen tartományhivatkozásokat tartalmazó FKERES függvény

A következő példában az =FKERES(A8;A2:D5;5;HAMIS) visszatérési értéke egy #REF! hibát ad vissza, mivel az 5. oszlopból keres egy értéket, de a hivatkozási tartomány az A:D, amely csak 4 oszlop.

Példa az FKERES képletre helytelen tartománnyal.  A képlet a következő: =FKERES(A8,A2:D5,5,HAMIS).  Az FKERES tartományában nincs ötödik oszlop, ezért az 5-ös érték #HIV! hibát okoz.

Megoldás

Megnövelheti a tartományt, vagy csökkentheti az oszlop keresési értékét úgy, hogy az megfeleljen a hivatkozási tartománynak. Az =FKERES(A8,A2:E5,5,HAMIS) egy érvényes hivatkozási tartomány, mint ahogyan az =FKERES(A8,A2:D5,4,HAMIS) is.

Példa – Helytelen sor- vagy oszlophivatkozással rendelkező INDEX függvény

Ebben a példában az =INDEX(B2:E5;5;5) képlet egy #REF! hibát adja vissza, mivel az INDEX tartománya 4 sorból és 4 oszlopból áll, a képlet azonban azt kéri, hogy adja vissza az 5. sorban és az 5. oszlopban lévő adatokat.

Példa INDEX képletre érvénytelen tartományhivatkozással.  A képlet a következő: =INDEX(B2:E5,5,5), de a tartomány mindössze 4 sorból és 4 oszlopból áll.

Megoldás

Módosítsa úgy a sor- vagy oszlophivatkozásokat, hogy azok az INDEX keresési tartományán belülre essenek. Az =INDEX(B2:E5,4,4) érvényes eredményt ad vissza.

Példa – Hivatkozás bezárt munkafüzetre az INDIREKT függvénnyel

A következő példában egy INDIREKT függvény egy bezárt munkafüzetre kísérel meg hivatkozni, és ez #HIV! hibát okoz.

Példa egy bezárt munkafüzetre való KÖZVETLEN hivatkozással okozott #HIV! hibára.

Megoldás

Nyissa meg a hivatkozott munkafüzetet. Ugyanez a hibaüzenet jelenik meg, ha egy dinamikus tömbképletet tartalmazó bezárt munkafüzetre hivatkozik.

OLE-problémák

Ha egy #HIV! hibát okozó objektumcsatolási és -beillesztési (OLE-) hivatkozást használt, akkor indítsa el a hivatkozás által meghívott programot.

Megjegyzés: Az OLE egy olyan technológia, amellyel információkat oszthat meg a programok között.

DDE-problémák

Ha olyan Dynamic Data Exchange (DDE) témaköre van, amely #HIV! hibát, először ellenőrizze, hogy a megfelelő témakörre hivatkozik-e. Ha továbbra is kap egy #REF! hiba miatt ellenőrizze, hogy az Adatvédelmi központ beállításai között a Külső tartalmak blokkolása vagy letiltásának feloldása című lapon ismertetettek szerint nem jelenik-e meg külső tartalom az Office-dokumentumokban.

Megjegyzés: A Dynamic Data Exchange (DDE)a Microsoft Windows-alapú programok közötti adatcsere protokollja.

Makróproblémák

Ha egy makró olyan függvényt ír be a munkalapra, amely a függvény fölötti cellára hivatkozik, és a függvényt tartalmazó cella az 1. sorban található, a függvény a következőt #REF! mivel az 1. sor felett nincsenek cellák. Ellenőrizze a függvényt, hogy egy argumentum nem hivatkozik-e érvénytelen cellára vagy cellatartományra. Ehhez szükség lehet a makró szerkesztésére a Visual Basic Editorban (VBE), hogy ezt a helyzetet is figyelembe vegye.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

A képlethibák feltárása

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

További segítségre van szüksége?

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×