Az operátorok határozzák meg, hogy milyen típusú számításokat szeretne végrehajtani a képlet elemein ( például összeadás, kivonás, szorzás vagy osztás). Ebben a cikkben megismerheti az alapértelmezett sorrendet, amelyben az operátorok egy számítás elemeire reagálnak. Azt is megtudhatja, hogyan módosíthatja ezt a sorrendet zárójelek használatával.

Operátortípusok

Az Excel a következő négy operátortípust tartalmazza: számtani, összehasonlító, szövegösszefűző és hivatkozási operátor.

Egyszerű matematikai műveletek, például összeadás, kivonás vagy szorzás – vagy számok összevonása – végrehajtásához és numerikus eredmények előállításához használja a táblázatban szereplő aritmetikai operátorokat.

Számtani operátor

Jelentés

Példa

+ (pluszjel)

Összeadás

=3+3

– (mínuszjel)

Kivonás
Tagadás

=3–1
=–1

* (csillag)

Szorzás

=3*3

/ (törtjel)

Osztás

=3/3

% (százalékjel)

Százalékszámítás

=20%

^ (kalap)

Hatványra emelés

=2^3

Az alábbi táblázatban szereplő operátorokkal két értéket hasonlíthat össze. Ha két értéket hasonlít össze ezekkel az operátorokkal, az eredmény egy IGAZ vagy HAMIS logikai érték.

Összehasonlító operátor

Jelentés

Példa

= (egyenlőségjel)

Egyenlő

=A1=B1

> (nagyobb, mint jel)

Nagyobb

=A1>B1

< (kisebb, mint jel)

Kisebb

=A1<B1

>= (nagyobb vagy egyenlő jel)

Nagyobb vagy egyenlő

=A1>=B1

<= (kisebb vagy egyenlő jel)

Kisebb vagy egyenlő

=A1<=B1

<> (nem egyenlő jel)

Nem egyenlő

=A1<>B1

Az és (&) segítségével egyetlen szövegrészt hozhat létre egy vagy több szöveges sztring összekapcsolásához vagy összefűzéséhez.

Szövegösszefűző

Jelentés

Példa

& (és karakter)

Két érték összekapcsolása vagy összefűzése egy folyamatos szöveges érték előállításához.

="Észak"&"szél"

Cellatartományok kombinálása számításhoz ezekkel az operátorokkal.

Hivatkozási operátor

Jelentés

Példa

: (kettőspont)

Tartományoperátor, amely a két hivatkozás közötti összes cellára (beleértve a két hivatkozást is) egyetlen hivatkozást eredményez

=SZUM(B5:B15)

; (pontosvessző)

Union operátor, amely több hivatkozást egyesít egyetlen hivatkozással.

=SZUM(B5:B15;D5:D15)

(szóköz)

Metszet operátor, amely a két hivatkozással közös cellákra mutató hivatkozást hoz létre.

=SZUM(B7:D7 C6:C8)

# (font)

A # szimbólum több környezetben is használható:

  • Hibanév részeként használatos.

  • A megjelenítéshez nem elegendő hely jelölésére szolgál. A legtöbb esetben szélesítheti az oszlopot, amíg a tartalom megfelelően nem jelenik meg.

  • Kibontott tartományoperátor, amely egy teljes tartományra hivatkozik egy dinamikus tömbképletben.

  • #ÉRTÉK!

  • #####

  • =SZUM(A2#)

@ (at)

Hivatkozási operátor, amely egy képlet implicit metszetét jelzi. 

=@A1:A10

=SZUM(1. tábla[@[Január]:[December]])

Műveletek végrehajtási sorrendje képletekben

Bizonyos esetekben a számítás végrehajtásának sorrendje befolyásolhatja a képlet visszatérési értékét, ezért fontos megérteni a sorrendet, és hogy hogyan módosíthatja a sorrendet a várt eredmények eléréséhez.

A képletek adott sorrendben számítják ki az értékeket. A Excel képletei mindig egyenlőségjellel (=) kezdődnek. Az egyenlőségjel azt jelzi Excel, hogy az ezt követő karakterek képletet alkotnak. Az egyenlőségjel után kiszámítandó elemek (operandusok) sorozata is lehet, amelyeket számítási operátorok választanak el egymástól. Excel balról jobbra számítja ki a képletet a képlet egyes operátorainak meghatározott sorrendje alapján.

Ha egyetlen képletben több operátort ad meg, az Excel a műveleteket az alábbi táblázat szerinti sorrendben hajtja végre. A képlet azonos prioritású műveleteit (például szorzás és osztás) az Excel balról jobbra haladva értékeli ki.

Operátor

Leírás

: (kettőspont)

(szóköz)

; (pontosvessző)

Hivatkozási operátorok

Ellentett képzése (például –1)

%

Százalék

^

Hatványra emelés

* és /

Szorzás és osztás

+ és –

Összeadás és kivonás

&

Karaktersorozatok összefűzése

=
< >
<=
>=
<>

Összehasonlítás

A végrehajtási sorrend módosításához az elsőnek kiértékelni kívánt képletrészt írja zárójelek közé. Az alábbi képlet például 11 értéket ad eredményként, mivel Excel szorzást számít ki az összeadás előtt. A képlet először megszorozza a 2-t 3-tal, majd hozzáad 5-öt az eredményhez.

=5+2*3

Ezzel szemben, ha zárójelek használatával módosítja a szintaxist, Excel összeadja az 5-öt és a 2-t, majd megszorozza az eredményt 3-tal a 21 előállításához.

=(5+2)*3

Az alábbi példában a képlet első részét tartalmazó zárójelek arra kényszerítik Excel, hogy először a B4+25 értéket számítsa ki, majd ossza el az eredményt a D5, E5 és F5 cellák értékeinek összegével.

=(B4+25)/SZUM(D5:F5)

További információért tekintse meg ezt a videót az operátori sorrendről Excel.

Hogyan konvertálja Excel a képletekben szereplő értékeket?

Képlet beírásakor Excel az egyes operátorokhoz meghatározott típusú értékeket vár. Ha a várttól eltérő típusú értéket ad meg, Excel átalakíthatja az értéket.

A képlet

Termel

Ismertetés

= "1"+"2"

3

Ha pluszjelet (+) használ, Excel számokat vár a képletben. Bár az idézőjelek azt jelentik, hogy az "1" és a "2" szöveges érték, Excel automatikusan számmá alakítja a szöveges értékeket.

= 1+"$4.00"

5

Ha egy képlet számot vár, Excel átalakítja a szöveget, ha olyan formátumban van, amelyet általában elfogadna egy számhoz.

= "6/1/2001"-"5/1/2001"

31

Excel a szöveget é.hh.nn. formátumban dátumként értelmezi, a dátumokat sorozatszámokká alakítja, majd kiszámítja a különbséget közöttük.

=GYÖK ("8+1")

#ÉRTÉK!

Excel nem tudja számmá alakítani a szöveget, mert a "8+1" szöveg nem alakítható számmá. A "8+1" helyett a "9" vagy a "8"+"1" értéket használhatja a szöveg számmá alakításához és a 3 eredményének visszaadásához.

= "A"&IGAZ

ATRUE

Ha szöveg várható, Excel számokat és logikai értékeket (például IGAZ és HAMIS) szöveggé alakít át.

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×