Argomenti correlati
×
Celle
Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.
Celle

Importare o esportare file di testo (txt o csv)

Esistono due modi per importare dati da un file di testo con Excel: è possibile aprirli in Excel oppure importarli come intervallo di dati esterno. Per esportare dati da Excel in un file di testo, usare il comando Salva con nome e cambiare il tipo di file dal menu a discesa.

Esistono due formati di file di testo usati comunemente:

  • File di testo delimitato (con estensione txt), nel quale in genere i campi di testo sono separati dal carattere di tabulazione (codice carattere ASCII 009).

  • File di testo con valori separati da virgola (con estensione csv), nel quale in genere i campi di testo sono separati dal carattere virgola (,).

È possibile modificare il carattere separatore usato in entrambi i tipi di file. Questo può essere necessario in modo che le operazioni di importazione ed esportazioni operino nel modo desiderato.

Nota: È possibile importare o esportare fino a 1.048.576 righe e 16.384 colonne.

Importare un file di testo aprendolo in Excel

È possibile aprire un file di testo creato in un'altra applicazione come cartella di lavoro di Excel usando il comando Apri. L'apertura in Excel non comporta un cambiamento del formato del file di testo, come risulta dalla barra del titolo di Excel, nella quale per il nome del file viene mantenuta l'estensione di file originale, ad esempio txt o csv.

  1. Passare a File > Apri e passare al percorso che contiene il file di testo.

  2. Selezionare File di testo nell'elenco a discesa Tipo di file nella finestra di dialogo Apri .

  3. Ricercare e fare doppio clic sul file di testo da aprire.

    • Se il file è un file di testo (con estensione txt), verrà avviata l'Importazione guidata Testo. Dopo avere completato tutti i passaggi, fare clic su Fine per completare l'operazione di importazione. Per altre informazioni sui delimitatori e sulle opzioni avanzate, vedere Importazione guidata testo .

    • Se il file è un file con estensione csv, verrà aperto automaticamente e i relativi dati verranno visualizzati in una nuova cartella di lavoro.

      Nota: Quando si apre un file con estensione csv in Excel, vengono usate le impostazioni di formato dati predefinite correnti per interpretare la modalità di importazione di ogni colonna di dati. Se si vogliono convertire le colonne in formati di dati diversi, è possibile usare l'Importazione guidata testo. Si consideri ad esempio il caso in cui il formato di una colonna di dati del file con estensione csv sia MGA e il formato dati predefinito di Excel sia AMG, o il caso in cui si voglia convertire una colonna di numeri contenente zeri iniziali in testo al fine di mantenere tali zeri iniziali. Per forzare l'esecuzione dell'Importazione guidata Testo in Excel, è possibile modificare l'estensione del nome file da .csv a .txt prima di aprirla oppure è possibile importare un file di testo connettendosi ad esso (per altre informazioni, vedere la sezione seguente).

Importare un file di testo usando una connessione

È possibile importare dati da un file di testo in un foglio di lavoro esistente.

  1. Fare clic sulla cella in cui si vogliono inserire i dati dal file di testo.

  2. Nel gruppo Recupera & trasforma dati della scheda Dati fare clic su Da testo/CSV.

  3. Nella finestra di dialogo Importa dati individuare e fare doppio clic sul file di testo da importare e fare clic su Importa.

    Seguire le istruzioni dell'Importazione guidata testo. Fare clic su ? Icona del pulsante in qualsiasi pagina dell'Importazione guidata testo per altre informazioni sull'uso della procedura guidata. Al termine della procedura guidata, fare clic su Fine per completare l'operazione di importazione.

  4. Nella finestra di dialogo Importa dati eseguire le operazioni seguenti:

    1. In Indicare dove inserire i dati eseguire una delle operazioni seguenti:

      • Per riportare i dati nella posizione selezionata, fare clic su Foglio di lavoro esistente.

      • Per inserire i dati nell'angolo superiore sinistro di un nuovo foglio, fare clic su In un nuovo foglio di lavoro.

    2. Facoltativamente fare clic su Proprietà per impostare le opzioni di aggiornamento, formattazione e layout da applicare ai dati importati.

    3. Fare clic su OK.

      L'intervallo dei dati esterni verrà inserito nella posizione specificata.

Se una colonna di dati non viene convertita nel formato desiderato, è possibile convertire i dati dopo l'importazione. Per altre informazioni, vedere Convertire in numeri i numeri memorizzati come testo e Convertire in date le date archiviate come testo.

Esportare dati in un file di testo con il salvataggio

È possibile convertire un foglio di lavoro di Excel in un file di testo usando il comando Salva con nome.

  1. Passare a File > Salva con nome.

  2. Verrà visualizzata la finestra di dialogo Salva con nome.

  3. Nella casella Tipo file scegliere il formato del file di testo per il foglio di lavoro.

    • Ad esempio, fare clic su Testo (con valori delimitati da tabulazioni) o CSV (delimitato dal separatore di elenco).

    • Nota: I diversi formati supportano diversi set di caratteristiche. Per altre informazioni sui set di caratteristiche supportati per i formati di file di testo diversi, vedere Formati di file supportati in Excel.

  4. Passare al percorso in cui salvare il nuovo file di testo e quindi fare clic su Salva.

  5. Verrà visualizzata una finestra di dialogo che ricorda all'utente che solo il foglio di lavoro corrente verrà salvato nel nuovo file. Se si è certi che il foglio di lavoro corrente sia quello che si vuole salvare come file di testo, fare clic su OK. È possibile salvare altri fogli di lavoro come file di testo separati ripetendo questa procedura per ogni foglio.

  6. Verrà visualizzata una seconda finestra di dialogo, che ricorda all'utente che il foglio di lavoro potrebbe includere caratteristiche non supportate dai formati di file di testo. Se si è interessati esclusivamente a salvare i dati del foglio di lavoro nel nuovo file di testo, fare clic su . Se non si è certi e si vogliono ottenere altre informazioni sulle caratteristiche di Excel non supportate dai formati di file di testo, fare clic su ?.

Per altre informazioni sul salvataggio di file in altri formati, vedere Salvare una cartella di lavoro in un formato di file diverso.

Importare un file di testo tramite connessione (Power Query)

È possibile importare dati da un file di testo in un foglio di lavoro esistente.

  1. Nel gruppo Recupera & trasforma dati della scheda Dati fare clic su Da testo/CSV.

  2. Nella finestra di dialogo Importa dati individuare e fare doppio clic sul file di testo da importare e fare clic su Importa.

  3. Nella finestra di dialogo anteprima sono disponibili diverse opzioni:

    • Selezionare Carica per caricare i dati direttamente in un nuovo foglio di lavoro.

    • In alternativa, selezionare Carica in se si vogliono caricare i dati in una tabella, una tabella pivot o un grafico pivot, un foglio di lavoro di Excel esistente o nuovo oppure creare semplicemente una connessione. È anche possibile scegliere di aggiungere i dati al modello di dati.

    • Selezionare Trasforma dati se si vogliono caricare i dati in Power Query e modificarli prima di portarli in Excel.

Se Excel non converte una determinata colonna di dati nel formato desiderato, è possibile convertire i dati dopo l'importazione. Per altre informazioni, vedere Convertire in numeri i numeri memorizzati come testo e Convertire in date le date archiviate come testo.

Esportare dati in un file di testo con il salvataggio

È possibile convertire un foglio di lavoro di Excel in un file di testo usando il comando Salva con nome.

  1. Passare a File > Salva con nome.

  2. Fare clic su Sfoglia.

  3. Nella casella Tipo file della finestra di dialogo Salva con nome scegliere il formato di file di testo per il foglio di lavoro. Ad esempio, fare clic su Testo (delimitato da tabulazioni) o CSV (delimitato da virgole).

    Nota: I diversi formati supportano diversi set di caratteristiche. Per altre informazioni sui set di caratteristiche supportati per i formati di file di testo diversi, vedere Formati di file supportati in Excel.

  4. Passare al percorso in cui salvare il nuovo file di testo e quindi fare clic su Salva.

  5. Verrà visualizzata una finestra di dialogo che ricorda all'utente che solo il foglio di lavoro corrente verrà salvato nel nuovo file. Se si è certi che il foglio di lavoro corrente sia quello che si vuole salvare come file di testo, fare clic su OK. È possibile salvare altri fogli di lavoro come file di testo separati ripetendo questa procedura per ogni foglio.

    Potrebbe essere visualizzato anche un avviso sotto la barra multifunzione che indica che alcune caratteristiche potrebbero andare perse se si salva la cartella di lavoro in formato CSV.

Per altre informazioni sul salvataggio di file in altri formati, vedere Salvare una cartella di lavoro in un formato di file diverso.

Il modo in cui si modifica il delimitatore durante l'importazione varia a seconda di come si importa il testo.

  • Se si usa Recupera & Trasforma dati > Da testo/CSV, dopo aver scelto il file di testo e aver fatto clic su Importa, scegliere un carattere da usare nell'elenco in Delimitatore. È possibile vedere immediatamente l'effetto della nuova scelta nell'anteprima dei dati, in modo da essere certi di effettuare la scelta desiderata prima di procedere.

  • Se si usa l'Importazione guidata testo per importare un file di testo, è possibile modificare il delimitatore usato per l'operazione di importazione nel passaggio 2 dell'Importazione guidata testo. Nel passaggio 2 è anche possibile cambiare la modalità di gestione dei delimitatori consecutivi, ad esempio virgolette consecutive.

    Per altre informazioni sui delimitatori e sulle opzioni avanzate, vedere Importazione guidata testo .

Se si vuole usare un punto e virgola come separatore di elenco predefinito quando si salva con nome .csv, ma è necessario limitare la modifica a Excel, è consigliabile impostare il separatore decimale predefinito su una virgola. In questo modo Excel dovrà usare un punto e virgola per il separatore di elenco. Ovviamente, questo cambierà anche la modalità di visualizzazione dei numeri decimali, quindi valuta anche la possibilità di modificare il separatore delle migliaia per limitare la confusione.

  1. Deselezionare Opzioni di Excel > Opzioni avanzate di modifica >> Usare i separatori di sistema.

  2. Impostare separatore decimale su , (una virgola).

  3. Impostare il separatore delle migliaia su . (un punto).

Quando si salva una cartella di lavoro come file di .csv, il separatore di elenco predefinito (delimitatore) è una virgola. È possibile impostare questo carattere come separatore diverso usando le impostazioni dell'area geografica di Windows. 

Attenzione: La modifica dell'impostazione di Windows causerà una modifica globale nel computer, che interessa tutte le applicazioni. Per modificare solo il delimitatore per Excel, vedere Modificare il separatore di elenco predefinito per il salvataggio dei file come testo (.csv) in Excel.

  1. In Microsoft Windows 11 selezionare la barra di Search e digitare Impostazioni area geografica.

  2. Seleziona Impostazioni lingua amministrativa.

  3. Nella scheda Formati seleziona Impostazioni aggiuntive.

  4. Nella scheda Numeri della finestra di dialogo Personalizza formato digitare un carattere da usare come nuovo separatore nella casella Separatore di elenco.

  5. Selezionare OK due volte.

  1. In Microsoft Windows 10 fare clic con il pulsante destro del mouse sul pulsante Start e quindi scegliere Impostazioni.

  2. Fare clic su Data/ora & lingua e quindi su Area geografica nel riquadro sinistro.

  3. Nel riquadro principale, in Impostazioni internazionali, fare clic su Data, ora e impostazioni internazionali aggiuntive.

  4. In Area geografica fare clic su Cambia data, ora o formati numerici.

  5. Nella scheda Formato della finestra di dialogo Area geografica fare clic su Impostazioni aggiuntive.

  6. Nella scheda Numeri della finestra di dialogo Personalizza formato digitare un carattere da usare come nuovo separatore nella casella Separatore di elenco.

  7. Selezionare OK due volte.

  1. In Microsoft Windows fare clic sul pulsante Start e quindi scegliere Pannello di controllo.

  2. In Orologio e opzioni internazionali fare clic su Cambia data, ora o formato dei numeri.

  3. Nella scheda Formato della finestra di dialogo Area geografica fare clic su Impostazioni aggiuntive.

  4. Nella scheda Numeri della finestra di dialogo Personalizza formato digitare un carattere da usare come nuovo separatore nella casella Separatore di elenco.

  5. Selezionare OK due volte.

Nota:  Dopo aver cambiato il carattere separatore di elenco per il computer, tutti i programmi useranno il nuovo carattere come separatore. È possibile reimpostare il carattere predefinito eseguendo la medesima procedura.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto della Tech Community di Excel o ottenere supporto nelle Community.

Vedere anche

Importare dati da origini dati esterne (Power Query)

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×