Risoluzione dei problemi di ricerca in Outlook

Scegliere lo scenario che descrive meglio il problema di ricerca di Outlook:

Ricerca di Outlook non restituisce risultati

Quando non si ottengono risultati con la ricerca di Outlook, seguire questa procedura nell'ordine indicato:

  • In Windows 10: selezionare il pulsante Start , selezionare Impostazioni > Aggiorna & sicurezzae quindi fare clic su risoluzione dei problemi. Trovare e fare clic su ricerca e indicizzazionee quindi su Esegui lo strumento di risoluzione dei problemi.

  • In Windows 8,1: dall' iniziocercare le impostazioni. In Impostazionicercare la risoluzione dei problemie selezionare risoluzione dei problemi nei risultati della ricerca. Trovare ed eseguire lo strumento di risoluzione dei problemi di ricerca e indicizzazione .

  • In Windows 7: dall' inizioselezionare Pannello di controlloe quindi selezionare risoluzione dei problemi. Trovare ed eseguire lo strumento di risoluzione dei problemi di ricerca e indicizzazione .

  1. Avviare Outlook e fare clic nella casella Cerca.

  2. Selezionare Strumenti di ricerca > Stato indicizzazione nel menu Cerca.

  3. Quando viene visualizzata la finestra di dialogo stato indicizzazione , dovrebbe essere visualizzata la seguente procedura:

    Stato di indicizzazione per la ricerca in Outlook

Se Outlook non ha completato l'indicizzazione, prendere nota degli elementi rimanenti da indicizzare, attendere 5 minuti e quindi controllare di nuovo. Se il numero di elementi non è diminuito, procedere con il passaggio successivo.

  1. Avviare Outlook e fare clic nella casella Cerca.

  2. Selezionare Strumenti di ricerca > Percorsi di ricerca nel menu Cerca.

  3. Assicurarsi che tutti i file dati/archivi elencati siano selezionati.

  1. Fare clic sul menu Start di Windows e fare clic nella casella di ricerca .

  2. Digitare Services. msc e premere INVIO.

  3. Nella colonna nome individuare e fare doppio clic su ricerca Windows.

  4. Impostare il tipo di avvio su automatico (avvio ritardato) se non lo era già.

  5. Se lo stato del servizio non viene visualizzato in corso, fare clic sul pulsante Start sotto di esso per avviare il servizio.

  1. Uscire da Outlook.

  2. Aprire Opzioni di indicizzazione nel Pannello di controllo di Windows.

  3. Nella finestra di dialogo Opzioni di indicizzazione assicurarsi che Microsoft Outlook sia elencato nella colonna Percorsi inclusi.

  4. Se Microsoft Outlook non è elencato, selezionare Modifica e quindi fare clic per abilitare la casella di controllo accanto a Microsoft Outlook.

  5. Fare clic su OK e quindi selezionare Chiudi.

Eseguire questa procedura per assicurarsi che le opzioni di indicizzazione siano configurate correttamente:

  1. Uscire da Outlook.

  2. Aprire Opzioni di indicizzazione nel Pannello di controllo di Windows.

  3. Nella finestra di dialogo Opzioni di indicizzazione selezionare Avanzate.

  4. Selezionare la scheda Tipi di file.

  5. Scorrere verso il basso fino a individuare msg nella colonna Estensione e selezionare tale voce.

  6. Assicurarsi che l'opzione Indicizza le proprietà e il contenuto del file sia abilitata.

  7. Fare clic su OK e quindi selezionare Chiudi.

Nota: Assicurarsi che nella colonna Descrizione filtro sia visualizzato Office Outlook MSG IFilter. In caso contrario, il servizio Windows Search non funziona correttamente oppure Microsoft Outlook non è riuscito a installare i filtri correttamente. In entrambi i casi è necessario rivolgersi al supporto tecnico Microsoft per assistenza con questo problema.

  1. Uscire da Outlook.

  2. Aprire Opzioni di indicizzazione nel Pannello di controllo di Windows.

  3. Nella finestra di dialogo Opzioni di indicizzazione selezionare Avanzate.

  4. Nella finestra di dialogo Opzioni avanzate selezionare Nuovo indice.

  5. Fare clic su OK e quindi selezionare Chiudi.

Se l'indicizzazione non viene completata, contattare il supporto tecnico Microsoft e richiedere assistenza per la funzionalità Desktop Search di Windows.

Eseguire questa procedura per creare un nuovo profilo e testare la funzionalità di ricerca:

  1. In Outlook selezionare File > Impostazioni account > Gestisci profili. In alternativa, è possibile uscire da Outlook e aprire Posta nel Pannello di controllo di Windows.

  2. Nella finestra di dialogo Configurazione della posta - Outlook selezionare Mostra profili e quindi selezionare Aggiungi nella scheda Generale.

  3. Nella casella Nome profilo digitare un nome per il nuovo profilo e quindi scegliere OK.

  4. Se richiesto, fornire le informazioni dell'account, come indirizzo di posta elettronica e password, quindi selezionare Avanti.

  5. Selezionare Fine. Il nome del nuovo profilo aggiunto apparirà nella scheda Generale della finestra di dialogo Posta.

  6. In All'avvio di Microsoft Outlook selezionare Richiedi un profilo da utilizzare e quindi scegliere OK.

  7. Riavviare Outlook.

  8. Nell'elenco a discesa della finestra di dialogo Scegli profilo scegliere il nome del nuovo profilo creato e fare clic su OK.

  9. Fare clic nella casella Cerca e provare a eseguire la ricerca.

Se la ricerca funziona, il problema potrebbe dipendere dal vecchio profilo. È consigliabile impostare questo profilo come nuovo profilo predefinito e trasferire le informazioni dal vecchio al nuovo profilo.

La procedura per accedere allo strumento di ripristino varia in base al sistema operativo. Scegliere dall'elenco a discesa qui sotto.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere App e funzionalità dal menu a comparsa.

    Screenshot del menu Start che mostra App e funzionalità
  2. Selezionare l'applicazione di Microsoft Office da ripristinare e scegliere Modifica.

    Nota: È necessario ripristinare l'intera famiglia di prodotti di Office anche se si intende ripristinare una singola applicazione come Word o Excel. Se si dispone di un'app autonoma, cercare l'applicazione in base al nome.

  3. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, verranno visualizzate le seguenti opzioni con continuare con il ripristino. Seguire la procedura corrispondente al tipo di installazione.

    A portata di clic

    Nella finestra In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online > Ripristina in modo da eseguire un ripristino completo. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  4. Seguire le istruzioni sullo schermo per completare il processo.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere Pannello di controllo dal menu a comparsa.

    Elenco di opzioni e comandi visualizzati dopo aver premuto il tasto logo Windows + X
  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic con il pulsante destro del mouse sull'applicazione di Microsoft Office da ripristinare e scegliere Cambia dal menu a discesa.

    Nota: Se si ha una famiglia di prodotti come Microsoft 365 Family, Office Home & Student 2016 o Office Home and Student 2013, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

  1. Fare clic sul pulsante Start Pulsante Start di Windows 7 > Pannello di controllo.

  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic sull'applicazione di Office da ripristinare e quindi su Cambia.

    Nota: Se si ha una famiglia di prodotti come Microsoft 365 Family, Office Home & Student 2016 o Office Home and Student 2013, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

  1. Fare clic sul pulsante sotto per scaricare e installare lo strumento di supporto per la disinstallazione di Office.

  2. Seguire questa procedura per scaricare lo strumento di supporto per la disinstallazione in base al browser usato.

    Suggerimento: Il download e l'installazione dello strumento potrebbero richiedere alcuni minuti. Dopo aver completato l'installazione, verrà aperta la finestra Disinstalla i prodotti Office.

    Microsoft Edge o Chrome

    Nell'angolo in basso a sinistra fare clic con il pulsante destro del mouse su SetupProd_OffScrub.exe > Apri.

    Come trovare e aprire il file di download di Assistente supporto in un Web browser Chrome

    Microsoft Edge (precedente) o Internet Explorer

    Nella parte inferiore della finestra del browser selezionare Esegui per avviare SetupProd_OffScrub.exe.

    Come trovare e aprire il file di download di Assistente supporto in un Web browser Microsoft Edge o Internet Explorer

    Firefox

    Nella finestra a comparsa fare clic su Salva file e quindi in alto a destra nella finestra del browser selezionare la freccia di download > e quindi scegliere SetupProd_OffScrub.exe.

    Come trovare e aprire il file di download di Assistente supporto in un Web browser Chrome
  3. Selezionare la versione da disinstallare, quindi selezionare Avanti.

  4. Seguire le istruzioni nelle finestre rimanenti e, quando richiesto, riavviare il computer.

    Dopo aver riavviato il computer, lo strumento di disinstallazione si riapre automaticamente per completare il passaggio finale del processo di disinstallazione. Seguire i prompt rimanenti.

  5. Selezionare i passaggi per la versione di Office da installare o reinstallare. Chiudere lo strumento di disinstallazione.

    Microsoft 365 | Office 2019 | Office 2016 | Office 2013 | Office 2010 | Office 2007

Nota: Se questa procedura non è utile, provare la procedura avanzata in questo articolo: Nessun risultato della ricerca per gli account POP, IMAP o Exchange

La ricerca di Outlook restituisce risultati incompleti

Quando si ottengono risultati incompleti tramite la ricerca di Outlook, seguire questa procedura nell'ordine indicato:

Se i risultati della ricerca mancanti si trovano nella cartella Posta eliminata, è possibile aggiungere la cartella ai risultati della ricerca:

  1. Avviare Outlook.

  2. Fare clic su Opzionifile > e quindi selezionare Cerca.

  3. Selezionare la casella di controllo Includi messaggi dalla cartella Posta eliminata in ogni file di dati durante la ricerca in tutti gli elementi e quindi fare clic su OK.

  4. Riavviare Outlook.

È possibile aumentare l'orario delle impostazioni offline dell'account di posta elettronica in modo che più o tutti i messaggi vengano memorizzati nella cache localmente per l'indicizzazione. Per eseguire questa operazione:

  1. Avviare Outlook.

  2. Fare clic su File > Impostazioni account > Impostazioni account.

  3. Nella scheda posta elettronica selezionare l'account di posta elettronica e fare clic su Cambia.

  4. Trascinare il messaggio di posta elettronica download per il passato: dispositivo di scorrimento fino alla quantità di tempo desiderata o all'estrema destra per tutti.

  5. Fare clic su Avantie quindi su fine. Chiudere la finestra e riavviare Outlook.

Per impostazione predefinita, Outlook visualizzerà i risultati della ricerca di 250. Puoi aumentare la visualizzazione per visualizzare tutti i risultati, ma la ricerca sarà più lenta. Per eseguire questa operazione:

  1. Apri Outlook.

  2. Fare clic su Opzionifile > e quindi selezionare Cerca.

  3. Deselezionare la casella di controllo migliora la velocità di ricerca limitando il numero di risultati visualizzati e quindi fare clic su OK.

  4. Riavviare Outlook.

Quando si esegue una ricerca in Outlook usando tutte le cassette postali o tutti gli ambiti degli elementi di Outlook , per la cassetta postale di archiviazione vengono restituiti risultati limitati o nessun risultato. È possibile cercare gli elementi spostati in una cassetta postale di archiviazione espansa automaticamente solo eseguendo la ricerca nella cartella stessa. Selezionare la cartella di archiviazione nell'elenco delle cartelle per selezionare l'opzione cartella corrente come ambito di ricerca. Se una cartella in un'area di archiviazione espansa automaticamente contiene sottocartelle, è necessario eseguire la ricerca separatamente in ogni sottocartella. Per altre informazioni, vedere Panoramica dell'archiviazione illimitata in Microsoft 365.

Ricerca di Outlook non riesce a trovare i messaggi meno recenti

Quando non è possibile trovare messaggi di posta elettronica di età superiore a 6 mesi tramite la ricerca di Outlook, seguire questa procedura nell'ordine indicato:

Se i risultati della ricerca mancanti si trovano nella cartella Posta eliminata, è possibile aggiungere la cartella ai risultati della ricerca:

  1. Avviare Outlook.

  2. Fare clic su Opzionifile > e quindi selezionare Cerca.

  3. Selezionare la casella di controllo Includi messaggi dalla cartella Posta eliminata in ogni file di dati durante la ricerca in tutti gli elementi e quindi fare clic su OK.

  4. Riavviare Outlook.

È possibile aumentare l'orario delle impostazioni offline dell'account di posta elettronica in modo che più o tutti i messaggi vengano memorizzati nella cache localmente per l'indicizzazione. Per eseguire questa operazione:

  1. Avviare Outlook.

  2. Fare clic su File > Impostazioni account > Impostazioni account.

  3. Nella scheda posta elettronica selezionare l'account di posta elettronica e fare clic su Cambia.

  4. Trascinare il messaggio di posta elettronica download per il passato: dispositivo di scorrimento fino alla quantità di tempo desiderata o all'estrema destra per tutti.

  5. Fare clic su Avantie quindi su fine. Chiudere la finestra e riavviare Outlook.

Per impostazione predefinita, Outlook visualizzerà i risultati della ricerca di 250. Puoi aumentare la visualizzazione per visualizzare tutti i risultati, ma la ricerca sarà più lenta. Per eseguire questa operazione:

  1. Apri Outlook.

  2. Fare clic su Opzionifile > e quindi selezionare Cerca.

  3. Deselezionare la casella di controllo migliora la velocità di ricerca limitando il numero di risultati visualizzati e quindi fare clic su OK.

  4. Riavviare Outlook.

La scheda Cerca è in grigio (solo Outlook 2016)

Questo problema può verificarsi dopo l'aggiornamento a Windows 10 versione 1709 e versioni precedenti. Il problema è stato risolto in Windows 10 versioni 1803 e successive. Per risolvere il problema, eseguire questa procedura:

La procedura per accedere allo strumento di ripristino varia in base al sistema operativo. Scegliere dall'elenco a discesa qui sotto.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere App e funzionalità dal menu a comparsa.

    Screenshot del menu Start che mostra App e funzionalità
  2. Selezionare l'applicazione di Microsoft Office da ripristinare e scegliere Modifica.

    Nota: È necessario ripristinare l'intera famiglia di prodotti di Office anche se si intende ripristinare una singola applicazione come Word o Excel. Se si dispone di un'app autonoma, cercare l'applicazione in base al nome.

  3. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, verranno visualizzate le seguenti opzioni con continuare con il ripristino. Seguire la procedura corrispondente al tipo di installazione.

    A portata di clic

    Nella finestra In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online > Ripristina in modo da eseguire un ripristino completo. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  4. Seguire le istruzioni sullo schermo per completare il processo.

  1. Fare clic con il pulsante destro del mouse sul pulsante Start Pulsante Start di Windows in Windows 8 e Windows 10 nell'angolo in basso a sinistra e scegliere Pannello di controllo dal menu a comparsa.

    Elenco di opzioni e comandi visualizzati dopo aver premuto il tasto logo Windows + X
  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic con il pulsante destro del mouse sull'applicazione di Microsoft Office da ripristinare e scegliere Cambia dal menu a discesa.

    Nota: Se si ha una famiglia di prodotti come Microsoft 365 Family, Office Home & Student 2016 o Office Home and Student 2013, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

  1. Fare clic sul pulsante Start Pulsante Start di Windows 7 > Pannello di controllo.

  2. Nella visualizzazione Categoria selezionare Disinstalla un programma in Programmi.

  3. Fare clic sull'applicazione di Office da ripristinare e quindi su Cambia.

    Nota: Se si ha una famiglia di prodotti come Microsoft 365 Family, Office Home & Student 2016 o Office Home and Student 2013, cercare il nome della famiglia di prodotti, anche se si vuole ripristinare solo una singola applicazione come Word o Excel. Se si ha un'applicazione autonoma come Word o Excel, cercare il nome dell'applicazione.

  4. A seconda se la copia di Office è A portata di clic o un'installazione basata su MSI, eseguire la procedura seguente per il tipo di installazione di Office:

    Tipo di installazione A portata di clic:

    In In che modo si vogliono ripristinare le applicazioni di Office? selezionare Ripristino online in modo da eseguire un ripristino completo, quindi scegliere Ripristina. È disponibile anche l'opzione Ripristino rapido, che però rileva e sostituisce solo i file danneggiati.

    Tipo di installazione basata su MSI

    In Modifica installazione selezionare Ripristina e quindi fare clic su Continua.

  5. Seguire le istruzioni sullo schermo restanti per completare il processo.

Cassetta postale condivisa: problemi con i risultati della ricerca

Se non si ottengono risultati previsti da una ricerca di cassette postali condivise o si riceve un errore, eseguire una delle operazioni seguenti:

Disabilitare la ricerca del server come soluzione a breve termine. A questo scopo, procedere come segue:

Importante: La procedura seguente mostra come modificare il Registro di sistema. Tuttavia, la modifica non corretta del Registro di sistema può causare problemi gravi. Assicurarsi di seguire attentamente tutti i passaggi. Per una maggiore sicurezza, eseguire un backup del Registro di sistema prima di modificarlo, in modo che sia possibile ripristinarlo in caso di problemi. Per altre informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedere Come eseguire il backup e il ripristino del Registro di sistema in Windows.

  1. In Windows fare clic con il pulsante destro del mouse su Start, quindi selezionare Esegui. Nella casella Apri: digitare regedit e fare clic su OK. Si aprirà l'editor del Registro di sistema.

  2. Nella finestra di dialogo dell'editor del registro di sistema individuare questa sottochiave nel registro e quindi fare clic su di essa:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search

  3. Fare clic su Modifica > Nuovo > Valore DWORD.

  4. Digitare DisableServerAssistedSearch per il nome del valore DWORD e quindi premere INVIO.

  5. Fare clic con il pulsante destro del mouse su DisableServerAssistedSearch e quindi scegliere modifica.

  6. Nella casella dati valore Digitare 1 per abilitare la voce del registro di sistema e quindi fare clic su OK.

  7. Chiudere l'editor del registro di sistema e quindi riavviare Windows.

Nota: Questo criterio e altre importanti considerazioni sono documentate nel Blog di ricerca.

Per eseguire la ricerca in una cassetta postale condivisa, fare clic sulla cassetta postale e usare l'ambito della cartella corrente . Si tratta di un limite di progettazione attualmente in fase di elaborazione per gli aggiornamenti futuri. Per altre informazioni sugli ambiti supportati in questo Blog, vedere informazioni sugli ambiti di ricerca .

Per risolvere il problema, è possibile aggiungere la cassetta postale condivisa come account di Exchange secondario al profilo. Prima di tutto è necessario verificare se la cassetta postale condivisa è già elencata come account nel profilo. In caso affermativo, sarà necessario rimuoverlo. A questo scopo, procedere come segue:

  • Scegliere Impostazioni accountdal menu file , quindi fare di nuovo clic su Impostazioni account .

  • Fare doppio clic sull'account di Exchange.

  • Scegliere altre impostazionie quindi selezionare la scheda Avanzate .

  • Nella sezione aprire le cassette postali aggiuntive scegliere la cassetta postale condivisa e quindi scegliere Rimuovi.

Aggiungere una cassetta postale condivisa come account secondario al profilo seguendo questa procedura:

  • Scegliere Aggiungi accountdal menu file .

  • In questa finestra di dialogo inserire il nome completo della cassetta postale, ad esempio support@company.com.

  • Quando viene richiesto di immettere una password, scegliere l'opzione di accesso con un altro account e utilizzare le credenziali dell'account di Exchange con le autorizzazioni per la cassetta postale condivisa.

Quando si cerca una cassetta postale condivisa aggiunta come cassetta postale aggiuntiva, potrebbe essere visualizzato questo messaggio di errore:

"Si verificano problemi durante il recupero dei risultati dal server. Alcuni elementi potrebbero non essere inclusi nei risultati della ricerca. "

Questo problema si verifica se si usa una versione di Outlook per la licenza per il volume perpetuo (MSI). Si tratta attualmente di una limitazione con le versioni perpetue di Office.

Per risolvere questo problema, è possibile disabilitare la ricerca del server come soluzione a breve termine. A questo scopo, procedere come segue:

Importante: La procedura seguente mostra come modificare il Registro di sistema. Tuttavia, la modifica non corretta del Registro di sistema può causare problemi gravi. Assicurarsi di seguire attentamente tutti i passaggi. Per una maggiore sicurezza, eseguire un backup del Registro di sistema prima di modificarlo, in modo che sia possibile ripristinarlo in caso di problemi. Per altre informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedere Come eseguire il backup e il ripristino del Registro di sistema in Windows.

  1. In Windows fare clic con il pulsante destro del mouse su Start, quindi selezionare Esegui. Nella casella Apri: digitare regedit e fare clic su OK. Si aprirà l'editor del Registro di sistema.

  2. Nella finestra di dialogo dell'editor del registro di sistema individuare questa sottochiave nel registro e quindi fare clic su di essa:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search

  3. Fare clic su Modifica > Nuovo > Valore DWORD.

  4. Digitare DisableServerAssistedSearch per il nome del valore DWORD e quindi premere INVIO.

  5. Fare clic con il pulsante destro del mouse su DisableServerAssistedSearch e quindi scegliere modifica.

  6. Nella casella dati valore Digitare 1 per abilitare la voce del registro di sistema e quindi fare clic su OK.

  7. Chiudere l'editor del registro di sistema e quindi riavviare Windows.

Nota: Questo criterio e altre importanti considerazioni sono documentate nel Blog di ricerca.

In Microsoft Outlook 2016 per Mac potrebbe essere visualizzato un messaggio "nessun risultato" quando si tenta di cercare un messaggio di posta elettronica o si applica un filtro a una cartella e gli elementi delle attività non vengono visualizzati nella cartella attività. Inoltre, quando si cercano gli elementi di posta elettronica usando la ricerca in evidenza nativa di Mac OS, la ricerca potrebbe non essere riuscita.

Ciò può verificarsi per i motivi seguenti:

  • L'indicizzazione della ricerca in evidenza è incompleta.

  • Il nome del profilo contiene caratteri speciali, ad esempio la barra (/).

  • Il profilo o una delle cartelle padre viene aggiunto alla scheda privacy in Spotlight.

  • La cartella profili di Outlook 15 non si trova in ~/Library/Group Containers/UBF8T346G9. Office/Outlook.

  • L'indice di ricerca in evidenza è danneggiato.

Per risolvere il problema, eseguire le operazioni seguenti:

  1. Eseguire l'utilità OutlookSearchRepair.

  2. Se di recente è stato creato un nuovo profilo di Outlook in Outlook 2016 per Mac, è stato aggiunto un nuovo account o se sono stati recentemente importati nuovi dati da un'origine, ad esempio un file PST o OLM, l'indicizzazione in evidenza potrebbe non essere completa. In questo caso, Outlook per Mac Visualizza un messaggio "nessun risultato". Per risolvere il problema, attendere il completamento dell'indicizzazione e quindi eseguire di nuovo la ricerca.

  3. Verificare che il nome del profilo in Outlook 2016 per Mac non contenga caratteri speciali, ad esempio la barra (/).

Per visualizzare il profilo o il nome dell'identità in Outlook 2016 per Mac:

  1. Fare clic su Vai, applicazioni.

  2. Right-Click Microsoft Outlook e selezionare Mostra contenuto del pacchetto.

  3. Espandere content, SharedSupport e aprire Outlook Profile Manager.


Se il nome del profilo o dell'identità contiene un carattere speciale, eseguire la procedura seguente per cambiare il nome:

  1. Aprire la cartella del profilo di Outlook 2016 per Mac disponibile in:/utenti/<nomeutente>/Library/Group Containers/UBF8T346G9. Profili di Office/Outlook/Outlook 15/

  2. Rinominare il nome della cartella del profilo di Outlook 2016 per Mac e rimuovere i caratteri speciali.

Se il problema è ancora irrisolto, l'indice dei riflettori potrebbe essere danneggiato. Per reindicizzare l'indice Spotlight, eseguire le operazioni seguenti:

  1. Riavviare il Mac, in modo che riavvii i servizi Spotlight.

  2. Passare al Finder > applicazioni > utilità > terminale.

  3. Digitare mdimport-L.

    Importante: Se sono presenti più istanze di "Microsoft Outlook Spotlight Importer. mdimporter", eliminare l'applicazione Outlook che non si sta usando, svuotarla dal Cestino, riavviare il Mac e tornare al passaggio 1.

  4. Nel terminale reindicizzare il database di Outlook usando il comando seguente e sostituendo il proprio nome utente per la <user_name> segnaposto: mdimport-g "/applicazioni/Microsoft Outlook. app/Contents/Library/Spotlight/Microsoft Outlook Importer Spotlight. mdimporter"-D1 "/utenti/<user_name>/Library/Group Containers/UBF8T346G9. Profili di Office/Outlook/Outlook 15/<my_profile_name> "

    Nota: In questo comando, il percorso dopo "-g" è il percorso predefinito dell'installazione di Outlook. Il percorso dopo "-D1" è il percorso predefinito del profilo, in cui <my_profile_name> è, per impostazione predefinita, "profilo principale". È necessario sostituire i percorsi effettivi se il profilo è stato rinominato o è stato installato Outlook in una posizione diversa.

La reindicizzazione avrà un po' di tempo per essere completata. Al termine del processo, uscire e quindi riavviare Outlook. 

Se non è ancora possibile eseguire la ricerca in evidenza dopo aver eseguito questa procedura e se è stato consentito il completamento dell'indicizzazione in evidenza, potrebbe essere necessario disinstallare Office per Mac e reinstallarlo. 

Vedere anche

Limitare i criteri di ricerca per ottimizzare le ricerche in Outlook

Trovare un messaggio o un elemento con Ricerca immediata

Un abbonamento per sfruttare al meglio il proprio tempo

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×