現象
実行時間が長いデータ定義言語 (DDL) ステートメントは、バックグラウンドの Tuple Mover タスクをブロックし、デッドロックを引き起こす可能性があります。 ほとんどの場合、Tuple Mover タスクがデッドロックの犠牲者として選択されます。 この場合、Microsoft SQL Server がクラッシュすることがあります。 さらに、SQL Server エラー ログに次のようなエラー メッセージが表示されます。
注
エラー: 1205、重大度: 13、状態: 18。
トランザクション (プロセス ID <プロセス ID>) は、別のプロセスとのロック リソースでデッドロックされ、デッドロックの対象として選択されました。 トランザクションを再実行します。
ex_terminator: スタックの展開中に例外が原因で終了する可能性があります。
同様に、Tuple Mover タスクが深刻なメモリ負荷下で実行されると (たとえば、メモリ使用率が 100% になる)、Tuple Mover タスクが予期せず終了し、これにより SQL Server がクラッシュします。
解決策
累積的な更新プログラムの情報
この問題の修正プログラムは、次の SQL Server の累積的な更新プログラムに含まれています。
SQL Server 用の累積的な更新プログラムについて
SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムを確認してください。
SQL Server 2016 の最新の累積的な更新プログラム
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
参考資料
マイクロソフトでソフトウェア更新プログラムの説明に使用する用語集を参照してください。