개수 구하기는 데이터 분석에 꼭 필요한 부분으로, 조직의 부서 인원수 총계를 내거나 분기별로 판매된 단위 수 총계를 내거나 관계없이 중요합니다. Excel은 데이터의 셀, 행 또는 열 개수를 구하는 데 사용할 수 있는 여러 가지 방법을 제공합니다. 최선의 선택을 할 수 있도록 이 문서에서는 포괄적인 방법 요약, 대화형 예제가 포함된 다운로드 가능한 통합 문서, 추가 이해를 위한 관련 topics에 대한 링크를 제공합니다.
참고
개수 구하기와 합산을 혼동하지 마세요. 셀, 열 또는 행의 값 합계를 계산하는 방법에 대한 자세한 내용은 Excel 데이터를 합산하고 계산하는 방법 요약을 참조하세요.
예제 다운로드
이 문서의 정보를 보완하는 예제를 제공하는 예제 통합 문서를 다운로드할 수 있습니다. 이 문서의 대부분의 섹션에서는 예제 및 추가 정보를 제공하는 예제 통합 문서 내의 적절한 워크시트를 참조합니다.
이 문서의 내용
-
- 동영상: COUNT, COUNTIF 및 COUNTA 함수 사용
- COUNT 함수를 사용하여 범위의 셀 개수 구하기
- COUNTIF 함수를 사용하여 단일 조건을 기반으로 범위의 셀 개수 구하기
- DCOUNT 함수를 사용하여 단일 조건 또는 여러 조건을 기반으로 열의 셀 개수 구하기
- COUNTIFS 함수를 사용하여 여러 조건에 따라 범위의 셀 개수 구하기
- COUNT 함수와 IF 함수를 함께 사용하여 조건을 기준으로 구하기
- SUM 함수와 IF 함수를 함께 사용하여 여러 텍스트 또는 숫자 값의 개수 구하기
- 피벗 테이블의 열이나 행에 있는 셀 개수 계산
간단한 개수 구하기
간단한 수식을 사용하거나, 단추를 선택하거나, 워크시트 함수를 사용하여 범위나 표의 값 수를 셀 수 있습니다.
Excel은 Excel 상태 표시줄에 선택한 셀 수를 표시할 수도 있습니다. 상태 표시줄 사용 방법을 빠르게 알아보려면 다음 비디오 데모를 참조하세요. 또한, 자세한 내용은 상태 표시줄에 계산 및 개수 표시 섹션을 참조하세요. 수식을 입력하지 않고 데이터를 빠르게 확인하려면 상태 표시줄에 표시된 값을 참조하면 됩니다.
동영상: Excel 상태 표시줄을 사용하여 셀 개수 구하기
상태 표시줄에서 개수를 보는 방법을 알아보려면 다음 비디오를 시청하세요.
자동 합계 사용
하나 이상의 숫자 값이 포함된 셀 범위를 선택하여 자동 합계 를 사용합니다. 그런 다음 수식 탭에서숫자 자동합계>를 선택합니다.
Excel은 선택한 범위에 인접한 셀에 범위의 숫자 값 개수를 반환합니다. 일반적으로 이 결과는 가로 범위의 경우 오른쪽 셀에 표시되고 세로 범위의 경우 아래쪽 셀에 표시됩니다.
소계 행 추가
Excel 데이터에 부분합 행을 추가할 수 있습니다. 데이터 내에서 아무 곳이나 클릭한 다음 데이터>개요>소계를 선택합니다.
참고
소계 옵션은 Excel 표, 피벗 테이블 또는 피벗 차트가 아닌 일반 Excel 데이터에서만 작동합니다.
또한 다음 문서도 참조하세요.
SUBTOTAL 함수를 사용하여 목록 또는 Excel 표 열의 셀 개수 구하기
SUBTOTAL 함수를 사용하여 Excel 표나 셀 범위의 값 수를 계산합니다. 테이블 또는 범위에 숨겨진 셀이 있는 경우 SUBTOTAL를 사용하여 숨겨진 셀을 포함하거나 제외할 수 있습니다. 이것이 SUM 함수와 SUBTOTAL 함수의 가장 큰 차이점입니다.
SUBTOTAL 구문은 다음과 같습니다.
SUBTOTAL(function_num,ref1,[ref2],...)
범위에 숨겨진 값을 포함하려면 function_num 인수를 2로 설정해야 합니다.
범위에서 숨겨진 값을 제외하려면 function_num 인수를 102로 설정합니다.
하나 이상의 조건을 기반으로 개수 구하기
여러 워크시트 함수를 사용하여 지정한 조건을 만족하는 범위의 셀 개수를 구할 수 있습니다.
동영상: COUNT, COUNTIF 및 COUNTA 함수 사용
COUNT 함수와 COUNTIF 및 COUNTA 함수를 사용하여, 지정한 조건을 만족하는 셀의 개수만 구하는 방법을 참조하려면 다음 동영상을 시청하세요.
COUNT 함수를 사용하여 범위의 셀 개수 구하기
수식에서 COUNT 함수를 사용하여 범위의 숫자 값 수를 계산합니다.
위의 예에서 A2, A3 및 A6은 범위에 숫자 값이 포함된 유일한 셀이므로 출력은 3입니다.
참고
A7은 시간 값이지만 텍스트(a.m.)가 포함되어 있으므로 COUNT는 이 값을 숫자 값으로 간주하지 않습니다. 오전을 제거하려면 셀에서 COUNT는 A7을 숫자 값으로 간주하고 출력을 4로 변경합니다.
COUNTIF 함수를 사용하여 단일 조건을 기반으로 범위의 셀 개수 구하기
COUNTIF 함수를 사용하여 셀 범위에 특정 값이 표시되는 횟수를 계산합니다.
DCOUNT 함수를 사용하여 단일 조건 또는 여러 조건을 기반으로 열의 셀 개수 구하기
DCOUNT 함수 는 목록이나 데이터베이스의 레코드 필드(열)에서 지정한 조건과 일치하는 숫자가 들어 있는 셀의 개수를 계산합니다.
다음 예제에서는 2016년 3월 또는 그 이후에 400개 이상의 단위가 판매된 월의 수를 찾으려고 합니다. 워크시트의 첫 번째 테이블인 A1부터 B7까지에는 판매 데이터가 들어 있습니다.
DCOUNT는 조건을 사용하여 값을 반환해야 하는 위치를 결정합니다. 조건은 일반적으로 워크시트 자체의 셀에 입력되며 criteria 인수에서 이러한 셀을 참조합니다. 이 예제의 A10 및 B10 셀에는 반환 값이 400보다 커야 함을 지정하는 조건과 종료 월이 2016년 3월 31일 이상이어야 함을 지정하는 두 가지 조건이 들어 있습니다.
다음 구문을 사용해야 합니다.
=DCOUNT(A1:B7,"월 말",A9:B10)
DCOUNT 는 A1부터 B7까지의 데이터를 검사하고 A10과 B10에 지정된 조건을 적용하고 두 조건(행 5와 7)을 모두 만족하는 총 행 수인 2를 반환합니다.
COUNTIFS 함수를 사용하여 여러 조건에 따라 범위의 셀 개수 구하기
COUNTIFS 함수는 COUNTIF 함수와 비슷하지만 COUNTIFS를 사용할 경우 여러 범위에 있는 셀에 조건을 적용하여 모든 조건이 충족되는 횟수가 계산된다는 점에서 차이가 있습니다. COUNTIFS에는 최대 127개의 범위/조건 쌍을 사용할 수 있습니다.
COUNTIFS의 구문은 다음과 같습니다.
COUNTIFS(criteria_range1, criteria1, [criteria_range2, criteria2],…)
다음 예제를 참조하세요.
COUNT 함수와 IF 함수를 함께 사용하여 조건을 기준으로 구하기
특정 품목을 판매한 판매원의 수를 지역별로 파악하거나 특정 판매원의 매출액이 일정액을 넘은 횟수를 확인해야 하는 경우 IF 함수와 COUNT 함수를 함께 사용할 수 있습니다. 즉, 먼저 IF 함수를 사용하여 조건을 검사한 다음 IF 함수의 결과가 True인 경우에만 COUNT 함수를 사용하여 셀의 개수를 계산합니다.
참고
- 이 예제의 수식은 배열 수식으로 입력해야 합니다. Windows용 Excel 또는 Mac용 Excel에서 이 통합 문서를 열었고 수식을 변경하거나 유사한 수식을 만들려면 F2 키를 누른 다음 Ctrl+Shift+Enter를 눌러 수식이 예상 결과를 반환하도록 합니다. 이전 버전의 Mac용 Excel에서는
를 사용합니다. +Shift+Enter 키를 누릅니다. - 예제 수식이 제대로 계산되려면 IF 함수의 두 번째 인수가 숫자여야 합니다.
SUM 함수와 IF 함수를 함께 사용하여 여러 텍스트 또는 숫자 값의 개수 구하기
아래 예제에서는 IF 함수와 SUM 함수를 함께 사용합니다. IF 함수가 먼저 일부 셀의 값을 검사한 다음 그 결과가 True이면 SUM 함수가 테스트를 통과하는 값의 합계를 구합니다.
예제 1
위의 함수는 C2:C7에 Buchanan 및 Dodsworth 값이 포함된 경우 SUM 함수는 조건이 충족되는 레코드의 합계를 표시해야 한다고 말합니다. 수식은 지정된 범위에서 Buchanan에 대한 레코드 3개와 Dodsworth에 대한 레코드 1개를 찾아 4를 표시합니다.
예제 2
위의 함수는 D2:D7에 $9,000보다 작거나 $19,000보다 큰 값이 포함된 경우 SUM은 조건이 충족되는 모든 레코드의 합계를 표시해야 한다고 말합니다. 수식은 값이 $9000보다 작은 D3 및 D5 레코드 2개와 값이 $19,000보다 큰 D4 및 D6 레코드 2개를 찾아 4를 표시합니다.
예제 3
위의 함수는 D2:D7에 $9000 미만의 Buchanan에 대한 청구서가 있는 경우 SUM은 조건이 충족되는 레코드의 합계를 표시해야 한다고 말합니다. 수식은 C6이 조건에 부합되는 것을 발견하고 1을 표시합니다.
중요
이 예제의 수식은 배열 수식으로 입력해야 합니다. 즉, F2 키를 누른 다음 Ctrl+Shift+Enter를 눌러야 합니다. 이전 버전의 Mac용 Excel에서는
+Shift+Enter 키를 누릅니다.
피벗 테이블의 열이나 행에 있는 셀 개수 계산
피벗 테이블은 데이터를 요약하고 데이터를 보려는 범주를 선택할 수 있도록 하여 데이터를 분석하고 드릴다운하는 데 도움이 됩니다.
데이터 범위 또는 Excel 표에서 셀을 선택한 다음 삽입 탭의 테이블 그룹에서 피벗 테이블을 선택하여 피벗 테이블을 빠르게 만들 수 있습니다.
특정 분기에 대한 골프 및 테니스의 판매 금액을 셀 수 있는 판매 스프레드시트의 샘플 시나리오를 살펴보겠습니다.
참고
대화형 환경을 위해 다운로드 가능한 통합 문서의 피벗 테이블 시트에 제공된 예제 데이터에서 이러한 단계를 실행할 수 있습니다.
Excel 스프레드시트에 다음 데이터를 입력합니다.
A2:C8을 선택합니다.
피벗 테이블삽입>을 선택합니다.
테이블/범위,새 워크시트에서 선택한 다음 확인을 선택합니다.
새 시트에 빈 피벗 테이블이 만들어집니다.
피벗 테이블 필드 창에서 다음을 실행합니다.
Sport를 행 영역으로 끕니다.
Quarter를 열 영역으로 끕니다.
Sales를 값 영역으로 끕니다.
c단계를 반복합니다.
피벗 테이블 및 값 영역 둘 다에서 필드 이름이 SumofSales2로 표시됩니다.
이 시점에서 피벗 테이블 필드 창은 다음과 같이 표시됩니다.
값 영역에서 SumofSales2 옆에 있는 드롭다운을 선택하고 값 필드 설정을 선택합니다.
값 필드 설정 대화 상자에서 다음을 실행합니다.
값 필드 요약 기준 섹션에서 Count를 선택합니다.
사용자 지정 이름 필드에서 이름을 로 수정합니다.
확인을 선택합니다.
피벗 테이블에 3분기와 4분기의 골프 및 테니스 레코드 수가 판매량 수치와 함께 표시됩니다.
데이터가 빈 값을 포함하는 경우 개수 구하기
워크시트 함수를 사용하여 데이터를 포함하거나 비어 있는 셀 개수를 구할 수 있습니다.
COUNTA 함수를 사용하여 범위의 비어 있지 않은 셀 개수 구하기
COUNTA 함수를 사용하면 범위 내에서 값이 있는 셀의 개수만 계산할 수 있습니다.
셀 개수를 구할 때 값이 들어 있는 셀만 의미가 있으므로 빈 셀은 무시하려는 경우가 있습니다. 예를 들어 판매를 이룬 총 영업 사원 수를 계산하려고 합니다(열 D).
COUNTA 는 D3, D4, D8 및 D11의 빈 값을 무시하고 D 열의 값이 포함된 셀만 계산합니다. 이 함수는 D열에서 값이 포함된 셀 6개를 찾아 6을 출력으로 표시합니다 .
DCOUNTA 함수를 사용하여 특정 조건의 목록에서 비어 있지 않은 셀 개수 계산
목록이나 데이터베이스의 레코드 열에서 지정한 조건과 일치하는 셀 중 비어 있지 않은 셀의 개수를 구하려면 DCOUNTA 함수를 사용합니다.
다음 예제에서는 DCOUNTA 함수를 사용하여 데이터베이스에서 A1:B7 범위에 포함된 조건 범위 A9:B10에 지정된 조건에 맞는 레코드 수를 계산합니다. 이러한 조건은 제품 ID 값이 2000보다 크거나 같아야 하고 등급 값이 50보다 크거나 같아야 한다는 것입니다.
DCOUNTA는 조건에 맞는 두 행(행 2와 4)을 찾아 값 2 를 출력으로 표시합니다.
COUNTBLANK 함수를 사용하여 연속된 범위의 빈 셀 개수 구하기
COUNTBLANK 함수 함수를 사용하여 인접한 범위에서 빈 셀의 수를 반환합니다(셀이 모두 끊기지 않은 순서로 연결되어 있으면 인접한 셀임). 셀에 빈 텍스트("")를 반환하는 수식이 포함된 경우 해당 셀은 계산됩니다.
셀의 개수를 구할 때 의미가 있기 때문에 빈 셀을 포함하려는 경우가 있을 수 있습니다. 다음 식료품 판매 스프레드시트 예시. 판매액 수치가 언급되어 있지 않은 셀이 몇 개나 되는지 확인하려는 경우를 가정해 보겠습니다.
참고
COUNTBLANK 워크시트 함수는 범위에서 빈 셀의 수를 확인하는 데 가장 편리한 방법을 제공하지만, 관심 셀이 닫힌 통합 문서에 있거나 연속된 범위를 형성하지 않는 경우에는 제대로 작동하지 않습니다.
SUM 함수와 IF 함수의 조합을 사용하여 연속되지 않은 범위의 빈 셀 개수 구하기
SUM 함수와 IF 함수의 조합을 사용합니다. 일반적으로 배열 수식에서 IF 함수를 사용하여 참조되는 각 셀에 값이 있는지 확인한 다음 수식에서 반환되는 FALSE 값의 수를 합산하여 이 작업을 수행합니다.
이전 섹션에서 SUM과 IF 함수 조합에 대한 몇 가지 예를 참조하세요. 이 항목에서는 SUM 및 IF 함수를 함께 사용하여 여러 텍스트 또는 숫자 값이 발생하는 빈도를 계산 합니다.
값의 고유 발생 개수 구하기
피벗 테이블, COUNTIF 함수, SUM 및 IF 함수를 함께 사용하거나 고급 필터 대화 상자를 사용하여 범위의 고유 값 개수를 계산할 수 있습니다.
고급 필터를 사용하여 목록 열의 고유 값 개수 구하기
데이터 열에서 고유 값을 찾으려면 고급 필터 대화 상자를 사용합니다. 제자리에서 값을 필터링하거나 값을 추출하여 새 위치에 붙여넣을 수 있습니다. 그런 다음 ROWS 함수를 사용하여 새 범위에 있는 항목의 개수를 구할 수 있습니다.
고급 필터를 사용하려면 데이터 탭을 선택하고 정렬 & 필터 그룹에서 고급을 선택합니다.
다음 그림은 고급 필터를 사용하여 고유 레코드만 워크시트의 새 위치에 복사하는 방법을 보여 줍니다.
다음 그림의 열 E에는 D 열의 범위에서 복사된 값이 들어 있습니다.
참고
- 제자리에서 데이터를 필터링하면 값이 워크시트에서 삭제되지 않으며, 하나 이상의 행이 숨겨질 수 있습니다. 데이터 탭의 정렬 & 필터 그룹에서 지우기를 선택하여 해당 값을 다시 표시합니다.
- 한눈에 고유 값 개수를 확인하려면 고급 필터를 사용(데이터를 필터링하거나 복사)한 후 데이터를 선택한 다음 상태 표시줄을 살펴봅니다. 상태 표시줄의 개수 값은 고유 값 개수와 동일합니다.
자세한 내용은 고급 조건을 사용한 필터링을 참조하세요
IF, SUM, FREQUENCY, MATCH 및 LEN 함수를 사용하여 범위에서 하나 이상의 조건을 충족하는 고유 값의 개수를 계산합니다.
IF, SUM, FREQUENCY, MATCH, LEN 함수의 다양한 조합을 사용합니다.
자세한 내용과 예제는 중 복 항목 중에서 고유 값 세기 문서의 "함수를 사용하여 고유 값 개수 계산" 섹션을 참조하세요.
특수한 경우(모든 셀 개수 구하기, 단어 개수 구하기)
다양한 워크시트 함수 조합을 사용하여 범위의 셀 개수 또는 단어 개수를 구할 수 있습니다.
ROWS 및 COLUMNS 함수를 사용하여 범위의 총 셀 개수 구하기
통합 문서에서 수동 계산을 사용할지 또는 자동 계산을 사용할지를 결정하기 위해 큰 워크시트의 크기를 확인하려 한다고 가정합니다. 범위의 모든 셀 수를 계산하려면 ROWS 및 COLUMNS 함수를 사용하여 반환 값을 곱하는 수식을 사용합니다. 예시는 다음 이미지를 참조하세요.
SUM, IF, LEN, TRIM 및 SUBSTITUTE 함수의 조합을 사용하여 범위의 단어 수 계산
배열 수식에는 SUM, IF, LEN, TRIM 및 SUBSTITUTE 함수의 조합을 사용할 수 있습니다. 다음 예제에서는 중첩된 수식을 사용하여 7개 셀(그 중 3개는 비어 있음)의 단어 수를 찾은 결과를 보여 줍니다. 일부 셀에는 선행 또는 후행 공백이 포함되어 있습니다. TRIM 및 SUBSTITUTE 함수는 계산이 수행되기 전에 이러한 추가 공백을 제거합니다. 다음 예제를 참조하세요.
이제 위의 수식이 올바르게 작동하려면 이 수식을 배열 수식으로 만들어야 하며, 그렇지 않으면 수식에서 #VALUE를 반환합니다! 오류가 발생합니다. 이렇게 하려면 수식이 있는 셀을 선택한 다음 수식 입력줄에서 Ctrl + Shift + Enter를 누릅니다. 수식의 시작과 끝에 중괄호를 추가하여 배열 수식으로 만듭니다.
배열 수식에 대한 자세한 내용은 Excel의 수식 개요 및 배열 수식 만들기를 참조하세요.
상태 표시줄에 계산 및 개수 표시
하나 이상의 셀을 선택하면 해당 셀의 데이터 정보가 Excel 상태 표시줄에 표시됩니다. 예를 들어 워크시트에서 4개 셀이 선택되어 있고 이 셀에 2, 3, 텍스트 문자열(예: "클라우드"), 4 값이 포함되어 있으면 평균, 개수, 숫자 데이터 개수, 최소값, 최대값, 합계 등 모든 값이 상태 표시줄에 동시에 표시될 수 있습니다. 상태 표시줄을 마우스 오른쪽 단추로 클릭하면 이러한 값 중 일부 또는 모두를 표시하거나 숨길 수 있습니다. 이러한 값은 다음 그림에 나와 있습니다.
추가 지원
언제든지 Excel 기술 커뮤니티의 전문가에게 문의하거나 커뮤니티에서 지원을 받을 수 있습니다.