증상
OpenSSL 1.1이 구성되어 있고 OpenSSL 1.0이 설치되지 않은 배포판에서 Linux용 SQL Server 2017을 연결하려고 하면 다음과 유사한 연결 오류 메시지가 나타날 수 있습니다.
서버와 연결이 성공적으로 설정되었지만 로그인 프로세스 중에 오류가 발생했습니다. (공급자: SSL 공급자, 오류:0 - 원격 호스트에 의해 기존 연결이 강제로 닫혔습니다.)
예를 들면 다음과 같습니다. SQLCMD를 사용하여 연결하려고 하면 다음과 같은 오류 메시지가 나타날 수 있습니다.
sqlcmd: 오류: SQL Server용 Microsoft ODBC 드라이버 17: TCP 공급자: 오류 코드 0x2746.
sqlcmd: 오류: Microsoft ODBC 드라이버 17 for SQL Server: 클라이언트가 연결을 설정할 수 없습니다.
참고: OpenSSL 1.1과 함께 제공되고 OpenSSL 1.0이 설치되지 않은 Linux 배포의 예로는 Red Hat Enterprise Linux 8.0이 있습니다.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.
해결 방법
이 문제는 SQL Server에 대한 다음 누적 업데이트에서 해결되었습니다.
SQL Server용 누적 업데이트 정보:
SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server에 대한 최신 누적 업데이트를 확인하세요.
참조 자료
Microsoft에서 소프트웨어 업데이트를 설명하는 데 사용하는 용어에 대해 알아보세요.