#OVERLOOP-fouten worden geretourneerd wanneer een formule meerdere resultaten retourneert en deze door Excel niet naar het raster kunnen worden geretourneerd. Zie de volgende Help-onderwerpen voor meer informatie over deze fouttypen:

Deze fout treedt op wanneer het overloopbereik voor een overlopende matrixformule niet leeg is.

#OVERLOOP!- fout: overloopbereik is niet leeg

Wanneer de formule is geselecteerd, geeft een onderbroken rand het beoogde overloopbereik aan.

U kunt de fout floatie selecteren en de optie Cellen met problemen selecteren kiezen om de blokkerende cel(en) onmiddellijk te verwijderen. U kunt de fout vervolgens wissen door de invoer van de blokkerende cel te verwijderen of te verplaatsen. Zodra de blokkade is gewist, loopt de matrixformule over zoals bedoeld.

De grootte van de overloopmatrix kan niet worden bepaald, omdat deze vluchtig is en tussen berekeningsruns van grootte verandert. Voorbeeld: de volgende formule activeert deze #OVERLOOP!- fout:

=REEKS(ASELECTTUSSEN(1;1000))

Dynamische grootten van matrices kunnen extra berekeningsruns activeren om ervoor te zorgen dat alles op het werkblad wordt berekend. Als de grootte van de matrix tijdens deze extra runs blijft veranderen en niet stabiliseert, wordt de dynamische matrix omgezet als #OVERLOOP!.

Deze foutwaarde gaat over het algemeen gepaard met het gebruik van de functies ASELECT, ASELECT.MATRIX en ASELECTTUSSEN. Andere vluchtige functies, zoals VERSCHUIVING, INDIRECTen VANDAAG retourneren geen andere waarden bij elke berekeningsrun. 

Als bijvoorbeeld de formule =VERT.ZOEKEN(A:A;A:C;2;ONWAAR) in cel E2 wordt geplaatst, zoals in het onderstaande voorbeeld, werd voorheen alleen de id in cel A2 opgezocht. In Excel met dynamische matrices veroorzaakt de formule echter een #OVERLOOP!- fout, omdat Excel de hele kolom opzoekt, 1.048.576 resultaten retourneert en naar het einde van het Excel-raster gaat.

#OVERLOOP!- fout veroorzaakt met =VERT.ZOEKEN(A:A,A:D,2,ONWAAR) in cel E2, omdat de resultaten overlopen buiten de rand van het werkblad. Verplaats de formule naar cel E1 en deze werkt correct.

U kunt dit probleem op drie eenvoudige manieren verhelpen:

#

Methode

Formule

1

Verwijs slechts naar de opzoekwaarden waarin u geïnteresseerd bent. Deze formulestijl retourneert een dynamische matrix, maar werkt niet met Excel-tabellen

Gebruik =VERT.ZOEKEN(A2:A7,A:C,2,ONWAAR) om een dynamische matrix te retourneren die niet resulteert in een #OVERLOOP!- fout.

=VERT.ZOEKEN(A2:A7;A:C;2;ONWAAR)

2

Verwijs alleen naar de waarde op dezelfde rij en kopieer de formule vervolgens omlaag. Deze traditionele formulestijl werkt in tabellen, maar retourneert geendynamische matrix.

Gebruik de traditionele VERT.ZOEKEN met één lookup_value-verwijzing: =VERT.ZOEKEN(A2,A:C,32,ONWAAR). Deze formule retourneert geen dynamische matrix, maar kan worden gebruikt met Excel-tabellen.

=VERT.ZOEKEN(A2;A:C;2;ONWAAR)

3

Vraag of Excel impliciet snijpunt uitvoert met behulp van de @-operator en kopieer vervolgens de formule omlaag. Deze formulestijl werkt in tabellen, maar retourneert geendynamische matrix.

Gebruik de operator @ en kopieer omlaag: =VERT.ZOEKEN(@A:A,A:C,2,ONWAAR). Deze verwijzingsstijl werkt in tabellen, maar retourneert geen dynamische matrix.

=VERT.ZOEKEN(@A:A2;A:C;2;ONWAAR)

Overlopende matrixformules worden in Excel-tabellen niet ondersteund. Verplaats de formule uit de tabel of converteer de tabel naar een bereik (klik op Tabelontwerp > Hulpprogramma's > Converteren naar bereik).

#OVERLOOP!- fout: tabelformule

De overlopende matrixformule die u wilt invoeren, heeft ertoe geleid dat Excel onvoldoende geheugen heeft. Verwijs naar een kleinere matrix of een kleiner bereik.

Overlopende matrixformules kunnen niet overlopen in samengevoegde cellen. Maak de samenvoeging van de cellen in kwestie ongedaan of verplaats de formule naar een ander bereik dat niet met samengevoegde cellen overlapt.

#OVERLOOP!- fout: overlopen naar samengevoegde cel

Wanneer de formule is geselecteerd, geeft een onderbroken rand het beoogde overloopbereik aan.

U kunt de fout floatie selecteren en de optie Cellen met problemen selecteren kiezen om de blokkerende cel(en) onmiddellijk te verwijderen. Zodra de samengevoegde cellen zijn gewist, loopt de matrixformule over zoals bedoeld.

Excel herkent de oorzaak van deze fout niet of kan deze niet in overeenstemming brengen. Zorg ervoor dat de formule alle vereiste argumenten voor uw scenario bevat.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

De functie FILTER

De functie ASELECT.MATRIX

De functie VOLGORDE

De functie SORTEREN

De functie SORTBY

De functie UNIQUE

Dynamische matrices en gedrag van matrices op aangrenzende cellen

Impliciete snijpuntoperator: @

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×