Terwijl u een transactielogboek herstelt voor een Microsoft SQL Server 2005-, Microsoft SQL Server 2008- of Microsoft SQL Server 2008 R2-database, wordt in het SQL Server Errorlog-bestand een foutbericht van de volgende strekking weergegeven:
Fout: 18272, Ernst: 16, Toestand: 1.
Tijdens het opnieuw opstarten van het herstellen is er een I/O-fout opgetreden in checkpoint-bestand 'X:\Microsoft SQL Server\MSSQL.1\MSSQL\Backup\CHECK. CKP' (besturingssysteemfout 1784(de opgegeven gebruikersbuffer is niet geldig voor de aangevraagde bewerking.)). De verklaring wordt verwerkt maar kan niet opnieuw worden gestart. Controleer of er een geldige opslaglocatie voor het controlepuntbestand bestaat.
Symptomen
Deze fout heeft een beperkte impact en voorkomt niet dat een herstelbewerking slaagt. Deze foutmelding treedt op wanneer een herstelbewerking wordt onderbroken en het controlepuntbestand dat wordt gebruikt om een herstelbewerking opnieuw te starten, niet is geschreven of het controlepuntbestand niet juist is geschreven. Als deze fout wordt weergegeven, betekent dit dat, als de herstelbewerking om een of andere reden midden in het proces wordt onderbroken, u deze opnieuw moet starten vanaf het begin van het back-upbestand in plaats van het controlepuntbestand.
Oorzaak
Informatie over cumulatieve updates
SQL Server 2005
De oplossing voor dit probleem is voor het eerst uitgebracht in cumulatieve update 10. Klik voor meer informatie over het verkrijgen van dit cumulatieve updatepakket voor SQL Server 2005 op het volgende artikelnummer in de Microsoft Knowledge Base:
983329 Cumulatief updatepakket 10 voor SQL Server 2005 Service Pack 3
Notitie Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2005-fixrelease. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat.
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
960598 De SQL Server 2005-builds die zijn uitgebracht nadat SQL Server 2005 Service Pack 3 is uitgebracht
SQL Server 2008 Service Pack 1
De oplossing voor dit probleem is voor het eerst uitgebracht in cumulatieve update 9 voor SQL Server 2008 Service Pack 1. Klik voor meer informatie over dit cumulatieve updatepakket op het volgende artikelnummer in de Microsoft Knowledge Base:
2083921 cumulatieve update 9 voor SQL Server 2008 Service Pack 1
Notitie Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2008-fixrelease. Microsoft raadt u aan de meest recente oplossing toe te passen die deze hotfix bevat. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
970365 De SQL Server 2008-builds die zijn uitgebracht nadat SQL Server 2008 Service Pack 1 is uitgebracht
Microsoft SQL Server 2008-hotfixes worden gemaakt voor specifieke servicepacks van SQL Server. U moet een hotfix voor SQL Server 2008 Service Pack 1 toepassen op een installatie van SQL Server 2008 Service Pack 1. Elke hotfix die deel uitmaakt van een SQL Server-servicepack wordt standaard opgenomen in het volgende SQL Server-servicepack.
SQL Server 2008 Service Pack 2
De oplossing voor dit probleem is voor het eerst uitgebracht in cumulatieve update 1 voor SQL Server 2008 Service Pack 2. Klik voor meer informatie over dit cumulatieve updatepakket op het volgende artikelnummer in de Microsoft Knowledge Base:
2289254 Cumulatieve update 1 voor SQL Server 2008 Service Pack 2
Notitie Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2008-fixrelease. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
2402659 De SQL Server 2008-builds die zijn uitgebracht nadat SQL Server 2008 Service Pack 2 is uitgebracht
SQL Server 2008 R2
De oplossing voor dit probleem is voor het eerst uitgebracht in cumulatieve update 4. Klik voor meer informatie over het verkrijgen van dit cumulatieve updatepakket voor SQL Server 2008 R2 op het volgende artikelnummer in de Microsoft Knowledge Base:
2345451 Cumulatief updatepakket 4 voor SQL Server 2008 R2
Notitie Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2008 R2-fixrelease. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
981356 De SQL Server 2008 R2-builds die zijn uitgebracht nadat SQL Server 2008 R2 zijn uitgebracht
Tijdelijke oplossing
Deze fout verschijnt doorgaans wanneer u meerdere back-upbestanden terugzet. Dit proces wordt ook wel 'striped herstel' genoemd. U kunt deze fout vermijden door niet meerdere back-upbestanden op te geven in de herstelbewerking.
Oplossing
Het probleem wordt vaak gemeld door klanten die back-upsoftware van derden gebruiken om back-ups te maken van hun SQL Server databases. Deze hulpprogramma's vergemakkelijken back-up- en herstelbewerkingen in meerdere bestanden.
Aanvullende verwijzingen: