KB2289254 - Cumulatief updatepakket 1 voor SQL Server 2008 Service Pack 2

Van toepassing op
SQL Server 2008 Standard SQL Server 2008 Developer SQL Server 2008 Enterprise SQL Server 2008 Workgroup SQL Server 2008 Web SQL Server 2008 Express SQL Server 2008 Express with Advanced Services

INLEIDING

Microsoft SQL Server 2008-hotfixes worden gemaakt voor specifieke servicepacks van SQL Server. U moet een hotfix voor SQL Server 2008 Service Pack 2 toepassen op een installatie van SQL Server 2008 Service Pack 2. Elke hotfix die deel uitmaakt van een SQL Server-servicepack wordt standaard opgenomen in het volgende SQL Server-servicepack.

Cumulatieve update 1 voor SQL Server 2008 Service Pack 2 (SP2) is bedoeld als een post-service pack rollup voor SQL Server 2008-klanten die een upgrade willen uitvoeren naar SQL Server 2008 SP2 en nog steeds de hotfixes uit SQL Server 2008 SP1 Cumulatieve Update 9 tot SQL Server 2008 SP1 Cumulatieve Update 10 behouden.

Opmerking: deze build van het cumulatieve updatepakket staat ook bekend als build 10.00.4266.00.

Het is raadzaam hotfixes te testen voordat u ze in een productieomgeving implementeert. Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2008-fixrelease. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat.
  Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:

2402659 De SQL Server 2008-builds die zijn uitgebracht nadat SQL Server 2008 Service Pack 2 is uitgebracht

Belangrijke opmerkingen over het cumulatieve updatepakket

  • Hotfixes voor SQL Server 2008 zijn nu beschikbaar in meerdere talen. Daarom is er slechts één cumulatief hotfixpakket voor alle talen.
  • Eén cumulatief hotfixpakket omvat alle onderdeelpakketten. Met het cumulatieve updatepakket worden alleen de onderdelen bijgewerkt die op het systeem zijn geïnstalleerd.

Meer informatie

Cumulatieve update 1 voor SQL Server 2008 Service Pack 2 verkrijgen

Een ondersteund cumulatief updatepakket is nu beschikbaar bij Microsoft. Het is echter alleen bedoeld om de problemen op te lossen die in dit artikel worden beschreven. Pas het alleen toe op systemen die deze specifieke problemen ondervinden. Dit cumulatieve updatepakket kan aanvullende tests ontvangen. Als u niet ernstig last hebt van een van deze problemen, raden wij u daarom aan te wachten op het volgende servicepack voor SQL Server 2008 dat de hotfixes in dit cumulatieve updatepakket bevat.

Als de cumulatieve update kan worden gedownload, vindt u de sectie 'Hotfix-download beschikbaar' bovenaan dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met de klantenservice en ondersteuning van Microsoft om het cumulatieve updatepakket te verkrijgen.

Opmerking: als er nog meer problemen optreden of als er problemen nodig zijn, moet u mogelijk een afzonderlijke serviceaanvraag maken. De gebruikelijke ondersteuningskosten zijn van toepassing op aanvullende ondersteuningsvragen en problemen die niet in aanmerking komen voor dit specifieke cumulatieve updatepakket. Voor een volledige lijst met telefoonnummers van de klantenservice en ondersteuning van Microsoft of om een afzonderlijke serviceaanvraag te maken, gaat u naar de volgende Microsoft-website:

/contactus/?ws=support Opmerking: het formulier 'Hotfix-download beschikbaar' geeft de talen weer waarvoor de cumulatieve update beschikbaar is. Als uw taal niet wordt weergegeven, komt dit doordat er geen cumulatief updatepakket voor die taal beschikbaar is.

Hotfixes die zijn opgenomen in cumulatieve update 1 voor SQL Server 2008 Service Pack 2

  Microsoft Knowledge Base-artikelen waarin deze hotfixes worden besproken, worden gepubliceerd zodra ze beschikbaar zijn.

  Voor meer informatie over de SQL Server-bugs klikt u op de volgende artikelnummers in de Microsoft Knowledge Base:

VSTS-bugnummer KB-artikelnummer Beschrijving
561807 942712 FIX: Het W3WP.exe proces van Internet Information Services stopt onverwacht wanneer u een samenvoegreplicatie configureert die gebruikmaakt van websynchronisatie in SQL Server 2005 en SQL Server 2008
549033 geen CDC-opnametaak kan de volgende assertvoorwaarde ervaren wanneer CDC is ingeschakeld in databasetabellen met XML of andere blobgegevenstypekolommen:

Bewering: Bestand: <bestandsnaam>
line=<line number> Failed Assertion = 'fNoWriters' -EN-
line=<line number> Failed Assertion = 'fNoReaderWriterConflict'
576988 979212 FIX: een DateTime-waarde wordt vervangen door een NULL-waarde wanneer een conflict wordt opgelost met een aangepaste resolver in Microsoft SQL Server 2005, Microsoft SQL Server 2008 of Microsoft SQL Server 2008 R2-samenvoegreplicatie
576899 980142 FIX: U ontvangt een foutbericht 'Provider laden mislukt' of het proces Wmiprvse.exe reageert niet meer wanneer u een SQL Server WMI-provider gebruikt om informatie te verkrijgen over services van SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2
548967 980350 FIX: Poolse woordbreker zorgt ervoor dat een Full-Text-query een onvolledig resultaat oplevert in SQL Server 2008
548983 980570 FIX: Foutbericht 'Indexfout in volledige tekst tijdens compressie of decompressie' wanneer u de zoekindex in volledige tekst opnieuw opbouwt in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
548985 980832 FIX: Foutbericht 'Een systeembevestigingscontrole is mislukt' wanneer u een Transaction-SQL-query uitvoert in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
576971 980849 FIX: Er is een hoge latentie voor peer-to-peer-distributieagents in Microsoft SQL Server 2005, Microsoft SQL Server 2008 of Microsoft SQL Server 2008 R2
548999 980883 FIX: proactieve caching wordt onverwacht gestart wanneer u gegevens in SQL Server 2005, SQL Server 2008 R2 of SQL Server 2008 invoegt
576984 980948 FIX: Metagegevens worden beschadigd wanneer u de gegevensmappen SSAS 2005, SSAS 2008 R2 of SSAS 2008 van de ene computer naar de andere verplaatst
548987 981120 FIX: Foutbericht wanneer u TDE inschakelt voor een database waarvoor de momentopname-isolatie is ingeschakeld in SQL Server 2008 of in SQL Server 2008 R2
549015 981502 OPLOSSING: een query met een parallel queryplan retourneert telkens wanneer u de query uitvoert in SQL Server 2005, SQL Server 2008 R2 of SQL Server 2008 andere resultaten
576985 981713 FIX: Een query retourneert een onjuist resultaat als deze een index gebruikt die online wordt opnieuw opgebouwd in SQL Server 2005, SQL Server 2008 R2 of SQL Server 2008
576992 981867 FIX: Een berekend lid dat filterde dimensieleden gebruikt, retourneert een onjuist resultaat in SSAS 2005, SSAS 2008 R2 of SSAS 2008
576993 981888 FIX: "Deadlock monitor heeft deze impasse niet kunnen oplossen. Server moet mogelijk opnieuw worden opgestart om van deze toestand te herstellen" wanneer een database wordt hersteld in Microsoft SQL Server 2005, Microsoft SQL Server 2008 of Microsoft SQL Server 2008 R2
548989 982034 FIX: De vertaalfunctie werkt niet wanneer u een groepeeractie uitvoert in een Excel-draaitabel die SSAS 2008 of SSAS 2008 R2 als gegevensbron gebruikt
577024 982363 OPLOSSING: SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2 kan er lang over doen om een ALTER TABLE-instructie te voltooien waarmee een XML-gegevenstypekolom wordt gewijzigd van 'NOT NULL' in 'NULL' in een tabel
576999 982376 FIX: een niet-renderende plannerfout of fout 8623 treedt op wanneer u een query met een grote IN-component uitvoert in SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2
561817 982808 Een analyserapport werkt mogelijk niet onjuist als de optie 'Vragen om referenties' wordt gebruikt in de gegevensbronnen in SQL Server 2008 Reporting Service
548995 982854 FIX: Foutbericht 'Er is onvoldoende systeemgeheugen in de resourcegroep 'intern' om deze query uit te voeren' wanneer u een full-text query uitvoert waarin samengestelde woorden worden gebruikt in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
548997 982857 FIX: Foutbericht bij het configureren van transactionele replicatie voor een database in SQL Server 2008 of in SQL Server 2008 R2
577003 982932 De prestaties van query's nemen af wanneer u cumulatieve update 7 of een latere versie van SQL Server 2005 SP2 toepast
577002 983429 FIX: Er ontstaat een impasse wanneer u een query of een opgeslagen procedure met een XML-kolom uitvoert in SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2
549007 983446 In een SSRS 2008-rapport wordt een dubbele eerste rij weergegeven voor elke groep van een subrapport wanneer u het rapport exporteert naar CSV-indeling
577006 983480 OPLOSSING: er doen zich verschillende problemen voor wanneer een database betrokken is bij een sessie voor databasespiegeling en bij een transactionele replicatie als traceringsvlag 1448 is ingeschakeld
577007 983500 FIX: het rolsynchronisatieproces wordt vertraagd wanneer een mirroring-automatische failover plaatsvindt in SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2
549013 983577 FIX: Het exportproces wordt nooit voltooid wanneer u een rapport exporteert met geneste tablixitems in SSRS 2008 of SSRS 2008 R2 naar de extensies die worden ondersteund door de harde pagina-einderenderers
442541 2022254 SQL Server kan fout 18272 rapporteren tijdens herstelbewerkingen
549017 2028406 FIX: Spaties tussen sommige items worden onjuist gegenereerd in een rapport van SQL Server 2008 of van SQL Server 2008 R2
561732 2028727 FIX: Kolomgroepwaarden worden alleen weergegeven in de laatste onderliggende rijgroep van de aangrenzende rijgroepen in SSRS 2008
549020 2028755 FIX: Er wordt een onjuist resultaat geretourneerd wanneer u een LIKE-query met jokertekens en de sortering Latin1_General_100_CS_AS uitvoert in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
561809 2028830 FIX: Gedeelde onderdelen worden op de verkeerde locatie geïnstalleerd wanneer u een failovercluster van SQL Server 2008 implementeert
561744 2121407 FIX: Foutbericht wanneer u het hulpprogramma sqlcmd gebruikt voor het uitvoeren van de Transact-SQL-query in SQL Server 2008 en SQL Server 2008 R2
549026 2152148 FIX: Foutbericht 'Interne fout: er is een onverwachte uitzondering opgetreden' wanneer u een MDX-query (Multidimensional Expressions) uitvoert met behulp van time intelligence in Microsoft SQL Server Analysis Services 2008
549039 2200755 FIX: Foutbericht wanneer u een MDX-query uitvoert in SSAS 2008 of SSAS 2008 R2
561746 2214666 FIX: een SSIS-pakket dat gebruikmaakt van de Unpivot-transformatie kan inconsistente resultaten opleveren in SQL Server 2008
549041 2220252 FIX: een SQL Server 2005-rapport waarin de functie voor wisselknoppen voor zichtbaarheid wordt gebruikt, wordt niet goed uitgevoerd in SQL Server 2008 of in SQL Server 2008 R2
577012 2222998 FIX: er wordt een onjuiste kardinaliteitsschatting geretourneerd wanneer u een query uitvoert in SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2
549031 2248999 FIX: Een index beschadigd wanneer u een weergave bijwerkt in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
549043 2255410 Een query retourneert inconsistente resultaten voordat de gegevenscache wordt opgewarmd in SSAS 2008 of SSAS 2008 R2
561750 2256829 FIX: een bepaald aantal van de laatste XML-kolommen wordt mogelijk niet correct gerepliceerd als u websynchronisatie gebruikt voor samenvoegreplicatie in SQL Server 2008
561757 2260502 FIX: de prestaties van query's nemen af na een upgrade van SQL Server 2000 naar SQL Server 2008 als in de query een door de gebruiker gedefinieerde scalaire functie wordt gebruikt
561760 2261403 FIX: het prestatieobject 'SQL Server:SSIS Pipeline 10.0' wordt niet weergegeven in de lijst 'Prestatieobject' terwijl een andere gebruiker toegang heeft tot enkele SSIS-pijplijntellers in SQL Server 2008 of in SQL Server 2008 R2
549028 2264562 FIX: een full-text query die gebruikmaakt van het predicaat CONTAINS of FREETEXT samen met de operator 'OR' duurt lang om uit te voeren in SQL Server 2008 of in SQL Server 2008 R2
577013 2268122 FIX: Foutbericht 'Gebruiker 'gast' heeft geen toestemming om DBCC checkdb uit te voeren voor database 'mssqlsystemresource'" wanneer u de opdracht DBCC CHECKDB('master') uitvoert op een computer met SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2
561766 2276330 FIX: de functie "CHANGETABLE" is traag in SQL Server 2008 en in SQL Server 2008 R2
561768 2276717 FIX: foutcode 1456 wanneer u een witness toevoegt aan een nieuwe sessie voor databasespiegeling die dezelfde databasenaam heeft als een bestaande sessie voor databasespiegeling in Microsoft SQL Server 2005, Microsoft SQL Server 2008 en Microsoft SQL Server 2008 R2
577014 2277207 FIX: De waarde van het label 'As' verschijnt in elke kolom en de waarde 'Rasterinterval' wordt niet geaccepteerd nadat een RDL-bestand is bijgewerkt van SSRS 2005 naar SSRS 2008
561770 2278042 FIX: Een afgeleide kolomtransformatie kan onjuiste resultaten opleveren in SSIS 2008 of SSIS 2008 R2 wanneer een kolom wordt afgeleid bij zowel alleen-lezen als lezen/schrijven
561773 2282743 FIX: De speciale tekens worden onjuist weergegeven in een "tekstvak"-besturingselement van een PDF-bestand wanneer u een rapport weergeeft in SSRS 2008
577017 2283072 OPLOSSING: er is een hotfix beschikbaar waarmee SQL Server 2008 Reporting Services en SQL Server 2008 R2 Reporting Services een 2048-bits RSA-sleutel kunnen gebruiken om een Reporting Services-sleutel te versleutelen voor FIPS-compliancy
561791 2287990 FIX: De transformatie 'Afgeleide kolom' kan onjuiste resultaten opleveren wanneer u een pakket uitvoert in Microsoft SQL Server 2008 Integration Services
561789 2292725 OPLOSSING: U ervaart verminderde prestaties wanneer u een MDX-query uitvoert in SQL Server 2008 SP1 met cumulatieve update 5 of een latere versie van het updatepakket geïnstalleerd
577020 2297308 FIX: Het foutbericht 'Een vorige configuratiepoging voor een bestandsstroom was onvolledig' en er treedt een toegangsfout op wanneer u de configuratie van de functie FILESTREAM na installatie uitvoert op een failovercluster van SQL Server 2008 of SQL Server 2008 R2
561783 2297709 FIX: er kan een foutbericht worden weergegeven wanneer u een 'BULK INSERT'-query uitvoert op een database waarin het herstelmodel 'BULK_LOGGED' of 'SIMPLE' in SQL Server 2008 wordt gebruikt
577018 2297903 FIX: gebeurtenis-id 322 wordt geregistreerd wanneer een servercontrole wordt uitgevoerd in SQL Server 2008 of SQL Server 2008 R2
561801 2300689 OPLOSSING: U kunt een back-up van een database niet terugzetten op een ander exemplaar van SQL Server als u transparante gegevensversleuteling uitschakelt voordat u de back-up maakt in SQL Server 2008 of in SQL Server 2008 R2
561787 2306162 OPLOSSING: Slechte prestaties en af en toe niet-renderende planningsfouten treden op wanneer u een complexe weergave maakt die verwijst naar een groot aantal geneste weergaven of tabellen in SQL Server 2008
561785 2316135 FIX: 'Er is een onverwachte uitzondering opgetreden' Interne fout en heapbeschadiging treedt op wanneer u een MDX-query uitvoert die wordt gegenereerd door software van derden in SSAS 2008
561793 2344600 FIX: Er treedt mogelijk een 'niet-renderende planning'-fout op wanneer u de functie CONTAINSTABLE gebruikt in combinatie met een groot aantal OF- en EN-predicaten in SQL Server 2008
561795 2352413 FIX: Queryfouten en het foutbericht 'Ongeldige kolomnaam' treden op wanneer u een query op een gekoppelde server uitvoert naar een ander exemplaar van SQL Server 2008
561742 2379466 FIX: De foutcode '0x84B10001', SQL Server 2008-installatiefout en een onverwerkte uitzondering treden op wanneer u SQL Server 2008 Setup uitvoert
561797 2380361 FIX: Foutbericht wanneer u de opgeslagen procedure 'sp_createstats' uitvoert in SQL Server 2008 of in SQL Server 2008 R2 als de tabel een niet-deterministische berekende kolom bevat
561799 2380435 FIX: Het queryplan voor een opgeslagen procedure wordt niet in de cache opgeslagen als de opgeslagen procedure gebruikmaakt van een BLOB-variabele en de variabele wordt gebruikt in een tekenreeksfunctie in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
561803 2384766 FIX: de eigenschap ANSI_NULLS van een geïndexeerde weergave wordt gewijzigd in ONWAAR nadat de geïndexeerde weergave is gerepliceerd naar de abonnementsdatabase in SQL Server 2008 of in SQL Server 2008 R2
561805 2387686 FIX: Foutbericht 'Er is een MOF-syntaxisfout opgetreden' treedt op wanneer u probeert SQL Server 2008 of SQL Server 2008 R2 te installeren
561813 2399715 FIX: Een 'UPDATE CUBE'-instructie retourneert een onjuist foutbericht wanneer u probeert een berekende maateenheid of een berekend lid in SSAS 2008 bij te werken
561811 2407172 FIX: Er treedt een uitzondering op voordat de foutuitvoer voor ongeldige gegevens van een 'XML-bron'-taak wordt omgeleid in SSIS 2005 of SSIS 2008

Cumulatieve updatepakketinformatie

Vereisten

Microsoft SQL Server 2008 Service Pack 2
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:

968382 Het meest recente servicepack voor SQL Server 2008 verkrijgen

Informatie over opnieuw opstarten

  Nadat u dit cumulatieve updatepakket hebt toegepast, moet u de computer wellicht opnieuw opstarten.

Registergegevens

  Als u een van de hotfixes in dit pakket wilt gebruiken, hoeft u geen wijzigingen in het register aan te brengen.

Meer informatie

  Voor meer informatie over het Incremental Servicing Model voor SQL Server klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:

935897
  Er is een incrementeel onderhoudsmodel beschikbaar van het SQL Server-team om hotfixes te leveren voor gemelde problemen

  Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het naamgevingsschema voor SQL Server-updates:

822499
  Nieuw naamgevingsschema voor software-updatepakketten voor Microsoft SQL Server
   Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over de terminologie van software-updates:

824684
  Beschrijving van de standaardterminologie die wordt gebruikt voor Microsoft-software-updates