INLEIDING
Cumulatieve update 6 bevat hotfixes voor de problemen met Microsoft SQL Server 2008 R2 die zijn opgelost sinds de release van SQL Server 2008 R2.
Opmerking: deze build van dit cumulatieve updatepakket staat ook bekend als build 10.50.1765.0.
Het is raadzaam hotfixes te testen voordat u ze in een productieomgeving implementeert. Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2008 R2-fixrelease. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
981356 De SQL Server 2008 R2-builds die zijn uitgebracht nadat SQL Server 2008 R2 zijn uitgebracht
Belangrijke opmerkingen over het cumulatieve updatepakket
- De hotfixes in dit cumulatieve updatepakket zijn opgenomen in SQL Server 2008 R2 Service Pack 1 (SP1).
- SQL Server 2008 R2-hotfixes zijn nu beschikbaar in meerdere talen. Daarom is er slechts één cumulatief hotfixpakket voor alle talen.
- Eén cumulatief hotfixpakket omvat alle onderdeelpakketten. Met het cumulatieve updatepakket worden alleen de onderdelen bijgewerkt die op het systeem zijn geïnstalleerd.
Meer informatie
Cumulatieve update 6 voor SQL Server 2008 R2 verkrijgen
Een ondersteund cumulatief updatepakket is nu beschikbaar bij Microsoft. Het is echter alleen bedoeld om de problemen op te lossen die in dit artikel worden beschreven. Pas het alleen toe op systemen die deze specifieke problemen ondervinden. Dit cumulatieve updatepakket kan aanvullende tests ontvangen. Daarom raden we u aan te wachten op het volgende servicepack voor SQL Server 2008 R2 dat de hotfixes in dit cumulatieve updatepakket bevat als u niet ernstig last hebt van een van deze problemen.
Als de cumulatieve update kan worden gedownload, vindt u de sectie 'Hotfix-download beschikbaar' bovenaan dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met de klantenservice en ondersteuning van Microsoft om het cumulatieve updatepakket te verkrijgen.
Opmerking: als er nog meer problemen optreden of als er problemen nodig zijn, moet u mogelijk een afzonderlijke serviceaanvraag maken. De gebruikelijke ondersteuningskosten zijn van toepassing op aanvullende ondersteuningsvragen en problemen die niet in aanmerking komen voor dit specifieke cumulatieve updatepakket. Voor een volledige lijst met telefoonnummers van de klantenservice en ondersteuning van Microsoft of om een afzonderlijke serviceaanvraag te maken, gaat u naar de volgende Microsoft-website:
Hotfixes voor SQL Server 2008 die zijn opgenomen in cumulatieve update 6 voor SQL Server 2008 R2
Microsoft Knowledge Base-artikelen waarin deze hotfixes worden besproken, worden gepubliceerd zodra ze beschikbaar zijn.
Voor meer informatie over de SQL Server-bugs klikt u op de volgende artikelnummers in de Microsoft Knowledge Base:
| VSTS-bugnummer | KB-artikelnummer | Beschrijving |
|---|---|---|
| 622431 | 980350 | FIX: Poolse woordbreker zorgt ervoor dat een Full-Text-query een onvolledig resultaat oplevert in SQL Server 2008 |
| 621227 | 2401548 | FIX: een ingesloten afbeelding van een rapport wordt onjuist weergegeven als een rood kruis in SQL Server 2008 Reporting Services |
| 642793 | 2403218 | FIX: sessie voor databasespiegeling wordt onderbroken in SQL Server 2005 als de modus Hoge prestaties (asynchrone) modus wordt gebruikt |
| 649236 | 2422081 | OPLOSSING: het geheugengebruik in SSAS 2008 is mogelijk groter dan in SSAS 2005 wanneer u een lokale kubus maakt |
| 561971 | 2424346 | FIX: rapport wordt niet goed weergegeven in een webonderdeel Rapportviewer wanneer u 'Hoogte aanpassen aan de zone' selecteert in SSRS 2008 R2 |
| 621243, 621246 | 2433265 | FIX: u ontvangt mogelijk een onjuist resultaat als u een query uitvoert die gebruikmaakt van de functie ROW_NUMBER in combinatie met een left outer join in SQL Server 2008 |
| 621919 | 2435404 | FIX: De computer reageert niet meer wanneer u een database maakt die een FILESTREAM-bestandsgroep bevat in SQL Server 2008 R2 als er een stuurprogramma voor minifilters van derden is geïnstalleerd |
| 621248 | 2435844 | FIX: een SQL Server Agent-taak wordt niet goed uitgevoerd na de opgegeven einddatum in SQL Server 2008 |
| 642079 | 2451540 | FIX: Slechte prestaties kunnen optreden wanneer u een query met meerdere self-join-bewerkingen uitvoert voor dezelfde kolom in SQL Server 2005 en in SQL Server 2008 |
| 649235 | 2454175 | FIX: Er wordt een verkeerde e-mailabonnement verwijderd als u de modus Geïntegreerde SharePoint gebruikt in SSRS 2008 als u de e-mailabonnementen sorteert |
| 572004 | 2455009 | FIX: Trage prestaties bij het herstellen van een database als het transactielogboek in SQL Server 2005 of SQL Server 2008 veel VLF's bevat |
| 628074 | 2472573 | FIX: Fout 'Kan geen verbinding maken met gegevensbron '*.xlsx'" wanneer u verbinding probeert te maken met een werkmap in de PowerPivot-galerie met behulp van Report Builder 3.0 in de geïntegreerde modus van SSRS 2008 R2 SharePoint |
| 649218 | 2478032 | FIX: 0xC002F325 fout wanneer u twee SSIS 2008-pakketten tegelijk uitvoert in SQL Server 2008 Integration Services |
| 632487 | 2479681 | FIX: De fout 'Een item met dezelfde code is al toegevoegd' wanneer u een rapport exporteert naar een PDF- of TIFF-bestand in SQL Server 2008 Reporting Services |
| 648196 | 2480368 | FIX: SSAS 2008 loopt vast nadat een ProcessFull-bewerking is uitgevoerd op een maateenheidgroep voor een serverkubus als SSAS een sessie probeert op te schonen die een sessiekubus bevat |
| 648209 | 2481245 | FIX: het draaitabelrapport retourneert mogelijk geen waarden nadat u een complex filter hebt toegepast in SSAS 2008 |
| 636021 | 2481926 | FIX: '#ERROR'-fout bij het genereren van een Hyperion Essbase-rapport in SQL Server 2008 R2 Reporting Services als een veldnaam een puntteken bevat |
| 649224 | 2482977 | FIX: 10061 Winsock-foutcode treedt op wanneer een toepassing de uitgebreide OLE DB-initialisatie-eigenschappen gebruikt voor de SQL Server Native Client 10.0 OLE DB-provider in de verbindingsreeks |
| 623572 | 2483381 | FIX: Een toepassing loopt vast wanneer de laatste verbinding met een lokaal kubusbestand in SSRS 2008 R2 wordt gesloten |
| 639010 | 2485396 | FIX: Fout bij het exporteren van een rapport in SSRS 2008 R2 met een harde weergave voor pagina-einden als de eigenschap HideDuplicates niet is ingesteld op Geen |
| 639636 | 2486113 | Er wordt altijd een vervolgkeuzelijst weergegeven in plaats van een zoekvak wanneer u dubbelklikt op de waarde van het vak voor filtercriteria voor een kenmerk in Entities Explorer van de SQL Server 2008 R2 MDS-website |
| 637780 | 2486777 | FIX: Foutbericht wanneer u een analyserapport weergeeft in het webonderdeelbesturingselement Rapportviewer in Microsoft SQL Server 2008 R2 Reporting Services in geïntegreerde SharePoint-modus: "rsExecutionNotFound" |
| 635423 | 2486793 | FIX: Het bovenliggende rapport bevat ten onrechte de parameters van een onderliggend rapport wanneer u klikt op "Ga Terug naar het bovenliggende rapport" in de geïntegreerde modus van SSRS 2008 R2 SharePoint |
| 630300 | 2487231 | Foutbericht 'DATABASE HERSTELLEN wordt abnormaal beëindigd' wanneer u een volledige back-up van een database maakt in SQL Server 2008 R2 |
| 632713 | 2490555 | FIX: gegevensupdate vindt niet dagelijks plaats in SQL Server 2008 R2 PowerPivot voor SharePoint als de kantooruren zijn ingesteld om de volgende dag te eindigen |
| 649222 | 2491210 | FIX: Onderhoudsplan maakt geen back-up van een database die is ingesteld op AUTO_CLOSE, HERSTELLEN of STAND-BY in SQL Server 2008 |
| 649233 | 2491214 | 'Niet-renderende planner'-fout en SQL Server 2008 reageert af en toe niet meer in Windows Server 2008 |
| 627317 | 2491439 | FIX: Fout bij het maken van een AMO-, ADOMD.NET- of XMLA-assembly in SQL Server 2008 R2 |
| 644831 | 2492027 | De rapporten die worden gegenereerd in SSRS 2008 R2 Report Manager voldoen niet aan de Section 508-normen |
| 645676 | 2492329 | FIX: Afname van renderingprestaties voor SQL Server 2008 R2 Reporting Services in geïntegreerde SharePoint-modus wanneer een rapport expressies bevat in acties 'Ga naar URL' |
| 648675 | 2492381 | FIX: SQL Server 2008 R2 presteert slecht als de meeste threads wachten op het CMEMTHREAD-wachttype als de threads tabelvariabelen of tijdelijke tabellen gebruiken om rijensets te laden of bij te werken |
| 646328 | 2493229 | FIX: Wanneer u gegevens importeert of vernieuwt in een PowerPivot voor Excel 2010-werkmap die is gepubliceerd op een SharePoint-site, kunnen onverwachte null-waarden worden weergegeven |
| 629581 | 2494447 | FIX: U ontvangt ten onrechte een aanmeldingsdialoogvenster wanneer u probeert toegang te krijgen tot een SQL Server 2008 R2 Reporting Services Report Manager-website |
| 648630 | 2495303 | FIX: De fout 'Parameterwaarden moeten worden opgegeven' wanneer u op een hyperlink in een e-mailbericht klikt om een SSRS 2008 R2-rapport te bekijken |
| 636807 | 2496707 | OPLOSSING: Er kan niet worden verwezen naar rafelige leden van een hiërarchie met behulp van de methode 'Name Style 2' in een MDX-query voor SQL Server 2008 R2 Analysis Services |
| 647200 | 2497301 | FIX: Het openen van de pagina 'Versie valideren' duurt erg lang of er treedt een time-out op nadat u op de MDS-website van SQL Server 2008 R2 op 'Versie valideren' hebt geklikt |
| 632667 | 2498796 | FIX: Er kan een toegangsfout optreden wanneer u de statistieken van een tabel bijwerkt nadat u conflictdetectie voor een tabel in SQL Server 2008 R2 hebt in- en uitgeschakeld |
| 647889 | 2498839 | FIX: er treedt een geheugenfout op wanneer u een volledig proces van een dimensie uitvoert in SSAS 2008 R2 |
| 646541 | 2498880 | FIX: Verbroken koppeling Start in het webonderdeel Rapportverkenner in SQL Server 2008 R2 Reporting Services |
| 649733 | 2501558 | FIX: De meting Uniek aantal kan onjuiste waarden retourneren nadat u partities afzonderlijk hebt verwerkt in SSAS 2008 R2 |
| 649672 | 2503278 | FIX: onjuist resultaat van een berekend lid dat verwijst naar een ander berekend lid als het berekende lid waarnaar wordt verwezen wordt gebruikt in een filterfunctie in SSAS 2008 R2 |
| 656725 | 2504112 | FIX: Prestatieprobleem bij het maken van entiteitsleden wanneer validatie van bedrijfsregels wordt uitgevoerd in SQL Server 2008 R2 MDS |
| 653979 | 2504524 | FIX: Fout 'Ongeldig variabeletype' of 'Type komt niet overeen' wanneer u een UPDATE CUBE-instructie uitvoert om de waarde van een null-cel in een kubus met writeback-functionaliteit in SSAS 2008 R2 te wijzigen |
Cumulatieve updatepakketinformatie
Informatie over opnieuw opstarten
Nadat u deze cumulatieve update hebt toegepast, moet u de computer wellicht opnieuw opstarten.
Registergegevens
Als u een van de hotfixes in dit pakket wilt gebruiken, hoeft u geen wijzigingen in het register aan te brengen.
Het cumulatieve updatepakket verwijderen
Voer de volgende stappen uit om het cumulatieve updatepakket te verwijderen:
Open in het Configuratiescherm de
Programma's toevoegen of verwijderen
-item.Klikt u op
Programma's wijzigen of verwijderen
.Als u alle updates voor de installatie van SQL Server 2008 R2 wilt zien, klikt u op de
Toon Updates
in.Verwijder het cumulatieve hotfixpakket.
Meer informatie
Voor meer informatie over het Incremental Servicing Model voor SQL Server klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
935897
Er is een incrementeel onderhoudsmodel beschikbaar van het SQL Server-team om hotfixes te leveren voor gemelde problemen
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het naamgevingsschema voor SQL Server-updates:
822499
Nieuw naamgevingsschema voor software-updatepakketten voor Microsoft SQL Server
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over de terminologie van software-updates:
824684
Beschrijving van de standaardterminologie die wordt gebruikt voor Microsoft-software-updates