KB3182545 - release-informatie SQL Server 2016 Service Pack 1

Releasedatum: vrijdag 16 november 2016
Versie: 13.0.4001.0

Dit artikel bevat belangrijke informatie die u moet lezen voordat u Microsoft SQL Server 2016 Service Pack 1 (SP1) installeert. Hierin wordt beschreven hoe u het servicepack kunt verkrijgen, een lijst met oplossingen die zijn opgenomen in het servicepack, bekende problemen en een lijst met auteursrechten voor het product.

Opmerking

In dit artikel kunt u alle documentatie vinden met betrekking tot dit servicepack. Het bevat alle informatie die u eerder aantrof in de releaseopmerkingen en Readme.txt bestanden.

Bekende problemen in dit servicepack

SQL Server Reporting Services

Na de installatie van SQL Server 2016 SP1 kunnen de volgende problemen optreden wanneer u SQL Server Reporting Services gebruikt:

  • Als Reporting Services is ingesteld op het gebruik van een beveiligde (https/SSL) verbinding, kan er een waarschuwing over beveiligingsinhoud worden weergegeven.

  • In sommige gevallen werkt de knop Afdrukken niet meer.

Installeer de hotfix in KB 3207512 om deze problemen op te lossen.

SQL Server Integration Services (SSIS)

Nadat u SQL Server 2016 SP1 hebt geïnstalleerd, worden de DCOM-machtigingen voor het starten van en de toegang tot de Integration Services-service teruggezet naar de standaardmachtigingen. Als u DCOM-machtigingen hebt aangepast, moet u de aanpassing opnieuw toepassen.

ODBC Driver 13.1

Met de standaardinstallatie van SQL Server 2016 wordt ODBC-stuurprogramma 13.0 geïnstalleerd op de server die wordt gebruikt door SQL Agent en SSMS (geïnstalleerd op de server) om verbinding te maken met het exemplaar van SQL Server. Als u om de een of andere reden ODBC-stuurprogramma 13.1 op uw server hebt geïnstalleerd, wordt de installatie van ODBC-stuurprogramma 13.1 vervangen door SQL Server 2016 SP1-installatie en gaan de correcties die in 13.1 werden geïntroduceerd, zoals KB-3185365 mogelijk verloren. In dit geval na de installatie van SQL Server 2016 SP1 is het raadzaam om het ODBC-stuurprogramma van SQL Server 2016 SP1 te verwijderen en ODBC-stuurprogramma 13.1 te installeren.

Als u wilt controleren of er een ODBC-stuurprogramma op de server is geïnstalleerd, gaat u naar het Configuratiescherm van de server -> Programma's en onderdelen -> ODBC zoeken. Het versienummer van ODBC-stuurprogramma 13.1 is 13.1.811.168, zoals hieronder wordt weergegeven:

Schermafbeelding van Microsoft ODBC-stuurprogramma 13 voor SQL Server.

Lijst met correcties in SQL Server 2016 SP1

Microsoft SQL Server 2016-servicepacks zijn cumulatieve updates. Alle edities en serviceniveaus van SQL Server 2016 SP1 worden in SQL Server 2016 SP1 bijgewerkt naar SQL Server 2016 SP1. Naast de oplossingen die in dit artikel worden vermeld, bevat SQL Server 2016 SP1 hotfixes die zijn opgenomen in SQL Server 2016 cumulatieve update 1 (CU1) naar SQL Server 2016 CU3.

Zie buildversies van SQL Server 2016 voor meer informatie over de cumulatieve updates die beschikbaar zijn in SQL Server 2016.

Opmerking

  • Aanvullende oplossingen die hier niet worden beschreven, kunnen ook in het servicepack worden opgenomen.
  • Deze lijst wordt bijgewerkt wanneer er meer artikelen worden uitgebracht.

Ga naar de volgende Microsoft Knowledge Base-artikelen voor meer informatie over de fouten die worden verholpen in SQL Server 2016 SP1.

Bugreferentie Beschrijving
7778636 Er is een update beschikbaar waarmee de uitgebreide traceringsgebeurtenis wordt uitgebreid met handshake-gegevens van het beveiligingsprotocol in SQL Server 2016 (KB3191296)
7898693 DBCC CLONEDATABASE gebruiken om een schema- en statistische kopie van een gebruikersdatabase te genereren in SQL Server 2014 SP2 en SQL Server 2016 SP1 (KB3177838)
7994008 Ondersteunt DROP TABLE DDL voor artikelen die zijn opgenomen in transactionele replicatie in SQL Server 2014 of in SQL Server 2016 SP1 (KB3170123)
8024963 Update voor het toevoegen van een geheugentoekenningswaarschuwing aan de Showplan XML in SQL Server 2014 of 2016 (KB3172997)
8024978 Update voor het toevoegen van DMF-sys.dm_db_incremental_stats_properties in SQL Server 2014 of 2016 (KB3170114)
8024984 Update om maximaal geheugen beschikbaar te maken ingeschakeld voor één query in Showplan XML in SQL Server 2014 of 2016 (KB3170112)
8024985 Informatie over ingeschakelde traceringsvlaggen wordt toegevoegd aan showplan XML in SQL Server 2014 SP2 of 2016 (KB3170115)
8025018 Verbeterde diagnostiek voor query-uitvoeringsplannen met resterende predicaat-pushdown in SQL Server (KB3107397)
8025088 Update voegt uitgebreide AlwaysOn-gebeurtenissen en prestatiemeteritems toe in SQL Server 2014 of 2016 (KB3173156)
8025128 Hiermee wordt een opgeslagen procedure toegevoegd voor het handmatig opschonen van de bijgehouden bijzetlijst in SQL Server 2014 SP2 of 2016 SP1 (KB3173157)
8103248 Er is een update beschikbaar die een nieuwe queryhint introduceert TIP GEBRUIKEN in SQL Server 2016 (KB3189813)
8103261 Een update voor de introductie van een nieuwe Transact-SQL-instructie CREATE OR ALTER in SQL Server 2016 (KB3190548)
8103265 Update voor het verbeteren van de diagnostiek door het gegevenstype van de parameters voor parameterquery's beschikbaar te stellen in showplan XML-uitvoer in SQL Server 2016 (KB3190761)
8110745 Er is een update beschikbaar die ondersteuning toevoegt voor zelfreferentiële beperkingen in de nieuwe operator voor referentiële integriteit in SQL Server 2016 (KB3191273)
8149617 Update voor het verbeteren van de diagnostiek voor query-uitvoeringsplannen met resterende predicaat-pushdown in SQL Server 2016 (KB3190762)
8155425 Een nieuwe DynamicManagement-functie "sys.dm_exec_query_statistics_xml" is beschikbaar in SQL Server 2016 Service Pack 1 (KB3190871)
8349500 Er is een update beschikbaar die algemene informatie uit de statistieken over het uitvoeren van query's toevoegt aan de STATISTISCHE XML-uitvoer in SQL Server 2016 (KB3201552)
7062744 FIX: 'Salt'-kenmerk voor wachtwoord ontbreekt in het projectmanifest'-fout bij het sluiten en opnieuw openen van een SSIS BI-project in SQL Server 2016 (KB3189687)
8024967 FIX: een ernstige fout bij het gebruik van de sys.dm_db_uncontained_entities DMV in SQL Server 2014 of 2016 (KB3172998)
8024976 Fout 'Logboekprovider 'Microsoft.LogProviderSQLServer' is niet correct geïnstalleerd' wanneer u het venster SSIS-logboeken configureren opent (KB3100256)
8025041 FIX: Fout 'Kan herstelplan niet maken vanwege breuk in de LSN-keten' wanneer u differentiële back-up terugzet in SSMS (KB3065060)
8025045 Fout bij het uitvoeren van een SSIS-pakket op Windows met FIPS-ondersteuning (KB2925865)
8025056 FIX: Geheugentoewijzing die vereist is om een geoptimaliseerde geneste lus-join uit te voeren, wordt niet weerspiegeld in Showplan XML in SQL Server 2014 of 2016 (KB3170116)
8025125 FIX: SQL Server foutenlogboek vermeldt ten onrechte logische processors wanneer soft-NUMA is ingeschakeld (KB3189663)
8025131 DMV sys.dm_os_memory_nodes retourneert een niet-nulwaarde voor de pages_kb waarde voor het DAC-knooppunt in SQL Server 2016 (KB3170015)
8025149 FIX: DBCC CHECKDB of CHECKTABLE retourneert fout-positieven voor beschadiging van gegevens en mislukte bevestigingen in SQL Server 2014 of 2016 (KB3173766)
8265472 FIX: Installatie van cumulatieve update 1 voor SQL Server 2016 mislukt op een benoemd exemplaar (KB3189709)
8273495 FIX: Impasse wanneer je een queryplan met een geneste lus-join in batchmodus uitvoert in SQL Server 2014 of 2016 (KB3195825)
8274352 FIX: lange compilatietijd voor een query met veel verschillende operators in SQL Server 2016 (KB3201554)
8338496 FIX: De map FileTable reageert niet meer als u meerdere bestanden tegelijk maakt in SQL Server 2014 of 2016 (KB3191062)
8343868 FIX: query's die CHANGETABLE gebruiken, gebruiken veel meer CPU in SQL Server 2014 SP1 of in SQL Server 2016 (KB3180060)
8451202 OPGELOST: SQL Server 2016 registreert geen foutberichten met een ernstniveau van 21 voor niet-overeenkomende controlesom in In-Memory OLTP-controlepuntbestanden (KB4019715)
8528563 FIX: SQL Server 2016 reageert niet meer wanneer u databases herstelt die voor geheugen geoptimaliseerde tabellen (KB3197605) bevatten
8529432 OPLOSSING: SQL Server Beheerde back-up naar Windows Azure probeert een back-up te maken van momentopnamen van databases in SQL Server (KB3168708)
Nieuwe prestatiefunctie die doorvoertijden van transacties (latentie) tot 2-4x versnelt bij gebruik van opslagklassegeheugen (niet-vluchtige NVDIMM-N-opslag)
Slechte prestaties bij het uitvoeren van INSERT. SELECT-bewerkingen in SQL Server 2016 (KB3180087)
Waarschuwing 'Een digitaal ondertekend stuurprogramma is vereist' wanneer u SQL Server pakketten installeert in Windows Server 2016 and Windows 10 (KB3203693)
8024991 FIX: Ontbrekende kolommen worden niet opgegeven in het foutbericht wanneer u gegevens importeert met behulp van de wizard Importeren en exporteren (KB3112704)

Aanvullende resoluties

Oplossingen voor de volgende problemen zijn ook opgenomen in SQL Server 2016 SP1.

Bugreferentie Beschrijving Oplossingsgebied

68674998024974
NULL-waarden worden genegeerd wanneer het gegevenstype van een kolom wordt gewijzigd van tekst in varchar(max). Motor
8024962 Sqlcmd stopt zonder fouten als de querytekst zowel ingesloten opmerkingen als accolades ("{" bevat, of "}"). Motor
8024968 Batchsorteren en geoptimaliseerde geneste lus kunnen stabiliteits- en prestatieproblemen veroorzaken. Motor
8024987 Tabelscans en indexscans met push-down-predicaat hebben de neiging om de geheugentoewijzing voor de bovenliggende operator te overschatten. Motor
8024997 De zoekfunctie Full-Text werkt niet zoals verwacht voor het Nederlands. Motor
8025069 De CREATE NONCLUSTERED INDEX instructie kan mislukken als de databasenaam begint met een teken#. Motor
8025097 Voeg informatieve berichten toe voor tempdb configuraties in het foutenlogboek van de SQL Server. Motor
8267453 MERGE Instructies die beide UPDATE bevatten en INSERT instructies mislukken met 'Kan dubbele sleutelrij niet invoegen' als de doeltabel een unieke index bevat. Motor
8279683 SQL Server loopt vast wanneer een Tuple Mover-taak onverwacht wordt beëindigd. Motor
8025058 Voeg de tabelnaam en informatie over de primaire-sleutelwaarde voor fout 20598 toe aan de msdistribution_history tabel (SQL Server Replicatie). Verbetering
8025059 Wanneer een replicatieagent mislukt met een querytime-out, wordt de querytekst geregistreerd zonder dat uitgebreide logboekregistratie is ingeschakeld. Replicatie
8025081 De agent voor de lezer van het replicatielogboek kan mislukken wanneer de doeltabel een lege tekenreeks is. Replicatie
4300066 Werk de copyrightinformatie bij naar '© 2016 Microsoft' in de installatie van de opdrachtprompt van SQL Server. Setup
5610151 Er wordt een onnodig waarschuwingsbericht geretourneerd in de opdrachtregeluitvoer wanneer slipstream SQL Server met opdrachtregeloptie installeert. Setup
7270486 Nadat u een of meer updates voor SQL Server hebt verwijderd, mislukt de herstelbewerking met fouten wanneer u SQL Server herstelt. Setup
7350315 Installatie van SQL Server op een computer met een niet-Engelse domeinnaam mislukt met de fout 'Ongeldige tekens in pad'. Setup
7439317 De tekenreeks 'Setup Discovery Report' in het 'Installed SQL Server features discovery report' is niet gelokaliseerd. Setup
7439502 In de installatiewizard van SQL Server 2016 wordt ten onrechte naar SQL Server 2008 SP3 verwezen terwijl SQL 2008 R2 SP3 wel vereist is. Setup
8024994 Op het tabblad Voltooien ontbreekt de koppeling naar de MSDN-documentatie 'Surface Area Configuration' in de sectie Document and Links in een slipstream-installatie. Setup
8051010 De installatie van SQL Server 2016 kan mislukken als ODBC-stuurprogramma 11 voor SQL Server is geïnstalleerd tijdens de installatie. Setup
8343905 Een slipstream-installatie kan mislukken met de fout 'Validatie van sterke naam is mislukt'. Setup
8348718 Als UpdateEnabled de optie is ingesteld op False een slipstream-installatie, bevat het logboek met setup-overzichten geen informatie over de updates die tijdens de installatie zijn geïnstalleerd. Setup
8024972 BCP mislukt met fout bij het parseren van de datumnotatie YYYY/MM/DD in een DATE kolom. SQL-connectiviteit
5128484 De standaardeditie van SQL Server 2016 Analysis Services (tabelmodus) negeert de geheugenlimiet van 16 GB. SSAS
7487320 Query's met Row-Level Security (RLS) kunnen mislukken, zelfs als de DataView is ingesteld op Voorbeeld. SSAS
8210484 Het affiniteitsmasker werkt niet goed voor NUMA-knooppunten in SQL Server 2016 Analysis Services. SSAS
8281121 Verbeter de schaalbaarheid van SSAS-tabellarische prestaties door NUMA-bewustzijn te implementeren in SSAS-tabelmodus. SSAS
8430619 Verbeter de schaalbaarheid van SSAS-prestaties in tabelvorm door gebruik te maken van Intel® Threading Building Blocks (Intel® TBB). SSAS
8024998 De fout 'Logboekprovider 'Microsoft.LogProviderEventLog is niet geïnstalleerd' treedt op wanneer u het dialoogvenster SSIS-logboeken configureren opent: Pakket in een SSIS-pakket dat al een logboek heeft. SSIS
8025032 Deze update wijzigt het gedrag waarbij Unicode-codering wordt gebruikt wanneer de XML-taak niet kan worden opgehaald uit de XML-documenten. SSIS
7330691 Hiermee wordt aanvullende informatie aan de uitvoeringslogboeken van de SSRS-rapportserver toegevoegd om aan te geven of een rapport een mobiel rapport is. SSRS
7807395 Mogelijk moet u opnieuw proberen de autorisatie uit te voeren als gegevensafstemming mislukt voor een tabel met Stretch Database. Stretch DB
8196154 Query-uitvoering kan mislukken voor een tabel met Stretch Database waarvoor een filterpredikaat is opgegeven. Stretch DB
8292093 Het maken, wijzigen of neerzetten van indexen in een tabel waarvoor Database uitrekken is ingeschakeld, kan mislukken. Stretch DB

Zie Ondersteunde versie- en editie-upgrades voor meer informatie over hoe u de SQL Server-installatie naar SQL Server 2016 SP1 bijwerkt.

Aan de slag met SQL Server 2016 SP1

U kunt SQL Server 2016 SP1 downloaden vanaf de downloadpagina van SQL Server 2016 SP1.

Opmerking

Nadat u het servicepack hebt geïnstalleerd, moet de serviceversie van SQL Server worden weergegeven als 13.0.4422.0.

Als u ervoor kiest om SQL Server 2016 SP1 om wat voor reden dan ook te verwijderen, wordt het verwijderen van SQL Server 2016 SP1 niet geblokkeerd en kunt u SQL Server 2016 SP1 net als elk ander servicepack verwijderen. Als u echter werkt met de Standard-, Web- of Express-editie van SQL Server en gebruikmaakt van enkele nieuwe functies die pas vanaf SQL Server 2016 SP1 worden ontgrendeld, ziet u mogelijk onverwachte fouten of worden databases mogelijk zelfs verdacht achtergelaten na het verwijderen van SQL Server 2016 SP1. Als de systeemdatabases gebruikmaken van nieuwe functies, zoals een gepartitioneerde tabel in de hoofddatabase, kan dit ertoe leiden dat een exemplaar van SQL Server niet meer kan worden gestart na het verwijderen van SQL Server 2016 SP1. Het is daarom raadzaam om te controleren of alle nieuwe functies zijn uitgeschakeld of verwijderd zijn voordat u ervoor kiest om SQL Server 2016 SP1 te verwijderen in andere edities dan Enterprise Edition. Het is niet mogelijk om memory_optimized_data bestandsgroep te verwijderen. Dus als u een setup-bestandsgroep in uw database met SP1 hebt ingesteldmemory_optimized_data, moet u SQL Server 2016 SP1 niet verwijderen. In dat geval wordt de database anders verdacht en wordt het volgende foutbericht in het foutenlogboek vastgelegd:

<DateTime> spid15s-fout: 41381, ernst: 21, status: 1.
<DateTime> spid15s De database kan niet worden gestart in deze editie van SQL Server omdat deze een MEMORY_OPTIMIZED_DATA bestandsgroep bevat. Zie Boeken Online voor meer informatie over de ondersteuning van functies in verschillende edities van SQL Server.

  • Dit product bevat software die is afgeleid van de Xerox Secure Hash-functie.

  • Dit product bevat software uit de zlib compressiebibliotheek voor algemeen gebruik.

  • Delen van deze software zijn gedeeltelijk gebaseerd op het werk van RSA Data Security, Inc. Omdat Microsoft de RSA Data Security, Inc.-software in dit product heeft opgenomen, is Microsoft verplicht de onderstaande tekst bij deze software op te nemen:

    • Copyright 1990, RSA Data Security, Inc. Alle rechten voorbehouden.
    • Licentie voor het kopiëren en gebruiken van deze software wordt verleend op voorwaarde dat deze wordt geïdentificeerd als het 'RSA Data Security, Inc., MD5 Message-Digest Algorithm' in al het materiaal waarin deze software of deze functie wordt genoemd of ernaar verwijst. Licentie wordt ook verleend om afgeleide werken te maken en te gebruiken, op voorwaarde dat dergelijke werken worden geïdentificeerd als "afgeleid van de RSA Data Security, Inc., MD5 Message-Digest Algorithm" in al het materiaal dat het afgeleide werk vermeldt of ernaar verwijst.
    • RSA Data Security, Inc. doet geen uitspraken over de verkoopbaarheid van deze software of de geschiktheid van deze software voor een bepaald doel. Deze wordt geleverd 'as is', zonder expliciete of impliciete garantie van welke aard dan ook.

    Deze kennisgevingen moeten worden bewaard in kopieën van enig deel van deze documentatie of software.

  • De toewijzingsfunctie van Reporting Services maakt gebruik van gegevens uit TIGER/Line Shapefiles die met dank aan het Census Bureau van de Verenigde Staten worden geleverd. TIGER/Line Shapefiles zijn een uittreksel van geselecteerde geografische en cartografische informatie uit de Census MAF/TIGER-database. TIGER/Line Shapefiles zijn gratis verkrijgbaar bij het Census Bureau van de Verenigde Staten. Ga voor meer informatie over de TIGER/Line shapefiles naar TIGER/Line shapefiles. De grensinformatie in de TIGER/Line Shapefiles is alleen bedoeld voor statistische gegevensverzameling en tabelleringsdoeleinden; De afbeelding en aanduiding voor statistische doeleinden vormt geen bepaling van jurisdictieautoriteit, eigendomsrechten of aanspraken, en weerspiegelt geen wettelijke landbeschrijvingen. Census TIGER en TIGER/Line zijn gedeponeerde handelsmerken van het Census Bureau van de Verenigde Staten.

Copyright 2012 Microsoft. Alle rechten voorbehouden.

Meer informatie

Als u meer informatie wilt over het bepalen van de huidige versie en editie van SQL Server, selecteert u het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:

321185 Uw SQL Server versie en editie identificeren

De producten van derden die in dit artikel worden besproken, worden ontwikkeld door bedrijven die losstaan van Microsoft. Microsoft biedt geen garantie, uitdrukkelijk noch impliciet, voor de prestaties en betrouwbaarheid van deze producten.