Tworzenie i udostępnianie pulpitu nawigacyjnego w programie Excel i grupach Microsoft

Dotyczy
Excel dla Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

Pulpit nawigacyjny to wizualna reprezentacja kluczowych metryk, która umożliwia szybkie wyświetlanie i analizowanie danych w jednym miejscu. Pulpity nawigacyjne nie tylko zapewniają skonsolidowane widoki danych, ale także umożliwiają samoobsługową analizę biznesową, dzięki której użytkownicy mogą filtrować dane, aby wyświetlić tylko to, co jest dla nich ważne. W przeszłości raportowanie w programie Excel często wymagało wygenerowania wielu raportów dla różnych osób lub działów w zależności od ich potrzeb.

Przykład pulpitu nawigacyjnego programu Excel z fragmentatorami i omówieniem osi czasu

W tym temacie omówiono sposób tworzenia dynamicznego pulpitu nawigacyjnego za pomocą wielu tabel przestawnych, wykresów przestawnych i narzędzi tabel przestawnych. Następnie użytkownicy będą mogli szybko filtrować dane w żądany sposób za pomocą fragmentatorów i osi czasu, które umożliwiają automatyczne rozszerzanie i zwężanie tabel przestawnych i wykresów w celu wyświetlania tylko tych informacji, które użytkownicy chcą zobaczyć. Ponadto można szybko odświeżyć pulpit nawigacyjny podczas dodawania lub aktualizowania danych. Jest to bardzo przydatne, ponieważ wystarczy raz utworzyć raport pulpitu nawigacyjnego.

W tym przykładzie utworzymy cztery tabele przestawne i wykresy z jednego źródła danych.

Po utworzeniu pulpitu nawigacyjnego pokażemy, jak udostępniać go innym osobom, tworząc grupę Microsoft. Mamy również interakcyjny skoroszyt programu Excel, który możesz pobrać i samodzielnie wykonać poniższe czynności.

Pobierz skoroszyt samouczka dotyczącego pulpitu nawigacyjnego programu Excel.

Uzyskiwanie danych

  1. Dane można kopiować i wklejać bezpośrednio do programu Excel lub skonfigurować zapytanie ze źródła danych. W tym temacie użyto zapytania analizy sprzedaży z szablonu Northwind Traders dla programu Microsoft Access. Jeśli chcesz z niej skorzystać, możesz otworzyć program Access i przejść do pozycji Wyszukiwanienowych> plików>, a następnie w polu wyszukiwania wprowadź ciąg "Northwind" i utwórz szablonową bazę danych. Gdy to zrobisz, uzyskasz dostęp do dowolnych zapytań zawartych w szablonie. Te dane zostały już umieszczone w skoroszycie programu Excel, więc nie musisz się martwić, jeśli nie masz programu Access.

  2. Sprawdź, czy dane mają prawidłową strukturę i nie brakuje w nich wierszy ani kolumn. Każdy wiersz powinien reprezentować pojedynczy rekord lub element. Aby uzyskać pomoc dotyczącą konfigurowania zapytania lub jeśli konieczne jest zmodyfikowanie danych, zobacz Pobieranie & przekształcanie w programie Excel.

    Przykładowe dane w tabeli programu Excel do użycia jako źródło danych tabeli przestawnej

  3. Jeśli jeszcze nie jest, sformatuj dane jako tabelę programu Excel. Podczas importowania z programu Access dane zostaną automatycznie zaimportowane do tabeli.

Tworzenie tabel przestawnych

  1. Zaznacz dowolną komórkę w zakresie danych i przejdź do pozycji Wstaw> tabelę >przestawnąNowy arkusz. Aby uzyskać więcej szczegółowych informacji, zobacz Tworzenie tabeli przestawnej do analizowania danych w arkuszu .

  2. Dodaj wybrane pola tabeli przestawnej, a następnie sformatuj je zgodnie z potrzebami. Ta tabela przestawna będzie bazą dla innych tabel, więc warto poświęcić trochę czasu na wprowadzenie niezbędnych dostosowań stylu, układu raportu i ogólnego formatowania już teraz, aby nie trzeba było tego robić wielokrotnie. Aby uzyskać więcej informacji, zobacz: Projektowanie układu i formatu tabeli przestawnej.
    W tym przypadku utworzyliśmy podsumowanie sprzedaży najwyższego poziomu według kategorii produktów i posortowaliśmy je według pola Sprzedaż w kolejności malejącej.

    Przykładowa tabela przestawna według kategorii, sprzedaż &% sumy

    Aby uzyskać więcej szczegółowych informacji, zobacz Sortowanie danych w tabeli przestawnej lub na wykresie przestawnym .

  3. Po utworzeniu wzorcowej tabeli przestawnej zaznacz ją, a następnie skopiuj i wklej tyle razy, ile potrzeba, aby puste obszary w arkuszu. Na przykład te tabele przestawne mogą zmieniać wiersze, ale nie kolumny, dlatego umieściliśmy je w tym samym wierszu z pustą kolumną między każdą z nich. Może się jednak okazać, że konieczne może być umieszczenie tabel przestawnych jedna pod drugą, jeśli umożliwiają one rozwijanie kolumn.

    Ważne

    Tabele przestawne nie mogą nakładać się na siebie, dlatego upewnij się, że w projekcie między tabelami jest wystarczająco dużo miejsca, aby umożliwić ich rozszerzanie i zwijanie podczas filtrowania, dodawania lub usuwania wartości.

    Na tym etapie warto nadać tabelom przestawnym nazwy opisowe, aby wiedzieć, do czego służą. W przeciwnym razie program Excel nada im nazwy Tabela przestawna1, Tabela przestawna2 itd. Możesz zaznaczyć każdą tabelę, przejść do pozycji Analiza>tabeli przestawnej , a następnie wprowadzić nową nazwę w polu Nazwa tabeli przestawnej . Jest to ważne, gdy przychodzi czas na połączenie tabel przestawnych z fragmentatorami i kontrolkami osi czasu.

    Zmienianie nazwy tabeli przestawnej na karcie Narzędzia > tabel przestawnych Okno dialogowe Analiza > nazwy tabeli przestawnej

Tworzenie wykresów przestawnych

  1. Kliknij dowolne miejsce w pierwszej tabeli przestawnej i przejdź do pozycjiWykres przestawny w obszarzeNarzędzia>do analizy> tabeli przestawnej, a następnie wybierz typ wykresu. Wybraliśmy wykres kombi z wykresem Sprzedaż jako wykres kolumnowy grupowany i % sumy jako wykres liniowy wykreślony na osi pomocniczej.

    Okno dialogowe wyświetlania wykresu złożonego z wykresem kolumnowym grupowanym i wykresem liniowym

  2. Zaznacz wykres, a następnie wybierz odpowiedni rozmiar i sformatuj go za pomocą kart Analiza, Projektowanie i Formatowaniewykresu przestawnego. Aby uzyskać więcej szczegółowych informacji, zobacz naszą serię dotyczącą formatowania wykresów.

  3. Powtórz te czynności dla każdej z pozostałych tabel przestawnych.

  4. Teraz jest też dobry moment na zmianę nazw wykresów przestawnych. Przejdź do pozycji Analizowanie wykresu przestawnego, a> następnie wprowadź nową nazwę w polu Nazwa wykresu.

Dodawanie fragmentatorów i osi czasu

Fragmentatory i osie czasu umożliwiają szybkie filtrowanie tabel i wykresów przestawnych w celu wyświetlenia informacji, które są istotne dla użytkownika.

Widok rozsunięty fragmentatorów i kontrolki osi czasu na pulpicie nawigacyjnym

  1. Wybierz dowolną tabelę przestawną i przejdź do pozycji Analiza tabeli przestawnej,Filtr>>,Wstaw fragmentator, a następnie zaznacz każdy element, którego chcesz użyć jako fragmentatora. Dla tego pulpitu nawigacyjnego wybraliśmy kolumny Kategoria, Nazwa produktu, Pracownik i Imię i nazwisko klienta. Po kliknięciu przycisku OK fragmentatory zostaną dodane na środku ekranu i ułożone jeden na drugim, więc trzeba będzie je odpowiednio rozmieścić i zmienić ich rozmiar.

    Opcja Wstaw fragmentator w obszarze Narzędzia > tabel przestawnych Analizuj > filtr

  2. Opcje fragmentatora: Po kliknięciu dowolnego fragmentatora możesz przejść do jego karty i wybrać różne opcje, takie jak Styl i Liczba wyświetlanych kolumn. Możesz wyrównać wiele fragmentatorów, zaznaczając je za pomocą klawiszy Ctrl+Lewy przycisk myszy, a następnie używając narzędzi Wyrównywanie na karcie Narzędzia fragmentatora .

  3. Połączenia fragmentatora: Fragmentatory będą połączone tylko z tabelą przestawną, za pomocą której zostały utworzone, więc musisz zaznaczyć każdy fragmentator, a następnie przejść do>strony Połączenia raportufragmentatora> fragmentatora i sprawdzić, które tabele przestawne chcesz połączyć z poszczególnymi tabelami. Fragmentatory i osie czasu mogą sterować tabelami przestawnymi w dowolnym arkuszu, nawet jeśli jest on ukryty.

    Połączenia raportu fragmentatora z opcji narzędzi > fragmentatora

  4. Dodaj oś czasu: Wybierz dowolną tabelę przestawną i przejdź do tabeli przestawnej, Analizuj,>Filtruj>, Wstaw oś czasu, a następnie zaznacz każdy element, którego chcesz użyć. Dla tego pulpitu nawigacyjnego wybraliśmy pozycję Data zamówienia.

  5. Opcje osi czasu: Kliknij oś czasu, przejdź do karty osi czasu i wybierz opcje, takie jak Styl, Nagłówek i Podpis. Wybierz opcję Połączenia raportu , aby połączyć oś czasu z wybranymi tabelami przestawnymi.

Dowiedz się więcej o fragmentatorach i kontrolkach osi czasu .

Następne kroki

Pulpit nawigacyjny jest teraz funkcjonalnie kompletny, ale prawdopodobnie nadal musisz dostosować go do swoich oczekiwań i wprowadzić ostateczne zmiany. Na przykład możesz dodać tytuł raportu lub tło. Na naszym pulpicie nawigacyjnym dodaliśmy kształty wokół tabel przestawnych i wyłączyliśmy nagłówki i linie siatki na karcie Widok .

Koniecznie przetestuj każdy fragmentator i każdą z osi czasu, aby upewnić się, że Twoje tabele przestawne i wykresy przestawne działają zgodnie z oczekiwaniami. Sytuacje, w których pewne zaznaczenia powodują problemy, mogą wystąpić sytuacje, w których jedna tabela przestawna chce dostosować i nałożyć się na inną tabelę, czego nie może zrobić i wyświetli komunikat o błędzie. Te problemy powinny zostać rozwiązane przed rozpowszechnieniem pulpitu nawigacyjnego.

Po zakończeniu konfigurowania pulpitu nawigacyjnego możesz kliknąć kartę Udostępnij pulpit nawigacyjny u góry tego tematu, aby dowiedzieć się, jak rozpowszechniać ten pulpit.

Zobacz też

Masz pytania, na które tutaj nie ma odpowiedzi?

Odwiedź społeczność Microsoft Answers.