Objawy
Rozważmy następujący scenariusz:
- Replikacji używa się w programie Microsoft SQL Server 2012 lub SQL Server 2014.
- W ramach subskrypcji replikacji dodawano subskrypcję, a następnie ją usuwano.
W tym scenariuszu może zostać wyświetlony następujący błąd 515:
Uwaga
Nie można wstawić wartości NULL w kolumnie "article_id", tabeli "<DistributionDatabaseName.dbo>. MSrepl_commands"; kolumna nie zezwala na wartości null. INSERT fails.
Przyczyna
Ten problem występuje z powodu regresji programu SQL Server 2012. Po dodaniu subskrypcji, a następnie jej usunięciu, metadane replikacji dotyczące subskrypcji są natychmiast usuwane, ponieważ występuje opóźnienie, zanim LogReader napotka polecenie dodania subskrypcji.
Rozwiązanie
Ten problem został po raz pierwszy rozwiązany w następującej aktualizacji zbiorczej programu SQL Server.
Aktualizacja skumulowana 1 dla systemu SQL Server 2012 z dodatkiem SP2 /pl-pl/pomoc/2976982
Zbiorcza aktualizacja 2 dla systemu SQL Server 2014 /pl-pl/pomoc/2967546
Skumulowana aktualizacja 10 dla SQL Server 2012 z dodatkiem Service Pack 1 /en-us/help/2954099
Informacje o aktualizacjach zbiorczych dla programu SQL Server
Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji skumulowanej. Sprawdź najnowsze aktualizacje zbiorcze dla programu SQL Server:
- Najnowsza aktualizacja zbiorcza dla programu SQL Server 2012 z dodatkiem SP2
- Najnowsza aktualizacja zbiorcza dla programu SQL Server 2014
- Najnowsza aktualizacja zbiorcza dla programu SQL Server 2012 z dodatkiem SP1
Stan
Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.