KB2958062 — POPRAWKA: Błąd 515 podczas dodawania subskrypcji, a następnie jej usuwania w SQL Server 2012 lub SQL Server 2014

Dotyczy
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Objawy

Rozważmy następujący scenariusz:

  • Replikacji używa się w programie Microsoft SQL Server 2012 lub SQL Server 2014.
  • W ramach subskrypcji replikacji dodawano subskrypcję, a następnie ją usuwano.

W tym scenariuszu może zostać wyświetlony następujący błąd 515:

Uwaga

Nie można wstawić wartości NULL w kolumnie "article_id", tabeli "<DistributionDatabaseName.dbo>. MSrepl_commands"; kolumna nie zezwala na wartości null. INSERT fails.

      

Przyczyna

Ten problem występuje z powodu regresji programu SQL Server 2012. Po dodaniu subskrypcji, a następnie jej usunięciu, metadane replikacji dotyczące subskrypcji są natychmiast usuwane, ponieważ występuje opóźnienie, zanim LogReader napotka polecenie dodania subskrypcji.

Rozwiązanie

Ten problem został po raz pierwszy rozwiązany w następującej aktualizacji zbiorczej programu SQL Server.

Aktualizacja skumulowana 1 dla systemu SQL Server 2012 z dodatkiem SP2 /pl-pl/pomoc/2976982

Zbiorcza aktualizacja 2 dla systemu SQL Server 2014 /pl-pl/pomoc/2967546

Skumulowana aktualizacja 10 dla SQL Server 2012 z dodatkiem Service Pack 1 /en-us/help/2954099

Informacje o aktualizacjach zbiorczych dla programu SQL Server

Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji skumulowanej. Sprawdź najnowsze aktualizacje zbiorcze dla programu SQL Server:

      

Stan

Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.