KB4023679 — POPRAWKA: Limit czasu podczas tworzenia kopii zapasowej dużej bazy danych pod adresem URL w SQL Server 2014 lub 2016

Dotyczy
SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use)

Objawy

Rozważ utworzenie kopii zapasowej bazy danych pod adresem URL (Azure obiektem blob) przy użyciu polecenia SQL Server BACKUP DATABASE lub zarządzanej kopii zapasowej. Jeśli kopia zapasowa jest bardzo duża, niektóre żądania między programem SQL Server i usługą magazynu obiektów blob na platformie Azure mogą przekroczyć limit czasu i operacja tworzenia kopii zapasowej może zakończyć się niepowodzeniem. Ponadto w pliku dziennika błędów programu SQL Server pojawia się komunikat o błędzie 1810 podobny do poniższego:

Uwaga

data i godzina Błąd kopii zapasowej: 18210, Ważność: 16, Stan: 1.
data i godzina Kopia zapasowa BackupIoRequest::ReportIoError: błąd zapisu na urządzeniu kopii zapasowej "https://xxxx.blob.core.windows.net/xxx/full/xxxx_FULL_20170211_230001.bak". Błąd systemu operacyjnego Kopia zapasowa adresu URL otrzymała wyjątek od zdalnego punktu końcowego. Komunikat o wyjątku: klient nie mógł ukończyć operacji w określonym limicie czasu.
data i godzina Błąd kopii zapasowej: 3041, Ważność: 16, Stan: 1.
data i godzina Kopia zapasowa BACKUP nie ukończyła polecenia BACKUP DATABASE MYDBNAME. Sprawdź, czy w dzienniku aplikacji kopii zapasowej są szczegółowe komunikaty.

Przyczyna

Ten problem występuje, ponieważ wartość limitu czasu operacji we/wy do obiektu blob platformy Azure nie jest wystarczająco długa. Ta poprawka zmienia wartość limitu czasu na dłuższą, elastyczną wartość, aby uniknąć częstotliwości limitu czasu operacji We/Wy.

Rozwiązanie

Ten problem został rozwiązany w następujących aktualizacjach zbiorczych programu SQL Server:

Aktualizacja zbiorcza 8 dla programu SQL Server 2016 RTM

Aktualizacja skumulowana 5 dla programu SQL Server 2016 z dodatkiem SP1

Aktualizacja zbiorcza 6 dla programu SQL Server 2014 z dodatkiem Service Pack 2

Aktualizacja zbiorcza 10 dla programu SQL Server 2012 z dodatkiem SP3

Informacje o aktualizacjach zbiorczych dla programu SQL Server

Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki i poprawki zabezpieczeń zawarte w poprzedniej aktualizacji skumulowanej. Sprawdź najnowsze aktualizacje zbiorcze dla programu SQL Server:

Najnowsza aktualizacja zbiorcza dla programu SQL Server 2016

Najnowsze aktualizacje zbiorcze dla programu SQL Server 2014

Najnowsza aktualizacja zbiorcza dla programu SQL Server 2012 z dodatkiem SP3

Stan

Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.

Źródła informacji

Dowiedz się więcej o terminologii używanej przez firmę Microsoft do opisywania aktualizacji oprogramowania.