Os bancos de dados do Access podem ajudá-lo a armazenar e controlar quase qualquer tipo de informação, como inventário, contatos ou processos comerciais. Vamos examinar as maneiras como você pode criar um banco de dados da área de trabalho do Access, adicionar dados a ele e, em seguida, aprender sobre as próximas etapas para personalizar e usar seu novo banco de dados.
Neste artigo
- Escolher um modelo
- Criar um banco de dados a partir do zero
- Adicionar uma tabela
- Copiar e colar dados
- Importar ou vincular a dados
- Organizar dados com a Análise de Tabela
- Próximas etapas
Escolher um modelo
Os modelos do Access têm tabelas, consultas, formulários e relatórios internos que estão prontos para uso. Os modelos são uma das primeiras coisas que você vê quando inicia o Access, e você pode pesquisar online por mais modelos.
- No Access, selecione Arquivo>Novo.
- Selecione um modelo de banco de dados da área de trabalho e insira um nome para o banco de dados em Nome do arquivo. Se você não encontrar um modelo que funcione para você, use a caixa Pesquisar modelos online .
- Você pode usar o local padrão exibido pelo Access abaixo da caixa Nome do Arquivo ou selecionar o ícone de pasta para escolher um.
- Selecione Criar.
Dependendo do modelo, talvez seja necessário seguir um destes procedimentos para começar:
Se o Access exibir uma caixa de diálogo Logon com uma lista de usuários vazia:
- Selecione Novo Usuário.
- Preencha o formulário Detalhes do usuário .
- Selecione Salvar e Fechar.
- Selecione o nome de usuário que você acabou de inserir e selecione Logon.
Se o Access exibir uma mensagem de Aviso de Segurança na barra de mensagens e você confiar na origem do modelo, selecione Habilitar Conteúdo. Se o banco de dados exigir um logon, entre novamente.
Para obter mais informações, consulte Criar um banco de dados da área de trabalho do Access a partir de um modelo.
Criar um banco de dados a partir do zero
Se nenhum dos modelos atender às suas necessidades, você pode começar com um banco de dados da área de trabalho em branco.
- No Access, selecione Novo>banco de dados da área de trabalho em branco.
- Digite um nome para o banco de dados na caixa Nome do Arquivo .
- Você pode usar o local padrão exibido pelo Access abaixo da caixa Nome do Arquivo ou selecionar o ícone de pasta para escolher um.
- Selecione Criar.
Adicionar uma tabela
Em um banco de dados, suas informações são armazenadas em várias tabelas relacionadas. Para criar uma tabela:
Ao abrir o banco de dados pela primeira vez, você verá uma tabela em branco no modo Folha de Dados onde poderá adicionar dados. Para adicionar outra tabela, selecione Criar>Tabela. Você pode começar a inserir dados no campo vazio (célula) ou colar dados de outra fonte, como uma pasta de trabalho do Excel.
Para renomear uma coluna (campo), clique duas vezes no título da coluna e digite o novo nome.
Dica
Nomes significativos ajudam você a saber o que cada campo contém sem ver seu conteúdo.
SelecioneSalvar Arquivo>.
- Para adicionar mais campos, digite na coluna Clique para adicionar .
- Para mover uma coluna, selecione-a clicando no título da coluna e arraste-a para o local desejado. Você também pode selecionar colunas adjacentes e arrastá-las juntas para um novo local.
Para saber mais, confira Introdução a tabelas.
Copiar e colar dados
Você pode copiar e colar dados de outro programa, como o Excel ou o Word, em uma tabela do Access. Isso funciona melhor quando os dados são separados em colunas. Se os dados estiverem em um programa de processamento de texto como o Word, use marcas para separar as colunas ou converter os dados em um formato de tabela antes de copiá-los.
Se os dados precisarem de edição, como separar nomes completos em nome e sobrenome, faça isso primeiro no programa de origem.
Abra a fonte e copie os dados pressionando Ctrl+C.
Abra a tabela do Access à qual você deseja adicionar os dados no modo Folha de Dados e cole-os pressionando Ctrl+V.
Clique duas vezes em cada título de coluna e digite um nome significativo.
Selecione Salvar Arquivo> e dê um nome à nova tabela.
Observação
O Access define o tipo de dados de cada campo com base nas informações coladas na primeira linha de cada coluna, portanto, verifique se as informações nas linhas seguintes correspondem à primeira linha.
Importar ou vincular a dados
Você pode importar dados de outras fontes ou vincular a dados do Access sem mover as informações de onde elas estão armazenadas. A vinculação pode ser uma boa opção se vários usuários atualizarem os dados e você quiser ter certeza de que está vendo a versão mais recente ou se quiser economizar espaço de armazenamento. Para a maioria dos formatos, você pode escolher se deseja vincular ou importar dados. Para obter mais informações, consulte Importar ou vincular a dados em outro banco de dados do Access.
O processo é um pouco diferente, dependendo da fonte de dados, mas estas instruções ajudarão você a começar:
Na guia Dados Externos , no grupo Importar & Vincular , selecione Nova Fonte de Dados e, em seguida, selecione o formato de dados que você importará ou vinculará nas opções do submenu listado.
Observação
Se ainda não conseguir encontrar o formato correto, talvez seja necessário exportar os dados primeiro para um formato de arquivo compatível com o Access, como um arquivo de texto delimitado.
Siga as instruções na caixa de diálogo Obter Dados Externos .
Quando você vincula, alguns formatos estão disponíveis como somente leitura. Aqui estão as fontes externas das quais você pode importar dados ou vincular:
| Origem | Importar | Link |
|---|---|---|
| Excel | Sim | Sim (somente leitura) |
| Access | Sim | Sim |
| Bancos de dados ODBC, como o SQL Server | Sim | Sim |
| Arquivos de texto ou CSV (arquivo separado por vírgula) | Sim | Sim (adicionar somente novos registros) |
| Lista do SharePoint | Sim | Sim |
| XML | Sim | |
| Serviços de Dados | Sim (somente leitura) | |
| Documento HTML | Sim | Sim |
| Pasta do Outlook | Sim | Sim |
Para obter mais informações, consulte Importar ou vincular a dados em outro banco de dados do Access.
Organizar dados com a Análise de Tabela
Você pode usar o Assistente de Analisador de Tabela para identificar rapidamente dados redundantes. O assistente fornece uma maneira simples de organizar os dados em tabelas separadas. O Access preserva a tabela original como backup.
- Abra o banco de dados do Access que contém a tabela que você deseja analisar.
- Selecione Ferramentas de Banco de Dados>Analisar Tabela. As duas primeiras páginas do assistente contêm um breve tutorial com exemplos. Se você vir uma caixa de marcação chamada Mostrar páginas introdutórias?, selecione-a e, em seguida, selecione Voltar duas vezes para ver a introdução. Se você não quiser ver as páginas introdutórias novamente, desmarque Mostrar páginas introdutórias?.
Para obter mais informações, consulte Normalizar seus dados usando o Analisador de Tabelas.
Próximas etapas
O restante do processo de design varia de acordo com o que você deseja fazer, mas você provavelmente desejará considerar a criação de consultas, formulários, relatórios e macros. Estes artigos podem ajudar: