KB2979121 - CORREÇÃO: O Log Reader Agent falha quando você atualiza do SQL Server 2008 para o SQL Server 2012 ou SQL Server 2014

Aplica-se a
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomas

Suponha que você use replicação transacional no Microsoft SQL Server 2008 e que haja uma consulta de atualização em execução na publicação. Quando você atualiza o SQL Server para o SQL Server 2012 ou o SQL Server 2014 e a consulta de atualização não é distribuída antes da atualização, o Log Reader Agent pode falhar com o seguinte erro:

Observação

<Data><Hora> Editor: {call sp_replcmds (500, 0, 0, , 0, 500000)}
<Data><e Hora> Status: 0, código: 20011, texto: 'O processo não pôde executar 'sp_replcmds' em '< Nome> do Editor'.'.
<Data><Hora> O processo não pôde executar 'sp_replcmds' em '<Nome> do Publicador'.
<Data><Hora> Agente Repl Status: 6
<Data><e hora> Status: 0, código: 542, texto: 'Foi encontrado um valor de data e hora inválido. O valor excede o ano 9999.».
<Data><e hora> Status: 0, código: 3621, texto: 'A instrução foi encerrada.'.
<Status de data><e hora> : 0, código: 22037, texto: 'O processo não pôde executar 'sp_replcmds' em '<Nome> do Editor'.'.

Mesmo que esse problema não tenha acontecido, os registros de log atualizados para instruções de atualização ainda podem ser interpretados incorretamente pelo Log Reader Agent e o seguinte erro pode surgir no Agente de Distribuição:

Observação

515 Não é possível inserir o valor NULL na coluna '<Nome da Coluna>', tabela '<Nome> da Tabela'; a coluna não permite nulos. FALHA NA ATUALIZAÇÃO.

Observação

  • Diferentes tipos de dados e restrições podem fazer com que diferentes erros sejam relatados, e esse problema pode até mesmo causar a não convergência.
  • O problema ocorre quando você atualiza do SQL Server 2008 ou do SQL Server 2008 R2 para o SQL Server 2012 ou o SQL Server 2014.

      

Resolução

Se o erro "515 Não é possível inserir o valor NULL na coluna '<Nome da Coluna>', tabela '<Nome> da Tabela'; A coluna não admite nulos. UPDATE fails" no Agente de Distribuição ocorreu, você deve reinicializar a replicação. Esse hotfix não corrige esse erro. Para evitar esse erro, você deve desabilitar o Log Reader Agent antes da atualização, atualizar até essa correção e habilitar novamente o Log Reader Agent.
O problema foi corrigido pela primeira vez na atualização cumulativa seguinte do SQL Server.

Atualização cumulativa 2 para SQL Server 2012 SP2 /en-us/help/2983175

Atualização cumulativa 3 para SQL Server 2014 /pt-br/help/2984923

Atualização cumulativa 11 para SQL Server 2012 SP1 /en-us/help/2975396

Sobre atualizações cumulativas para o SQL Server

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

      

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".