Sintomas
Quando você usa o recurso de replicação no Microsoft SQL Server 2012 ou SQL Server 2014, o agente leitor de log pode falhar intermitentemente. Adicionalmente, recebe uma das seguintes mensagens de erro no registo de erros SQL Server:
Erro 1
Observação
<
Data><Horário><SPID> Despejo de pilha sendo enviado para o <DiskLocation>
<
Data><Horário><SPID> * *******************************************************************************
<
Data><Horário><SPID> *
<
Data><Horário><SPID> * BEGIN STACK DUMP:
<
Data><Horário><SPID> * <Data><Hora><SPID>
<
Data><Horário><SPID> *
<
Data><Horário><SPID> * Localização: replicat.cpp:2746
<
Data><Horário><SPID> * Expressão: pRowset
<
Data><Horário><SPID> * SPID: <SPID>
<
Data><Horário><SPID> * ID do processo: <ProcessID>
<
Data><Horário><SPID> *
<
Data><Horário><SPID> * Buffer de entrada 109 bytes -
<
Data><Horário><SPID> * 16 00 00 00 12 00 00 00 02 00 00 00 00 00 00 00 00 00
<
Data><Horário><SPID> * s p _ r e p 01 00 00 00 0b 00 73 00 70 00 5f 00 72 00 65 00 70 00
<
Data><Horário><SPID> * l c m d s & ô 6c 00 63 00 6d 00 64 00 73 00 00 00 00 00 26 04 04 f4
<
Data><Horário><SPID> * & & ÿ 01 00 00 00 00 26 04 04 00 00 00 00 00 00 26 04 04 ff
<
Data><Horário><SPID> * ÿÿÿ ¥ & ff ff ff 00 00 a5 0a 00 00 00 00 00 00 26 04 04 00 00 00
<
Data><Horário><SPID> * & & ¡ 00 00 00 26 04 04 00 00 00 00 00 00 26 04 04 20 a1 07
<
Data><Horário><SPID> * 00
Erro 2
Observação
<Data><Hora><Erro SPID> : 5243, gravidade: 22, estado: 7.
<Data><Hora><SPID> Foi detetada uma inconsistência durante uma operação interna. Contacte o suporte técnico.
<Data><e Hora<>SPID> ex_raise2: Exceção gerada, maior=52, menor=43, estado=7, gravidade=22, tentando criar despejo de sintomas
<Data><Hora><SPID> **Dump thread - spid = 0, EC = 0x000000297EC97DE0
<Data><Hora><SPID> ***Stack Dump sendo enviado para <DiskLocation>
<Data><Hora><SPID> * *******************************************************************************
<Data><Hora><SPID> *
<Data><Hora><SPID> * BEGIN STACK DUMP:
<Data><Hora><SPID> * <Data><Hora><SPID>
<Data><Hora><SPID> *
<Data><Hora><SPID> * ex_raise2: Exceção elevada, maior=52, menor=43, estado=7, gravidade=22
<Data><Hora><SPID> *
<Data><Hora><SPID> * Buffer de entrada 109 bytes -
<Data><Hora><SPID> * 16 00 00 00 12 00 00 00 02 00 00 00 00 00 00 00 00 00 00 00
<Data><Hora><SPID> * s p _ r e p 01 00 00 00 0b 00 73 00 70 00 5f 00 72 00 65 00 70 00
<Data><Hora><SPID> * l c m d s & ô 6c 00 63 00 6d 00 64 00 73 00 00 00 00 00 26 04 04 f4
<Data><Hora><SPID> * & & ÿ 01 00 00 00 00 26 04 04 00 00 00 00 00 26 04 04 ff
<Data><Hora><SPID> * ÿÿÿ ¥ & ff ff ff 00 00 a5 0a 00 00 00 00 00 26 04 04 00 00 00
<Data><Hora><SPID> * & & ¡ 00 00 00 26 04 04 00 00 00 00 00 00 26 04 04 20 a1 07
<Data><Hora><SPID> * 00
Causa
Este problema ocorre quando o mesmo artigo é publicado em mais do que uma publicação transacional ou quando o mesmo artigo faz parte do CDC e da publicação transacional.
Resolução
Informações sobre a atualização cumulativa
O problema foi corrigido na seguinte atualização cumulativa do SQL Server:
- Atualização cumulativa 13 para SQL Server 2014
- Atualização cumulativa 2 para SQL Server 2012 Service Pack 3
- Atualização cumulativa 5 para SQL Server 2014 SP1
- Atualização cumulativa 12 para SQL Server 2012 SP2
Recomendação: Instale a atualização cumulativa mais recente para o SQL Server
Cada nova atualização cumulativa para SQL Server contém todos os hotfixes e todas as correções de segurança que foram incluídas com a atualização cumulativa anterior. Recomendamos que transfira e instale as atualizações cumulativas mais recentes para SQL Server:
- Atualização cumulativa mais recente para o SQL Server 2014
- Atualização cumulativa mais recente para o SQL Server 2012 SP3
- Atualização cumulativa mais recente para o SQL Server 2014 SP1
- Atualização cumulativa mais recente para o SQL Server 2012 SP2
Status
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".