INTRODUÇÃO
Este artigo descreve o pacote de atualização cumulativa 4 para o Microsoft SQL Server 2012. Esta atualização contém hotfixes para problemas que foram corrigidos após o lançamento do SQL Server 2012.
Observação O número de compilação deste pacote de atualização cumulativa é 11.0.2383.0.
Recomendamos que você teste os hotfixes antes de implantá-los em um ambiente de produção. Como as compilações são cumulativas, cada nova versão de correção contém todos os hotfixes e todas as correções de segurança que foram incluídas com o anterior SQL Server 2012 corrigir lançamento. Recomendamos que você considere aplicar o lançamento de correção mais recente que contém esse hotfix.
Para obter mais informações, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:
2692828 As compilações SQL Server 2012 lançadas após o lançamento do SQL Server 2012
Observações importantes sobre o pacote de atualização cumulativa
- SQL Server correções de 2012 são agora multilingues. Portanto, há apenas um pacote de hotfix cumulativo para todos os idiomas.
- Um pacote de hotfix cumulativo inclui todos os pacotes de componentes. O pacote de atualizações cumulativas atualiza apenas os componentes que estão instalados no sistema.
Mais informações
Como obter a Atualização Cumulativa 4 para o SQL Server 2012
Um pacote de atualizações cumulativas suportado está agora disponível na Microsoft. No entanto, destina-se a corrigir apenas os problemas descritos neste artigo. Aplique-o apenas aos sistemas que estão enfrentando esses problemas específicos. Este pacote de atualizações cumulativas poderá receber testes adicionais. Portanto, se você não tiver sido gravemente afetado por qualquer um desses problemas, recomendamos que você aguarde o próximo SQL Server 2012 service pack que contém os hotfixes neste pacote de atualização cumulativa.
Se a atualização cumulativa estiver disponível para download, há uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta secção não for apresentada, contacte o Suporte ao Cliente da Microsoft para obter o pacote de atualizações cumulativas.
Observação Se ocorrerem problemas adicionais ou qualquer solução de problemas for necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais do suporte serão aplicados a problemas e questões de suporte adicionais que não se qualifiquem para este pacote de atualizações cumulativas específico. Para obter uma lista completa dos números de telefone do Suporte e Atendimento ao Cliente da Microsoft ou para criar um pedido de serviço separado, aceda ao seguinte site da Microsoft:
Os hotfixes incluídos neste pacote de atualizações cumulativas
Os artigos da Base de Dados de Conhecimento Microsoft que abordam esses hotfixes serão lançados assim que estiverem disponíveis.
Para obter mais informações sobre os erros de SQL Server na lista a seguir, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft.
| Número do bug VSTS | Número do artigo KB | Descrição |
|---|---|---|
| 1056314 | 2406666 | CORREÇÃO: Erro "[Teradata Database] [3737]" ao clicar em "Contar" no Assistente de Design de Agregação no SSAS 2008, no SSAS 2012 ou no SSAS 2008 R2 |
| 969184 | 2661644 | CORRECÇÃO: Violação de acesso no sqlservr! ReplicaToPrimaryPageCopier::ReadIoCompletionRoutine function in SQL Server 2008 R2 or in SQL Server 2008 R2 |
| 872764 | 2671318 | CORREÇÃO: A primeira execução do procedimento armazenado xp_cmdshell não é concluída até que a última execução seja concluída no SQL Server 2012 |
| 1043442 | 2714634 | CORREÇÃO: SQL Server 2008 R2 ou SQL Server 2012 leva muito tempo para gerar scripts para uma tabela particionada que usa o recurso de compactação de dados |
| 1043432 | 2723979 | CORREÇÃO: Violação de acesso em SQL Server monitor de impasse interno quando você executa vários aplicativos junto com vários conjuntos de resultados ativos habilitados no SQL Server 2008 R2 ou no SQL Server 2012 |
| 1043428 | 2728419 | CORREÇÃO: Mensagem de erro "Processo de ajuste saiu inesperadamente" quando você executa Orientador de Otimização do Mecanismo de Banco de Dados sob a função db_owner no SQL Server 2008 R2 ou no SQL Server 2012 |
| 1043434 | 2728534 | CORREÇÃO: Erro "Uma asserção de sistema marcar falhou" ao recriar um índice não clusterizado em uma coluna no SQL Server 2008 R2 ou no SQL Server 2012 |
| 1043440 | 2731068 | CORREÇÃO: "Ocorreu um erro inesperado" quando você consulta alguns dados de cálculo de um modelo de tabela SSAS usando o SQL Server 2008 R2 PowerPivot para Excel 2010 ou SQL Server 2008 R2 PowerPivot para SharePoint 2010 |
| 1043448 | 2733630 | O agente de mesclagem pode falhar durante a sincronização de replicação de mesclagem no SQL Server 2008 R2 ou no SQL Server 2012 |
| 1043455 | 2733673 | CORREÇÃO: Mensagem de erro "Atualizações ad hoc para catálogos do sistema não são permitidas" ao usar o SSMS para SQL Server 2008 R2 ou SQL Server 2012 para alterar as propriedades do servidor vinculado |
| 1043436 | 2737499 | CORREÇÃO: KeepTogether propriedade não funciona quando você gera um relatório que contém um tablix no SSRS 2008 R2 ou no SSRS 2012 |
| 1028254 | 2737580 | CORREÇÃO: Erro interno quando você executa consultas em um modelo de mineração não retangular usando DMX ou MDX no SQL Server 2012 Analysis Services |
| 1009860 | 2738197 | CORREÇÃO: Os threads de trabalho não são ativados imediatamente quando várias tarefas de E/S intensivas estão sendo executadas ao mesmo tempo no SQL Server 2012 |
| 1019868 | 2739940 | CORREÇÃO: O banco de dados está offline e no estado "Em recuperação" quando você recria um índice no SQL Server 2012 se o log de transações estiver cheio |
| 1043454 | 2740507 | CORREÇÃO: Mensagem de erro "Não é possível obter os tipos de dados suportados da conexão de banco de dados" quando você usa o Assistente para importar e exportar dados para se conectar a um banco de dados Sybase no SQL Server 2008 R2 ou no SQL Server 2012 |
| 1044000 | 2752511 | CORREÇÃO: Mensagem "Erro de estouro aritmético" quando você executa o procedimento armazenado do sistema sys.sp_tables_info_90_rowset_64 em um servidor vinculado no SQL Server 2012 |
| 1046164 | 2754444 | CORREÇÃO: Mensagem de erro "Índice e comprimento devem se referir a um local dentro da cadeia de caracteres" quando você extrai um grande volume de dados do SAP BW em um pacote SSIS 2012 |
| 1048061 | 2754939 | CORREÇÃO: Violação de acesso ocorre quando você executa uma consulta de texto completo no SQL Server 2012 |
| 1056330 | 2755079 | CORREÇÃO: As alterações não são sincronizadas com os assinantes depois de alterar um filtro de artigo em uma publicação transacional no SQL Server 2008, no SQL Server 2012 ou no SQL Server 2008 R2 |
| 985109 | 2756097 | CORREÇÃO: "Community Technology Preview (August CTP)" é exibido no assistente de instalação ou desinstalação de uma atualização do SQL Server 2012 |
| 1043772 | 2758569 | CORREÇÃO: Uma mensagem de erro "Falha na operação com 0x8007000B de erro" quando você executa uma instalação desanexada para adicionar o SQL Server 2012Reporting Services de 32 bits |
| 1043740 | 2758628 | Uma atualização que corrige um problema de correção para a função SUMMARIZE e aprimora o recurso de cache no SQL Server 2012 |
| 985483 | 2762557 | CORREÇÃO: Mensagem de erro "A lista> de bloqueio de processo <parece não estar cedendo no ID> do Agendador<" ao executar uma consulta no SQL Server 2012 |
| 1051891 | 2762559 | CORREÇÃO: Falhas do SQL Server 2012 são exibidas na caixa de diálogo Notificações de Status da Tarefa no System Center Operations Manager 2012 |
| 1056385 | 2762593 | CORREÇÃO: O utilitário Tablediff relata resultados incorretos quando uma tabela contém uma chave primária em uma coluna uniqueidentifier no SQL Server 2012 |
Informações sobre o pacote de atualizações cumulativas
Informações sobre reinicialização
Talvez seja necessário reiniciar o computador após aplicar essa atualização cumulativa.
Informações do Registro
Para usar um dos hotfixes no pacote, não é necessário fazer nenhuma alteração no Registro.
Como desinstalar este pacote de atualização cumulativa
Para desinstalar este pacote de atualização cumulativa, siga estas etapas:
No Painel de Controle, abra a opção Adicionar ou Remover Programas
item.Observação Se você estiver executando o Windows 7, abra o item Programas e Recursos no Painel de Controle.
Localize a entrada que foi instalada por este pacote de atualizações cumulativas.
Clique com o botão direito do mouse na entrada e clique em Desinstalar.
Referências
Para obter mais informações sobre o Incremental Servicing Model para o SQL Server, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
935897
Um Modelo de Manutenção Incremental foi disponibilizado pela equipe do SQL Server a fim de fornecer hotfixes para problemas relatados
Para obter mais informações sobre o esquema de nomenclatura para atualizações do SQL Server, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
822499
Esquema de nomeação para pacotes de atualização de software do Microsoft SQL Server
Para obter informações adicionais sobre a terminologia da atualização de segurança, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684
Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft