Мастер импорта текста

Хотя вы не можете экспортировать данные в Excel текстового файла или документа Word, вы можете импортировать данные из текстового файла на Excel с помощью мастера импорта текста в word. Мастер импорта текста проверяет импортируемый текстовый файл и гарантирует, что данные будут импортироваться нужным образом.     

Примечание: Мастер импорта текста — это устаревшая функция, которая по-прежнему поддерживается для обеспечения совместимости с текстом. Кроме того, вы можете импортировать текстовый файл, подключившиськ ним с помощью Power Query.

Перейдите на вкладку Данные и > Внешние данные > из текста. Затем в диалоговом окне Импорт текстового файла дважды щелкните текстовый файл, который вы хотите импортировать, и откроется диалоговое окно Мастер импорта текста.

Шаг 1 из 3

Исходный тип данных    Если элементы текстового файла разделены знаками табули, двоеточиями, за двоеточиями, пробелами или другими символами, выберите разделимы. Если все элементы в каждом столбце имеют одинаковые длину, выберите Фиксированная ширина.

Начало импорта в строке    Введите или выберите номер строки, чтобы указать первую строку данных, которые нужно импортировать.

Источник файла    Выберите набор символов, используемый в текстовом файле. В большинстве случаев этот параметр можно оставить по умолчанию. Если вы знаете, что текстовый файл был создан с использованием не того набора символов, который используется на компьютере, необходимо изменить этот параметр в зависимости от набора символов. Например, если на компьютере установлен набор символов 1251 (кириллица, Windows), но известно, что файл был произведен с использованием набора символов 1252 (западноевропейский, Windows), необходимо установить для файла 1252.

Предварительный просмотр файла    В этом поле текст будет отображаться так, как он будет отображаться при разделении на столбцы на этом сайте.

Шаг 2 из 3 (данные с делегами)

Разделители    Выберите знак, который разделяет значения в текстовом файле. Если символа нет в списке, выберите другой и введите символ в поле, содержа которое содержит курсор. Эти параметры недоступны, если ваш тип данных имеет тип Фиксированная ширина.

Обрабатывать последовательные седиметры как один    Если данные содержат несколько символов между полями данных или данные содержат несколько настраиваемого разного знака, выберите этот вариант.

Квалификатор текста    Вы можете выбрать символ, который должен быть заключен в текстовый файл. При Excel знака квалификатора текста весь текст, следующий за ним и предшествующий следующему вхождению этого знака, импортируется как одно значение, даже если текст содержит знак с замещением. Например, если в качестве запятой является запятая (,), а квалификатор текста — кавычка ("), "Даллас, Штат" импортируется в одну ячейку, например Даллас,штат Техас. Если в качестве квалификатора текста не указан символ или апостроф ('), "Даллас, Штат" импортируется в две смежные ячейки, например "Даллас и Техас".

Если между текстовыми квалификаторами есть знак с Excel, Excel опустить квалификаторы в импортируемом значении. Если между текстовыми квалификаторами нет знака Excel квалификатор включается в импортируемом значении. Следовательно, "Даллас, Техас" (с помощью квалификатора текста кавычка) импортируется в одну ячейку с искомым названием "Даллас Штата".

Предварительный просмотр данных    Просмотрите текст в этом поле, чтобы убедиться, что текст будет разделен на столбцы на нужном вам поле.

Шаг 2 из 3 (данные фиксированной ширины)

Предварительный просмотр данных    Установите ширину полей в этом разделе. Щелкните окно предварительного просмотра, чтобы установить разрыв столбца, который представлен вертикальной линией. Дважды щелкните разрыв столбца, чтобы удалить его, или перетащите разрыв столбца, чтобы переместить его.

Шаг 3 из 3

Нажмите кнопку "Дополнительные", чтобы сделать следующее:

  • Укажите тип десятичных и тысячных сепараторов, используемых в текстовом файле. При импорте данных в Excel будут совпадать с теми, которые указаны в параметрах языка и региональных параметров или региональных Параметры (Windows панели управления).

  • Укажите, что одно или несколько числных значений могут содержать знак "минус".

Формат данных столбца    Выберите формат данных столбца, выбранного в разделе Предварительный просмотр данных. Если вы не хотите импортировать выбранный столбец, выберите не импортировать столбец (пропустить).

После выбора формата данных для выбранного столбца в заголовке столбца в области Предварительный просмотр данных отображается формат. Если вы выбрали Дата, выберите формат даты в поле Дата.

Выберите формат данных, который полностью соответствует предварительным данным, Excel правильно преобразовать импортируемые данные. Например:

  • Чтобы преобразовать столбец всех номеров валюты в формат Excel, выберите Общий.

  • Чтобы преобразовать столбец со всеми числами знаков в формат Excel текст, выберите Текстовый.

  • Чтобы преобразовать столбец всех знаков даты, каждой даты в порядке года, месяца и дня, в формат даты Excel, выберите Дата ,а затем в поле Дата выберите тип ДАТЫ.

Excel импортировать столбец как общий, если преобразование может привести к непредвиденным результатам. Например:

  • Если столбец содержит сочетание форматов, таких как буквы и цифры, Excel преобразует столбец в общий.

  • Если в столбце дат каждая дата упорядочена по году, месяцу и дате, а вы выбрали Date вместе с типом даты MDY,Excel преобразует столбец в общий формат. Столбец, содержащий символы даты, должен полностью соответствовать Excel или пользовательским форматам даты.

Если Excel не преобразует столбец в нужный формат, вы можете преобразовать данные после импорта.

Выбрав нужные параметры, нажмите кнопку Готово, чтобы открыть диалоговое окно Импорт данных и выберите место для хранения данных.

Импорт данных

Эти параметры можно настроить для управления процессом импорта данных, включая свойства подключения к данным, а также файл и диапазон для заполнения импортируемыми данными.

  • Параметры в списке Выберите способ просмотра этих данных в книге доступны только в том случае, если у вас подготовлена модель данных, и вы можете добавить этот импорт в эту модель (см. третий элемент в этом списке).

  • Укажите целевую книгу:

    • Если вы выбрали ВариантНа существующий лист, щелкните ячейку на листе, чтобы разместить первую ячейку импортируемых данных, или щелкните и перетащите, чтобы выбрать диапазон.

    • Выберите элемент "Новый таблица", чтобы импортировать его на новый (начиная с ячейки A1)

  • Если у вас есть модель данных, щелкните Добавить эти данные в модель данных, чтобы включить этот импорт в модель. Дополнительные сведения см. в статье Создание модели данных в Excel.

    Обратите внимание, что при выборе этого параметра параметры в области Выберите способ просмотра данных в книге будут разблокированы.

  • Нажмите кнопку Свойства, чтобы настроить нужные свойства диапазона внешних данных. Дополнительные сведения см. в управлении диапазонами внешних данных и их свойствами.

  • Когда вы будете готовы завершить импорт данных, нажмите кнопку ОК.

Примечания: Мастер импорта текста — это устаревшая функция, которую может потребоваться включить. Если вы еще не сделали этого, то: 

  1. Щелкните Параметры > > данных.

  2. В области Показать устаревшие мастеры импорта данныхвыберите Из текста (устаревшие).

После включения перейдите на вкладку Данные > Получить & Transform Data > Get Data > Legacy Wizards > From Text (Legacy). Затем в диалоговом окне Импорт текстового файла дважды щелкните текстовый файл, который нужно импортировать, и откроется мастер импорта текста.

Шаг 1 из 3

Исходный тип данных    Если элементы текстового файла разделены знаками табули, двоеточиями, за двоеточиями, пробелами или другими символами, выберите разделимы. Если все элементы в каждом столбце имеют одинаковые длину, выберите Фиксированная ширина.

Начало импорта в строке    Введите или выберите номер строки, чтобы указать первую строку данных, которые нужно импортировать.

Источник файла    Выберите набор символов, используемый в текстовом файле. В большинстве случаев этот параметр можно оставить по умолчанию. Если вы знаете, что текстовый файл был создан с использованием не того набора символов, который используется на компьютере, необходимо изменить этот параметр в зависимости от набора символов. Например, если на компьютере установлен набор символов 1251 (кириллица, Windows), но известно, что файл был произведен с использованием набора символов 1252 (западноевропейский, Windows), необходимо установить для файла 1252.

Предварительный просмотр файла    В этом поле текст будет отображаться так, как он будет отображаться при разделении на столбцы на этом сайте.

Шаг 2 из 3 (данные с делегами)

Разделители    Выберите знак, который разделяет значения в текстовом файле. Если символа нет в списке, выберите другой и введите символ в поле, содержа которое содержит курсор. Эти параметры недоступны, если ваш тип данных имеет тип Фиксированная ширина.

Обрабатывать последовательные седиметры как один    Если данные содержат несколько символов между полями данных или данные содержат несколько настраиваемого разного знака, выберите этот вариант.

Квалификатор текста    Вы можете выбрать символ, который должен быть заключен в текстовый файл. При Excel знака квалификатора текста весь текст, следующий за ним и предшествующий следующему вхождению этого знака, импортируется как одно значение, даже если текст содержит знак с замещением. Например, если в качестве запятой является запятая (,), а квалификатор текста — кавычка ("), "Даллас, Штат" импортируется в одну ячейку, например Даллас,штат Техас. Если в качестве квалификатора текста не указан символ или апостроф ('), "Даллас, Штат" импортируется в две смежные ячейки, например "Даллас и Техас".

Если между текстовыми квалификаторами есть знак с Excel, Excel опустить квалификаторы в импортируемом значении. Если между текстовыми квалификаторами нет знака Excel квалификатор включается в импортируемом значении. Следовательно, "Даллас, Техас" (с помощью квалификатора текста кавычка) импортируется в одну ячейку с искомым названием "Даллас Штата".

Предварительный просмотр данных    Просмотрите текст в этом поле, чтобы убедиться, что текст будет разделен на столбцы на нужном вам поле.

Шаг 2 из 3 (данные фиксированной ширины)

Предварительный просмотр данных    Установите ширину полей в этом разделе. Щелкните окно предварительного просмотра, чтобы установить разрыв столбца, который представлен вертикальной линией. Дважды щелкните разрыв столбца, чтобы удалить его, или перетащите разрыв столбца, чтобы переместить его.

Шаг 3 из 3

Нажмите кнопку "Дополнительные", чтобы сделать следующее:

  • Укажите тип десятичных и тысячных сепараторов, используемых в текстовом файле. При импорте данных в Excel будут совпадать с теми, которые указаны в параметрах языка и региональных параметров или региональных Параметры (Windows панели управления).

  • Укажите, что одно или несколько числных значений могут содержать знак "минус".

Формат данных столбца    Выберите формат данных столбца, выбранного в разделе Предварительный просмотр данных. Если вы не хотите импортировать выбранный столбец, выберите не импортировать столбец (пропустить).

После выбора формата данных для выбранного столбца в заголовке столбца в области Предварительный просмотр данных отображается формат. Если вы выбрали Дата, выберите формат даты в поле Дата.

Выберите формат данных, который полностью соответствует предварительным данным, Excel правильно преобразовать импортируемые данные. Например:

  • Чтобы преобразовать столбец всех номеров валюты в формат Excel, выберите Общий.

  • Чтобы преобразовать столбец со всеми числами знаков в формат Excel текст, выберите Текстовый.

  • Чтобы преобразовать столбец всех знаков даты, каждой даты в порядке года, месяца и дня, в формат даты Excel, выберите Дата ,а затем в поле Дата выберите тип ДАТЫ.

Excel импортировать столбец как общий, если преобразование может привести к непредвиденным результатам. Например:

  • Если столбец содержит сочетание форматов, таких как буквы и цифры, Excel преобразует столбец в общий.

  • Если в столбце дат каждая дата упорядочена по году, месяцу и дате, а вы выбрали Date вместе с типом даты MDY,Excel преобразует столбец в общий формат. Столбец, содержащий символы даты, должен полностью соответствовать Excel или пользовательским форматам даты.

Если Excel не преобразует столбец в нужный формат, вы можете преобразовать данные после импорта.

Выбрав нужные параметры, нажмите кнопку Готово, чтобы открыть диалоговое окно Импорт данных и выберите место для хранения данных.

Импорт данных

Эти параметры можно настроить для управления процессом импорта данных, включая свойства подключения к данным, а также файл и диапазон для заполнения импортируемыми данными.

  • Параметры в списке Выберите способ просмотра этих данных в книге доступны только в том случае, если у вас подготовлена модель данных, и вы можете добавить этот импорт в эту модель (см. третий элемент в этом списке).

  • Укажите целевую книгу:

    • Если выбрать на существующемлисте , щелкните ячейку на листе, чтобы разместить первую ячейку импортируемых данных, или щелкните и перетащите, чтобы выбрать диапазон.

    • Выберите элемент "Новый таблица", чтобы импортировать его на новый (начиная с ячейки A1)

  • Если у вас есть модель данных, щелкните Добавить эти данные в модель данных, чтобы включить этот импорт в модель. Дополнительные сведения см. в статье Создание модели данных в Excel.

    Обратите внимание, что при выборе этого параметра параметры в области Выберите способ просмотра данных в книге будут разблокированы.

  • Нажмите кнопку Свойства, чтобы настроить нужные свойства диапазона внешних данных. Дополнительные сведения см. в управлении диапазонами внешних данных и их свойствами.

  • Когда вы будете готовы завершить импорт данных, нажмите кнопку ОК.

Примечание: Если данные есть в документе Word, сначала сохраните их в виде текстового файла. Щелкните Файл > сохранить каки выберите тип файла .txt (обычный текст).

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

См. также

Общие сведения о Microsoft Power Query для Excel

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

×