KB3058865 — сведения о выпуске пакета обновления 1 SQL Server 2014 г.

Применяется к
SQL Server 2014 Developer SQL Server 2014 Enterprise SQL Server 2014 Express SQL Server 2014 Standard SQL Server 2014 Web SQL Server 2014 Business Intelligence

В этой статье содержатся важные сведения, которые следует прочитать перед установкой Microsoft SQL Server 2014 с пакетом обновления 1 (SP1). В нем описано, как получить пакет обновления, приведен список исправлений, включенных в пакет обновления, как выбрать правильный вариант скачивания в зависимости от установленной версии, а также приводится список авторских прав для продукта.

Примечание. Эта статья служит единственным источником информации для поиска всей документации, связанной с этим пакетом обновления. Он включает в себя все сведения, которые вы ранее нашли в заметках о выпуске и Readme.txt файлах.

Примечание. Если вы пытаетесь обновить экземпляр с накопительного пакета обновления 11 за SQL Server 2014 г. (номер сборки 12.0.2560.0) до SQL Server пакетом обновления 1, установка пакета обновления завершится ошибкой из-за двоичного несоответствия между файлами SQLServr.exe и qds.dll, и после этого SQL Server не удастся запустить.

Для решения проблемы используйте один из следующих способов:

  • Чтобы продолжить использовать накопительный пакет обновления 11 для SQL Server 2014, необходимо удалить незавершенную установку пакета обновления. Для этого нажмите кнопку "Добавить или удалить программы" на панели управления и перезапустите SQL Server.

  • Чтобы выполнить обновление до пакета обновления 1 с CU11 и сохранить исправления до CU11, выполните следующие действия.

    1. Удалите CU11 с помощью команды "Установка и удаление программ" на панели управления.
    2. Скачайте и установите пакет обновления 1 (SP1) из центра загрузки Microsoft SQL Server 2014 с пакетом обновления 1 (SP1).
    3. Скачайте и установите накопительный пакет обновления 4 для пакета обновления 1 (SP1) из накопительного пакета обновления 4 для SQL Server 2014 с пакетом обновления 1 (SP1).

    

Дополнительные сведения

Получение SQL Server 2014 SP1

SQL Server 2014 с пакетом обновления 1 (SP1) доступен для загрузки со страницы загрузки SQL Server 2014 SP1. Скачать пакет дополнительных компонентов для SQL Server 2014 с пакетом обновления 1 (SP1) можно здесь.

Примечание. После установки пакета обновления версия службы SQL Server должна отображаться как 12.0.4100.1.

Список исправлений, включенных в SQL Server 2014 SP1

Пакеты обновления Microsoft SQL Server 2014 представляют собой накопительные обновления. SQL Server 2014 SP1 обновляет все выпуски и уровни обслуживания SQL Server 2014 до SQL Server 2014 SP1.

Помимо исправлений, перечисленных в этой статье, SQL Server 2014 SP1 включает исправления, которые были включены в SQL Server 2014 CU1 для SQL Server 2014 CU 5.

Дополнительные сведения о накопительных обновлениях, доступных в SQL Server 2014, см. в статье Версии сборок SQL Server 2014.

Заметки

  • Дополнительные исправления, не описанные здесь, также могут быть включены в пакет обновления.
  • Этот список будет обновляться по мере выхода новых статей.

Дополнительные сведения об ошибках, исправленных в SQL Server 2014 с пакетом обновления 1 (SP1), см. по следующим ссылкам в базе знаний Майкрософт.

Номер ошибки VSTS Номер статьи базы знаний Описание
2275929 3044954 ИСПРАВЛЕНО: При включении функции автозакрытия в SQL Server 2014 происходит нарушение прав доступа в процедуре завершения ввода-вывода
2364636 2969781 ИСПРАВЛЕНО: ошибка при добавлении пользовательского диспетчера подключений в Designer служб SSIS 2014
2580631 2963404 ИСПРАВЛЕНО: откат приводит к переходу базы данных в подозрительный режим в SQL Server 2012 или SQL Server 2014
2580750 2806979 ИСПРАВЛЕНИЕ: низкая производительность при выполнении запроса к таблице в базе данных с поддержкой RCSI в SQL Server 2012 или 2014
2580628 2965035 Улучшение функции ведения журнала SSAS 2012 в SQL Server 2012 с пакетом обновления 2 (SP2)
2581015 2963412 Новые sys.dm_fts_index_keywords_position_by_document DMF в SQL Server 2012 с пакетом обновления 2 (SP2) и SQL Server 2014 с пакетом обновления 1 (SP1)
2581019 2966520 ИСПРАВЛЕНО. При перезапуске службы Windows Reporting Services в службах SSRS 1 января не создаются новые файлы журнала
2581025 3051521 ИСПРАВЛЕНО: ошибка "Модель базы данных не может быть открыта" при перезапуске SQL Server после резервного копирования хвостового журнала для базы данных модели
2581225 2964762 ИСПРАВЛЕНИЕ. При использовании команды обнаружения в SSAS 2012 регистрируется событие с кодом 22 или ошибка 0xC1000016
2581168 2966522 ИСПРАВЛЕНИЕ: подписка на файловый ресурс не заполняет столбец описания в SSRS 2012 или SSRS 2014
2581259 2966523 FIX: Раскрывающийся список "Имя" пуст, если указан отчет в SSRS 2012 или SSRS 2014
2581317 2963382 ИСПРАВЛЕНИЕ: не удается подключиться к серверу при выполнении запроса MDX о создании куба в SSAS 2012 или SSAS 2014
2581323 2963384 ИСПРАВЛЕНО: сбой SQL Server при заполнении файла журнала базы данных tempdb в SQL Server 2012 или SQL Server 2014
2581360 2927741 ИСПРАВЛЕНИЕ: изображение не отображается должным образом на веб-странице при использовании действия детализации в отчете SSRS 2012 или 2014
2581371 2963383 ИСПРАВЛЕНО: Усеченный текст при использовании отрисовщика HPB для просмотра отчета в SSRS 2012 или SSRS 2014
2700155 3044958 ИСПРАВЛЕНО: восстановление с откатом на snapshot завершается сбоем при запуске DBCC CHECKDB, а затем SQL Server неожиданно завершает работу
3860819 3030619 ИСПРАВЛЕНИЕ: Неверные данные, возвращаемые при использовании типа данных DATE в качестве ограничителя в запросе в SQL Server 2014
3879685 3020112 ИСПРАВЛЕНО: при выполнении инструкций DML в SQL Server 2014 возникает ошибка, не возвращающая данные
3919713 3027860 Ошибка 17066 или 17310 во время запуска SQL Server
3933346 3044953 ИСПРАВЛЕНО: Проблема с невозвращением планировщика при записи страниц в файл расширения буферного пула в SQL Server 2014
4011750 3029977 ИСПРАВЛЕНО: ошибка ОС 665 при выполнении команды DBCC CHECKDB для базы данных, содержащей индекс columnstore в SQL Server 2014
4033440 3021757 FIX: Duplicate sequence value is generated when you run sp_sequence_get_range in parallel with NEXT VALUE FOR (ДЛЯ функции)
4034813 3029825 ИСПРАВЛЕНО: ВЫПОЛНЕНИЕ DBCC CHECKDB и DBCC CHECKTABLE занимает больше времени, если в SQL Server 2012 или SQL Server 2014 задействованы UDT SQL CLR
4050109 3026082 ИСПРАВЛЕНО: SOS_CACHESTORE Spinlock Competition on system table rowset cache causes high CPU in SQL Server 2012 or 2014
4075490 3034679 ИСПРАВЛЕНО: группы доступности AlwaysOn сообщают как НЕ СИНХРОНИЗИРУЕМЫЕ
4093558 3035165 ИСПРАВЛЕНО: ошибка 8646 при выполнении инструкций DML в таблице с кластеризованным индексом columnstore в SQL Server 2014
3534419, 3534439, 2512250, 1456033, 2274636 3044952 ИСПРАВЛЕНО: проблемы при включении функции расширения буферного пула в SQL Server 2014
3731772, 3731776 3044519 ИСПРАВЛЕНО. Проблемы с производительностью запросов при включении нового средства оценки количества элементов в SQL Server 2014
2581312 2904152 ИСПРАВЛЕНИЕ: использование отчетов на удаленной ферме не работает в SharePoint Интегрировано для опубликованного приложения службы SSRS 2014

Дополнительные резолюции

Решения следующих проблем также включены в SQL Server 2014 SP1.

Номер ошибки VSTS Описание
1957464 ВОССТАНОВИТЬ ЗАГОЛОВОКТОЛЬКО для файла Зашифрованной Резервной Копии Базы Данных не показывает, зашифрована резервная копия или нет.
После применения пакета обновления 1 (SP1) выходные данные RESTORE HEADONLY будут включать три дополнительных столбца: KeyAlgorithm, EncryptorThumbprint и EncryptorType, которые могут предоставить дополнительные сведения о зашифрованной резервной копии. Дополнительные сведения см. в разделе ВОССТАНОВИТЬ ТОЛЬКО ЗАГОЛОВОК в онлайн-учебниках по SQL Server.
2366022 При установке SQL Server требуется платформа .NET Framework 3.5 при установке SQL Server 2014 Express Edition (только с ядром СУБД) в Windows 8. Теперь она пропускается при установке такого типа носителей.
2535853 При установке экспресс-пакетов SQL Server 2014 RTM требуется ввод данных пользователем.
2580641 Недопустимый синтаксис запроса в хранимой процедуре при удалении статьи, опубликованной в
более одной публикации.
2580651 Сообщения о конфликте одноранговой сети (P2P) требуют дополнительных сведений.

Примечание После применения пакета обновления 2 (SP2) для версии 2012 или пакета обновления 1 (SP1) для версии 2014 сообщение об ошибке 22815 будет содержать информацию об имени таблицы, первичном ключе (первичных ключах), текущей версии, предварительной версии и последующей версии. Помимо имени таблицы и первичного ключа, версия Post Version существует для всех трех типов конфликтов (удаление, обновление и вставка). Текущая версия неприменима для типа конфликта удаления, а предварительная версия неприменима к существующему типу конфликта вставки.
2580686 Update-Update конфликтов в репликации P2P при обновлении текстового столбца с помощью функций UPDATE или WRITE.
2580693 Некорректные результаты при работе с унарными операторами режима блокировки.
2580746 Полное резервное копирование DPM на сервере с AlwaysOn вторичным будет преобразовано в резервное копирование copy_only
2581191 Улучшение ведения журнала репликации слиянием:
Чтобы устранить проблемы с производительностью репликации слияния, добавьте выходные данные TraceFlag 101, если уровень детализации выходных данных агента слияния равен 4.
2581192 Улучшение ведения журнала репликации транзакций:
Чтобы устранить проблемы с производительностью репликации транзакций, добавьте подробные сообщения в статистику в таблицах журнала и более подробные сообщения в журналы агента.
2581222 SSMS аварийно завершает работу во время перемещения задач плана обслуживания, если имя плана обслуживания совпадает с именем первого SUB_PLAN плана.
2581197 Конечный оператор SCOPE не совпадает с открывающим оператором SCOPE.
2581377 "ACTIONABLE_HEAP_CORRUPTION", когда файл конфигурации SSRS анализируется с использованием недопустимого идентификатора экземпляра.
2581382 Предоставляет сведения о платформе в журнале SSRS 2014
2733205 Сообщение "Имя> действия <не найдено" при выборе параметра "Фасеты" в контекстном меню экземпляра сервера отчетов в обозревателе объектов
2841734 Исключение возникает при выполнении пакета накопительного обновления SQL Server 2014 (например, SQLServer2014-KB2967546-x64.exe) с параметром командной строки /?
3143194 Чтение бизнес-приложений отображается равным нулю, если во время выполнения запроса с кластеризованным индексом columnstore включена функция "ЗАДАТЬ СТАТИСТИКУ ВВОДА-ВЫВОДА".
3506361 Некоторые общие компоненты не удалось исправить для последующего обслуживания, если SSDT BI версии 12.0.2299.1 и SQL Server 2014 установлены параллельно.
3731350 При использовании функций, которые зависят от кэша пула журналов (например, Always On) в системах с несколькими сокетами, вы можете заметить высокие значения счетчика "ожидание записи в журнале". Перед пакетом обновления 1 (SP1) необходимо включить флаг трассировки T9024, чтобы активировать исправление для этой проблемы в SQL Server 2014. Начиная с пакета обновления 1 (SP1), вам не нужно вручную добавлять флаг трассировки, так как исправление уже включено. Дополнительные сведения см. в статье FIX: High "log write waits" counter value on an instance SQL Server 2012.
3732057 Если экземпляр SQL Server обрабатывает тысячи сбросов подключений из-за пула подключений, проблемы с производительностью возникают при увеличении активности блокировки базы данных в SQL Server. Эта проблема устранена в накопительном пакете обновления 1 для SQL Server 2014, и вам необходимо добавить флаг трассировки T1236 для запуска параметров для активации исправления. Это исправление включено в пакет обновления 1 для SQL Server 2014 по умолчанию, и вам не нужно добавлять флаги трассировки, чтобы активировать исправление. Дополнительные сведения см. в статье ИСПРАВЛЕНИЕ. Проблемы с производительностью возникают при увеличении активности блокировки базы данных в SQL Server.
3909490 Ошибка 4819 возникает для некоторой комбинации схемы базы данных и данных, если включен контекст быстрой загрузки (TF610) для массовой загрузки и TF4199.
3938420 Не удалось обновить экземпляр SQL Server до SQL Server 2014, поскольку отсутствует каталог JOBS агента SQL Server, а система находится в неполном состоянии.

Исправления для подключения элементов

Следующие исправления для элементов подключения были представлены сообществом, а также включены в SQL Server 2014 SP1.

Идентификатор ошибки подключения Описание
714689 Результаты оценки многократно записываются в выходной xml-файл при реализации Enterprise Management Framework для нескольких серверов и возникновении ошибки на одном из серверов в списке.
735543 База данных переходит в режим восстановления, когда ее резервная копия восстанавливается как другая база данных в том же экземпляре.
736509 Невозможно отладить хранимую процедуру, вызывающую sp_executesql in SQL Server Management Studio (SSMS). При нажатии клавиши F11 появляется сообщение об ошибке "Ссылка на объект не установлена в экземпляр объекта".
740181 SSMS не полностью управляет Full-Text в SQL Server Express.
745566 SQL Server SMO игнорирует ограничение по умолчанию в SQL Server 2012 и SQL Server 2014.
764197 SSMS обрабатывает пронумерованные хранимые процедуры несогласованно.
769121 "Столбец "<имя> столбца" не относится к сводке таблицы. (System.Data)" при репликации таблиц с одинаковыми именами, но в разных схемах.
773710 После возврата к snapshot базы данных, содержащей полнотекстовые индексы, невозможно создать ft_catalogs до перезапуска SQL Server, отсоединения и последующего подключения базы данных или переноса базы данных в автономный режим и последующего перевода базы данных в оперативный режим.
774317 При закрытии SSMS иногда дает сбой, что приводит к автоматическому перезапуску
785064 Сообщение об ошибке "Значение 'null' недопустимо для 'stream'" при работе с компонентами конвейера клиентов в Business Intelligence Development Studio (BIDS).
785151 При выполнении запросов с включенным параметром "Показать фактический план запроса" возвращается значение NULL и появляется следующее сообщение об ошибке:
Ошибка: MSG 50000, уровень 16, состояние 10, проверка процедуры, строка 34 Строковые или двоичные данные будут усечены.
791929 Сообщение об ошибке "Сбой проверки системного утверждения" при вставке данных в секционированное представление с триггерами.
797967 Создание сценария дублирует операторы при создании сценариев разрешений на уровне столбца в SSMS.
799430 SSMS может аварийно завершить работу при попытке обновить значок окна SSMS на панели задач.
804901 При развертывании новых версий больших проектов во время развертывания в базе данных каталога служб SSIS (SSISDB) возникает тайм-аут. Кроме того, вы получаете следующие сообщения об ошибке:
Не удалось развернуть project. Чтобы получить дополнительные сведения, запросите в operation_messages представлении идентификатор операции "219". (Microsoft SQL Server, ошибка: 27203) Не удалось развернуть проект. Устраните проблемы и повторите попытку позже.:Время ожидания истекло. Время ожидания истекло до завершения операции или сервер не отвечает. Заявление было прекращено.
805659 "Некоторая часть вашего SQL-оператора вложена слишком глубоко. Перепишите запрос или разбейте его на более мелкие запросы" при анализе или выполнении хранимой процедуры.

Выберите нужный файл для скачивания и установки

На странице скачивания SQL Server 2014 SP1 приведены системные требования для установки SQL Server 2014 SP1, а также основные инструкции по установке. Дополнительную документацию по обновлению установленных компонентов 2014 с пакетом обновления 1 (SP1) с помощью служебного обновления SQL Server 2014 см. в разделе "Установка обновлений для SQL Server 2014 с обслуживанием".

В таблице ниже приведены сведения о расположении и имени скачиваемого файла (в зависимости от установленной версии). На страницах загрузки приведены системные требования и основные инструкции по установке.

Версия, установленная в данный момент Действие, которое необходимо выполнить Файл для скачивания и установки
32-разрядная версия любого выпуска SQL Server 2014 Обновление до 32-разрядной версии SQL Server 2014 SP1 SQLServer2014SP1-KB3018269-x86-ENU.exe отсюда
32-разрядная версия SQL Server 2014 RTM Express Обновление до 32-разрядной версии SQL Server 2014 Express с пакетом обновления 1 (SP1) SQLServer2014SP1-KB3018269-x86-ENU.exe отсюда
32-разрядная версия только клиента и средств управления для SQL Server 2014 (включая SQL Server 2014 Management Studio) Обновление клиента и средств управления до 32-разрядной версии SQL Server 2014 SP1 SQLManagementStudio_x86_ENU.exe отсюда
32-разрядная версия SQL Server 2014 Management Studio Express Обновление до 32-разрядной версии SQL Server 2014 SP1 Management Studio Express SQLManagementStudio_x86_ENU.exe отсюда
32-разрядная версия любого выпуска SQL Server 2014 и 32-разрядная версия клиента и средств управления (включая SQL Server 2014 RTM Management Studio) Обновление всех продуктов до 32-разрядной версии SQL Server 2014 SP1 SQLServer2014SP1-KB3018269-x86-ENU.exe отсюда
32-разрядная версия одного или нескольких средств из пакета дополнительных компонентов Microsoft SQL Server 2014 RTM Обновите средства до 32-разрядной версии пакета дополнительных компонентов Microsoft SQL Server 2014 SP1 Один или несколько файлов из пакета дополнительных компонентов Microsoft SQL Server 2014 с пакетом обновления 1 (SP1)
Отсутствует 32-разрядная установка SQL Server 2014 Management Studio Установка 32-разрядной версии SQL Server 2014 Management Studio, включающей пакет обновления 1 (SP1) SQLManagementStudio_x86_ENU.exe отсюда
Нет 32-разрядной версии SQL Server 2014 RTM Express Установка 32-разрядной версии SQL Server 2014 Express, включая пакет обновления 1 (SP1) SQLEXPR32_x86_ENU.exe отсюда
64-разрядная версия любого выпуска SQL Server 2014 Обновление до 64-разрядной версии SQL Server 2014 SP1 SQLServer2014SP1-KB3018269-x64-ENU.exe отсюда
64-разрядная версия SQL Server 2014 RTM Express Обновление до 64-разрядной версии SQL Server 2014 SP1 SQLServer2014SP1-KB3018269-x64-ENU.exe отсюда
64-разрядная версия только клиента и средств управления для SQL Server 2014 (включая SQL Server 2014 Management Studio) Обновление клиента и средств управления до 64-разрядной версии SQL Server 2014 SP1 SQLManagementStudio_x64_ENU.exe отсюда
64-разрядная версия SQL Server 2014 Management Studio Express Обновление до 64-разрядной версии SQL Server 2014 SP1 Management Studio Express SQLManagementStudio_x64_ENU.exe отсюда
64-разрядная версия любого выпуска SQL Server 2014 и 64-разрядная версия клиента и средств управления (включая SQL Server 2014 RTM Management Studio) Обновите все продукты до 64-разрядной версии SQL Server 2014 SP1 SQLServer2014SP1-KB3018269-x64-ENU.exe отсюда
64-разрядная версия одного или нескольких средств из пакета дополнительных компонентов Microsoft SQL Server 2014 RTM Обновите средства до 64-разрядной версии пакета дополнительных компонентов Microsoft SQL Server 2014 SP1 Один или несколько файлов из пакета дополнительных компонентов Microsoft SQL Server 2014 с пакетом обновления 1 (SP1)
Нет 64-разрядной установки SQL Server 2014 Management Studio Установка 64-разрядной версии SQL Server 2014 Management Studio, включая пакет обновления 1 (SP1) SQLManagementStudio_x64_ENU.exe отсюда
64-разрядная версия SQL Server 2014 RTM Express отсутствует Установка 64-разрядной версии SQL Server 2014 Express, включая пакет обновления 1 (SP1) SQLEXPR_x64_ENU.exe отсюда

Дополнительные сведения о том, как обновить установку SQL Server до SQL Server 2014 SP1, см. в разделе Поддерживаемые обновления версий и выпусков.

Примечание. Если у вас установлена версия 12.0.4050.0 SQL Server 2014 Service SP1 (KB3018269), необходимо удалить это обновление из всех экземпляров установки перед установкой этого обновления. Для этого воспользуйтесь командой "Установка и удаление программ" на панели управления. Дополнительные сведения см. в статье базы знаний 3018269 . Обратите внимание, что вы могли установить KB3018269 по одной из следующих причин:

  • Вы применили обновление к существующему экземпляру SQL Server 2014
  • Вы установили новый экземпляр SQL Server 2014 с пакетом обновления 1 (SP1) с помощью KB3018269 "Объединенного пакета" (например, SQLServer2014SP1-FullSlipstream-x64-ENU)
  • Вы установили любой из пакетов SQL Server 2014 SP1 Express Edition
  • Этот продукт содержит программное обеспечение, основанное на функции Xerox Secure Hash Function.

  • Этот продукт включает программное обеспечение из библиотеки сжатия общего назначения zlib.

  • Некоторые компоненты этого программного обеспечения частично основаны на разработках RSA Data Security, Inc. Так как корпорация Майкрософт включила программное обеспечение RSA Data Security, Inc. в этот продукт, корпорация Майкрософт обязана включить приведенный ниже текст, который прилагается к такому программному обеспечению:

    • Авторские права 1990 г., RSA Data Security, Inc. Все права защищены.
    • Лицензия на копирование и использование этого программного обеспечения предоставляется при условии, что оно обозначено как «RSA Data Security, Inc., MD5 Message-Digest Algorithm» во всех материалах, упоминающих или ссылающихся на это программное обеспечение или эту функцию. Лицензия также предоставляется на создание и использование производных работ при условии, что такие работы идентифицированы как «производные от RSA Data Security, Inc., MD5 Message-Digest Algorithm» во всех материалах, упоминающих или ссылающихся на производную работу.
    • RSA Data Security, Inc. не делает никаких заявлений относительно товарной пригодности данного программного обеспечения или его пригодности для какой-либо конкретной цели. Он предоставляется "как есть" без явных или подразумеваемых гарантий любого рода.

    Эти уведомления должны храниться во всех копиях любой части документации или программного обеспечения.

  • Функция картографирования Reporting Services использует данные из шейп-файлов TIGER/Line, которые любезно предоставлены Бюро переписи населения США (http://www.census.gov/). Шейп-файлы TIGER/Line представляют собой извлечение избранной географической и картографической информации из базы данных Census MAF/TIGER. Шейп-файлы TIGER/Line доступны бесплатно в Бюро переписи населения США. Для получения дополнительной информации о шейп-файлах TIGER/Line перейдите на http://www.census.gov/geo/www/tiger. Информация о границах в шейп-файлах TIGER/Line предназначена только для сбора статистических данных и подсчета таблиц; Его описание и назначение для статистических целей не представляют собой определения юрисдикционных полномочий, прав собственности или прав и не отражают юридических описаний земли. Census TIGER и TIGER/Line являются зарегистрированными товарными знаками Бюро переписи населения США.

Авторское право 2012 Microsoft. Все права защищены.

Ссылки

Для получения дополнительных сведений о том, как определить текущую версию и выпуск SQL Server, щелкните следующий номер статьи, чтобы перейти к статье в базе знаний Майкрософт:

321185
  Определение версии и выпуска SQL Server
 Продукты сторонних разработчиков, рассмотренные в этой статье, выпущены компаниями, независимыми от корпорации Майкрософт. Корпорация Майкрософт не гарантирует надлежащую работоспособность и надежность этих продуктов.