Det här avsnittet innehåller vanliga orsaker till felvärdet #VÄRDEFEL! i funktionerna SUMMA.OM och SUMMA.OMF och hur du löser dem.

Problem: Formeln refererar till celler i en stängd arbetsbok

Funktionerna SUMMA.OM/SUMMA.OMF som refererar till en cell eller ett område i en stängd arbetsbok resulterar i #VALUE! fel.

Obs! Det här är ett känt problem med flera andra Excel till exempel ANTAL.OM, ANTAL.OMF, ANTAL.OMTOM för att nämna några. Se funktionerna SUMMA.OM, ANTAL.OM och ANTAL.OMTOM returnerar "#VALUE!" Fel för mer information.

Lösning: Öppna arbetsboken som angetts i formeln och tryck på F9 för att uppdatera formeln.

Du kan också lösa problemet genom att använda funktionerna SUMMA och OM tillsammans i en matrisformel. Se funktionerna SUMMA.OM, ANTAL.OM och ANTAL.BLANK returnerar #VALUE!-fel för mer information.

Problem: Kriteriesträngen är längre än 255 tecken

Funktionerna SUMMA.OM/SUMMA.OMF returnerar felaktiga resultat om du försöker att matcha strängar som är längre än 255 tecken.

Lösning: Förkorta strängen om möjligt. Om du inte kan korta ned den använder du funktionen SAMMANFOGA eller et-tecknet (&) för att dela upp värdet i flera strängar. Till exempel:

=SUMMA.OM(B2:B12;"lång sträng"&"annan lång sträng")

Problem: I SUMMA.OMF är inte argumentet villkorsområde konsekvent med argumentet summaområde.

Områdesargumenten måste alltid vara desamma i SUMMA.OMF. Det betyder att argumenten villkorsområde och summaområde måste innehålla samma antal rader och kolumner.

I följande exempel ska formeln returnera summan av den dagliga försäljningen av äpplen i Bellevue. Argumentet sum_range (C2:C10) motsvarar emellertid inte samma antal rader och kolumner i argumenten criteria_range (A2:A12 & B2:B12). Om du använder syntaxen =SUMMA.OMF(C2:C10,A2:A12,A14,B2:B12,B14) blir resultatet #VALUE! fel.

Felaktig formel är =SUMMA.OM(C2:C10;A2:A12;A14;B2:B12;B14) där C2:C10 måste vara C2:C12

Lösning: Följ det här exemplet och ändra summaområde till C2:C12 och prova formeln igen.

Obs!:  SUMMA.OMF kan använda olika storleksområden.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Korrigera felet #VÄRDE! fel

Funktionen SUMMA.OM

Funktionen SUMMA.OMF

Videofilmer om avancerade OM-funktioner

Översikt över formler i Excel

Hur du undviker felaktiga formler

Upptäck fel i formler

Alla Excel (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Gå med i Microsoft Office Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×