简介
本文介绍了 Microsoft SQL Server 2012 的累积更新程序包 1。 此更新包含用于解决 SQL Server 2012 发布后修复的问题的修补程序。
注意:此累积更新包的内部版本号为 11.0.2316.0。
建议在将修补程序部署到生产环境中之前先测试修补程序。 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2012 修补程序版本中包含的所有修补程序和所有安全修补程序。 建议应用包含此修补程序的最新修补程序版本。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2692828 2012 SQL Server 发布之后发布的 SQL Server 2012 内部版本
有关累积更新包的重要说明
- 此累积更新包中的修补程序包含在 SQL Server 2012 Service Pack 1 (SP1) 中。
- SQL Server 2012 修补程序现在是多语言的。 因此,所有语言只有一个累积修补程序包。
- 一个累积修补程序包包括所有组件包。 累积更新包仅更新系统上安装的组件。
详细信息
如何获取 SQL Server 2012 的累积更新 1
Microsoft 现在提供了一个受支持的累积更新程序包。 但是,它仅用于更正本文中描述的问题。 仅将其应用于遇到这些特定问题的系统。 此累积更新包可能会接受额外的测试。 因此,如果你没有受到上述任何问题的严重影响,我们建议你等待包含此累积更新包中修补程序的下一个 SQL Server 2012 Service Pack。
如果累积更新可供下载,则本知识库文章顶部的“修补程序下载可用”部分。 如果此部分不存在,请联系 Microsoft 客户服务和支持人员以获取累积更新包。
注意 如果发生其他问题或需要进行任何故障排除,您应该另行创建服务请求。 通常的支持费用将应用于不符合此特定累积更新包条件的其他支持问题和问题。 若要获取 Microsoft 客户服务和支持部门的完整电话号码列表或另行创建服务请求,请访问以下 Microsoft 网站:
此累积更新包中包含的修补程序
讨论这些修补程序的 Microsoft 知识库文章将在可用时进行发布。
有关 SQL Server bug 的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
| VSTS 错误号 | 知识库文章编号 | 说明 |
|---|---|---|
| 899274 | 2562753 | 修复:如果对 SSAS 2008 R2 或 SSAS 2012 中的父/子层次结构成员使用一元运算符时,如果对这些成员定义范围计算,并且查询访问时间维度中的多个日期,则这些成员的性能会降低 |
| 887635 | 2574714 | 修复:如果将 RealTimeOlap 属性设置为 True,则在 MDX 查询针对 SSAS 2008 或 SSAS 2012 数据库运行时出现错误结果 |
| 892370 | 2588047 | 修复:如果链接的多维数据集包含多对多维度和不同的计数度量值组,MDX 查询在 SSAS 2008 R2 或 SSAS 2012 中错误地返回 NULL 值 |
| 892362 | 2590200 | 修复:当 UpdateCells 命令在 SSAS 2008 R2 或 SSAS 2012 中同时执行多个写回操作时,出现“当前语句的结果无法存储在服务器上”错误 |
| 885538 | 2590839 | 修复:即使在 SQL Server 2008 R2 或 SQL Server 2012 中没有用户活动,CPU 峰值也较低,SQL Server 在设定的时间间隔内也是如此 |
| 896319 | 2591902 | 修补程序:在 SQL Server 2005、SQL Server 2008、SQL Server 2008 R2 或 SQL Server 2012 中,合并复制遇到外键冲突错误时,SQL Server SQL Server SQL Server 2012 中会丢失 XML 数据 |
| 893296 | 2603910 | 修复:如果在数据库上启用更改跟踪,则在 SQL Server 2008、SQL Server 2008 R2 或 SQL Server 2012 中备份失败 |
| 885533 | 2605756 | 修复:从 SSAS 2005 升级到 SSAS 2008、SSAS 2008 R2 或 SSAS 2012 后,运行使用 Descendants 函数的 MDX 查询时出现内部错误 |
| 899270 | 2606211 | 修复:在 SSAS 2008 R2 或 SSAS 2012 中,如果 WHERE 子句具有命名集,则复杂 MDX 查询包含 NONEMPTY 子句时会出现错误 |
| 895589 | 2606883 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中的分区表上运行 AFTER 触发器时性能下降 |
| 896325 | 2606918 | 修复:sysmergepublications 表中“保留”列中的 NULL 值以及在 SQL Server 2008 R2 或 SQL Server 2012 中的重新发布拓扑中设置合并复制环境时对元数据清理过程的影响 |
| 895595 | 2616481 | 修复:如果使用 SharePoint 报表查看器 Web 部件中的现成查看器页面,则 SSRS 2008 R2 报表或 SSRS 2012 报表在 Internet Explorer 9.0 中没有“导出”菜单 |
| 896327 | 2616718 | 修复:将数据从 SQL Server 2008 R2 或 SQL Server 2012 发布服务器同步到 SQL Server Compact 3.5 订阅者时性能不佳 |
| 896330 | 2622668 | 修复:如果表的架构名称不是“[dbo]”,则在发布服务器上删除表中的某些记录时出现错误消息 |
| 899281 | 2626637 | 修复:如果在 SSAS 2008 R2 或 SSAS 2012 中针对某些属性成员(其值包含一个或多个双引号)运行 DRILLTHROUGH 语句,则该语句不起作用 |
| 892372 | 2629168 | 修复:针对 SSAS 2008 R2 或 SSAS 2012 中的透视运行查询后返回的单元格集时更新内部错误 |
| 885539 | 2636425 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中同时更新多个使用 PowerPivot for Excel 2010 的 Excel 2010 工作表时,出现错误结果 |
| 884204 | 2637802 | 修复:如果使用 ReportExecutionService.Render 方法以图像格式或 EMF 格式呈现报表,则 SSRS 2008 R2 或 SSRS 2012 报告的页面会错误地传递 |
| 895728 | 2638448 | 修复:在 SQL Server 2008、SQL Server 2008 R2 或 SQL Server 2012 中编译或重新编译查询时出现访问冲突 |
| 881813 | 2638932 | 修复:当对具有使用 SSAS 2008 或 SSAS 2008 R2 中聚合设计的分区的多维数据集运行 ProcessUpdate 命令时出错 |
| 896336 | 2644396 | 修复:当订阅 SQL Server 2008 R2 或 SQL Server 2012 中的分区时,SQL Server Compact 订阅者上缺少合并复制更改 |
| 895600 | 2647120 | 修复:将 SSRS 2008 R2 报告导出为 PDF 格式时显示不正确的页码 |
| 891519 | 2648158 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中,在日志读取器代理的 MaxCmdsInTran 参数中设置非零值时,出现“进程无法执行”错误消息 |
| 895618 | 2649359 | 修复:“sqlservr!SQL Server 2008 R2 或 SQL Server 2012 中的 CSbMsgDispatcher::CSbReceivedDialog::AppendMsg“类 |
| 885844 | 2695802 | 修复:SQL Server 2012 MDS 的订阅视图中不存在VersionMember_ID列 |
| 885534 | 2649913 | 修复:从 SQL Server 2005 升级到 SQL Server 2008、SQL Server 2008 R2 或 SQL Server 2012 后,运行使用 sp_cursoropen 存储过程的查询可能会降低性能 |
| 877206 | 2652024 | 修复:尝试在 SQL Server 2012 的 Data Quality Client 中打开知识库时收到错误消息“ConfigServiceConfigurationAlreadyExists” |
| 896199 | 2652582 | 修复:使用 SQL Server 身份验证模式运行 SQL Server 2008 R2 Analysis Services 部署向导时出现“无效的授权规范”错误消息 |
| 893278 | 2653893 | 修复:在 SQL Server 2008 R2、SQL Server 2008 或 SQL 2012 中还原数据库需要很长时间 |
| 885542 | 2655789 | 修复:如果将发布文章表的“arge value types out of row”表选项设置为 ON 时,复制日志读取器代理会失败,并显示“18773”和“18805”错误消息 |
| 885544 | 2658214 | 修复:在 SQL Server 2008、SQL Server 2008 R2 或 SQL Server 2012 中运行包含相关 AND 谓词的查询时性能不佳 |
| 881809 | 2658234 | 修补程序:如果将一篇新文章添加到 SQL Server 2008 或 SQL Server 2012 中的发布,则在重新初始化订阅者后会对其进行不必要的SQL Server更新 |
| 885548 | 2661225 | 修复:如果在 Internet Explorer 的“连接”选项卡中启用“自动检测设置”选项,则在使用 SQL Server Analysis Services 10.0 OLE DB 提供程序时无法连接到数据源 |
| 885549 | 2662301 | 修复:如果在 QUERY_EXEC_STATS 旋转锁争用时观察到 CPU 使用率较高,则 SQL Server 2008 R2 或 SQL Server 2012 中会出现性能下降 |
| 885550 | 2669148 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中运行包含 CLR UDA 函数的并行查询时,可能会发生异常 |
| 871311 | 2669955 | 修复:使用 DQS 对 SQL Server 2012 中的大型数据源执行数据清理时性能降低 |
| 887936 | 2672531 | 修复:如果使用 Service Broker 在 SQL Server 2012 中运行分布式查询,则会出现“在计划程序上不生成”错误 |
| 884202 | 2673056 | 修复:如果安装了许多 SQL Server 2008 R2 或 SQL Server 2012 实例,则 SQL Server 配置管理器需要很长时间才能打开 |
| 874242 | 2674817 | 修复:SQL Server 2012 AlwaysOn 故障转移群集实例不支持 Data Quality Services 功能 |
| 866374 | 2678370 | 修复:执行触发 SQL Server 2012 中审核规范中定义的审核事件的操作时出现错误 17310 |
| 875390 | 2683293 | 修复:使用 AMO 连接到 SQL Server 2012 Analysis Services 时出现“反序列化失败:找不到请求的值'<ServerEdition>'”错误消息 |
| 887776 | 2683467 | 修复:SQL Server 2012 的群集安装不支持 Master Data Services |
| 872113 | 2683514 | 修复:在创建属性名称包含空格的业务规则时,SQL Server 2012 中出现“发生数据库错误”错误消息 |
| 872110 | 2683516 | 修复:在 SQL Server 2012 中使用 MDSModelDeploy.exe 部署包含超过 1000000 行的模型部署包时,发生 SystemOutOfMemory 错误 |
| 887665 | 2685308 | 修复:SSAS 在 SQL Server 2012 Business Intelligence 中仅使用 20 个核心 |
| 891933 | 2686690 | 修复:如果在 SQL Server 2012 故障转移群集安装期间,如果单个驱动器号下有超过 20 个磁盘或卷,则群集磁盘验证会意外需要较长时间 |
| 893874 | 2688692 | 修复:运行 SQL Server 2012 安装程序并启用 FileStream 配置时出现错误代码 17883 |
| 893881 | 2688697 | 修补程序:在使用 NUMA 的计算机上运行 SQL Server 2012 时出现内存不足错误 |
| 893908 | 2688721 | 修复:如果对 SQL Server 2012 实例使用超过 30 个用户定义的资源调控器资源池,则会出现错误消息:“非生成 IOCP 侦听器” |
| 893913 | 2688722 | 修复:如果虚拟机状态保存较长时间,则在虚拟机中运行 SQL Server 2012 时会发生溢出异常 |
| 894427 | 2688967 | 修复:安装或卸载 SQL Server 2012 修补程序包时,进度栏长时间冻结 |
| 893254 | 2693568 | 修补程序:在 SQL Server 2012 Analysis Services 中针对表格模型运行 DAX 查询时出现内存不足错误 |
| 894853 | 2689367 | 修复:如果在 SQL Server 2012 中两次将次要副本 (replica) 加入 AG,则辅助数据库将处于“未知”状态 |
| 894307 | 2688964 | 修补程序:使用 SQL Server 2012 安装介质升级、修复或卸载功能时出现错误消息:“安装执行后未更改 SQL Server 安装状态” |
894249 |
2688946 | 修复:安装 SQL Server 2012 时出现错误消息:“清单的标识相同,但内容不同” |
| 896026 | 2685132 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 的实例上运行日志传送备份作业时,日志传送还原作业会将损坏的事务日志备份还原到辅助数据库 |
| 897990 | 2692145 | 修复:在 SQL Server 2012 中打开加密时,数据库可能未加密 |
| 868373 | 2685303 | 修复:在 SSAS 2012 中设置 PowerPivot for SharePoint 的数据刷新计划时,数据刷新仅意外运行一次 |
| 885541 | 2672888 | 修复:如果在 BIDS 中重新打开 SSAS 2008 R2 项目中的角色,则基本属性层次结构设置会丢失 |
| 887930 | 2671058 | 修复:如果 MDX 查询包含引用某些计算度量值的子选择子句,则在 SSAS 2012 中针对多维数据集运行 MDX 查询时会出现错误消息 |
| 887922 | 2652738 | 修复:在 SQL Server 2008 R2 Analysis Services 中处理大型维度时出现“文件系统错误”错误消息 |
| 899285 | 2637503 | 修复:在 SSAS 2008 R2 或 SSAS 2012 中运行使用 YTD 计算的 MDX 查询时,存储引擎读取同一日期维度两次 |
| 868741 | 2518306 | 修复:如果未填充数据缓存,MDX 查询在 SSAS 2008、SSAS 2008 R2 或 SSAS 2012 中返回错误结果 |
| 885552 | 2675232 | 修复:运行使用 ROLAP 分区的 MDX 查询时 SSAS 2008 R2 停止响应 |
| 880000 | 2567304 | 修复:如果重定向 StdOut 流,则调用 WshShell.Exec 时会从 DTExec.exe 输出日志文件中截断文本 |
| 871960;894895 | 2800256 | 修复:“System_health”会话诊断收集任务Microsoft SQL Server 2012 冻结 |
累积更新包信息
重启信息
应用此累积更新后,可能必须重启计算机。
注册表信息
要使用此程序包中的某个修补程序,不必对注册表进行任何更改。
如何卸载此累积更新包
若要卸载此累积更新程序包,请按照下列步骤操作:
在控制面板中,打开“添加或删除程序”
项目。注意 如果运行的是 Windows 7,请在控制面板中打开“程序和功能”项。
找到此累积更新包安装的条目。
右键单击该条目,然后选择“卸载”以删除累积更新包。
参考资料
有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
935897
可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序
有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
822499
Microsoft SQL Server 软件更新包的新命名架构
有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:
824684
用于描述 Microsoft 软件更新标准术语的说明