简介
本文介绍 Microsoft SQL Server 2012 Service Pack 1 (SP1) 的累积更新包 5。 此更新包含用于解决 SQL Server 2012 SP1 发布后修复的问题的修补程序。
注意 累积更新包的内部版本号为 11.0.3373.0。
建议在将修补程序部署到生产环境中之前先测试修补程序。 由于版本是累积的,因此每个新更新版本都包含之前 SQL Server 2012 更新版本中包含的所有修补程序和安全更新。 建议考虑应用最新的更新版本。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2772858 在 SQL Server 2012 Service Pack 1 发布之后发布的 SQL Server 2012 内部版本
有关此累积更新包的重要说明
- SQL Server 2012 SP1 修补程序现在是多语言的。 因此,此累积更新不仅仅特定于一种语言。 它适用于所有支持语言。
- 一个累积更新程序包包含所有组件包。 不过,累积更新程序包仅更新安装在系统中的组件。
详细信息
如何获取此累积更新程序包
Microsoft 现在提供了一个受支持的累积更新程序包。 但是,它仅用于更正本文中描述的问题。 仅将其应用于遇到这些特定问题的系统。 此累积更新包可能会接受额外的测试。 因此,如果你没有受到上述任何问题的严重影响,我们建议你等待包含此累积更新包中修补程序的下一个 SQL Server 2012 Service Pack。
如果累积更新可供下载,则本知识库文章顶部的“修补程序下载可用”部分。 如果此部分不存在,请联系 Microsoft 客户服务和支持人员以获取累积更新包。
注意 如果发生其他问题或需要进行任何故障排除,您应该另行创建服务请求。 通常的支持费用将应用于不符合此特定累积更新包条件的其他支持问题和问题。 若要获取 Microsoft 客户服务和支持部门的完整电话号码列表或另行创建服务请求,请访问以下 Microsoft 网站:
/contactus/?ws=support 注意 “修补程序下载可用”窗体显示累积更新的可用语言版本。 如果您找不到您的语言,是因为该语言的累积更新程序包不可用。
此累积更新包中包含的修补程序
讨论这些修补程序的 Microsoft 知识库文章将在可用时进行发布。
有关 SQL Server 问题的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
| VSTS 错误号 | 知识库文章编号 | 说明 |
|---|---|---|
| 1363711 | 2833989 | 修复:内存中使用的对象 ID 与 SQL Server 2012 中磁盘上的对象 ID 不同 |
| 1356013 | 2837247 | 修复:在 SQL Server 2008 R2 中多个合并复制订阅者同时同步时,W3WP.exe 进程意外停止 |
| 1277961 | 2846345 | 修复:呈现使用 SQL Server 2012 SP1 PowerPivot 工作簿作为数据源的 Power View 报表时性能降低 |
| 1356019 | 2847467 | 修复:在 SQL Server 2008 R2 的 WHERE 子句中运行使用 LIKE 运算符的查询时性能不佳 |
| 1356021 | 2849351 | 修复:在 SQL Server 2008 R2 中运行 RESTORE FILELISTONLY 语句时出现错误 3241 |
| 1319121 | 2850388 | 修复:使用 SSDT 在 SSAS 2012 中创建透视时出现“索引超出范围”错误消息 |
| 1325209 | 2852061 | 修复:在 SQL Server 2012 的 BIDS 或 SSDT 中,MDX 查询超出所需的时间比预期长 |
| 1330298 | 2854370 | 修复:无法更新使用 .bism 文件连接到 SSAS 实例的工作簿中的数据 |
| 1356015 | 2854420 | 修补程序:在 SQL Server 2008 R2 Service Pack 2 中的报表管理器中呈现报表时,发生 UnhandledReportRenderingException 错误 |
| 1332122 | 2855020 | 修复:在 SSRS 2012 中将报告导出到 Word 后,日期和电话号码显示不正确 |
| 1340145 | 2858573 | 修复:在 SQL Server 2012 中运行使用 TVP 的存储过程时出现非生成计划程序错误 |
| 1347214 | 2860520 | 修复:SSIS 2012 中 SSIS 包的 DateTime 值分析不正确 |
| 1352560 | 2861387 | 修复:当 CTE 调用 SQL Server 2012 中的同义词时会发生访问冲突 |
| 1317007 | 2862837 | 修复:如果所选实体成员在 SQL Server 2012 中具有只读权限,则“添加成员”按钮不起作用 |
| 1338633 | 2863144 | 修复:在 SSAS 2012 中,当属于不同角色的许多用户同时对多维数据集运行查询时,会出现访问冲突 |
| 1242784 | 2863192 | 修复:在 SQL Server 2012 MDS 中验证大量数据时遇到性能低下问题 |
| 1361005 | 2863256 | 修复:包含多值参数的报表在 SSRS 2012 中显示为空白页 |
| 1352669 | 2863728 | 在 SQL Server 2012 中未保存包含 SSIS 包作业步骤的双引号的属性值和路径 |
| 1263738 | 2863979 | 修复:在 SQL Server 2012 中配置事务复制时,不会在订阅数据库上生成存储过程 |
| 1375290 | 2866504 | 修复:在 SSRS 2012 中创建 SharePoint 文档库订阅时出现“找不到指定的用户 DOMAIN\Username”错误 |
| 1226090 | 2869734 | 修复:在次要副本 (replica) 上执行数据库备份时,SQL Server 2012 中的 AlwaysOn 可用性组主要副本 (replica) 上的计划程序死锁 |
| 1352539 | 2869735 | 修复:SSRS 2012 中无法滚动水平滚动条以查看多值参数的标签的所有字符 |
| 1333060 | 修复:CU 刷新仅在创建 Microsoft Azure 映像时才会针对 ENU 删除 MSI。 | |
| 1333051 | 修复:SQL 映像安装程序使用的配置文件被硬编码为 ENU。 | |
| 1326849 | 修复:Windows 2012 映像不会触发 ConfigureImage 工作流。 | |
| 1356011 | 在 SQL Server 2012 中运行查询时,可能会创建内存转储。 |
累积更新包信息
先决条件
要应用此累积更新程序包,必须运行 SQL Server 2012 SP1。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2755533 如何获取 SQL Server 2012 的最新 Service Pack
重启信息
应用此累积更新包后,可能必须重启计算机。
注册表信息
要使用此程序包中的某个修补程序,不必对注册表进行任何更改。
如何卸载此累积更新包
若要卸载此累积更新程序包,请按照下列步骤操作:
在控制面板中,打开“添加或删除程序”项。
注意 如果运行的是 Windows 7,请在控制面板中打开“程序和功能”项。
找到此累积更新包安装的条目。
右键单击该条目,然后单击“卸载”。
参考资料
有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
935897 可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序
有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
822499 Microsoft SQL Server 软件更新包的命名架构
有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:
824684 用于描述Microsoft软件更新的标准术语说明