症状
在 Microsoft SQL Server 2012 或 SQL Server 2008 R2 环境中运行执行 sys.fn_xe_file_target_read_file 存储过程的语句或作业时,以下错误消息将记录在 SQL Server 错误日志中:
注意
使用“dbghelp.dll”版本“4.0.5”
原因
出现此问题的原因是,每次语句或作业执行sys.fn_xe_file_target_read_file存储过程时都会加载 DBGhelp.dll 文件。
解决方法
此问题已首先在 SQL Server 的以下累积更新中修复。
SQL Server 2008 R2 SP2 累积更新 12 /en-us/help/2938478
SQL Server 2012 SP1 累积更新 6 /en-us/help/2874879
关于 SQL Server 的累积更新
SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。