简介
本文介绍了 Microsoft SQL Server 2012 的累积更新程序包 6。 此更新包含用于解决 SQL Server 2012 发布后修复的问题的修补程序。
注意 累积更新包的内部版本号为 11.0.2401.0。
建议在将修补程序部署到生产环境中之前先测试修补程序。 由于版本是累积的,因此每个新更新版本都包含之前 SQL Server 2012 更新版本中包含的所有修补程序和安全更新。 建议考虑应用最新的更新版本。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2692828 2012 SQL Server 发布之后发布的 SQL Server 2012 内部版本
有关此累积更新包的重要说明
- SQL Server 2012 修补程序现在是多语言的。 因此,此累积更新不仅仅特定于一种语言。 它适用于所有支持语言。
- 一个累积更新程序包包含所有组件包。 不过,累积更新程序包仅更新安装在系统中的组件。
详细信息
如何获取此累积更新程序包
Microsoft 现在提供了一个受支持的累积更新程序包。 但是,它仅用于更正本文中描述的问题。 仅将其应用于遇到这些特定问题的系统。 此累积更新包可能会接受额外的测试。 因此,如果你没有受到上述任何问题的严重影响,我们建议你等待包含此累积更新包中修补程序的下一个 SQL Server 2012 Service Pack。
如果累积更新可供下载,则本知识库文章顶部的“修补程序下载可用”部分。 如果此部分不存在,请联系 Microsoft 客户服务和支持人员以获取累积更新包。
注意 如果发生其他问题或需要进行任何故障排除,您应该另行创建服务请求。 通常的支持费用将应用于不符合此特定累积更新包条件的其他支持问题和问题。 若要获取 Microsoft 客户服务和支持部门的完整电话号码列表或另行创建服务请求,请访问以下 Microsoft 网站:
/contactus/?ws=support 注意 “修补程序下载可用”窗体显示累积更新的可用语言版本。 如果您找不到您的语言,是因为该语言的累积更新程序包不可用。
此累积更新包中包含的修补程序
讨论这些修补程序的 Microsoft 知识库文章将在可用时进行发布。
有关 SQL Server 问题的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
| VSTS 错误号 | 知识库文章编号 | 说明 |
|---|---|---|
| 1155738 | 2734191 | 修复:使用 RSClientPrint 控件在 SSRS 2008 R2 或 SSRS 2012 中打印报表时,报表不会以定义的页面大小打印 |
| 1158565 | 2755192 | 修复:当您执行与 SSRS 2008 R2 或 SSRS 2012 数据库的角色相关的管理操作时,SSMS 冻结 |
| 1158567 | 2765785 | 修复:在具有多个 CPU 的计算机上执行包含排序转换的 SSIS 2008 R2 或 SSIS 2012 包时发生访问冲突 |
| 1158569 | 2770258 | 修复:针对 SQL Server 2008 R2 或 SQL Server 2012 中的分区表运行查询时收到错误的结果 |
| 1169523 | 2770635 | 修复:在对具有多个数据源的 SSAS 2008 R2 或 SSAS 2012 数据库运行 MDX 查询时,出现错误结果 |
| 1087085 | 2772525 | 改进了用于 SQL Server 2012 的 SQL Server Native Client 中的元数据发现进程性能 |
| 1158571 | 2776344 | 修复:如果在 SQL Server 2008 R2 或 SQL Server 2012 中启用了锁分区,则执行存储过程以更改临时表时会发生SQL Server 死锁 |
| 1158573 | 2778479 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中执行二进制大型对象相关操作的大型批次中运行 sp_refreshview 存储过程时出现 17066 和 3624 错误 |
| 1158577 | 2780146 | 修复:尝试解密从 SQL Server 2008 R2、SQL Server 2012 或 SQL Server 2008 中的另一个数据库迁移的数据时,出现“'IDENTITY_VALUE'附近的语法不正确”错误错误 |
| 1158579 | 2781008 | 修补程序:在 Active Directory 中更改登录名后,SSRS 2008 R2 或 SSRS 2012 中出现“找不到用户”错误消息 |
| 1155751 | 2781486 | 修补程序:对 SQL Server 2008 R2 或 SQL Server 2012 的 UCP 托管实例执行产品更新时出现错误消息 |
| 1130624 | 2783983 | 修复:在 SSDT 2012 中的控制流或数据流设计器窗口中移动组件时,滚动条移动速度过快 |
| 1158587 | 2785079 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中,Service Broker 消息转发服务器上发生“非生成”错误 |
| 1155757 | 2786212 | 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中通过链接服务器运行空间查询时发生访问冲突 |
| 1158591 | 2788362 | 修复:启动从 SQL Server 7.0 升级的 SQL Server 2008 R2 或 SQL Server 2012 的实例时,出现错误 28921 和错误 SQL Server 18054 |
| 1172949 | 2791745 | 修复:在 SQL Server 2008 中运行在 IN 子句中包含多个常量值的查询时发生访问冲突 |
| 988881 | 2800842 | 修复:SQL Server 2012 PowerPivot for Excel 中 MDX 查询设计器的性能改进 |
| 1176644 | 2807974 | 修复:在 SQL Server 2012 异步数据库镜像环境中将新文件组添加到主体数据库后出现错误 3456 |
| 1166623 | 2811020 | 修复:当您使用 Microsoft.SqlServer.XEvent.Linq 程序集读取 SQL Server 2012 扩展事件文件中的事件时,不会释放内存 |
| 1155600 | 2811607 | 修复:行级别安全用户在 SQL Server 2012 中运行 MDX 查询时,MDX 查询不返回任何结果 |
| 1155748 | 972936 | 修复:在 SQL Server 2012、SQL Server 2008、SQL Server 2008 R2 或 SQL Server 2005 中运行查询时出现“SqlDumpExceptionHandler:进程 <spid> 生成的致命异常 c0000005 EXCEPTION_ACCESS_VIOLATION”错误 |
| 898456 | 980142 | 修复:使用 SQL Server WMI 提供程序获取有关 SQL Server 2012、SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 服务的信息时,出现“提供程序加载失败”错误消息或 Wmiprvse.exe 进程停止响应 |
累积更新包信息
先决条件
要应用此累积更新程序包,必须运行 SQL Server 2012。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2755533 如何获取 SQL Server 2012 的最新 Service Pack
重启信息
应用此累积更新包后,可能必须重启计算机。
注册表信息
要使用此程序包中的某个修补程序,不必对注册表进行任何更改。
如何卸载此累积更新包
若要卸载此累积更新程序包,请按照下列步骤操作:
在控制面板中,打开“添加或删除程序”项。
注意 如果运行的是 Windows 7,请在控制面板中打开“程序和功能”项。
找到此累积更新包安装的条目。
右键单击该条目,然后单击“卸载”。
参考资料
有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
935897 可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序
有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
822499 Microsoft SQL Server 软件更新包的命名架构
有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:
824684 用于描述Microsoft软件更新的标准术语说明