KB4538275 - 修复:在 SQL Server 2017 中使用自动种子设定可能会导致数据库初始化失败

应用对象
SQL Server 2017 on Linux

症状

假设你使用 SQL Server 2017。 尝试使用自动种子设定初始化 AG) (SQL Server Always On 可用性组中的多个数据库时,会注意到某些数据库的种子设定可能会失败,需要在一个或多个次要副本上重试。

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。

解决方法

此问题已在 SQL Server 的累积更新中进行了修复:

关于 SQL Server 的累积更新:

SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:

备注使用修补程序时,必须应用相应的 pacemaker 程序包,以便 Linux 上的 SQL Server 正常工作。

解决方法

若要解决此问题,可以重试、使用备份或使用还原进行初始化。

参考资料

了解 Microsoft 用于描述软件更新的术语。