症状
从 SQL Server 2017 卸载累积更新 20 (CU20) 时,脚本降级可能会失败并返回以下错误消息:
DateTime SpidNum 错误:935,严重性:21,状态:1。
DateTime SpidNum 数据库 'master' 中的 'system_xevents_modification.sql' 的脚本级别不能从 LevelOne 降级到该服务器支持的 LevelTwo。 这通常意味着附加了将来的数据库,并且当前安装不支持降级路径。 安装较新版本的 SQL Server 并重新尝试打开数据库。
DateTime SpidNum 错误:3417,严重性:21,状态:3。
DateTime SpidNum 无法恢复 master 数据库。 SQL Server 无法运行。 从完整备份还原 master、修复或重建它。 有关如何重建主数据库的详细信息,请参阅 SQL Server 联机丛书。
DateTime SpidNum SQL 跟踪由于服务器关闭而停止。 跟踪 ID = '1'。 这只是一个信息来源的消息;无需用户操作。
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
解决方法
此问题已在 SQL Server 的累积更新中进行了修复:
关于 SQL Server 的累积更新:
SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:
解决方法
要解决此问题,可以启用跟踪标志 - T902,然后 SQL Server 将联机,脚本降级正常工作。 无需再次卸载它。 若要升级到新的 CU,需要首先删除此标志。
参考资料
了解 Microsoft 用于描述软件更新的术语。