Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.
Jak opravit chybu #NENÍ_K_DISPOZICI

Chyba #N/A obecně značí, že vzorec nemůže najít to, co se od něj žádá.

Nejlepší řešení

Nejčastější příčinou chyby #N/A je, když vzorec nemůže u funkcí XLOOKUP, SVYHLEDAT, VVYHLEDAT, VYHLEDAT nebo POZVYHLEDAT najít odkazovanou hodnotu. Třeba když vyhledávací hodnota ve zdrojových datech neexistuje.

Vyhledávací hodnota neexistuje.  Vzorec v buňce E2 je =SVYHLEDAT(D2,$D$6:$E$8,2,NEPRAVDA).  Hodnotu Banán se nepodařilo najít a proto vzorec vrátí chybu #NENÍ_K_DISPOZICI.

V tomto případě položka „Banány“ není uvedena ve vyhledávací tabulce, takže funkce SVYHLEDAT vrátí chybu #N/A.

Řešení: Buď se ujistěte, že vyhledávací hodnota ve zdrojových datech existuje, nebo ve vzorci použijte obslužnou rutinu chyb, jako je například IFERROR. Například =IFERROR(FORMULA();0), která znamená:

  • = KDYŽ(váš vzorec vyhodnotí chybu; pak zobrazit 0; jinak zobrazit výsledek vzorce)

Pro zobrazení prázdného pole můžete použít “” nebo můžete doplnit vlastní text: =IFERROR(FORMULA();“Tady bude chybová zpráva.”)

Poznámky: 

  • Pokud potřebujete nápovědu k chybě #N/A ke konkrétní funkci, třeba SVYHLEDAT nebo INDEX a POZVYHLEDAT, zvolte jednu z těchto možností:

  • Může být také užitečné získat informace o některých běžných funkcích, ve kterých k této chybě dochází, například XLOOKUP, SVYHLEDAT, VVYHLEDAT, VYHLEDAT nebo POZVYHLEDAT.

Pokud si nejste jistí, co máte v tuto chvíli dělat nebo jaký druh pomoci potřebujete, můžete podobné otázky vyhledat v komunitě Microsoftu nebo publikovat vlastní.

Odkaz na fórum komunity Excelu

Pokud stále potřebujete pomoc s řešením této chyby, použijte tento kontrolní seznam, který obsahuje postupy pro řešení potíží, pomocí kterých můžete zjistit, co by ve vzorcích mohlo být špatně.

Vyhledávací hodnota a zdrojová data jsou různé datové typy. Pokusíte se třeba odkázat funkcí SVYHLEDAT na číslo, ale zdrojová data jsou uložena jako text.

Nesprávné typy hodnot.  Příklad zobrazuje vzorec SVYHLEDAT vracející chybu #NENÍ_K_DISPOZICI, protože vyhledávací hodnota je formátovaná jako číslo, ale vyhledávací tabulka je formátovaná jako text.

Řešení: Ujistěte se, že všechny datové typy jsou stejné. Formátování buněk můžete zkontrolovat, když vyberete buňku nebo oblast buněk, pak kliknete pravým tlačítkem myši a vyberete Formát buněk > Číslo (nebo stiskněte Ctrl+1). V případě potřeby můžete změnit formát čísla.

Dialogové okno Formát buněk zobrazující kartu Číslo a vybranou možnost Text

Tip: Pokud potřebujete vynutit změnu formátování celého sloupce, použijte nejdřív požadovaný formát a pak můžete kliknout na Data > Text do sloupců > Dokončit.

Všechny úvodní a koncové mezery můžete odebrat funkcí PROČISTIT. Následující příklad používá funkci PROČISTIT vnořenou do funkce SVYHLEDAT. Takový vzorec odebere úvodní mezery ze jmen v oblasti A2:A7 a vrátí název oddělení.

Použití funkce SVYHLEDAT s funkcí PROČISTIT v maticovém vzorci k odebrání úvodních a koncových mezer.  Vzorec v buňce E3 je {=SVYHLEDAT(D2,PROČISTIT(A2:B7),2,NEPRAVDA)} a musí být zadaný pomocí kombinace kláves CTRL+SHIFT+ENTER.

=SVYHLEDAT(D2;PROČISTIT(A2:B7);2;NEPRAVDA)

Poznámka: 24. září 2018 – Dynamické maticové vzorce – Pokud máte aktuální verzi Microsoft 365 a odebíráte kanál vydávaných verzí programu Insider Fast, můžete zadat vzorec do horní levé buňky výstupní oblasti a potom stisknutím klávesy Enter vzorec potvrdit jako dynamický maticový vzorec. Jinak musíte vzorec zadat jako starší maticový vzorec tak, že nejprve vyberete výstupní oblast, potom zadáte vzorec do horní levé buňky výstupní oblasti a potvrdíte ho stisknutím Ctrl+Shift+Enter. Excel vloží složené závorky na začátku a konci vzorce. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

Ve výchozím nastavení musí být funkce, které vyhledávají informace v tabulce, seřazené ve vzestupném pořadí. Funkce listu SVYHLEDAT a VVYHLEDAT však obsahují argument typ, který zajišťuje, aby funkce našla přesnou shodu, i když tabulka není seřazená. Když chcete najít přesnou shodu, nastavte argument typ na hodnotu NEPRAVDA. Všimněte si, že když použijete hodnotu PRAVDA, která říká funkci, aby hledala přibližnou shodu, nemusí být výsledkem pouze chyba #N/A. Funkce může taky vrátit nesprávné výsledky, jak je vidět v následujícím příkladu.

Příklad použití funkce SVYHLEDAT s hodnotou PRAVDA argumentu typ, které může mít nesprávné výsledky.

V tomto příkladu nejenže vznikne chyba #N/A u položky „Banány“, ale u položky „Pomeranče“ navíc funkce vrátí špatnou cenu. Ta je způsobená použitím argumentu PRAVDA, který funkci SVYHLEDAT říká, že má hledat přibližnou shodu místo přesné shody. Položka „Banány“ blízkou shodu nemá a položka „Pomela“ abecedně předchází položku „Pomeranče“. V tomto případě by funkce SVYHLEDAT s argumentem NEPRAVDA vrátila správnou cenu pro položku „Pomeranče“, ale u položky „Banány“ by pořád zůstala chyba #N/A, protože nic, co by odpovídalo položce „Banány“, v seznamu vyhledávání neexistuje.

Pokud používáte funkci POZVYHLEDAT, zkuste změnit hodnotu argumentu shoda tak, aby určovala pořadí řazení v tabulce. Pokud chcete najít přesnou shodu, nastavte argument shoda na hodnotu 0 (nula).

Pokud chcete tento problém vyřešit, zajistěte, aby oblast, na kterou odkazuje maticový vzorec, obsahovala stejný počet řádků a sloupců jako oblast buněk, do které je vložený maticový vzorec, nebo zadejte maticový vzorec do menšího nebo většího počtu buněk tak, aby odpovídal odkazu na oblast dat ve vzorci.

V tomto příkladu buňka E2 odkazovala na neodpovídající oblasti:

Příklad maticového vzorce s neodpovídajícími odkazy na oblasti, jejichž výsledkem je chyba #NENÍ_K_DISPOZICI.  Vzorec v buňce E2 je {=SUMA(KDYŽ(A2:A11=D2,B2:B5))} a musí být zadaný pomocí kombinace kláves CTRL+SHIFT+ENTER.

=SUMA(KDYŽ(A2:A11=D2;B2:B5))

Pokud má vzorec provést správný výpočet, musí se změnit tak, aby obě oblasti zohledňovaly řádky 2–11.

=SUMA(KDYŽ(A2:A11=D2;B2:B11))

Poznámka: 24. září 2018 – Dynamické maticové vzorce – Pokud máte aktuální verzi Microsoft 365 a odebíráte kanál vydávaných verzí programu Insider Fast, můžete zadat vzorec do horní levé buňky výstupní oblasti a potom stisknutím klávesy Enter vzorec potvrdit jako dynamický maticový vzorec. Jinak musíte vzorec zadat jako starší maticový vzorec tak, že nejprve vyberete výstupní oblast, potom zadáte vzorec do horní levé buňky výstupní oblasti a potvrdíte ho stisknutím Ctrl+Shift+Enter. Excel vloží složené závorky na začátku a konci vzorce. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

Příklad hodnot #NENÍ_K_DISPOZICI zadaných do buněk bránících správnému výpočtu vzorce SUMA.

V tomto případě květen až prosinec mají hodnoty #N/A, takže celkový součet nejde vypočítat a místo něj vznikne chyba #N/A.

Pokud chcete tento problém vyřešit, zkontrolujte ve vzorci, který vrací chybu, syntaxi u používané funkce, a zadejte všechny požadované argumenty. Ke kontrole této funkce budete možná potřebovat Visual Basic Editor (VBE). Do VBE se dostanete z karty Vývojář nebo stisknutím kombinace kláves Alt+F11.

Pokud to chcete opravit, zkontrolujte, jestli je sešit, který obsahuje uživatelem definovanou funkci, otevřený a jestli funkce správně funguje.

Pokud to chcete opravit, zkontrolujte, jestli jsou argumenty ve funkci správné a na správné pozici.

Tyto chyby můžete opravit stisknutím kombinace kláves Ctr+Alt+F9, aby se list přepočítal.

Použijte Průvodce funkcí, který vám pomůže, když si nejste jistí, jaký argument máte použít. Vyberte buňku s daným vzorcem, přejděte na kartu Vzorce a stiskněte Vložit funkci.

Tlačítko Vložit funkci.

Excel načte Průvodce automaticky za vás:

Příklad dialogového okna průvodce vzorcem.

Při kliknutí na jednotlivé argumenty vám Excel nabídne příslušné informace pro každý z nich.

Hodnota #N/A může být užitečná! Je běžně ji používat, když máte data, jako jsou třeba v následujícím příkladu s grafy, protože hodnota #N/A se na graf nevykreslí. Toto jsou příklady, jak vypadá graf, když ho vykreslíte s nulami oproti tomu, když ho vykreslíte s hodnotou #N/A.

Příklad spojnicového grafu vykreslujícího 0 hodnot.

U předchozího příkladu můžete vidět, že se nulové hodnoty vykreslily. Zobrazují se jako rovná čára ve spodní části grafu a pak vystřelí nahoru, aby zobrazily Součet. V následujícím příkladu jsou nulové hodnoty nahrazeny hodnotami #N/A.

Příklad spojnicového grafu, který nevykresluje hodnoty #NENÍ_K_DISPOZICI.

​​​​

Začátek stránky

Potřebujete další pomoc?

Kdykoli se můžete zeptat odborníka z komunity Excel Tech nebo získat podporu v komunitách.

Viz také

Převod čísel uložených jako text na čísla

Funkce SVYHLEDAT

VVYHLEDAT

VYHLEDAT

POZVYHLEDAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Klávesové zkratky v Excelu

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×