Pokud funkce PRŮMĚR nebo SUMA odkazuje na buňky, které #VALUE! výsledkem vzorců bude #VALUE! .

Chyba #HODNOTA! u funkce PRŮMĚR

Aby se nebraly v úvahu chybové hodnoty, vytvoříme vzorec, který ignoruje chyby v referenční oblasti, a vypočteme průměr se zbývajícími „normálními“ hodnotami.

Tento scénář obejdeme tak, že pomocí kombinace funkcí PRŮMĚR, KDYŽ a JE.CHYBHODN určíme, jestli je v zadané oblasti chyba. Tento konkrétní scénář vyžaduje maticový vzorec:

=PRŮMĚR(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Toto je maticový vzorec. Takže buď musíte stisknout ENTER (jenom pokud používáte Microsoft 365 ) nebo CTRL+SHIFT+ENTER ve vzorci.

Poznámka: Pokud máte aktuální verzi Microsoft 365 ,můžete jednoduše zadat vzorec do výstupní buňky a stisknutím klávesy ENTER vzorec potvrdit jako dynamický maticový vzorec. V opačném případě je nutné vzorec zadat jako starší maticový vzorec tak, že nejdřív vyberete výstupní buňku, zadáte vzorec do výstupní buňky a stisknutím kombinace kláves CTRL+SHIFT+ENTER ji potvrdíte. Excel vloží složené závorky na začátku a konci vzorce za vás. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

Maticová funkce v argumentu PRŮMĚR k vyřešení #VALUE! #BUSY!

Poznámka: Výše uvedená funkce bude kromě funkce #HODNOTA! fungovat také pro funkce #NENÍ_K_DISPOZICI, #NULL, #DĚLENÍ_NULOU! a další.

Stejným způsobem můžete použít také funkci SUMA:

=SUMA(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Oprava chyby #HODNOTA! #BUSY!

PRŮMĚR

SUMA

Přehled vzorců v Excelu

Zjišťování chyb ve vzorcích

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti

Projít školení >

Získejte nové funkce jako první

Připojit se k programu Microsoft Insider >

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×