Toto téma popisuje nejběžnější scénáře chyby #HODNOTA! při práci s funkcí SOUČIN.SKALÁRNÍ.

Problém: Argumenty matice nemají stejnou dimenzi

Všechny maticové argumenty by měly mít stejnou dimenzi. Pokud ne, dostanete #VALUE! . Pokud například matice 1 odkazuje na oblast 3 řádků a 2 sloupce, musí matice 2 odpovídat také podobné oblasti.

Vzorec SOUČIN.SKALÁRNÍ, který způsobuje chybu, je =SUMPRODUCT(D2:D13;E2:E10) – E10 je nutné změnit na E13, aby to vyhovovalo první oblasti.
  • =SOUČIN.SKALÁRNÍ(D2:D13;E2:E10)

Protože odkazované oblasti nemají stejný počet řádků (13 v první oblasti), ale jenom 10 ve druhé), dojde k chybě.

Řešení: Změňte vzorec takto:

  • =SOUČIN.SKALÁRNÍ(D2:D13;E2:E13)

Obě oblasti pak budou mít stejná čísla počátečního a koncového řádku. Vzorec pak zkuste použít znovu v této nové podobě.

Vyřešení chyby SOUČIN.SKALÁRNÍ vyřešením chyby #HODNOTA! v datech

Problém: Minimálně jedna buňka v oblasti obsahuje text

Pokud jedna nebo více buněk v odkazované oblasti obsahuje text nebo je naformátovaná jako datový typ Text, zobrazí se #VALUE! . Text může být výsledkem výpočtu z jiného vzorce nebo je možné, že buňka není jednoduše správně naformátovaná.

Vzorec v buňce E15 zobrazuje #VALUE! errror, protože existuje #VALUE! ve sloupci E.

Řešení: Vyhledejte veškeré buňky, které obsahují text nebo jsou naformátované jako text, a nastavte u nich správný datový typ.

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Oprava chyby #HODNOTA! #BUSY!

SOUČIN.SKALÁRNÍ

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti

Projít školení >

Získejte nové funkce jako první

Připojit se k programu Microsoft Insider >

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×