Log på med Microsoft
Log på, eller opret en konto.
Hej
Markér en anden konto.
Du har flere konti
Vælg den konto, du vil logge på med.
Sådan retter du en #REF! fejl

Fejlen #REF! vises, når en formel refererer til en ugyldig celle. Dette sker oftest, når celler, der er refereres til i formler, bliver slettet eller overskrevet.

Det følgende eksempel anvender formlen =SUM(B2,C2,D2) i kolonne E.

En formel, der bruger eksplicitte cellereferencer som f.eks. =SUM(B2,C2,D2), kan medføre en #REF! hvis en kolonne slettes.

Hvis du slettede kolonne B, C eller D, ville det medføre en #REF! som fejl. I dette tilfælde sletter vi kolonne C (2007 Salg), og formlen læser nu =SUM(B2,#REF!,C2). Når du bruger eksplicitte cellereferencer som denne (hvor du refererer til hver celle enkeltvis adskilt af et komma) og sletter en refereret række eller kolonne, kan Excel ikke løse problemet, så det returnerer #REF! som fejl. Dette er den primære årsag til, at det ikke anbefales at bruge eksplicitte cellereferencer i funktioner.

Eksempel på #REF! fejl, der er opstået ved at slette en kolonne.

Løsning

  • Hvis du ved et uheld har slettet rækker eller kolonner, kan du straks vælge knappen Fortryd på værktøjslinjen Hurtig adgang (eller trykke på Ctrl+Z) for at gendanne dem.

  • Justér formlen, så den bruger et områdereference i stedet for individuelle celler, såsom =SUM(B2:D2). Nu kan du slette enhver kolonne inden for området sum, og så vil Excel justere automatisk formlen. Du kan også bruge =SUM(B2:B5) til en sum af rækker.

I følgende eksempel vil =LOPSLAG(A8,A2:D5,5,FALSK) returnere en #REF! fordi den leder efter en værdi, der skal returneres fra kolonne 5, men referenceområdet er A:D, som kun er 4 kolonner.

Eksempel på en LOPSLAG-formel med et forkert område.  Formlen er =LOPSLAG(A8;A2:D5;5;FALSK).  Der er ingen femte kolonne i LOPSLAG-området, så 5 forårsager en #REF! som fejl.

Løsning

Juster området, så det er større, eller reducer opslagsværdien for kolonnen, så det svarer til referenceområdet. =VOPSLAG(A8,A2:E5,5,FALSK) ville være et gyldigt referenceområde, ligesom = VOPSLAG(A8,A2:D5,4,FALSK) også ville.

I dette eksempel returnerer formlen =INDEKS(B2:E5,5,5) en #REF! fordi INDEKS-området er 4 rækker gange 4 kolonner, men formlen beder om at returnere det, der er i 5. række og 5. kolonne.

Eksempel på en INDEKS-formel med en ugyldig områdereference.  Formlen er = INDEKS(B2:E5,5,5), men området er kun 4 rækker med 4 kolonner.

Løsning

Justér referencerne række eller kolonne, så de er inden for INDEKS-opslagsområde. =INDEKS(B2:E5,4,4) ville returnere et gyldigt resultat.

I følgende eksempel forsøger en INDIREKTE-funktion at referere til en projektmappe, der er lukket, hvilket medfører en #REF! som fejl.

Eksempel på en #REF! forårsaget af INDIREKTE henvisning til en lukket projektmappe.

Løsning

Åbn den projektmappe, der refereres til. Du vil støde på den samme fejl, hvis du refererer til en lukket projektmappe med en dynamisk matrixfunktion.

Strukturerede referencer til tabel- og kolonnenavne i sammenkædede projektmapper understøttes ikke.

Beregnede referencer til sammenkædede projektmapper understøttes ikke.

Flytning eller sletning af celler forårsagede en ugyldig cellereference, eller funktionen returnerer referencefejl.

Hvis du har brugt en OLE-kæde (Object Linking and Embedding), der returnerer en #REF! og derefter starte det program, som linket kalder.

Bemærk! OLE er en teknologi, som du kan bruge til at dele oplysninger mellem programmer.

Hvis du har brugt et Dynamic Data Exchange (DDE)-emne, der returnerer en #REF! skal du først kontrollere, at du refererer til det korrekte emne. Hvis du stadig modtager en #REF! skal du kontrollere indstillingerne for Center for sikkerhed og rettighedsadministration for eksternt indhold som beskrevet i Bloker eller fjern blokering af eksternt indhold i Microsoft 365-dokumenter.

Bemærk! DDE (Dynamic Data Exchange)er en etableret protokol til at udveksle data mellem Microsoft Windows-baserede programmer.

Makroproblemer

Hvis en makro indsætter en funktion i regnearket, der refererer til en celle over funktionen, og den celle, der indeholder funktionen, er i række 1, returnerer funktionen #REF! fordi der ikke er nogen celler over række 1. Kontrollér funktionen for at se, om et argument refererer til en celle eller et celleområde, der ikke er gyldigt. Dette kan kræve, at du redigerer makroen i Visual Basic Editor (VBE) for at tage højde for denne situation.

Har du brug for mere hjælp?

Se også

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Har du brug for mere hjælp?

Vil du have flere indstillinger?

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af sproget?
Hvad påvirkede din oplevelse?
Når du trykker på Send, bliver din feedback brugt til at forbedre Microsoft-produkter og -tjenester. Din it-administrator kan indsamle disse data. Erklæring om beskyttelse af personlige oplysninger.

Tak for din feedback!

×