Sådan retter du et #DIV/0! fejl

Microsoft Excel viser fejlen #DIV/0!, når et tal divideres med nul (0). Dette sker, når du angiver en enkel formel som f.eks. =5/0, eller når en formel refererer til en celle med værdien 0, eller som er tom, sådan som det er vist på dette billede.

Eksempler på formler forårsager #DIV/0! -fejl.

Gør et af følgende for at rette fejlen:

  • Kontrollér, at divisoren i funktionen eller formlen ikke er nul eller en tom celle.

  • Skift cellereferencen i formlen til en anden celle, som ikke har et nul (0) eller en tom værdi.

  • Skriv #I/T i den celle, der refereres som divisoren i formlen, hvilken ændrer formelresultatet til #I/T for at angive, at divisorværdien ikke er tilgængelig.

Ofte kan fejlen #DIV/0! ikke undgås, da dine formler venter på input fra dig eller en anden. I så fald ønsker du slet ikke fejlmeddelelsen vist, så der er et par metoder til håndtering af fejl, du kan bruge til at undertrykke fejlen, mens du venter på input.

Vurder nævneren til 0 eller ingen værdi

Den nemmeste måde at undertrykke #DIV/0! er at bruge funktionen HVIS til at evaluere eksistensen af nævneren. Hvis det er en værdi på 0 eller ingen, vises værdien 0 eller ingen som formelresultatet i stedet for #DIV/0! ellers beregnes formlen.

Hvis den formel, der returnerer fejlen, f.eks. er =A2/A3,skal du bruge =HVIS(A3,A2/A3,0) for at returnere 0 eller =HVIS(A3,A2/A3,"") for at returnere en tom streng. Du kan også få vist en brugerdefineret meddelelse som denne: =HVIS(A3,A2/A3,"Input nødvendig"). Med funktionen KVOTIENT fra det første eksempel skal du bruge =HVIS(A3,KVOTIENT(A2;A3);0). Dette fortæller Excel HVIS(A3 findes, returneres resultatet af formlen, ellers ignoreres den).

Eksempler på løsning af #DIV/0! -fejl.

Brug HVIS.FEJL til at undertrykke #DIV/0! fejl

Du kan også undertrykke denne fejl ved at indlejre din divisionshandling i funktionen HVIS.FEJL. Igen ved hjælp af A2/A3 kan du bruge =HVIS.FEJL(A2/A3,0). Dette fortæller Excel, om formlen vurderes som en fejl, returnerer derpå 0, eller returnerer resultatet af formlen.

Til versioner af Excel før Excel 2007 kan du bruge metoden HVIS(ER.FEJL()): =HVIS(ER.FEJL(A2/A3),0,A2/A3) (se ER-funktioner).

Bemærk: både HVIS.FEJL- og HVIS(ER.FEJL())-metoderne er tomme fejlbehandlere, idet de vil undertrykke alle fejl, ikke kun #DIV/0!. Du skal sørge for, at din formel fungerer korrekt, før du anvender en fejlhåndtering, ellers vil du måske ikke opdage, at din formel ikke fungerer som forventet.

Tip!: Hvis fejlkontrol er aktiveret i Excel, kan du klikke på Knapflade ud for den celle, der viser fejlen. Klik på Vis beregningstrin, hvis den er tilgængelig, og vælg den løsning, der fungerer for dine data.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Funktionen HVIS

Funktionen HVIS.FEJL

ER-funktioner

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Har du brug for mere hjælp?

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×