Vigtigt!: I Excel 2016, Excel Mobileog Excel til internetteter SAMMENKÆDE blevet erstattet af funktionen SAMMENKÆDNING. Selvom funktionen SAMMENKÆDE stadig er tilgængelig af hensyn til bagudkompatibilitet, bør du overveje at bruge SAMMENKÆDNING, da det er en mere robust funktion.

Et af de mest almindelige scenarier, hvor du støder på #VALUE! med SAMMENKÆDE er, når du forsøger at opbygge en streng, der indeholder en cellereference, der indeholder en fejl, f.eks. #VALUE!.

I følgende eksempel vil vi gerne sammenkæde D2, E2 og F2, hvor E2 har en #VALUE! som fejl.

#VÆRDI! i SAMMENKÆDE

Fejlen i E2 får funktionen til at vise #VALUE! som fejl. Hvis fejlen skal fungere korrekt, skal du erstatte fejlen med en anden værdi end fejlen. Du kan oprette en formel, der kontrollerer, om der er fejl i cellereferencen, og hvis det sker, skal du vise tekststrengen, hvor der vises et 0 i stedet for fejlen (eller du kan erstatte 0 med din egen tekst, men du skal ombryde teksten i anførselstegn – "Din tekst").

En formel som denne ville fungere:

=HVIS(ER.FEJL(E2);SAMMENKÆDNING(D2;" ";0;" ";F2))

Funktionerne HVIS og ER.FEJL bruges som en løsning til at sammenkæde en streng med #VALUE! fejl

Hvordan fungerer det? Funktionen HVIS bruger funktionen HVIS.FEJL til at afgøre, om der er en fejl i E2, og hvis det er tilfældet, kombinerer funktionen SAMMENKÆDE værdierne i D2, E2 og F2 (funktionen erstatter fejlen med et 0) og viser den resulterende tekststreng. Bemærk, at formlen også bruger mellemrum (" ") til at adskille værdierne.

Ret fejlen #VÆRDI! med SAMMENKÆDE i Excel 2003 og ældre versioner

Hvis du får fejlen #VÆRDI! i Office Excel 2003 eller ældre versioner, skal du fjerne markeringen af indstillingen Overgangsformelevaluering i Excel. Følg de trin, der er beskrevet i #VALUE!-fejl, når der oprettes forbindelse mellem celler for at løse problemet.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community eller få support i Answers-forummet

Se også

Rette fejlen #VÆRDI! fejl

Funktionen SAMMENKÆDNING

Funktionen SAMMENKÆDNING

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Har du brug for mere hjælp?

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Deltag i Microsoft Office Insiders

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af sproget?
Hvad påvirkede din oplevelse?

Tak for din feedback!

×