XVERWEIS (Funktion)

Verwenden Sie die XVERWEIS-Funktion, wenn Sie Elemente in einer Tabelle oder einem Bereich nach Zeile suchen müssen. Suchen Sie z. B. nach dem Preis eines Kfz-Teils anhand der Artikelnummer oder einen Mitarbeiternamen anhand der Mitarbeiter-ID. Mit XVERWEIS können Sie in einer Spalte nach einem bestimmten Suchbegriff suchen und ein Ergebnis aus derselben Zeile in einer anderen Spalte abrufen, und zwar unabhängig davon, auf welcher Seite sich die Ergebnisspalte befindet.

Machen Sie einen guten Eindruck mit Ankündigungen

Hinweis: Diese Funktion steht derzeit für Microsoft 365-Abonnenten im aktuellen Kanal zur Verfügung. Sie steht ab Juli 2020 für Microsoft 365 Abonnenten im halbjährlichen Unternehmens Kanal zur Verfügung. Weitere Informationen dazu, wie Features für Microsoft 365 Abonnenten bereit stehen, finden Sie unter Wann erhalte ich die neuesten Features für Microsoft 365.

Die XVERWEIS-Funktion sucht nach einem Bereich oder Array und gibt ein Element zurück, das zur ersten gefundenen Übereinstimmung passt. Wenn es keine Übereinstimmung gibt, kann XVERWEIS die beste (ungefähre) Übereinstimmung zurückgeben. 

=XVERWEIS(Suchkriterium; Suchmatrix; Rückgabematrix; [wenn_nicht_gefunden]; [Vergleichsmodus]; [Suchmodus]) 

Argument

Beschreibung

Suchkriterium

Erforderlich

Das Suchkriterium

Suchmatrix

Erforderlich

Das Array oder der Bereich, das/der durchsucht werden soll

Rückgabematrix

Erforderlich

Das Array oder der Bereich, das/der zurückgegeben werden soll

[wenn_nicht_gefunden]

Optional

Wenn keine gültige Übereinstimmung gefunden wird, wird der von Ihnen bereitgestellte "[wenn_nicht_gefunden]"-Text zurückgegeben.

Wenn keine gültige Übereinstimmung gefunden wird und "[wenn_nicht_gefunden]" nicht angegeben ist, wird "#N/V" zurückgegeben.

[match_mode]

Optional

Geben Sie den Übereinstimmungstyp an:

0: genaue Übereinstimmung. Wenn keine gefunden wird, wird "#N/V" zurückgegeben. Dies ist die Standardeinstellung.

-1: genaue Übereinstimmung. Wenn keine gefunden wurde, geben Sie das nächstkleinere Element zurück.

1: genaue Übereinstimmung. Wenn keine gefunden wurde, geben Sie das nächstgrößere Element zurück.

2: eine Platzhalterübereinstimmung, wobei *, ? und ~ eine Sonderbedeutung haben.

[search_mode]

Optional

Geben Sie den zu verwendenden Suchmodus an:

1: Führen Sie eine Suche durch, die beim ersten Element beginnt. Dies ist die Standardeinstellung.

-1: Führen Sie eine umgekehrte Suche durch, die beim letzten Element beginnt.

2: Führen Sie eine Binärsuche durch, die darauf basiert, dass eine Suchmatrix in aufsteigender Reihenfolge sortiert ist. Ist diese nicht so sortiert, werden ungültige Ergebnisse zurückgegeben.

-2: Führen Sie eine Binärsuche durch, die darauf basiert, dass eine Suchmatrix in absteigender Reihenfolge sortiert ist. Ist diese nicht so sortiert, werden ungültige Ergebnisse zurückgegeben.

Beispiele

Beispiel 1

Dieses Beispiel beruht auf dem obigen Video und verwendet einen einfachen XVERWEIS, um einen Landesnamen zu finden, und gibt dann die Landesvorwahl zurück. Er umfasst nur die Argumente „Suchkriterium“ (Zelle F2), „Suchmatrix“ (Bereich B2:B11) und „Rückgabematrix“ (Bereich D2:D11). Er enthält nicht das „Vergleichsmodus“-Argument, da XVERWEIS standardmäßig eine exakte Übereinstimmung aufweist.

Beispiel für die Verwendung der XVERWEIS-Funktion, um den Namen und die Abteilung eines Mitarbeiters anhand der Mitarbeiter-ID zurückzugeben. Die Formel lautet: =XVERWEIS(B2;B5:B14;C5:C14).

Hinweis: XVERWEIS unterscheidet sich von SVERWEIS insofern, als dass er separate Such- und Rückgabematrizen verwendet, wohingegen SVERWEIS ein einzelnes Tabellenarray, gefolgt von einer Spaltenindexnummer, verwendet. Die äquivalente SVERWEIS-Formel wäre in diesem Fall: =SVERWEIS(F2;B2:D11;3;FALSCH)

Beispiel 2

In diesem Beispiel suchen wir Mitarbeiterdaten anhand einer Mitarbeiter-ID. Im Gegensatz zu SVERWEIS kann XVERWEIS ein Array mit mehreren Elementen zurückgeben, wodurch eine einzelne Formel sowohl den Mitarbeiternamen als auch die Abteilung aus den Zellen C5:D14 zurückgeben kann.

Beispiel für die Verwendung der XVERWEIS-Funktion, um den Namen und die Abteilung eines Mitarbeiters anhand der Mitarbeiter-ID zurückzugeben. Die Formel lautet: =XVERWEIS(B2;B5:B14;C5:D14;0;1)

Beispiel 3

In diesem Beispiel wird das "wenn_nicht_gefunden"-Argument dem obigen Beispiel hinzugefügt.

Beispiel für die Verwendung der XVERWEIS-Funktion, um den Namen und die Abteilung eines Mitarbeiters anhand der Mitarbeiter-ID mit dem Argument wenn_nicht_gefunden zurückzugeben. Die Formel lautet: =XVERWEIS(B2;B5:B14;C5:D14;0;1;"Mitarbeiter nicht gefunden")

Beispiel 4

Das folgende Beispiel sucht in Spalte C nach dem persönlichen Einkommen, das in Zelle E2 eingegeben wurde, und findet einen passenden Steuersatz in Spalte B. Damit wird das "Wenn_nicht_gefunden"-Argument so festgelegt, dass 0 zurückgegeben wird, wenn nichts gefunden wird. Das "Vergleichsmodus"-Argument ist auf 1 festgelegt, was bedeutet, dass die Funktion nach einer genauen Übereinstimmung sucht, und wenn sie keine findet, das nächste größere Element zurückgibt. Schließlich wird das "Suchmodus"-Argument auf 1 festgelegt, was bedeutet, dass die Funktion vom ersten bis zum letzten Element sucht.

Abbildung der XVERWEIS-Funktion, die verwendet wird, um nach einem Steuersatz auf der Grundlage des höchsten Einkommens zu suchen. Dies ist eine ungefähre Übereinstimmung. Die Formel lautet: =XVERWEIS(E2;C2:C7;B2:B7;1;1)

Hinweis: Im Gegensatz zu SVERWEIS befindet sich die Spalte „Suchmatrix“ rechts neben der Spalte „Rückgabematrix“, wobei SVERWEIS nur von links nach rechts suchen kann.

Beispiel 5

Im nächsten Schritt wenden wir eine geschachtelte XVERWEIS-Funktion an, um sowohl einen vertikalen als auch horizontalen Vergleich durchzuführen. In diesem Fall sucht sie zuerst nach Bruttogewinn in Spalte B und anschließend in der obersten Zeile der Tabelle nach Qrtl1 (Bereich C5:F5). Der Wert wird an der Schnittstelle der beiden Werte zurückgegeben. Dies ähnelt der gleichzeitigen Verwendung der Funktionen INDEX und VERGLEICH. Sie können XVERWEIS auch verwenden, um die Funktion WVERWEIS zu ersetzen.

Abbildung der XVERWEIS-Funktion, die verwendet wird, um horizontale Daten aus einer Tabelle durch Verschachteln von 2 XVERWEISEN abzurufen. Die Formel lautet: =XVERWEIS(D2;$B6:$B17;XVERWEIS($C3;$C5:$G5;$C6:$G17))

Die Formel in den Zellen D3:F3 lautet: =XVERWEIS(D2;$B6:$B17;XVERWEIS($C3;$C5:$G5;$C6:$G17)).

Beispiel 6

In diesem Beispiel werden die SUMME-Funktion und zwei ineinander verschachtelte XVERWEIS-Funktionen verwendet, um alle Werte zwischen zwei Bereichen zu summieren. In diesem Fall möchten wir die Werte für „Trauben“, „Bananen“ einschließlich „Birnen“ addieren, die zwischen den beiden liegen.

Verwendung von XVERWEIS mit SUMME, um einen Wertebereich zu summieren, der zwischen zwei Auswahlmöglichkeiten liegt

Die Formel in der Zelle E3 lautet: =SUMME(XVERWEIS(B3;B6:B10;E6:E10):XVERWEIS(C3;B6:B10;E6:E10))

Wie funktioniert das? XVERWEIS gibt einen Bereich zurück, sodass die Formel bei der Berechnung wie folgt aussieht: =SUMME($E$7:$E$9). Sie können selbst sehen, wie dies funktioniert, indem Sie eine Zelle mit einer XVERWEIS-Formel auswählen, die dieser ähnlich ist. Wechseln Sie dann zu Formeln > Formelüberwachung > Formelauswertung und drücken Sie auf die Schaltfläche Auswerten, um die Berechnung durchzuführen.

Hinweis: Dank Microsoft Excel MVP, Bill Jelen, für dieses Beispiel.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

XVERGLEICH (Funktion)

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×