Inhaltsverzeichnis
×
Formeln und Funktionen
Formeln und Funktionen

XVERWEIS

Verwenden Sie die XVERWEIS Funktion, wenn Sie Elemente in einer Tabelle oder einem Bereich nach Zeile suchen. Sie können z. B. nach dem Preis eines Kfz-Teils anhand der Artikelnummer suchen oder nach einem Mitarbeiternamen anhand seiner Mitarbeiter-ID. Mit XLOOKUP können Sie in einer Spalte nach einem Suchbegriff suchen und ein Ergebnis aus derselben Zeile in einer anderen Spalte zurückgeben, unabhängig davon, auf welcher Seite sich die Rückgabespalte befindet.

Hinweis: XLOOKUP ist in Excel 2016 und Excel 2019 nicht verfügbar. Möglicherweise kommt es jedoch vor, dass Sie eine Arbeitsmappe in Excel 2016 oder Excel 2019 mit der XVERWEIS-Funktion verwenden, die von einer anderen Person mit einer neueren Version von Excel erstellt wurde.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Syntax

Die XVERWEIS-Funktion durchsucht einen Bereich oder eine Anordnung und gibt dann das Element zurück, das der ersten gefundenen Übereinstimmung entspricht. Wenn keine Übereinstimmung vorhanden ist,   kann XVERWEIS zur nächsten (ungefähren) Übereinstimmung zurückkehren. 

=XVERWEIS(Suchkriterium; Suchmatrix; Rückgabematrix; [wenn_nicht_gefunden]; [Vergleichsmodus]; [Suchmodus]) 

Argument

Beschreibung

Suchkriterium

Erforderlich*

Der Wert für die Suche nach

*Wenn er ausgelassen wird, gibt XVERWEIS leere Zellen zurück, die in Suchmatrix gefunden werden.   

Suchmatrix

Erforderlich

Das Array oder der Bereich, das/der durchsucht werden soll

Rückgabematrix

Erforderlich

Das Array oder der Bereich, das/der zurückgegeben werden soll

[wenn_nicht_gefunden]

Optional

Wenn keine gültige Übereinstimmung gefunden wird, wird der von Ihnen bereitgestellte "[wenn_nicht_gefunden]"-Text zurückgegeben.

Wenn keine gültige Übereinstimmung gefunden wird und [wenn_nicht_gefunden] fehlt, wird #N/A zurückgegeben.

[Vergleichsmodus]

Optional

Geben Sie den Übereinstimmungstyp an:

0: genaue Übereinstimmung. Wenn keine gefunden wird, wird "#N/V" zurückgegeben. Dies ist die Standardeinstellung.

-1: genaue Übereinstimmung. Wenn keine gefunden wurde, geben Sie das nächstkleinere Element zurück.

1: genaue Übereinstimmung. Wenn keine gefunden wurde, geben Sie das nächstgrößere Element zurück.

2: eine Platzhalterübereinstimmung, wobei *, ? und ~ eine Sonderbedeutung haben.

[Suchmodus]

Optional

Geben Sie den zu verwendenden Suchmodus an:

1: Führen Sie eine Suche durch, die beim ersten Element beginnt. Dies ist die Standardeinstellung.

-1: Führen Sie eine umgekehrte Suche durch, die beim letzten Element beginnt.

2: Führen Sie eine Binärsuche durch, die darauf basiert, dass eine Suchmatrix in aufsteigender Reihenfolge sortiert ist. Ist diese nicht so sortiert, werden ungültige Ergebnisse zurückgegeben.

-2: Führen Sie eine Binärsuche durch, die darauf basiert, dass eine Suchmatrix in absteigender Reihenfolge sortiert ist. Ist diese nicht so sortiert, werden ungültige Ergebnisse zurückgegeben.

Beispiele

Beispiel 1    verwendet XVERWEIS, um einen Ländernamen in einem Bereich zu suchen und dann die Landesvorwahl des Telefons zurückzugeben. Sie enthält die Argumente Suchkriterium (Zelle F2), Suchmatrix (Bereich B2:B11) und Rückgabematrix (Bereich D2:D11). Es enthält nicht das Vergleichsmodus Argument, da XVERWEIS standardmäßig eine genaue Übereinstimmung erzeugt.

Beispiel für die Verwendung der XVERWEIS-Funktion, um den Namen und die Abteilung eines Mitarbeiters anhand der Mitarbeiter-ID zurückzugeben. Die Formel lautet: =XVERWEIS(B2;B5:B14;C5:C14).

Hinweis: XVERWEIS verwendet eine Suchanordnung und eine Rückgabeanordnung, während SVERWEIS eine einzelne Tabellenanordnung gefolgt von einer Spaltenindexnummer verwendet. Die entsprechende SVERWEIS-Formel wäre in diesem Fall: =SVERWEIS(F2,B2:D11,3,FALSE)

———————————————————————————

Beispiel 2    sucht anhand einer Mitarbeiter-ID-Nummer nach Mitarbeiterinformationen. Im Gegensatz zu SVERWEIS, kann XVERWEIS eine Anordnung mit mehreren Elementen zurückgeben, wodurch eine einzelne Formel sowohl den Mitarbeiternamen als auch die Abteilung aus den Zellen C5:D14 zurückgeben kann.

Beispiel für die Verwendung der XVERWEIS-Funktion, um den Namen und die Abteilung eines Mitarbeiters anhand der Mitarbeiter-ID zurückzugeben. Die Formel lautet: =XVERWEIS(B2;B5:B14;C5:D14;0;1)

———————————————————————————

Beispiel 3    fügt ein wenn_nicht_gefunden Argument hinzu.

Beispiel für die Verwendung der XVERWEIS-Funktion, um den Namen und die Abteilung eines Mitarbeiters anhand der Mitarbeiter-ID mit dem Argument wenn_nicht_gefunden zurückzugeben. Die Formel lautet: =XVERWEIS(B2;B5:B14;C5:D14;0;1;"Mitarbeiter nicht gefunden")

———————————————————————————

Beispiel 4    sucht in Spalte C nach dem in Zelle E2 eingegebenen persönlichen Einkommen und sucht in Spalte B nach einem übereinstimmenden Steuersatz. Er legt das wenn_nicht_gefunden Argument fest, um 0 (null) zurückzugeben, wenn nichts gefunden wird. Das Vergleichsmodus Argument ist auf 1festgelegt, was bedeutet, dass die Funktion nach einer genauen Übereinstimmung sucht und wenn sie keine finden kann, das nächste größere Element zurückgibt. Schließlich wird das Suchmodus Argument auf 1festgelegt, was bedeutet, dass die Funktion vom ersten bis zum letzten Element sucht.

Abbildung der XVERWEIS-Funktion, die verwendet wird, um nach einem Steuersatz auf der Grundlage des höchsten Einkommens zu suchen. Dies ist eine ungefähre Übereinstimmung. Die Formel lautet: =XVERWEIS(E2;C2:C7;B2:B7;1;1)

Hinweis: Die Suchmatrix Spalte von XARRAY befindet sich rechts neben der RückgabematrixSpalte, wohingegen SVERWEIS nur von links nach rechts sehen kann.

———————————————————————————

Beispiel 5    Verwendet eine geschachtelte XVERWEIS-Funktion, um sowohl eine vertikale als auch eine horizontale Übereinstimmung durchzuführen. Zuerst wird nach Bruttogewinn in Spalte B und dann nach Qtr1 in der obersten Zeile der Tabelle (Bereich C5:F5) gesucht und schließlich wird der Wert an der Schnittmenge der beiden zurückgegeben. Dies ähnelt der gleichzeitigen Verwendung der Funktionen INDEX und MATCH.

Tipp: Sie können XVERWEIS auch verwenden, um die Funktion WVERWEIS zu ersetzen.

Abbildung der XVERWEIS-Funktion, die verwendet wird, um horizontale Daten aus einer Tabelle durch Verschachteln von 2 XVERWEISEN abzurufen. Die Formel lautet: =XVERWEIS(D2;$B6:$B17;XVERWEIS($C3;$C5:$G5;$C6:$G17))

Hinweis: Die Formel in den Zellen D3:F3 lautet: =XVERWEIS(D2,$B6:$B17,XVERWEIS($C3,$C5:$G5,$C6:$G17)).

———————————————————————————

Beispiel 6    verwendet die SUMME-Funktion und zwei geschachtelte XVERWEIS-Funktionen, um alle Werte zwischen zwei Bereichen zu addieren. In diesem Fall möchten wir die Werte für „Trauben“, „Bananen“ einschließlich „Birnen“ addieren, die zwischen den beiden liegen.

Verwendung von XVERWEIS mit SUMME, um einen Wertebereich zu summieren, der zwischen zwei Auswahlmöglichkeiten liegt

Die Formel in Zelle E3 lautet:  =SUMME(XVERWEIS(B3;B6:B10;E6:E10):XVERWEIS(C3;B6:B10;E6:E10))

Wie funktioniert das? XVERWEIS gibt einen Bereich zurück, sodass die Formel bei der Berechnung wie folgt aussieht: =SUMME($E$7:$E$9). Sie können selbst sehen, wie dies funktioniert, indem Sie eine Zelle mit einer ähnlichen XVERWEIS-Formel auswählen, dann Formeln > Formelüberwachung > Formel auswerten auswählen und dann Auswerten auswählen, um die Berechnung schrittweise durchzuführen.

Hinweis: Vielen Dank an Microsoft Excel MVP Bill Jelen für das Vorschlagen dieses Beispiels.

———————————————————————————

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

XVERGLEICH (Funktion)

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×