Symptome
Angenommen, Sie erstellen einen gruppierten Columnstore-Index über eine MARS-Verbindung (Multiple Active Result Sets) in Microsoft SQL Server 2014. Wenn Sie den Wert von maxdop größer als 1 festlegen, tritt beim Erstellen oder Neuerstellen des gruppierten Columnstore-Indexes ein Fehler auf. Darüber hinaus erhalten Sie den Fehler 35377 wie folgt:
Hinweis
ErrorNumber: 35377
ErrorSeverity: EX_USER
ErrorOwner: <OwnerName>
rrorFormat: Wenn MARS aktiviert ist, ist der Zugriff auf gruppierte Columnstore-Indizes nicht zulässig.
ErrorCause: Ungültiger Zugriff auf gruppierte Columnstore-Indizes für eine MARS-Verbindung.
ErrorCorrectiveAction: Die Verbindung sollte nicht MARS-fähig sein.
ErrorFirstProduct: SQL14
Hinweis Dieses Problem tritt nicht auf, wenn Sie maxdop auf 1 festlegen.
Lösung
Die beiden Probleme wurden zuerst im folgenden kumulativen Update von SQL Server behoben.
Kumulatives Update 1 für SQL Server 2014 /en-us/help/2931693
Informationen zu kumulativen Updates für SQL Server
Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und alle Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.