KB3029977 – FIX: Betriebssystemfehler 665 beim Ausführen des Befehls DBCC CHECKDB für Datenbank, die den Columnstore-Index in SQL Server 2014 enthält

Gilt für
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptome

Angenommen, Sie verfügen über eine Datenbank mit großen Columnstore-Indizes in Microsoft SQL Server 2014. Wenn Sie den Befehl DBCC CHECKDB für die Datenbank ausführen, erhalten Sie die folgende Fehlermeldung im SQL Server Fehlerprotokoll:

Hinweis

Das Betriebssystem hat den Fehler 665 (Der angeforderte Vorgang konnte aufgrund einer Dateisystemeinschränkung nicht abgeschlossen werden) zurückgegeben, der während eines Schreibvorgangs im Offset-0x00004a21310000 in der Datei "<Datenträgername>:\Programm Files\Microsoft SQL Server\MSSQL12" SQL Server wurde. MSSQLSERVER\MSSQL\Data\XXXX.mdf'. Zusätzliche Meldungen im SQL Server Fehlerprotokoll und Systemereignisprotokoll enthalten möglicherweise weitere Details. Dies ist ein schwerwiegender Fehler auf Systemebene, der die Datenbankintegrität bedroht und sofort behoben werden muss. Führen Sie eine vollständige Datenbankkonsistenzprüfung (DBCC CHECKDB) aus. Dieser Fehler kann durch viele Faktoren verursacht werden. Weitere Informationen finden Sie in der SQL Server-Onlinedokumentation.

Wenn Sie den Befehl DBCC CHECKTABLE für die Tabelle ausführen, die den Columnstore-Index enthält, wird die folgende Fehlermeldung angezeigt:

Hinweis

Meldung 0, Ebene 11, Status 0, Zeile 0
Für den aktuellen Befehl ist ein schwerwiegender Fehler aufgetreten. Die Ergebnisse sollten, falls vorhanden, verworfen werden.

Gleichzeitig wird die folgende Fehlermeldung im Fehlerprotokoll angezeigt:

Hinweis

DBCC CHECKTABLE (<Table_Name>) executed by DomainName\UserName abnormal wegen Fehlerstatus 6 beendet. Verstrichene Zeit: 0 Stunden 3 Minuten 36 Sekunden

Ursache

Dieses Problem tritt aufgrund eines Fehlers im Prefetch-Mechanismus der SQL Server Columnstore-Indexfunktion auf. Dieser Fehler führt dazu, dass Datenseiten die Momentaufnahme-Datenbank unnötig auffüllen, was zu einem vorzeitigen Betriebssystem 665-Fehler führen würde.

HinweisDBCC Der Befehl CHECKDB erstellt intern automatisch eine Datenbank-Momentaufnahme. Das gleiche Problem kann auftreten, wenn Sie manuell eine Datenbank-Momentaufnahme erstellen und mehrere Abfragen ausführen, die den Columnstore-Index verwenden.

Lösung

Informationen zum Service Pack

Installieren Sie Service Pack 1 für SQL Server 2014, um dieses Problem zu beheben.

Weitere Informationen zu SQL Server 2014 Service Pack 1 (SP1) finden Sie unter In SQL Server 2014 Service Pack 1 behobene Fehler.

Informationen zum kumulativen Update

Das Problem wurde erstmals im folgenden kumulativen Update von SQL Server behoben.

Empfehlung: Installieren des neuesten kumulativen Updates für SQL Server

Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Es wird empfohlen, die neuesten kumulativen Updates für SQL Server herunterzuladen und zu installieren:

      

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.