Symptome
Wenn eine Speicherabbilddatei entweder vom Benutzer oder von SQL Server unter bestimmten Bedingungen in SQL Server 2014 RTM-Version generiert wird, meldet das SQL Server-Fehlerprotokoll fälschlicherweise eine Informationsmeldung, die der folgenden ähnelt:
Hinweis
<Datum><Uhrzeit> spid# Der Server wurde konfiguriert, um bei dem folgenden Ereignis ein Speicherabbild zu erzeugen: ex_dump_if_requested: Ausnahme ausgelöst, major = 2, minor = 8, zustand = 1, schweregrad = 25, versucht, einen Symptomspeicherabbild zu erstellen
<Datum><Uhrzeit> spid# **Dumpthread - spid = 0, EC = 0x000000084F2BAAD0
<Datum><Uhrzeit> SPID# ***Stack-Speicherabbild wird gesendet an <Dateipfad Dateiname>\<>.txt
<Datum><Uhrzeit> spid# * *******************************************************************************
<Datum><Uhrzeit> SPID# *
<Datum><Uhrzeit> spid# * BEGIN STACK DUMP:
<Datum><Uhrzeit> spid# * <Datum><Uhrzeit> SPID#
<
Datum><Time> spid# * Privater Serverbuild.
Hinweis: Sie können das Problem reproduzieren, indem Sie die folgenden Befehle verwenden:
dbcc dumptrigger('set',208)
select * from foo
dbcc dumptrigger('clear',208)
Ursache
Das Problem tritt aufgrund eines Fehlers in SQL Server 2014 auf.
Lösung
Das Problem wurde erstmals im folgenden kumulativen Update von SQL Server behoben.
Kumulatives Update 1 für SQL Server 2014 /de-de/help/2931693
Informationen zu kumulativen Updates für SQL Server
Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und Sicherheitsfixes, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.