NEM függvény

Ha meg akar róla győződni, hogy egy érték nem azonos egy másik értékkel, használja a NEM függvényt, amely a logikai függvények közé tartozik.

Példa

Példák a nem függvényre az argumentumok megfordításához.  EMELKEDÉS PL = NOT (1 + 1 = 2)

A NEM függvény megfordítja a beleírt argumentum értékét.

A NEM függvény egyik leggyakoribb szerepe más, logikai vizsgálatokat végrehajtó függvények hasznosságának kiterjesztése. A HA függvény például egy logikai vizsgálatot végez, és IGAZ eredmény esetén egy adott értéket, HAMIS eredmény esetén pedig egy másik értéket ad vissza. Ha a NEM függvényt használja fel a HA függvény logikai_vizsgálat argumentumaként, akkor nem csak egy, hanem egyszerre több különböző feltételt vizsgálhat.

Szintaxis

NEM(logikai)

A NEM függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • Logikai:    Megadása kötelező. Olyan érték vagy kifejezés, amelynek kiértékelése az IGAZ vagy a HAMIS értéket adja.

Megjegyzések

Ha az argumentum értéke HAMIS, a NEM függvény visszatérési értéke IGAZ lesz, ha az argumentum értéke IGAZ, a NEM függvény visszatérési értéke HAMIS lesz.

Példák

Az alábbiakban általános jellegű példákat adunk a NEM függvény önálló, illetve HA, ÉS és VAGY. függvénnyel történő együttes használatára.

Példák a NEM függvényre a HA, az ÉS és a VAGY függvényekkel

Képlet

Leírás

=NEM(A2>100)

Az A2 cella értéke NEM nagyobb 100-nál.

=HA(ÉS(NEM(A2>1);NEM(A2<100));A2;"Az érték a tartományon kívül esik")

50 nagyobb, mint 1 (IGAZ) ÉS 50 kisebb, mint 100 (IGAZ), ezért a NEM mindkét argumentumot HAMIS értékűre változtatja. Az ÉS függvény esetében mindkét argumentumnak IGAZ értékűnek kell lennie, ezért a HAMIS eredményt adja vissza.

=HA(VAGY(NEM(A3<0);NEM(A3>50));A3;"Az érték a tartományon kívül van.")

100 kisebb, mint a 0 (HAMIS) és 100 nagyobb, mint 50 (IGAZ), így a NEM megfordítja a az argumentumok értékét IGAZ/HAMIS értékre. A VAGY függvény esetében csak az egyik argumentumnak kell IGAZ értékűnek kell lennie, ezért az IGAZ eredményt adja vissza.

Értékesítési jutalék kiszámítása

A következő példa azt szemlélteti, hogy miként számítható ki az értékesítők bónusza a NEM függvény HA és ÉSfüggvénnyel való használatával.

Példa: értékesítési bónusz számítása a ha, a és a nem értékkel.  A E14 cellában szereplő képlet az = ha (és (nem (B14 tetőterasszal<$B $7), nem (C14<$B $5)), B14 tetőterasszal * $B $8, 0)
  • =HA(ÉS(NEM(B14<$B$7);NEM(C14<$B$5));B14*$B$8;0)- HA az összforgalom NEM kisebb, mint az értékesítési célérték, ÉS az ügyfélszerzések száma NEM kisebb, mint az ügyfélszerzési célérték, akkor szorozza meg az összforgalmat a jutalék százalékos értékével, egyéb esetben a visszatérési érték legyen 0.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Kapcsolódó témakörök

Videó: az Advanced if függvényekkel
megtudhatja, hogy miként használhat beágyazott függvényeket a képletekben
, ha függvény
és függvény
vagy függvény
– képletek áttekintése az Excelben
,Hogyan lehet elkerülni a hibás képleteket
az Excellogikai függvények (segédlet)
Excel-függvények (segédlet) aképletekben
használhatóbillentyűparancsokkal
(betűrendes) Excel-
függvények (kategória szerint)

Megjegyzés:  Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Hasznos volt ez az információ az Ön számára? Itt találja az eredeti angol nyelvű cikket.

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×