はじめに
この記事では、Microsoft SQL Server 2008 Service Pack 3 (SP3) によって修正される SQL Server 2008 の問題を示します。
メモ
- ドキュメント化されていない問題の一部は、Service Pack によって修正される場合があります。
- 問題の一覧は、問題の記事が公開されるときに更新されます。
SQL Server 2008 Service Pack の入手方法の詳細については、以下のサポート技術情報番号をクリックしてください。
968382
SQL Server 2008 の最新の Service Pack を入手する方法
注: マイクロソフトでは、Microsoft SQL Server 2008 の修正を 1 つのダウンロード可能なファイルとして配布しています。 修正は累積的であるため、新しいリリースの修正には、以前のリリースの SQL Server 2008 の修正に含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれます。 通常は最新の Service Pack をダウンロードする必要があります。
今すぐ SQL Server 2008 Service Pack 3 をダウンロード
追加情報
SQL Server 2008 SP3 では、次の問題が修正されます。
この記事に記載されている問題
次の Microsoft SQL Server 2008 Service Pack 2 (SP2) の累積的な更新プログラム パッケージで修正された問題:
- SQL Server 2008 SP2 の累積的な更新プログラム パッケージ 1
- SQL Server 2008 SP2 の累積的な更新プログラム パッケージ 2
- SQL Server 2008 SP2 の累積的な更新プログラム パッケージ 3
- SQL Server 2008 SP2 の累積的な更新プログラム パッケージ 4
SQL Server 2008 SP2 で利用可能な累積的な更新プログラム パッケージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
2402659 SQL Server 2008 Service Pack 2 以降にリリースされた SQL Server 2008 ビルド 次の表に、SQL Server のインスタンスと SQL Server のバージョンについて、この条件を自動的にチェックする製品またはツールの詳細を示しますルールが評価される製品。
| ルール ソフトウェア | ルール タイトル | ルールの説明 | ルールが評価される対象である製品バージョン |
|---|---|---|---|
| System Center Advisor | プリンシパルの LazyWriter が開始されることを保証する更新KB2546951 SQL Server不足しています | System Center Advisor によって、この SQL Server インスタンスが 64 を超える論理プロセッサを持つサーバー上で実行されているかどうかが確認されます。 また、アドバイザーは sqlservr.exe の現在のビルドとバージョンを確認します。 sqlservr.exe の現在のビルドが修正ビルドより小さい場合、アドバイザーはこの問題に関するアラートを生成します。 Advisor アラートの「収集された情報」セクションに記載されている詳細を確認し、この記事で説明する修正プログラムを適用します。 この Advisor アラートは、この記事で説明されている修正 ID 337272を参照しています。 | SQL Server 2008 |
SQL Server 2008 SP3 で修正される問題
問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
| VSTS バグ番号 | サポート技術情報番号 | 説明 |
|---|---|---|
| 721415 | 2550552 | 修正: バッファーなしのアクセス パスを使用して SQL Server 2008 R2 または SQL Server 2008 の FILESTREAM ファイルにアクセスすると、SQL Server コマンドが応答を停止する |
| 611967 | 922578 | 修正: SQL Server 2005 で SQL Server プロファイルを使用すると、メッセージ ID 19030 およびメッセージ ID 19031 のメッセージが SQL Server 2005 エラー ログ ファイルに多数記録される |
| 628427 | 2463682 | 修正プログラム: SQL Server 2008 R2 でサーバー証明書が削除されると、透過的なデータ暗号化が有効になっているデータベースが "疑わしい" とマークされることがある |
| 729461 | 2500042 | SQL Server 2008 の Service Pack 2 (SP2) を適用すると、エラー メッセージ "SQL Server 2008 のセットアップには Microsoft .NET Framework 4.0 が必要です) が表示される |
| 757676 | 2565683 | 修正: SQL Server 2008 環境で、サブクエリに集計関数、結合関数、個別関数を含む複雑なクエリを実行すると、誤った結果を受け取ることがある |
| 746231 | 2569923 | 修正プログラム: ジョブが SQL Server 2008 または SQL Server 2008 R2 の MDW データベースにデータをアップロードする場合に、データ コレクターのSQL Serverのジョブが多数の TCP ポートをすばやく開いたり閉じたりする |
| 429231 | 2588050 | 修正プログラム: SQL Server 2008 Service Pack のスリップストリームのインストールが失敗する場合がある |
| 717065 | 2588453 | 修正: テーブルの空間データ型列にインデックスがある場合、DTA が SQL Server 2008 のテーブルに対してクエリを実行するとアクセス違反が発生する |
| 644781 | 2589980 | 修正: SQL Server 2008 で row_number 関数と並列実行プランを使用する SELECT ステートメントまたは DML ステートメントを実行すると、誤った結果または制約違反が発生する |
| 420834 | 2590124 | 修正: SQL Server 2008 のインストール時の "ChainerInfrastructureException" エラー |
| 666690 | 969052 | 見つからない Windows インストーラーのキャッシュ ファイルを復元し、SQL Server の更新中に発生する問題を解決する方法 |
| 406407 | 2591753 | 修正プログラム: サービス アカウントの SPN 情報を Reporting Services ログ ファイルに追加する更新プログラムが利用可能です |
SQL Server 2008 SP3 で修正されるその他の問題
以下の問題も SQL Server 2008 SP3 で修正されています。
| VSTS バグ番号 | 説明 |
|---|---|
| 295196, 771825 | SQL Server 2008 で [データベースの圧縮] オプションが有効になっている場合、メンテナンス プランを作成するときに次の警告メッセージが表示される場合があります。"データ ファイルを圧縮するとデータが移動され、それらのファイル内のインデックスの断片化が発生する可能性があります。" |
| 295750 | さまざまな診断ツールによって、SQL Server 2008 の他のデータベースに対して実行されたクエリのマスター データベースが誤って報告される。 |
| 337272 | 0 NUMA ノードに SQL Server 2008 のプロセッサが含まれていない場合、プリンシパルの Lazy Writer が起動しません。 |
| 444202 | ユーザーは、SQL Server 2008 の SQL Server Management Studio (SSMS) を使用して、SQL Server 2005 のパスワードを変更できません。 |
| 447990 | インデックス付きビューがベース テーブルと非ベース テーブルから列を投影し、非ベース テーブルの列がベース テーブルの列と同じ順序 ID および型であると仮定します。 このシナリオでは、SQL Server 2008 SP3 がインストールされている場合、パーティション スイッチの代わりにエラーが発生します。 |
| 450529 | 管理者以外のユーザーとして SSMS を開き、データベースのアタッチを試みるとします。 このシナリオでは、SQL Server 2008 SP3 がインストールされている場合、例外ではなく「アクセスが拒否されました」エラーが表示されます。 |
| 507222 | たとえば次のようなシナリオを考えてみます。
このシナリオでは、SQL Server 2008 で "FullXactImpBase::GetXdes xact.cpp @ 2536 での読み取りアクセス違反" エラーが表示されます。 |
| 546001 | このバグの問題の修正プログラムでは、テーブル値パラメーターの既定値を作成すると、テーブル値パラメーターの名前がリセットされます。 SQL Server 2008 SP3 をインストールした後、Temp テーブル キャッシュから既定値を取得するとき、TableVarElem 要素は常に正しい名前を付けます。 |
| 643903 | データベース間の DDL 操作が実行されたときに、データベース レベルのイベントのイベント通知が生成されない場合があります。 この問題は、正しくないダイアログ ハンドルが使用されているために発生します。 |
| 650111 | コードネーム「Denali」の SQL Server のサイドバイサイド インストールがインストールされている場合、アプリケーションは SQL Server 2008 に接続できません。 この問題は、null ポインターが原因で発生します。 null ポインターを使用すると、コンピューターにインストールされている上位レベルのインスタンスは無視されます。 SQL Server 2008 SP3 をインストールした後、SQL Server 2008 Configuration Manager を使用するときに null ポインターは使用されません。 |
| 703968 | SQL Server 2008 SP3 をインストールした後、クエリ オプティマイザーは、CRYPT_GEN_RANDOM 列の同じ入力値に対して異なる出力値を処理できます。 |
| 704992 | x64 ベースのオペレーティング システムでの整数データ変換に関する問題。 これらの問題は、BindParameter メソッドと、このメソッドで使用される LONG データ型パラメーターが原因で発生します。 |
| 707059 | プロファイラーには、SQL Server データベース エンジンと SQL Server Analysis Services の両方のすべてのイベントと列が表示されない場合があります。 SQL Server 2008 SP3 をインストールすると、SQL Server データベース エンジンと SQL Server Analysis Services 用の新しいトレース テンプレート ファイルが個別に生成されます。 |
| 709063 | mdw_purge_data_[<MDW データベース名>] データ コレクター ジョブを実行して DELETE 操作を実行すると、パフォーマンス低下の問題が発生します。 この問題は、Microsoft SQL Server 2008 Management Data Warehouse (MDW) のデータ コレクターが大規模な MDW データベースで実行されている場合に発生します。 |
| 741462 | DTExec.exe ランタイム ユーティリティまたは SQL Agent ジョブ ステップから SSIS パッケージを実行すると、一部の出力ログ イベントがログに記録されないことがあります。 OnInformation、OnProgress、Diagnostic、OnPostExecute、PackageEnd イベントなどのイベントが出力に欠落している可能性があります。 OnInformation: "OLE DB Destination" が ###### 行を書き込んだなど、よく観察される情報ログ イベントが出力に存在しない可能性があります。 DTExecUI.exe や DtsDebugHost.exe などの他のランタイム ユーティリティ (BIDS 環境から SSIS パッケージをデバッグする場合) は、この問題の影響を受けません。 |
| 755932 | パッケージおよび展開ウィザード (PDW) エンジンでは、LAG および LEAD 分析機能が機能しない。 この問題は、MemoXML スキームの一部の情報が削除されるために発生します。 |
| 771381 | FILESTREAM ファイル グループを持つデータベースを削除するときに割り当てられるメモリ オブジェクトの誤ったポインター。 |
| 540323 | アプリケーションが 9530 エラー コードを表示しようとすると、アクセス違反が発生します。 この問題は、NULL ポインターが使用されているために発生します。 |
| 778341 | SCOPE_IDENTITY() 関数から間違った値が返される場合があります。 |
| 536835 | SQL Server 2000 Service Pack 3 (SP3) Online Analytical Processing (OLAP) がインストールされているコンピューターに Microsoft SQL Server 2008 をインストールすると、セットアップがクラッシュする。 この問題は、SQL Server 2000 SP3 OLAP でバージョン レジストリ キーが Service Pack 3.0 に正しく設定されていないことが原因で発生します。 |
| 544926 | DatabaseEncryptionKey SQL Server Management Objects (SMO) オブジェクトを変更しようとしたときにプロパティを変更しない場合、データベース SMO オブジェクトは DatabaseEncryptionKey 値を更新しません。 |
| 729229 | SQL Server 2008 SP3 をインストールした後、列挙の結果はキャッシュされず、リソースを列挙するためのローカル変数に格納されません。 また、ディスクは 1 回だけ検証され、結果は後続の要求用に格納されます。 |
| 425485 | SQL Server 2008 SP3 をインストールすると、セットアップ シナリオを実行するすべてのランディング ページのリンクが無効になります。 |
| 700081 | アプリケーションが比率カウンターの基本カウンターの名前を検索する場合、SQL Server 2008 では大文字と小文字が区別されない部分文字列参照操作を実行する必要があります。 |
| 281309 | sys.dm_exec_query_stats テーブルに対して並列クエリ プランを実行するときの CPU 時間が正しくありません。 |
| 356915 | 非同期読み出し操作用の内部バッファーが複数文字の列区切り記号を 2 つの部分に分割すると、エラーが発生します。 SQL Server 2008 SP3 をインストールした後、バッファーが切り替えられた後に、現在の解析ポインターがリセットされます。 |
| 645220 | コマンド プロンプトで有効な SQLAgent.exe コマンドが入力された場合、SQLAgent.exe は実行されません。 この問題は、共有メモリのアクセス許可エラーが原因で発生します。 |
| 747046 | SQL Server 2008 SP3 をインストールした後、データベース名が現在のデータベース ユーザーの名前と同じデータベースは作成されません。 |
| 769191 | SQL Server 2008 SP3 には、Ntverp.h ファイルの更新された VER_PRODUCTLEVEL_STR および VER_PRODUCTLEVEL_WSTR グローバル変数が含まれています。 これらの変数は SP3 に更新されます。 |
| 453592 | ユーザーが Microsoft SQL Server 2008 Reporting Services Configuration Manager でデータベース サーバーのポートを指定すると、カタログ データベースにアクセスできません。 |
| 773344 | 実行アカウント情報に、ロシア語にローカライズされたビルドの Microsoft SQL Server 2008 Reporting Services Configuration Manager で切り捨てられた文字列が含まれています。 |
参考資料
現在の SQL Server のバージョンとエディションを確認する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
321185
SQL Server のバージョンとエディションを識別する方法
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。