概要
この記事では、Microsoft SQL Server 2012 Service Pack 2 (SP2) で修正されるバグの一覧を示します。
メモ
- ここに記載されていないその他の修正プログラムも、Service Pack に含まれている可能性があります。
- この一覧は、さらに資料が公開されたときに、更新される予定です。
SQL Server 2012 Service Pack の入手方法の詳細については、以下のサポート技術情報番号をクリックしてください。
2755533 SQL Server 2012 の最新の Service Pack を入手する方法 注 利用可能なダウンロード リストから選択するダウンロードの詳細については、こちらのリリース ノートチェック。
追加情報
SQL Server 2012 Service Pack は累積的な更新プログラムであり、SQL Server 2012 のすべてのエディションとサービス レベルを SP2 にアップグレードします。 この記事に記載されている修正プログラムに加えて、この Service Pack には、Microsoft SQL Server 2012 SP1 累積更新プログラム 9 (CU9) まで含まれています。
SQL Server 2012 SP1 で利用可能な累積的な更新プログラム パッケージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
2772858 SQL Server 2012 Service Pack 1 以降にリリースされた SQL Server 2012 のビルド
この Service Pack で修正される問題
SQL Server 2012 SP2 で修正される問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
| VSTS バグ番号 | サポート技術情報番号 | 説明 |
|---|---|---|
| 1374617 | 2028830 | 修正: SQL Server 2008 または SQL Server 2012 フェールオーバー クラスターのインストールを実装すると、共有コンポーネントが間違った場所にインストールされる |
| 1703014 | 2963382 | 修正: SSAS 2012 でキューブ作成 MDX クエリを実行するとサーバーに接続できない |
| 2011247 | 2927741 | 修正: SSRS 2012 レポートでドリルスルー アクションを使用すると、Web ページに画像が正しく表示されない |
| 2034994 | 2963383 | 修正: SSRS 2012 で HPB レンダラーを使用してレポートを表示するとテキストが切り捨てられる |
| 1769469 | 2963384 | 修正プログラム: SQL Server 2012 で tempdb データベースのログ ファイルがいっぱいになると、SQL Server がクラッシュする |
| 1973168 | 2963386 | 修正プログラム: Excel ワークシートにエクスポートされたサブスクリプションが 10 MB を超えると、SSRS 2012 が IsolatedStorageException で失敗する |
| 1973196 | 2963388 | 修正: SSRS 2012 では、10 MB を超えるレポートを Excel 形式にエクスポートできません |
| 787358 | 2963404 | 修正プログラム: ロールバックにより SQL Server 2012 でデータベースが疑わしいモードになる |
| 1043717 | 2806979 | 修正: SQL Server 2012 の RCSI 対応データベースのテーブルに対してクエリを実行するとパフォーマンスが低下する |
| 1178585 | 2963412 | SQL Server 2012 SP2 の新しい DMF sys.dm_fts_index_keywords_position_by_document |
| 1182241 | 2966520 | 修正済み: 1 月 1 日に SSRS 2012 で Reporting Services Windows サービスを再起動しても、新しいログ ファイルが作成されない |
| 1240848 | 2966519 | 修正: SQL Server 2012 でログ バックアップが失敗したときにエラー メッセージが表示されない |
| 1253861 | 2936004 | 修正プログラム: ローカル モードの Report Viewer 2012 UI でデータ ソースのバインドが完了すると、アクセス違反が原因で Visual Studio 2012 がクラッシュする |
| 1262029 | 2966522 | 修正プログラム: ファイル共有サブスクリプションで SSRS 2012 の説明列が入力されない |
| 1481773 | 2966523 | 修正: SSRS 2012 レポートを指定すると、[名前] ドロップダウン リストが空になる |
| 1419367 | 2964762 | 修正: SSAS 2012 で Discover コマンドを使用すると、イベント ID 22 またはエラー 0xC1000016 がログに記録される |
| 2103903 | 2972285 | 修正: SQL Server 2012 で配置ストアとして SSISDB を使用する場合のパフォーマンスの問題 |
| 2021581 | 2965035 | SQL Server 2012 Service Pack 2 での SSAS 2012 ログ機能の向上 |
| 203749 | 2952444 | 修正: SQL Server 2012 でテーブル変数を使用するとパフォーマンスが低下する |
| 2095064 | 2936328 | 修正: SQL Server 2008 R2 または SQL Server 2012 で計算列を保持しているテーブルに対して CHECKTABLE または CHECKDB を実行すると、アクセス違反が発生する |
| 1222472 | 2827857 | 修正: 補足的な文字照合順序を使用する SQL Server 2012 インスタンスで DTA が機能しない |
| 2124209 | 2939277 | 修正: SQL Server で並列クエリ プランを使用して UNION 演算子を含むクエリを実行すると、結果が正しくない |
以下の問題に対する解決策は、SQL Server 2012 SP2 にも含まれています。
| VSTS バグ番号 | 説明 |
|---|---|
| 950185 | 大規模な HTML レポートを操作する際のエラーと警告の処理に関するメッセージが改善されました。 |
| 950189 | 多数のパラメーターを含むレポートを操作する際のエラーと警告の処理に関するメッセージが改善されました。 |
| 994470 | ブロック モードの単項演算子を使用すると、結果が正しくありません。 |
| 1041277 | AlwaysOn セカンダリを使用するサーバー上の DPM の完全バックアップは、copy_onlyバックアップに変換されます。 |
| 1278767 | 表形式のインスタンスのパフォーマンス カウンター: Memory\VertiPaq <TypeName> KB の値は常に 0 です。 |
| 1355346 | end SCOPE ステートメントは、開始 SCOPE ステートメントと一致しません。 |
| 1374617 | 修正プログラム: SQL Server 2008 フェールオーバー クラスター インストールを実装すると、共有コンポーネントが間違った場所にインストールされる |
| 1610447 | 初期化されていないオブジェクトは、条件付き計算を使用して DAX 式を実行するときにクラッシュし、間違った結果になる可能性があります。 |
| 1610492 | PowerPivot v2 11.0.3000.0 を使用すると、単純な DAX クエリは予期しない結果を返します。 |
| 2060218 | 無効な InstanceId を使用して SSRS 構成ファイルが解析された場合は "ACTIONABLE_HEAP_CORRUPTION" が返されます。 |
| 2065570 | リング バッファー内の NonYieldProcessTable レコードRING_BUFFER_NONYIELD_PROCESSTABLEユーザーとカーネルのプロセス時間がありません。 |
| 2075161 | SSRS 2012 のログにプラットフォーム情報を提供します |
| 1347204 | 修正: SQL Server 2012 のデータベース間トランザクションからシーケンス既定値の列を持つテーブルにデータを挿入すると、アクセス違反が発生する |
| 1184332 | モデル データベースに対してテール ログ バックアップを実行すると、サーバーの再起動中にモデル データベースが復元状態でフリーズし、SQL Server が正常に起動しなくなります。 これは、サーバーの起動中に Tempdb データベースを作成できず、"データベース '<DatabaseName>' を開けません" というエラー メッセージが表示されるためです |
| 1243853 | エラー 3456 は、64704 KB を超える初期サイズで新しいデータ ファイルが追加された一括ログ DB のログ バックアップを復元するときに発生します。 |
| 1404999 | LOCK_TIMEOUT設定のセッションでデータベース スナップショットのドロップが発行されると、タイムアウト エラーの後にアサーション エラーが発生することがあります。 |
| 1190211 | InstallShield を使用した SQL Server のインストールは、ハング状態になります。 詳細については、 このサポート技術情報の記事を参照してください。 |
| 1386073 | SQL Server 2012 SP2 をインストールした後、SQL Server が構成マネージャーまたはサービス コントロール マネージャーから停止されると、シャットダウンが発行された直後に情報メッセージが SQL Server に記録されます。 以前のバージョンでは、このメッセージは、.NET Framework、サービス ブローカーなどの内部サービスが停止した後に発行されました。 |
コミュニティから送信された接続アイテムの修正
| 接続 バグ ID | 説明 |
|---|---|
| 714689 | Enterprise Management Framework を複数のサーバーに実装し、一覧のいずれかのサーバーに対してエラーが発生すると、評価結果が出力 xml ファイルに複数回書き込まれます。 |
| 735543 | バックアップが同じインスタンス上の別のデータベースとして復元されると、データベースは復元モードに入ります。 |
| 736509 | SQL Server Management Studio (SSMS) で sp_executesql を呼び出すストアド プロシージャは、デバッグできません。 F11 キーを押すと、"オブジェクト参照がオブジェクトのインスタンスに設定されていません" というエラー メッセージが表示されます。 |
| 740181 | SSMS は、SQL Server Express の Full-Text を完全には管理しません。 |
| 745566 | SQL Server SMO は、SQL Server 2012 および SQL Server 2014 の既定の制約を無視します。 |
| 764197 | SSMS は、番号付きストアド プロシージャを一貫性なく処理します。 |
| 769121 | "列 '<列名>' はテーブルの概要に属していません。 (System.Data)」というエラー メッセージが、レプリケートするテーブルの名前が同じであるが、異なるスキーマ内にある場合に表示されます。 |
| 773710 | フルテキスト インデックスを含むデータベース スナップショットに戻した後は、SQL Server再起動するか、データベースを切断して接続するか、データベースをオフラインにしてからデータベースをオンラインに設定するまで、ft_catalogsを作成することはできません。 |
| 774317 | SSMS が終了時にクラッシュすることがあり、これにより自動的に再起動されます |
| 785064 | Business Intelligence Development Studio (BIDS) で顧客パイプライン コンポーネントを操作すると、「'null' の値は 'stream' に対して有効ではありません」というエラー メッセージが表示されます。 |
| 785151 | [実際のクエリ プランの表示] をオンにしてクエリを実行すると、結果として Null が返され、次のエラー メッセージが表示されます。 エラー: メッセージ 50000、レベル 16、状態 10、プロシージャ テスト、行 34 文字列またはバイナリ データが切り捨てられます。 |
| 791929 | トリガーのあるパーティション分割ビューにデータを挿入すると、「システム アサーション チェックに失敗しました」というエラー メッセージが表示されます。 |
| 797967 | スクリプトの作成は、SSMS で列レベルのアクセス許可をスクリプト化するときにステートメントを複製します。 |
| 799430 | タスク バーの SSMS ウィンドウ アイコンを更新しようとすると、SSMS がクラッシュすることがあります。 |
| 804901 | 大規模プロジェクトの新しいバージョンをデプロイすると、SSIS カタログ データベース (SSISDB) へのデプロイ中にタイムアウトが発生します。 さらに、次のエラー メッセージが表示されます。 プロジェクトをデプロイできませんでした。 詳細については、operation_messages ビューで操作識別子 '219' を照会してください。 (Microsoft SQL Server、エラー: 27203) プロジェクトをデプロイできませんでした。 問題を修正し、後でもう一度やり直してください。タイムアウトが発生しました。 処理が完了する前にタイムアウトの期間が経過したか、サーバーが応答していません。 ステートメントは終了しました。 |
| 805659 | 「SQL ステートメントの一部が入れ子になりすぎています。 Rewrite the query or break it into small queries" というエラー メッセージが、ストアド プロシージャを解析または実行するときに表示されます。 |
SQL Server 2012 SP2 のハイライト
ここでは、SQL Server 2012 Service Pack 2 (別名 SP2) に加えられた変更のいくつかを紹介します。
AlwaysOn
サポートの可否:
- メッセージ 35285 は、エラーとしてではなく、予期したとおり情報メッセージとして表示されます。
機能:
- SQL ライターのサポート COPY_ONLY バックアップ: AlwaysOn セカンダリを使用するサーバー上の Data Protection Manager (DPM) の完全バックアップは、COPY_ONLYバックアップに変換されます。
Analysis Services (別名 SSAS)
ローカル キューブ作成シナリオにサポートを追加します。
- SQL Server 2012 Analysis Services (SSAS 2012) SP2 を使用すると、SQL Browser が無効になっている既定以外の静的ポートで実行されている SSAS に接続するローカル キューブを作成することができます。 この新機能は、msmdsrv.ini の新しい構成設定 "ConfigurationSettings\LocalCubeServerPortInConnectionString" によって制御されます。この機能を有効にするには、値を 1 に設定します。 SSAS 2012 がフェールオーバー クラスターとして構成されている場合、または既定のポートで実行されている場合、この設定は効果がありません。
さらにログ記録を追加します。
- この Service Pack では、トラブルシューティングの改善に役立つ情報が SSAS ログ ファイルに追加されています。 これには、SSAS のバージョン、コンピューター名、NetBIOS 名、CPU の数、RAM サイズ、IP、ポート、プロトコルの種類、デッドロック、ロック タイムアウト、およびその他の情報が含まれます。
Integration Services (別名 SSIS)
SSISDB デッドロックとクリーンアップのパフォーマンスの向上
概要
ストアド プロシージャへの同時呼び出しでの SSISDB データベースのデッドロックSSISDB.catalog.create_execution
- SSISDB の同時性とデッドロックの問題が修正されました。 ただし、これですべての問題が解決するわけではありません。 現在の回避策は、ジョブを数秒ずらすことです。 ただし、この回避策を使用することはできません。
- SSISDB メンテナンス ジョブのパフォーマンスの低下
SSISDB のメンテナンス ジョブに使用できる修正プログラムがあります。
アーキテクチャ
以前のモデル:
- 各トランザクションでは、証明書と対称キーが作成されます。このキーは、保守タスクまたはクリーンアップ タスクで保存および処理する必要があります。
新しいモデル:
- カタログ プロパティ テーブルSERVER_OPERATION_ENCRYPTION_LEVELに新しい行を導入し、既定値を PER_EXECUTION に設定します。下位互換性を維持するために、プロジェクトごとに 1 つのキーまたは証明書のペアを作成するPER_PROJECT値を変更できます。 PER_EXECUTION から PER_PROJECT に変更する前に、完全なクリーンアップが必要です。 完全なクリーンアップのために 2 つの新しいストア プロシージャが導入されます。
変更の概要:
SSISDB プロパティ テーブル SERVER_OPERATION_ENCRYPTION_LEVELに新しい行を導入します。
- 有効な値は 2 つの値 (1 と 2) のみです。
- 値 "1": 既定値です。 実行レベルに応じて対称キーと証明書で暗号化されます。 セキュリティは高いが、パフォーマンスやデッドロックの問題が発生する可能性があります。
- 値 "2": プロジェクト レベルに応じて対称キーと証明書で暗号化されます。 セキュリティを下げ、パフォーマンスまたはデッドロックの問題を解決します。
2 つの新しいストアド プロシージャ (SP) Cleanup_server_logsと cleanup_server_execution_keys を導入します
SPは、暗号化レベルを「1」から「2」に変更したときに使用するように設計されています。SSISDB を良好な状態にするために、非常に迅速に終了できる Cleanup_server_logs を最初に実行できます。 SSISDB データベースを暗号化レベルに変更する準備ができています。
Cleanup_server_keys は Cleanup_server_logs よりも時間がかかります。 ただし、暗号化レベルが "2" に変更された後に実行され、オフ ピーク時に定期的に実行されます。
Cleanup_server_logs: すべての操作ログのみをクリーンします。
Cleanup_server_execution_keys: 機密性の高い実行パラメーターを保護するために使用される対称キーと証明書をクリーンします。
@cleanup\_flag int (in (1,2))
- cleanup_flag = 1: 実行レベルの対称キーと証明書を削除する
- cleanup_flag = 2: プロジェクト レベルの対称キーと証明書を削除します (この特定のプロジェクトが削除され、このプロジェクトに関連するすべての操作ログが消去された場合にのみ削除されます)。
@delete\_batch\_size int = 1000
- このストア プロシージャの 1 回の呼び出しで、多数のキーまたは証明書が削除されます。
internal.cleanup_server_retention_window で、delete_batch_sizeを 10 から 1000 に変更します。
リレーショナル エンジン
クエリ プランを改善するためのテーブル変数の行数のオプションのサポート:
テーブル変数が SQL Server 内の他のテーブルと結合されている場合、SQL Server はクエリ プランの作成中に統計をサポートしたり、テーブル変数の行数を追跡したりしないため、非効率的なクエリ プランの選択によりパフォーマンスが低下する可能性があります。
SQL Server 2012 SP2 では、新しいトレース フラグが導入されています。これにより、クエリ オプティマイザーは、より効率的なクエリ プランを選択するために、テーブル変数に挿入された行数に関する情報を使用できるようになります。 この動作をアクティブにするには、トレース フラグ 2453 を有効にします。
注:
- 一部のシナリオでは、トレース フラグ 2453 を有効にすると、実行時にテーブル変数に挿入される実際の行数を考慮するために追加のコンパイルが必要になるため、パフォーマンスが低下する可能性があります。 通常、テーブル変数に大量の行が他のテーブルと結合されている場合や、複数の行がありネストされたループ結合演算子の外側で使用され、内側に大量の行を処理するプランがある場合、このトレース フラグが役立ちます。
- 同様の動作は、OPTION (再コンパイル) クエリ ヒントを使用することによって、他のバージョンの SQL Server でも実現される可能性があります。 ただし、クエリ ヒントでは、テーブル変数による大量の作業による不適切なプランの選択に悩まされているすべてのクエリを検出して変更する必要があります。また、トレース フラグ 2453 を有効にすると、既存のワークロードに影響を与える可能性があります。
並列クエリ実行プランのパフォーマンスのトラブルシューティングが強化されました
- DMV sys.dm_exec_requests は並列クエリ実行プランのcpu_timeの正確な値を返すようになりました。 統計 IO 診断は、並列クエリ実行プランの正確な論理読み取りを報告するようになりました。
ハッシュ スピル診断の改善
- クエリの実行中にハッシュ結合またはハッシュ集計演算子が tempdb データベースにデータをスピルした場合、STATISTICS IO 診断の対応する I/O が報告されるようになりました。
フルテキスト インデックス診断の強化
- 場合によっては、特定のフル テキスト クエリの結果がどのように返されるかを理解するのが難しい場合があります。 フルテキスト検索サブシステムは、外部のワード ブレーカーおよびストップ リストと対話します。この相互作用の結果として、ドキュメント内のキーワードの位置情報が実際のテキストで観察されるものと異なる場合があります。 これは、単語間のデルタが内部計算で一致するドキュメントを見つけるために使用されるため、'phrase' または 'NEAR' 検索を行うときに非常に重要です。
- SQL Server 2012 SP2 では、文書内でインデックス付けされたキーワードの位置情報へのアクセスを提供するために、新しい動的管理機能 (DMF) が追加されました。 新しい DMF は既存の DMF sys.dm_fts_index_keywords_by_documentに似ており、構文は次のとおりです:sys。 dm_fts_index_keywords_position_by_document
(
DB_ID('database_name'), OBJECT_ID('table_name')
) - 出現回数の代わりに、各出現回数と、インデックス付きドキュメント内での位置に関する情報を返します。
- この情報を使用して、テキストと内部インデックスとのマッピングを調べることができます。内部インデックスでは、検索語句の差分 (差がある場合) が表示されます。 これは、語句検索の結果を理解するのに役立ちます。
レプリケーション
サポート可能
トランザクション レプリケーション:
履歴テーブルの統計に追加された詳細メッセージと、エージェント ログの詳細なメッセージ:
- <stats> xml 出力にテキスト メッセージを追加して、logreader エージェントとディストリビューター エージェントの両方で異なる状態を定義しました。
- ディストリビューターおよびログリーダーのパラメーター化されたコマンドの記事レベルの統計を追加しました。
- ディストリビューター エージェントの出力ファイルにスキップされたコマンドの数を追加しました。
- ディストリビューター エージェントでのスキーマ変更にかかる時間が追加されました。
LogReader: ユーザー ダンプ .TXT キャプチャされると、ログ レコードがファイルに追加されます。
ピアツーピア: 挿入、更新、削除の手順が更新され、競合メッセージに以下の詳細が提供されます。
- テーブル名
- 主キー列の名前と値
- 現在のバージョン
- バージョンより前
- ポスト バージョン
マージ レプリケーション:
- マージ エージェントの出力詳細レベルが 4 に設定されている場合にログ ファイルに追加されるトレース フラグ 101 の出力。
機能性
トランザクション レプリケーション:
- ピア ツー ピア レプリケーションでは、Update または を使用してテキスト列に対して行われる部分的な更新がサポートされるようになりました。セマンティックを記述する。
マージ レプリケーション:
- クリーンアップ ストアド プロシージャは、データの冗長なアップロードを回避するように再設計されました。
Reporting Services (別名 SSRS)
CSS、大規模な HTML レポートへの一般的な呼び出しを防ぐために、処理エラーと警告を含むメッセージをログに記録します。
概要:
- レポート デザインの検出により、大きな HTML レポートが作成され、パフォーマンスの問題が発生する可能性があるかどうかを判断します。 これは、対話型のページの高さと幅の設定を調べることで簡単に検出できるはずです。
ユーザー シナリオ:
レポートは Report Builder で作成します。 InteractiveSize プロパティに値 '0' を入力します。 パフォーマンスへの影響の可能性について警告する次のメッセージを含むポップアップ ウィンドウが表示されます。
注
Interactive Heigth を 0 mat に設定すると、パフォーマンスに影響します。
ストレージ エンジン
パフォーマンスの強化
以下の記事に記載されているように、Service Pack 2 のパフォーマンス強化がいくつか含まれています。
- SQL Server 2012 でデータベース ロック アクティビティが増加すると、パフォーマンスの問題が発生する
- SQL Server 2012 での外部ページ処理中に、NUMA 環境でパフォーマンスの問題が発生する
- ALTER INDEX の実行後、パフォーマンスが低下する...SQL Server 2012 でオンライン操作が中止される
DMV の機能強化
- sys.dm_db_session_space_usage は、セッションごとにユーザー オブジェクトによって tempdb データベースで使用されている領域の量を反映します。 削除される行数が 1024 ページを超えると、これらのページの割り当て解除が延期されます。 SQL Server 2012 Service Pack 2 では、user_objects_deferred_dealloc_page_count という新しい列で繰延される割り当て単位のスペース使用量も DMV に含まれます。
- SQL Server がフェールオーバー クラスターにインストールされている場合、sys.dm_server_services はcluster_nodename列にノード名を正しく指定するようになりました。
リング バッファーの機能強化
アプリ ドメインのリング バッファーには、 <DoomReason> フィールドにアプリ ドメインがアンロードされた理由RING_BUFFER_CLRAPPDOMAINが含まれます。
- 1 = ドロップ アセンブリなどの DDL 操作によってアンロードされます。
- 2 = アクセス許可の変更などのセキュリティ関連操作によってアンロードされます。
- 3 = メモリ プレッシャー処理のためアンロードされます。
- 4 = 初期化に失敗したためアンロードされました。
対応する拡張イベント app_domain_ring_buffer_recordedには、イベント データ フィールドdoom_reasonアンロードの理由が含まれます。
RING_BUFFER_RESOURCE_MONITOR には、リソース モニターによって監視されている状態で変更が検出されたときにエントリがあります。 さらに、システムとプロセス リソースの通知の場合、プール通知は <IndicatorsPool></IndicatorsPool> ノードでも使用できます。
拡張イベントResource_monitor_ring_buffer_recorded、プール全体の通知が pool_indicators データ フィールドに含まれます。
RING_BUFFER_NONYIELD_PROCESSTABLEには、プロセス名に加え、リング バッファー エントリを記録する時点でシステムで実行されているスレッド (最大 8,192 スレッド) が含まれます。
バックアップと復元の機能強化
norecovery オプションを使用したモデルのテール ログのバックアップは、Service Pack 2 以降では許可されなくなりました。
エラー ログのバックアップと復元の完了メッセージには、期間とスループットの情報が含まれます。
- バックアップ データベースは、0.026 秒 (89.261 MB/秒) で 298 ページを正常に処理しました。
- データベースの復元は、0.016 秒 (145.050 MB/秒) で 298 ページを正常に処理しました。
拡張イベント
SQL Server 2012 Service Pack 2 では、次の拡張イベントが追加または変更されています。
メモリの割り当て:
- 拡張イベント page_allocated と page_freed を使用して、SQL Server メモリの上位のコンシューマーを確認できます。 Service Pack 2 以降、これらの拡張イベントは、クエリの実行中に割り当てられ解放された予約済みメモリも報告します。
ゴースト クリーンアップ:
テーブルまたはインデックス内のレコードが削除された場合、このような削除操作では、ページからレコードが物理的に削除されることはありません。レコードが削除またはゴーストされたものとしてマークされるだけです。 これは、削除操作をより迅速に完了できるようにするパフォーマンスの最適化です。 その後、ゴースト クリーンアップ タスクと呼ばれるバックグラウンド タスクによって、削除されたすべてのレコードが物理的に削除されます。 Service Pack 2 には、このタスクのさまざまなフェーズに関する洞察を提供するいくつかの拡張イベントが追加されました。
- ghost_cleanup_task_start
- ghost_cleanup_task_suspend
- ghost_cleanup_task_packet_enqueue
- ghost_cleanup_task_process_packet
- ghost_cleanup_task_process_pages_for_db_packet
参考資料
現在の SQL Server のバージョンとエディションを確認する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
321185 SQL Server とそのコンポーネントのバージョンとエディションを確認する方法