소개
이 문서에서는 Microsoft SQL Server 2008 SP3(서비스 팩 3)에서 해결된 SQL Server 2008 문제를 나열합니다.
노트
- 문서화되지 않은 일부 문제는 서비스 팩으로 해결될 수 있습니다.
- 문제에 대한 문서가 공개되면 문제 목록이 업데이트됩니다.
SQL Server 2008 서비스 팩을 구하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
968382
SQL Server 2008용 최신 서비스 팩을 구하는 방법
참고 Microsoft는 Microsoft SQL Server 2008 수정 사항을 하나의 다운로드 가능한 파일로 배포합니다. 수정 사항은 누적되므로 각 새 릴리스에는 이전 SQL Server 2008 픽스 릴리스에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. 일반적으로 최신 서비스 팩을 다운로드해야 합니다.
지금 SQL Server 2008 서비스 팩 3 다운로드
추가 정보
SQL Server 2008 SP3에서는 다음 문제를 해결합니다.
이 문서에 나열된 문제
Microsoft SQL Server 2008 SP2(서비스 팩 2)에 대한 다음 누적 업데이트 패키지에서 해결된 문제:
- SQL Server 2008 SP2용 누적 업데이트 패키지 1
- SQL Server 2008 SP2용 누적 업데이트 패키지 2
- SQL Server 2008 SP2용 누적 업데이트 패키지 3
- SQL Server 2008 SP2용 누적 업데이트 패키지 4
SQL Server 2008 SP2에 사용할 수 있는 누적 업데이트 패키지에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하세요.
2402659 SQL Server 2008 서비스 팩 2가 출시된 후 출시된 SQL Server 2008 빌드 다음 표에서는 이 상태에 대해 자동으로 검사되는 제품 또는 도구에 대한 자세한 정보를 SQL Server instance 및 버전 규칙이 평가될 SQL Server 제품입니다.
| 규칙 소프트웨어 | 규칙 제목 | 규칙 설명 | 규칙이 평가되는 제품 버전 |
|---|---|---|---|
| System Center Advisor | 보안 주체 LazyWriter가 시작되도록 보장하기 위한 누락된 업데이트 KB2546951 SQL Server | System Center Advisor는 이 SQL Server instance가 64개 이상의 논리 프로세서가 있는 서버에서 실행 중인지 확인합니다. 또한 advisor는 sqlservr.exe의 현재 빌드 및 버전을 확인합니다. sqlservr.exe의 현재 빌드가 픽스 빌드보다 작으면 어드바이저는 이 문제에 대한 경고를 생성합니다. Advisor 경고의 "수집된 정보" 섹션에 제공된 세부 정보를 검토하고 이 문서에서 설명하는 수정 사항을 적용합니다. 이 Advisor 경고는 이 문서에 언급된 픽스 ID 337272를 참조합니다. | SQL Server 2008 |
SQL Server 2008 SP3에서 해결된 문제
이 문제에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
| VSTS 버그 번호 | 기술 자료 문서 번호 | 설명 |
|---|---|---|
| 721415 | 2550552 | 해결 방법: 버퍼링되지 않은 액세스 경로를 사용하여 SQL Server 2008 R2 또는 SQL Server 2008의 FILESTREAM 파일에 액세스하는 경우 SQL Server 명령이 응답하지 않음 |
| 611967 | 922578 | 해결 방법: SQL Server 2005에서 SQL Server 프로필을 사용할 때 메시지 ID 19030 및 메시지 ID 19031이 있는 메시지가 SQL Server 2005 오류 로그 파일에 많이 기록됨 |
| 628427 | 2463682 | 해결 방법: 투명한 데이터 암호화를 사용하도록 설정한 데이터베이스는 서버 인증서가 SQL Server 2008 R2에서 삭제된 경우 "의심 사항"으로 표시될 수 있습니다. |
| 729461 | 2500042 | SQL Server 2008용 서비스 팩 2(SP2)를 적용할 때 "SQL Server 2008 설치하려면 Microsoft .NET Framework 4.0이 설치되어야 합니다." 오류 메시지가 표시됨 |
| 757676 | 2565683 | 해결: SQL Server 2008 환경에서 하위 쿼리에 집계 함수, 조인 함수 및 고유 함수가 포함된 복잡한 쿼리를 실행할 때 잘못된 결과를 받을 수 있음 |
| 746231 | 2569923 | 해결 방법: 작업이 SQL Server 2008 또는 SQL Server 2008 R2의 MDW 데이터베이스에 데이터를 업로드하는 경우 데이터 수집기의 업로드 작업이 많은 수의 TCP 포트를 빠르게 열고 닫습니다. |
| 429231 | 2588050 | 해결 방법: SQL Server 2008 서비스 팩의 슬립스트림 설치가 실패할 수 있음 |
| 717065 | 2588453 | 해결 방법: 테이블의 공간 데이터 형식 열에 인덱스가 있는 경우 DTA가 SQL Server 2008의 테이블에 대해 쿼리를 실행할 때 액세스 위반 |
| 644781 | 2589980 | 픽스: SQL Server 2008에서 row_number 함수와 병렬 실행 계획을 사용하는 SELECT 문 또는 DML 문을 실행할 때 잘못된 결과 또는 제약 조건 위반 |
| 420834 | 2590124 | 해결: SQL Server 2008을 설치할 때 "ChainerInfrastructureException" 오류 발생 |
| 666690 | 969052 | 누락된 Windows Installer 캐시 파일을 복원하고 SQL Server 업데이트 중에 발생하는 문제를 resolve하는 방법 |
| 406407 | 2591753 | 해결 방법: 서비스 계정에 대한 SPN 정보를 Reporting Services 로그 파일에 추가하는 업데이트를 사용할 수 있습니다. |
SQL Server 2008 SP3에서 해결된 추가 문제
다음 문제도 SQL Server 2008 SP3에서 해결되었습니다.
| VSTS 버그 번호 | 설명 |
|---|---|
| 295196, 771825 | SQL Server 2008에서 데이터베이스 축소 옵션을 사용하는 경우 유지 관리 계획을 만들 때 "데이터 파일을 축소하면 데이터가 이동하고 해당 파일 내의 인덱스가 조각화될 수 있습니다."라는 경고 메시지가 나타날 수 있습니다. |
| 295750 | 다양한 진단 도구가 SQL Server 2008의 다른 데이터베이스에 대해 실행된 쿼리에 대해 master 데이터베이스를 잘못 보고합니다. |
| 337272 | 0 NUMA 노드에 SQL Server 2008의 프로세서가 없으면 주 지연 기록기가 시작되지 않습니다. |
| 444202 | 사용자는 SQL Server 2008의 SSMS(SQL Server Management Studio)를 사용하여 SQL Server 2005에서 암호를 변경할 수 없습니다. |
| 447990 | 인덱싱된 뷰가 기본 테이블과 비기본 테이블의 열을 프로젝션한다고 가정하고, 비기본 테이블의 열이 기본 테이블의 열과 동일한 주문 ID 및 형식을 갖는다고 가정합니다. 이 시나리오에서는 SQL Server 2008 SP3이 설치된 경우 파티션 전환 대신 오류가 발생합니다. |
| 450529 | SSMS를 관리자가 아닌 권한으로 연 다음 데이터베이스를 연결한다고 가정합니다. 이 시나리오에서는 SQL Server 2008 SP3이 설치된 경우 예외 대신 "액세스가 거부되었습니다." 오류가 발생합니다. |
| 507222 | 다음 시나리오를 고려하세요.
이 시나리오에서는 SQL Server 2008에서 "FullXactImpBase::GetXdes xact.cpp @ 2536의 읽기 액세스 위반" 오류가 발생합니다. |
| 546001 | 이 버그 문제에 대한 수정은 테이블 반환 매개 변수의 기본값을 만들 때 테이블 반환 매개 변수의 이름을 다시 설정합니다. SQL Server 2008 SP3을 설치한 후 TableVarElem 요소는 임시 테이블 캐시에서 기본값을 검색할 때 항상 올바른 이름을 갖습니다. |
| 643903 | 데이터베이스 간 DDL 작업이 수행될 때 데이터베이스 수준 이벤트에 대한 이벤트 알림이 생성되지 않을 수 있습니다. 이 문제는 잘못된 대화 상자 핸들이 사용되어 발생합니다. |
| 650111 | 코드명 "Denali"의 SQL Server를 병렬로 설치한 경우 애플리케이션이 SQL Server 2008에 연결할 수 없습니다. 이 문제는 null 포인터 때문에 발생합니다. null 포인터를 사용하면 컴퓨터에 설치된 상위 인스턴스가 무시됩니다. SQL Server 2008 SP3을 설치한 후 SQL Server 2008 구성 관리자를 사용하면 null 포인터가 사용되지 않습니다. |
| 703968 | SQL Server 2008 SP3을 설치하면 쿼리 최적화 프로그램이 CRYPT_GEN_RANDOM 열의 동일한 입력 값에 대해 서로 다른 출력 값을 처리할 수 있습니다. |
| 704992 | x64 기반 운영 체제에서 정수 데이터 변환 문제. 이러한 문제는 BindParameter 메서드 및 이 메서드에서 사용하는 LONG 데이터 형식 매개 변수로 인해 발생합니다. |
| 707059 | 프로파일러는 SQL Server 데이터베이스 엔진과 SQL Server Analysis Services 모두에 대한 모든 이벤트와 열을 표시하지 않을 수 있습니다. SQL Server 2008 SP3을 설치하면 SQL Server 데이터베이스 엔진 및 SQL Server Analysis Services용 새 추적 템플릿 파일이 별도로 생성됩니다. |
| 709063 | mdw_purge_data_[<MDW 데이터베이스 이름>] 데이터 수집기 작업을 실행하여 DELETE 작업을 수행할 때 성능 저하 문제가 발생합니다. 이 문제는 Microsoft SQL Server 2008 Management Data Warehouse(MDW)의 데이터 수집기가 대규모 MDW 데이터베이스에서 실행되는 경우에 발생합니다. |
| 741462 | DTExec.exe 런타임 유틸리티 또는 SQL 에이전트 작업 단계에서 SSIS 패키지를 실행할 때 일부 출력 로깅 이벤트가 로깅된 출력에서 누락될 수 있습니다. OnInformation, OnProgress, Diagnostic, OnPostExecute 및 PackageEnd 이벤트와 같은 이벤트가 출력에서 누락될 수 있습니다. 일반적으로 관찰되는 정보 로그 이벤트(예: OnInformation: "OLE DB Destination" written ###### rows.")가 출력에서 누락되었을 수 있습니다. DTExecUI.exe 및 DtsDebugHost.exe(BIDS 환경에서 SSIS 패키지를 디버깅할 때)와 같은 다른 런타임 유틸리티는 이 문제의 영향을 받지 않습니다. |
| 755932 | LAG 및 LEAD 분석 함수는 PDW(패키지 및 배포 마법사) 엔진에서 작동하지 않습니다. 이 문제는 MemoXML 체계의 일부 정보가 제거되었기 때문에 발생합니다. |
| 771381 | FILESTREAM 파일 그룹이 있는 데이터베이스를 삭제할 때 메모리 개체의 잘못된 포인터가 할당됩니다. |
| 540323 | 응용 프로그램이 9530 오류 코드를 발생시키려고 하면 액세스 위반이 발생합니다. 이 문제는 NULL 포인터를 사용하여 발생합니다. |
| 778341 | SCOPE_IDENTITY() 함수가 잘못된 값을 반환할 수 있습니다. |
| 536835 | SQL Server 2000 SP3(서비스 팩 3) OLAP(온라인 분석 처리)가 설치된 컴퓨터에 Microsoft SQL Server 2008을 설치하면 설치가 중단됩니다. 이 문제는 SQL Server 2000 SP3 OLAP가 버전 레지스트리 키를 서비스 팩 3.0으로 잘못 설정했기 때문에 발생합니다. |
| 544926 | DatabaseEncryptionKey SQL Server SMO(관리 개체) 개체를 변경하려고 할 때 속성을 수정하지 않으면 데이터베이스 SMO 개체가 DatabaseEncryptionKey 값을 업데이트하지 않습니다. |
| 729229 | SQL Server 2008 SP3을 설치한 후 열거 결과는 캐시되지 않고 리소스를 열거하기 위한 로컬 변수에 저장되지 않습니다. 또한 디스크는 한 번만 유효성을 검사하고 결과는 후속 요청을 위해 저장됩니다. |
| 425485 | SQL Server 2008 SP3을 설치하면 설치 시나리오를 실행하는 모든 방문 페이지 링크를 사용할 수 없습니다. |
| 700081 | 응용 프로그램이 비율 카운터의 기본 카운터의 이름을 검색할 때 응용 프로그램은 SQL Server 2008에서 대/소문자를 구분하지 않는 부분 문자열 조회 작업을 수행해야 합니다. |
| 281309 | sys.dm_exec_query_stats 테이블에 대해 병렬 쿼리 계획을 실행할 때 CPU 시간이 잘못되었습니다. |
| 356915 | 비동기 읽기 작업용 내부 버퍼가 여러 문자로 된 열 구분 기호를 두 부분으로 나눌 때 오류가 발생합니다. SQL Server 2008 SP3을 설치하면 버퍼가 전환되면 현재 구문 분석 포인터가 다시 설정됩니다. |
| 645220 | 명령 프롬프트에 유효한 SQLAgent.exe 명령을 입력하면 SQLAgent.exe가 실행되지 않습니다. 이 문제는 공유 메모리에 대한 사용 권한 오류로 인해 발생합니다. |
| 747046 | SQL Server 2008 SP3을 설치한 후 데이터베이스 이름이 현재 데이터베이스 사용자의 이름과 같으면 데이터베이스가 만들어지지 않습니다. |
| 769191 | SQL Server 2008 SP3에는 Ntverp.h 파일의 업데이트된 VER_PRODUCTLEVEL_STR 및 VER_PRODUCTLEVEL_WSTR 전역 변수가 포함되어 있습니다. 이 변수는 SP3으로 업데이트됩니다. |
| 453592 | 사용자가 Microsoft SQL Server 2008 Reporting Services 구성 관리자에서 데이터베이스 서버의 포트를 지정하는 경우 사용자는 카탈로그 데이터베이스에 액세스할 수 없습니다. |
| 773344 | Microsoft SQL Server 2008 Reporting Services 구성 관리자의 러시아어 지역화 빌드에서 실행 계정 정보에 잘린 문자열이 포함되어 있습니다. |
참조 자료
현재 SQL Server 버전 및 에디션을 확인하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
321185
SQL Server 버전 및 에디션을 확인하는 방법
이 문서에서 설명하는 타사 제품은 Microsoft와 무관한 별개의 공급업체에서 제조한 것입니다. Microsoft는 이들 제품의 성능이나 안정성에 관하여 명시적이든 묵시적이든 어떠한 보증도 하지 않습니다.